]> git.pld-linux.org Git - packages/itk.git/blob - itk.spec
b8bc17cb4ab7db7a3d81683f1a361fcd72e4671a
[packages/itk.git] / itk.spec
1 Summary:        [incr Tk] - object-oriented extension of the Tcl/Tk language
2 Summary(pl.UTF-8):      [incr Tk] - obiektowo zorientowane rozszerzenie języka Tcl/Tk
3 Name:           itk
4 Version:        4.1.0
5 Release:        1
6 License:        Tcl (BSD-like)
7 Group:          Development/Languages/Tcl
8 Source0:        http://downloads.sourceforge.net/incrtcl/%{name}%{version}.tar.gz
9 # Source0-md5:  600df0a12868507c52d46fd59d4e1c16
10 Patch0:         %{name}-soname.patch
11 Patch1:         %{name}-tclconfig.patch
12 URL:            http://incrtcl.sourceforge.net/itk/
13 BuildRequires:  autoconf >= 2.13
14 BuildRequires:  itcl-devel >= 4.1
15 BuildRequires:  tk-devel >= 8.6
16 Requires:       itcl >= 4.1
17 Requires:       tk >= 8.6
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _ulibdir        %{_prefix}/lib
21
22 %description
23 [incr Tk] is a framework for building mega-widgets using the [incr
24 Tcl] object system. Mega-widgets are high-level widgets like a file
25 browser or a tab notebook that act like ordinary Tk widgets but are
26 constructed using Tk widgets as component parts, without having to
27 write C code. In effect, a mega-widget looks and acts exactly like a
28 Tk widget, but is considerably easier to implement.
29
30 %description -l pl.UTF-8
31 [incr Tk] to szkielet do tworzenia mega-widgetów przy użyciu systemu
32 obiektów [incr ZTcl]. Mega-widgety to widgety wyższego poziomu, takie
33 jak przeglądarka plików czy notatnik z zakładkami, zachowujące się jak
34 zwykłe widgety Tk, ale skonstruowane z części składowych będących
35 widgetami Tk bez potrzeby pisania kodu w C. W efekcie mega-widget
36 wygląda i zachowuje się dokładnie tak, jak widget Tk, ale jest
37 znacząco łatwiejszy w implementacji.
38
39 %package devel
40 Summary:        Header files for itk library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki itk
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       itcl-devel >= 4.1
45 Requires:       tk-devel >= 8.6
46
47 %description devel
48 Header files for itk library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki itk.
52
53 %prep
54 %setup -q -n %{name}%{version}
55 %patch0 -p1
56 %patch1 -p1
57
58 %build
59 %{__autoconf}
60 %configure \
61         --libdir=%{_ulibdir}
62
63 %{__make} \
64         CFLAGS_DEFAULT=
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{_libdir}
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %{__mv} $RPM_BUILD_ROOT%{_ulibdir}/itk%{version}/libitk* $RPM_BUILD_ROOT%{_libdir}
74
75 libfile=$(basename $RPM_BUILD_ROOT%{_libdir}/libitk%{version}.so.0.*)
76 ln -sf $libfile $RPM_BUILD_ROOT%{_libdir}/libitk%{version}.so.0
77 ln -sf $libfile $RPM_BUILD_ROOT%{_libdir}/libitk%{version}.so
78 ln -sf $libfile $RPM_BUILD_ROOT%{_libdir}/libitk.so
79
80 # some substs missing in configure, install missing in Makefile
81 %{__sed} -i -e "s,ITCL_VERSION='@ITCL_VERSION@',ITK_VERSION='%{version}'," \
82         -e 's,@ITK_LIB_FILE@,libitk%{version}.so,' \
83         -e 's,@ITK_BUILD_LIB_SPEC@,-litk%{version},' \
84         -e 's,@ITK_LIB_SPEC@,-litk%{version},' \
85         -e 's,@ITK_STUB_LIB_FILE@,,' \
86         -e 's,@ITK_BUILD_STUB_LIB_SPEC@,,' \
87         -e 's,@ITK_STUB_LIB_SPEC@,,' \
88         -e 's,@ITK_SRC_DIR@,%{_ulibdir},' itkConfig.sh
89 install itkConfig.sh $RPM_BUILD_ROOT%{_ulibdir}
90
91 %{__sed} -i -e 's#%{_ulibdir}#%{_libdir}#' $RPM_BUILD_ROOT%{_ulibdir}/itk%{version}/pkgIndex.tcl
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc license.terms
102 %attr(755,root,root) %{_libdir}/libitk%{version}.so.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libitk%{version}.so.0
104 %dir %{_ulibdir}/itk%{version}
105 %{_ulibdir}/itk%{version}/*.itk
106 %{_ulibdir}/itk%{version}/*.tcl
107 %{_ulibdir}/itk%{version}/tclIndex
108 %{_mandir}/mann/Archetype.n*
109 %{_mandir}/mann/Toplevel.n*
110 %{_mandir}/mann/Widget.n*
111 %{_mandir}/mann/itk.n*
112 %{_mandir}/mann/itkvars.n*
113 %{_mandir}/mann/usual.n*
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libitk%{version}.so
118 %attr(755,root,root) %{_libdir}/libitk.so
119 %{_ulibdir}/itkConfig.sh
120 %{_includedir}/itk*.h
This page took 0.336537 seconds and 2 git commands to generate.