]> git.pld-linux.org Git - packages/itk.git/blob - itk.spec
1ccee1b1d3ba8951826a751a22476cc438b4145e
[packages/itk.git] / itk.spec
1 Summary:        [incr Tk] - object-oriented extension of the Tcl/Tk language
2 Summary(pl.UTF-8):      [incr Tk] - obiektowo zorientowane rozszerzenie języka Tcl/Tk
3 Name:           itk
4 %define vermaj  3.4
5 Version:        %{vermaj}.2
6 Release:        1
7 License:        Tcl (BSD-like)
8 Group:          Development/Languages/Tcl
9 Source0:        http://downloads.sourceforge.net/incrtcl/%{name}%{version}.tar.gz
10 # Source0-md5:  e05b7a47f3dd026345d98fa3a4cdfde1
11 Patch0:         %{name}-soname.patch
12 Patch1:         %{name}-tclconfig.patch
13 URL:            http://incrtcl.sourceforge.net/itk/
14 BuildRequires:  autoconf >= 2.13
15 BuildRequires:  itcl-devel >= 3.4.1
16 BuildRequires:  tk-devel >= 8.4.6
17 Requires:       itcl >= 3.4.1
18 Requires:       tk >= 8.4.6
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _ulibdir        %{_prefix}/lib
22
23 %description
24 [incr Tk] is a framework for building mega-widgets using the [incr
25 Tcl] object system. Mega-widgets are high-level widgets like a file
26 browser or a tab notebook that act like ordinary Tk widgets but are
27 constructed using Tk widgets as component parts, without having to
28 write C code. In effect, a mega-widget looks and acts exactly like a
29 Tk widget, but is considerably easier to implement.
30
31 %description -l pl.UTF-8
32 [incr Tk] to szkielet do tworzenia mega-widgetów przy użyciu systemu
33 obiektów [incr ZTcl]. Mega-widgety to widgety wyższego poziomu, takie
34 jak przeglądarka plików czy notatnik z zakładkami, zachowujące się jak
35 zwykłe widgety Tk, ale skonstruowane z części składowych będących
36 widgetami Tk bez potrzeby pisania kodu w C. W efekcie mega-widget
37 wygląda i zachowuje się dokładnie tak, jak widget Tk, ale jest
38 znacząco łatwiejszy w implementacji.
39
40 %package devel
41 Summary:        Header files for itk library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki itk
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       itcl-devel >= 3.4.1
46 Requires:       tk-devel >= 8.4.6
47
48 %description devel
49 Header files for itk library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki itk.
53
54 %prep
55 %setup -q -n %{name}%{vermaj}
56 %patch0 -p1
57 %patch1 -p1
58
59 %build
60 %{__autoconf}
61 %configure \
62         --libdir=%{_ulibdir}
63
64 %{__make} \
65         CFLAGS_DEFAULT=
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT%{_libdir}
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %{__mv} $RPM_BUILD_ROOT%{_ulibdir}/itk%{vermaj}/libitk* $RPM_BUILD_ROOT%{_libdir}
75
76 libfile=$(basename $RPM_BUILD_ROOT%{_libdir}/libitk%{vermaj}.so.0.*)
77 ln -sf $libfile $RPM_BUILD_ROOT%{_libdir}/libitk%{vermaj}.so.0
78 ln -sf $libfile $RPM_BUILD_ROOT%{_libdir}/libitk%{vermaj}.so
79 ln -sf $libfile $RPM_BUILD_ROOT%{_libdir}/libitk.so
80
81 # some substs missing in configure, install missing in Makefile
82 %{__sed} -i -e "s,ITCL_VERSION='@ITCL_VERSION@',ITK_VERSION='%{version}'," \
83         -e 's,@ITK_LIB_FILE@,libitk%{vermaj}.so,' \
84         -e 's,@ITK_BUILD_LIB_SPEC@,-litk%{vermaj},' \
85         -e 's,@ITK_LIB_SPEC@,-litk%{vermaj},' \
86         -e 's,@ITK_STUB_LIB_FILE@,,' \
87         -e 's,@ITK_BUILD_STUB_LIB_SPEC@,,' \
88         -e 's,@ITK_STUB_LIB_SPEC@,,' \
89         -e 's,@ITK_SRC_DIR@,%{_ulibdir},' itkConfig.sh
90 install itkConfig.sh $RPM_BUILD_ROOT%{_ulibdir}
91
92 %{__sed} -i -e 's#%{_ulibdir}#%{_libdir}#' $RPM_BUILD_ROOT%{_ulibdir}/itk%{vermaj}/pkgIndex.tcl
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc license.terms
103 %attr(755,root,root) %{_libdir}/libitk%{vermaj}.so.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libitk%{vermaj}.so.0
105 %dir %{_ulibdir}/itk%{vermaj}
106 %{_ulibdir}/itk%{vermaj}/*.itk
107 %{_ulibdir}/itk%{vermaj}/*.tcl
108 %{_ulibdir}/itk%{vermaj}/tclIndex
109 %{_mandir}/mann/Archetype.n*
110 %{_mandir}/mann/Toplevel.n*
111 %{_mandir}/mann/Widget.n*
112 %{_mandir}/mann/itk.n*
113 %{_mandir}/mann/itkvars.n*
114 %{_mandir}/mann/usual.n*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libitk%{vermaj}.so
119 %attr(755,root,root) %{_libdir}/libitk.so
120 %{_ulibdir}/itkConfig.sh
121 %{_includedir}/itk*.h
This page took 0.048458 seconds and 2 git commands to generate.