]> git.pld-linux.org Git - packages/issue-logo.git/blob - issue-logo.spec
- fix getting distversion
[packages/issue-logo.git] / issue-logo.spec
1 %define distnamever     %(. /etc/os-release && echo $VERSION)
2 %define distversion     %(. /etc/os-release && echo ${VERSION_ID:-0})
3
4 Summary:        PLD Linux prelogin message and identification file with logo
5 Summary(de.UTF-8):      PLD Linux Systemidentifikationsdatei mit logo
6 Summary(pl.UTF-8):      Plik z logiem identyfikujący system PLD Linux, wyświetlany przed zalogowaniem
7 Name:           issue-logo
8 Version:        %{distversion}
9 Release:        2
10 License:        GPL
11 Group:          Base
12 BuildRequires:  pld-release >= 3.0
13 %requires_eq    pld-release
14 Provides:       issue
15 Conflicts:      issue-alpha < 3.0-1
16 Conflicts:      issue-fancy < 3.0-1
17 Conflicts:      issue-nice < 3.0-1
18 Conflicts:      issue-pure < 3.0-1
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 PLD Linux prelogin message and identification file with logo.
24
25 %description -l de.UTF-8
26 PLD Linux Systemidentifikationsdatei mit logo.
27
28 %description -l pl.UTF-8
29 Plik z logiem identyfikujący system PLD Linux,
30 wyświetlany przed zalogowaniem.
31
32 %prep
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{_sysconfdir}
37
38 cat > $RPM_BUILD_ROOT%{_sysconfdir}/issue <<EOF
39   _
40  / )     PLD Linux %{distnamever} \m, \r
41 / /       Welcome to \n
42  ( -.      \u user(s)
43  \\\\   \\\\
44   \\\\  \\\\\\\\
45    \\\`| \\\\\\\\
46     |  \\\`
47     |
48
49 EOF
50
51 echo -ne "\l " >> $RPM_BUILD_ROOT%{_sysconfdir}/issue
52
53 cat > $RPM_BUILD_ROOT%{_sysconfdir}/issue.net <<EOF
54   _
55  / )     PLD Linux %{distnamever} %m, %r
56 / /       Welcome to %h
57  ( -.
58  \\\\   \\\\
59   \\\\  \\\\\\\\
60    \\\`| \\\\\\\\
61     |  \\\`
62     |
63
64 EOF
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %config(noreplace) %{_sysconfdir}/issue*
This page took 0.084876 seconds and 3 git commands to generate.