]> git.pld-linux.org Git - packages/issue-logo.git/blob - issue-logo.spec
- fixed version, only use /etc/os-release for generating issue file
[packages/issue-logo.git] / issue-logo.spec
1 %define distversion     %(. /etc/os-release 2>/dev/null ; echo $VERSION)
2
3 Summary:        PLD Linux prelogin message and identification file with logo
4 Summary(de.UTF-8):      PLD Linux Systemidentifikationsdatei mit logo
5 Summary(pl.UTF-8):      Plik z logiem identyfikujący system PLD Linux, wyświetlany przed zalogowaniem
6 Name:           issue-logo
7 Version:        3.0
8 Release:        2
9 License:        GPL
10 Group:          Base
11 BuildRequires:  pld-release >= 3.0
12 %requires_eq    pld-release
13 Provides:       issue
14 Conflicts:      issue-alpha < 3.0-1
15 Conflicts:      issue-fancy < 3.0-1
16 Conflicts:      issue-nice < 3.0-1
17 Conflicts:      issue-pure < 3.0-1
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 PLD Linux prelogin message and identification file with logo.
23
24 %description -l de.UTF-8
25 PLD Linux Systemidentifikationsdatei mit logo.
26
27 %description -l pl.UTF-8
28 Plik z logiem identyfikujący system PLD Linux,
29 wyświetlany przed zalogowaniem.
30
31 %prep
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT%{_sysconfdir}
36
37 cat > $RPM_BUILD_ROOT%{_sysconfdir}/issue <<EOF
38   _
39  / )     PLD Linux %{distversion} \m, \r
40 / /       Welcome to \n
41  ( -.      \u user(s)
42  \\\\   \\\\
43   \\\\  \\\\\\\\
44    \\\`| \\\\\\\\
45     |  \\\`
46     |
47
48 EOF
49
50 echo -ne "\l " >> $RPM_BUILD_ROOT%{_sysconfdir}/issue
51
52 cat > $RPM_BUILD_ROOT%{_sysconfdir}/issue.net <<EOF
53   _
54  / )     PLD Linux %{distversion} %m, %r
55 / /       Welcome to %h
56  ( -.
57  \\\\   \\\\
58   \\\\  \\\\\\\\
59    \\\`| \\\\\\\\
60     |  \\\`
61     |
62
63 EOF
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %config(noreplace) %{_sysconfdir}/issue*
This page took 0.069346 seconds and 3 git commands to generate.