]> git.pld-linux.org Git - packages/issue-fancy.git/blob - issue-fancy.spec
c720a2edbb5fed25e4ad90278ce928e6a9085e03
[packages/issue-fancy.git] / issue-fancy.spec
1 %define distnamever     %(. /etc/os-release 2>/dev/null ; echo $VERSION)
2 %define distversion     %([ -e /etc/os-release ] && . /etc/os-release 2>/dev/null ; echo ${VERSION_ID:-0})
3
4 Summary:        PLD Linux release file with logo
5 Summary(de.UTF-8):      PLD Linux Release-Datei mit logo
6 Summary(pl.UTF-8):      Wersja Linuksa PLD z logiem
7 Name:           issue-fancy
8 Version:        %{distversion}
9 Release:        2
10 License:        GPL
11 Group:          Base
12 Source0:        %{name}-gen
13 Source1:        %{name}.crontab
14 Source2:        %{name}.init
15 # In fact it requires quote_logo_backslashes patch.
16 BuildRequires:  linux_logo >= 3.9b5
17 BuildRequires:  pld-release >= 3.0
18 %requires_eq    pld-release
19 Requires(post,preun):   /sbin/chkconfig
20 Requires:       linux_logo >= 3.9b5
21 Requires:       crondaemon
22 Provides:       issue
23 Conflicts:      issue-alpha < 3.0-1
24 Conflicts:      issue-logo < 3.0-1
25 Conflicts:      issue-nice < 3.0-1
26 Conflicts:      issue-pure < 3.0-1
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _sbindir        /sbin
31
32 %description
33 PLD Linux release file with logo.
34
35 %description -l pl.UTF-8
36 Wersja Linuksa PLD z logiem.
37
38 %prep
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{/etc/{cron.d,rc.d/init.d},%{_sbindir}}
43
44 install %{SOURCE0} $RPM_BUILD_ROOT%{_sbindir}
45 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/%{name}
46 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/issue-fancy
47
48 $RPM_BUILD_ROOT%{_sbindir}/issue-fancy-gen $RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 /sbin/issue-fancy-gen
55 /sbin/chkconfig --add issue-fancy
56
57 %preun
58 if [ "$1" = "0" ]; then
59         /sbin/chkconfig --del issue-fancy
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 # Can't use "noreplace" here because issues are regenerated from cron
65 # and %post. Without "noreplace" at least ".rpmsave" will stay.
66 %config %verify(not md5 mtime size) %{_sysconfdir}/issue
67 %config %verify(not md5 mtime size) %{_sysconfdir}/issue.net
68 %attr(755,root,root) %{_sbindir}/*
69 %attr(600,root,root) /etc/cron.d/*
70 %attr(754,root,root) /etc/rc.d/init.d/*
This page took 0.103744 seconds and 2 git commands to generate.