]> git.pld-linux.org Git - packages/issue-fancy.git/blob - issue-fancy.spec
- fixed version, only use /etc/os-release for generating issue file
[packages/issue-fancy.git] / issue-fancy.spec
1 %define distversion     %(. /etc/os-release 2>/dev/null ; echo $VERSION)
2
3 Summary:        PLD Linux release file with logo
4 Summary(de.UTF-8):      PLD Linux Release-Datei mit logo
5 Summary(pl.UTF-8):      Wersja Linuksa PLD z logiem
6 Name:           issue-fancy
7 Version:        3.0
8 Release:        2
9 License:        GPL
10 Group:          Base
11 Source0:        %{name}-gen
12 Source1:        %{name}.crontab
13 Source2:        %{name}.init
14 # In fact it requires quote_logo_backslashes patch.
15 BuildRequires:  linux_logo >= 3.9b5
16 BuildRequires:  pld-release >= 3.0
17 %requires_eq    pld-release
18 Requires(post,preun):   /sbin/chkconfig
19 Requires:       linux_logo >= 3.9b5
20 Requires:       crondaemon
21 Provides:       issue
22 Conflicts:      issue-alpha < 3.0-1
23 Conflicts:      issue-logo < 3.0-1
24 Conflicts:      issue-nice < 3.0-1
25 Conflicts:      issue-pure < 3.0-1
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _sbindir        /sbin
30
31 %description
32 PLD Linux release file with logo.
33
34 %description -l pl.UTF-8
35 Wersja Linuksa PLD z logiem.
36
37 %prep
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{/etc/{cron.d,rc.d/init.d},%{_sbindir}}
42
43 install %{SOURCE0} $RPM_BUILD_ROOT%{_sbindir}
44 install %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/%{name}
45 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/issue-fancy
46
47 $RPM_BUILD_ROOT%{_sbindir}/issue-fancy-gen $RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 /sbin/issue-fancy-gen
54 /sbin/chkconfig --add issue-fancy
55
56 %preun
57 if [ "$1" = "0" ]; then
58         /sbin/chkconfig --del issue-fancy
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 # Can't use "noreplace" here because issues are regenerated from cron
64 # and %post. Without "noreplace" at least ".rpmsave" will stay.
65 %config %verify(not md5 mtime size) %{_sysconfdir}/issue
66 %config %verify(not md5 mtime size) %{_sysconfdir}/issue.net
67 %attr(755,root,root) %{_sbindir}/*
68 %attr(600,root,root) /etc/cron.d/*
69 %attr(754,root,root) /etc/rc.d/init.d/*
This page took 0.052865 seconds and 3 git commands to generate.