]> git.pld-linux.org Git - packages/isdn4k-utils.git/blob - isdn4k-utils.spec
- raw version from Caldera OL.
[packages/isdn4k-utils.git] / isdn4k-utils.spec
1 %define Version 2.1b1
2
3 Summary         : Utilities for the kernel ISDN-subsystem.
4 Name            : isdn4k-utils
5 Version         : %{Version}
6 Release         : 6
7 Group           : Communication/ISDN
8 Copyright       : distributable
9 Packager        : rf@lst.de (Ralf Flaxa)
10 URL             : http://www.franken.de/ftp/pub/isdn4linux/
11 BuildRoot       : /tmp/isdn4k-utils-%{Version}
12
13 Source0: ftp://ftp.franken.de/pub/isdn4linux/v2.1/isdn4k-utils-%{Version}.tar.gz
14 Source1: isdn4k-utils-%{Version}.config
15 Patch0: isdn4k-utils-%{Version}-COL.patch
16
17
18 %Description
19 Utilities for the kernel ISDN-subsystem and some contributions.
20
21
22 %Prep
23 %setup
24 %patch -P 0 -p1
25 cp -p $RPM_SOURCE_DIR/isdn4k-utils-%{Version}.config .config
26
27
28 %Build
29 make OPTIM="$RPM_OPT_FLAGS" oldconfig
30 make CFLAGS="$RPM_OPT_FLAGS"
31
32
33 %Install
34 DESTDIR=$RPM_BUILD_ROOT; export DESTDIR
35 [ -n "`echo $DESTDIR | sed -n 's:^/tmp/[^.].*$:OK:p'`" ] && rm -rf $DESTDIR ||
36 (echo "Invalid BuildRoot: '$DESTDIR'! Check this .spec ..."; exit 1) || exit 1
37
38 make devices
39
40 mkdir -p $DESTDIR/etc/isdn
41 mkdir -p $DESTDIR/sbin
42 mkdir -p $DESTDIR/usr/X11R6/lib/app-defaults
43 mkdir -p $DESTDIR/usr/bin
44 mkdir -p $DESTDIR/usr/doc/faq/isdn4linux
45 mkdir -p $DESTDIR/var/lock/isdn
46
47 make install
48
49 cp -a isdnlog/isdnrep/isdnrep.1 ${DESTDIR}/usr/man/man1
50 cp -a isdnlog/isdnlog/isdnlog.8 ${DESTDIR}/usr/man/man8
51 ln -sf ttyI.4 ${DESTDIR}/usr/man/man4/cui.4
52
53 strip $DESTDIR/sbin/avmcapictrl
54 strip $DESTDIR/sbin/hisaxctrl
55 strip $DESTDIR/sbin/icnctrl
56 strip $DESTDIR/sbin/imon
57 strip $DESTDIR/sbin/imontty
58 strip $DESTDIR/sbin/ipppd
59 strip $DESTDIR/sbin/ipppstats
60 strip $DESTDIR/sbin/iprofd
61 strip $DESTDIR/sbin/isdnctrl
62 strip $DESTDIR/sbin/isdnlog
63 strip $DESTDIR/sbin/pcbitctl
64 strip $DESTDIR/usr/bin/isdnconf
65 strip $DESTDIR/usr/bin/isdnrep
66 strip $DESTDIR/usr/bin/xisdnload
67 strip $DESTDIR/usr/bin/xmonisdn
68
69 # gzip man pages and fix sym-links
70 MANPATHS=`find $DESTDIR -type d -name "man[1-9n]" -print`
71 if [ -n "$MANPATHS" ]; then
72   chown -Rvc root.root $MANPATHS
73   find $MANPATHS -type l -print |
74     perl -lne '($f=readlink($_))&&unlink($_)&&symlink("$f.gz","$_.gz")||die;'
75   find $MANPATHS -type f -print |
76     xargs -r gzip -v9nf
77 fi
78
79
80 %Clean
81 DESTDIR=$RPM_BUILD_ROOT;export DESTDIR;[ -n "$UID" ]&&[ "$UID" -gt 0 ]&&exit 0
82 [ -n "`echo $DESTDIR | sed -n 's:^/tmp/[^.].*$:OK:p'`" ] && rm -rf $DESTDIR ||
83 (echo "Invalid BuildRoot: '$DESTDIR'! Check this .spec ..."; exit 1) || exit 1
84
85
86 %Files
87 %doc COPYING README
88 %dir /usr/doc/faq/isdn4linux
89 /usr/doc/faq/isdn4linux/de-i4l-faq.asc
90 /usr/doc/faq/isdn4linux/de-i4l-faq.html
91 /usr/doc/faq/isdn4linux/eng-i4l-faq.asc
92 /usr/doc/faq/isdn4linux/eng-i4l-faq.html
93
94 %dir /var/lock/isdn
95
96 %dir /etc/isdn
97 %config /etc/isdn/callerid.conf
98 %config /etc/isdn/isdn.conf
99
100 /dev/*
101
102 /sbin/avmcapictrl
103 /sbin/hisaxctrl
104 /sbin/icnctrl
105 /sbin/imon
106 /sbin/imontty
107 /sbin/ipppd
108 /sbin/ipppstats
109 /sbin/iprofd
110 /sbin/isdnctrl
111 /sbin/isdnlog
112 /sbin/pcbitctl
113 /sbin/telesctrl
114
115 /usr/X11R6/lib/X11/app-defaults/XISDNLoad
116
117 /usr/bin/isdnconf
118 /usr/bin/isdnrep
119 /usr/bin/xisdnload
120 /usr/bin/xmonisdn
121
122 %dir /usr/lib/isdn
123 /usr/lib/isdn/areacodes
124
125 /usr/lib/vbox
126
127 /usr/man/man1/isdnrep.1*
128 /usr/man/man1/xisdnload.1x*
129 /usr/man/man1/xmonisdn.1x*
130 /usr/man/man4/cui.4*
131 /usr/man/man4/ttyI.4*
132 /usr/man/man4/isdninfo.4*
133 /usr/man/man4/isdn_audio.4*
134 /usr/man/man7/isdn_cause.7*
135 /usr/man/man8/avmcapictrl.8*
136 /usr/man/man8/hisaxctrl.8*
137 /usr/man/man8/icnctrl.8*
138 /usr/man/man8/imon.8*
139 /usr/man/man8/ipppd.8*
140 /usr/man/man8/ipppstats.8*
141 /usr/man/man8/iprofd.8*
142 /usr/man/man8/isdnctrl.8*
143 /usr/man/man8/telesctrl.8*
144
145
146 %ChangeLog
147 * Mon Jan 01 1997 ...
148
149 $Id: isdn4k-utils.spec,v 1.1 1999-07-16 21:35:36 kloczek Exp $
This page took 0.08004 seconds and 4 git commands to generate.