]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- added color_support_for_gui_entry patch
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 %bcond_without  dynamic # without dynamic libraries
7 #
8 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
9
10 Summary:        Irssi is a IRC client
11 Summary(fr.UTF-8):      Irssi est un client IRC
12 Summary(pl.UTF-8):      Irssi - wygodny w użyciu klient IRC
13 Name:           irssi
14 Version:        0.8.12
15 Release:        7
16 License:        GPL
17 Group:          Applications/Communications
18 #Source0:       http://www.irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
19 Source0:        http://www.irssi.org/files/%{name}-%{version}.tar.gz
20 # Source0-md5:  ddf717a430e1c13a272f528c4f529430
21 Source1:        %{name}.desktop
22 Source2:        %{name}.png
23 %define         idea_ver        0.1.46
24 # NXDOMAIN
25 #Source3:       http://real.irssi.org/files/plugins/idea/%{name}-idea-%{idea_ver}.tar.gz
26 Source3:        %{name}-idea-%{idea_ver}.tar.gz
27 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
28 Patch0:         %{name}-dcc-send-limit.patch
29 Patch1:         %{name}-tinfo.patch
30 Patch2:         %{name}-home_etc.patch
31 Patch3:         %{name}.conf.patch
32 Patch4:         %{name}-idea-listlen.patch
33 Patch5:         %{name}-gcc4.patch
34 Patch6:         %{name}-dynamic.patch
35 Patch7:         %{name}-invalid_free.patch
36 Patch8:         %{name}-color_support_for_gui_entry.patch
37 URL:            http://www.irssi.org/
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 BuildRequires:  gettext-devel
41 # for idea only
42 BuildRequires:  glib-devel >= 1:1.2.10-13
43 BuildRequires:  glib2-devel >= 2.1.0
44 BuildRequires:  libtool
45 BuildRequires:  ncurses-devel >= 5.0
46 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
47 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
48 BuildRequires:  pkgconfig
49 BuildRequires:  popt-devel
50 %{?with_perl:BuildRequires:     rpm-perlprov}
51 BuildRequires:  rpmbuild(macros) >= 1.315
52 BuildRequires:  sed >= 4.0
53 Requires:       perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
54 Obsoletes:      irssi-speech
55 Obsoletes:      irssi-sql
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %if %{with dynamic}
59 %define         filterout_ld    -Wl,--as-needed
60 %endif
61
62 %description
63 Irssi is a textUI IRC client with IPv6 support.
64
65 %description -l fr.UTF-8
66 Irssi est client IRC.
67
68 %description -l pl.UTF-8
69 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
70
71 %package plugin-idea
72 Summary:        Irssi plugin IDEA crypt
73 Summary(pl.UTF-8):      Wtyczka do irssi do szyfrowania IDEA
74 Group:          Applications/Communications
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       glib >= 1:1.2.10-13
77
78 %description plugin-idea
79 This package contains IDEA Crypt plugin for Irssi.
80
81 %description plugin-idea -l pl.UTF-8
82 Ten pakiet zawiera wtyczkę do Irssi z szyfrowaniem IDEA.
83
84 %prep
85 %setup -q -a3
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p1
90 %patch4 -p1
91 %patch5 -p1
92 %if %{with dynamic}
93 %patch6 -p1
94 %endif
95 %patch7 -p1
96 %patch8 -p0
97
98 echo 'AC_DEFUN([AM_PATH_GLIB],[:])' > glib1.m4
99
100 # hack
101 sed -i -e 's#\./libtool#%{_bindir}/libtool#g' configure.in
102
103 %build
104 %{__libtoolize}
105 %{__aclocal} -I .
106 %{__autoconf}
107 %{__automake}
108 %configure \
109         --without-socks \
110         --with-bot \
111         --with-textui \
112         --with-proxy \
113         --with-terminfo \
114         --with-modules \
115         %{?with_perl:--with-perl=yes} \
116         %{?with_perl:--with-perl-lib=vendor} \
117         %{!?with_perl:--with-perl=no} \
118         %{?with_ipv6:--enable-ipv6} \
119         --enable-nls \
120         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
121
122 %{__make}
123
124 # to fool idea configure script
125 touch irssi-config
126 cd irssi-idea-%{idea_ver}
127 %{__libtoolize}
128 %{__aclocal} -I .
129 %{__autoconf}
130 %{__automake}
131 %configure
132
133 %{__make}
134
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT \
142         docdir=%{_datadir}/%{name}-%{version}
143
144 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
145 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
146
147 %{__make} -C irssi-idea-%{idea_ver} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
156 %attr(755,root,root) %{_bindir}/*
157 %dir %{_libdir}/irssi
158 %dir %{_libdir}/irssi/modules
159 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
160 %if %{with dynamic}
161 %attr(755,root,root) %{_libdir}/libirssi*.so.*
162 %endif
163 %{_datadir}/%{name}
164 %{_desktopdir}/irssi.desktop
165 %{_pixmapsdir}/*
166 %{_sysconfdir}/irssi.conf
167 %{_mandir}/man1/*
168
169 %if %{with perl}
170 %{perl_vendorarch}/*.pm
171 %dir %{perl_vendorarch}/Irssi
172 %{perl_vendorarch}/Irssi/*.pm
173
174 %dir %{perl_vendorarch}/auto/Irssi
175 %{perl_vendorarch}/auto/Irssi/*.bs
176 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
177
178 %dir %{perl_vendorarch}/auto/Irssi/Irc
179 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
180 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
181
182 %dir %{perl_vendorarch}/auto/Irssi/TextUI
183 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
184 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
185
186 %dir %{perl_vendorarch}/auto/Irssi/UI
187 %{perl_vendorarch}/auto/Irssi/UI/*.bs
188 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
189 %endif
190
191 %files plugin-idea
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.084738 seconds and 4 git commands to generate.