]> git.pld-linux.org Git - packages/irssi.git/blob - irssi.spec
- merge from DEVEL
[packages/irssi.git] / irssi.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # without perl support
4 %bcond_without  ipv6    # without IPv6 support
5 %bcond_without  ssl     # without SSL  support
6 #
7 %define         _snap           20041010
8 %define         _rc             rc5
9 %define         _idea_ver       0.1.46
10 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
11 Summary:        Irssi is a IRC client
12 Summary(fr):    Irssi est un client IRC
13 Summary(pl):    Irssi - wygodny w u¿yciu klient IRC
14 Name:           irssi
15 Version:        0.8.10
16 Release:        0.%{_snap}.1
17 License:        GPL
18 Group:          Applications/Communications
19 Source0:        http://real.irssi.org/files/snapshots/%{name}-%{_snap}.tar.gz
20 # Source0-md5:  5c243d5b8d8897cf398f9eb639236d32
21 # Source0-size: 1192158
22 Source1:        %{name}.desktop
23 Source2:        %{name}.png
24 Source3:        http://real.irssi.org/files/plugins/idea/%{name}-idea-%{_idea_ver}.tar.gz
25 # Source3-md5:  c326efe317b8f67593a3cd46d5557280
26 # Source0-size: 1192158
27 Patch0:         %{name}-dcc-send-limit.patch
28 Patch1:         %{name}-tinfo.patch
29 Patch2:         %{name}-home_etc.patch
30 Patch3:         %{name}.conf.patch
31 Patch4:         %{name}-idea-listlen.patch
32 URL:            http://www.irssi.org/
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  gettext-devel
36 BuildRequires:  glib-devel
37 BuildRequires:  glib2-devel >= 2.1.0
38 BuildRequires:  libtool
39 BuildRequires:  ncurses-devel >= 5.0
40 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
41 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8.4}
42 BuildRequires:  pkgconfig
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44 Obsoletes:      %{name}-speech
45 Obsoletes:      %{name}-sql
46
47 %description
48 Irssi is a textUI IRC client with IPv6 support.
49
50 %description -l fr
51 Irssi est client IRC.
52
53 %description -l pl
54 Irssi jest tekstowym klientem IRC ze wsparciem dla IPv6.
55
56 %package plugin-idea
57 Summary:        Irssi plugin IDEA crypt
58 Summary(pl):    Wtyczka do irssi do szyfrowania IDEA
59 Group:          Applications/Communications
60 Requires:       %{name} = %{version}
61
62 %description plugin-idea
63 This package contains IDEA Crypt plugin for Irssi.
64
65 %description plugin-idea
66 Ten pakiet zawiera wtyczkê do Irssi z szyfrowaniem IDEA.
67
68 %prep
69 %setup -q -n %{name}-%{version}-%{_rc} -a3
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74 %patch4 -p1
75
76 %build
77 rm -f missing
78 %{__libtoolize}
79 %{__aclocal} -I .
80 %{__autoconf}
81 %{__automake}
82 %configure \
83         --without-socks \
84         --with-bot \
85         --with-textui \
86         --with-proxy \
87         --with-terminfo \
88         --with-modules \
89         %{?with_perl:--with-perl=yes} \
90         %{?with_perl:--with-perl-lib=vendor} \
91         %{!?with_perl:--with-perl=no} \
92         %{?with_ipv6:--enable-ipv6} \
93         --enable-nls \
94         --%{?with_ssl:en}%{!?with_ssl:dis}able-ssl
95
96 %{__make}
97
98 cd irssi-idea-%{_idea_ver}
99 rm -f missing
100 %{__libtoolize}
101 %{__aclocal} -I .
102 %{__autoconf}
103 %{__automake}
104 %configure
105
106 %{__make}
107
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT \
115         docdir=%{_datadir}/%{name}-%{version}
116
117 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
118 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
119
120 %{__make} -C irssi-idea-%{_idea_ver} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog README TODO NEWS docs/*.{txt,html}
129 %attr(755,root,root) %{_bindir}/*
130 %dir %{_libdir}/irssi
131 %dir %{_libdir}/irssi/modules
132 %attr(755,root,root) %{_libdir}/irssi/modules/libirc_proxy.so*
133 %{_datadir}/%{name}
134 %{_desktopdir}/irssi.desktop
135 %{_pixmapsdir}/*
136 %{_sysconfdir}/irssi.conf
137 %{_mandir}/man1/*
138
139 %if %{with perl}
140 %{perl_vendorarch}/*.pm
141 %dir %{perl_vendorarch}/Irssi
142 %{perl_vendorarch}/Irssi/*.pm
143
144 %dir %{perl_vendorarch}/auto/Irssi
145 %{perl_vendorarch}/auto/Irssi/*.bs
146 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/*.so
147
148 %dir %{perl_vendorarch}/auto/Irssi/Irc
149 %{perl_vendorarch}/auto/Irssi/Irc/*.bs
150 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/Irc/*.so
151
152 %dir %{perl_vendorarch}/auto/Irssi/TextUI
153 %{perl_vendorarch}/auto/Irssi/TextUI/*.bs
154 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/TextUI/*.so
155
156 %dir %{perl_vendorarch}/auto/Irssi/UI
157 %{perl_vendorarch}/auto/Irssi/UI/*.bs
158 %attr(755,root,root) %{perl_vendorarch}/auto/Irssi/UI/*.so
159 %endif
160
161 %files plugin-idea
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/irssi/modules/libidea.so
This page took 0.109163 seconds and 4 git commands to generate.