]> git.pld-linux.org Git - packages/ipython3.git/blob - ipython3.spec
e856eb5652153a01cc6950200288422f50a7bc48
[packages/ipython3.git] / ipython3.spec
1 # TODO:
2 # - check docs folder for valuable files
3 #
4 %define         pname   IPython
5 %define         mname   ipython
6 Summary:        An enhanced Interactive Python shell
7 Summary(pl.UTF-8):      Interaktywna powłoka języka Python
8 Name:           ipython3
9 Version:        5.3.0
10 Release:        3
11 License:        BSD
12 Group:          Applications/Shells
13 # Source0:      https://pypi.python.org/packages/source/i/ipython/%{mname}-%{version}.tar.gz
14 Source0:        https://github.com/ipython/ipython/archive/%{version}.tar.gz
15 # Source0-md5:  30045499fa745e2f1893cadcba3f94c5
16 URL:            http://ipython.org
17 BuildRequires:  pydoc3
18 BuildRequires:  python3-devel
19 BuildRequires:  python3-devel-tools
20 BuildRequires:  python3-setuptools
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 Requires:       python3-%{mname} = %{version}-%{release}
24 Requires:       python3-ipython_genutils
25 Requires:       python3-pexpect
26 Requires:       python3-pickleshare
27 Requires:       python3-prompt_toolkit
28 Requires:       python3-ptyprocess
29 Requires:       python3-pygments
30 Requires:       python3-setuptools
31 Requires:       python3-simplegeneric
32 Requires:       python3-traitlets
33 Suggests:       python3-rpy2
34 Suggests:       python3-tornado
35 Suggests:       python3-zmq
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 IPython is a free software project which tries to:
41
42 1. Provide an interactive interpreter superior to Python's default.
43 IPython has many features for object introspection, shell access, and
44 its own special command system for adding functionality when working
45 interactively.
46
47 2. Serve as an embeddable, ready to use interpreter for your own
48 programs. IPython can be started with a single call from inside
49 another program, providing access to the current namespace. This can
50 be very useful both for debugging purposes and for situations where a
51 blend of batch-processing and interactive exploration are needed.
52
53 3. Offer a flexible framework which can be used as the base
54 environment for other systems with Python as the underlying language.
55 Specifically scientific environments like Mathematica, IDL and Mathcad
56 inspired its design, but similar ideas can be useful in many fields.
57
58 This package contains IPython shell.
59
60 %description -l pl.UTF-8
61 IPython jest wolnym oprogramowaniem, którego celem jest:
62
63 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
64 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
65 dostęp do powłoki oraz własny system poleceń, który umożliwia
66 rozszerzanie funkcjonalności podczas pracy interaktywnej.
67
68 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
69 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
70 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
71 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
72 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
73 wymagane połączenie przetwarzania wsadowego z interaktywną
74 introspekcją.
75
76 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
77 systemu, którego polecenia opierają się na zasadach języka Python.
78 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
79 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
80 w wielu przypadkach.
81
82 Pakiet ten zawiera powłokę IPython.
83
84 %package -n python3-ipython
85 Summary:        An enhanced Interactive Python shell modules
86 Summary(pl.UTF-8):      Moduły interaktywnej powłoki języka Python
87 Group:          Libraries/Python
88 Requires:       pydoc3
89 Requires:       python3-devel-tools
90 Requires:       python3-jinja2
91
92 %description -n python3-ipython
93 IPython is a free software project which tries to:
94
95 1. Provide an interactive interpreter superior to Python's default.
96 IPython has many features for object introspection, shell access, and
97 its own special command system for adding functionality when working
98 interactively.
99
100 2. Serve as an embeddable, ready to use interpreter for your own
101 programs. IPython can be started with a single call from inside
102 another program, providing access to the current namespace. This can
103 be very useful both for debugging purposes and for situations where a
104 blend of batch-processing and interactive exploration are needed.
105
106 3. Offer a flexible framework which can be used as the base
107 environment for other systems with Python as the underlying language.
108 Specifically scientific environments like Mathematica, IDL and Mathcad
109 inspired its design, but similar ideas can be useful in many fields.
110
111 This package contains IPython modules.
112
113 %description -n python3-ipython -l pl.UTF-8
114 IPython jest wolnym oprogramowaniem, którego celem jest:
115
116 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
117 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
118 dostęp do powłoki oraz własny system poleceń, który umożliwia
119 rozszerzanie funkcjonalności podczas pracy interaktywnej.
120
121 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
122 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
123 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
124 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
125 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
126 wymagane połączenie przetwarzania wsadowego z interaktywną
127 introspekcją.
128
129 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
130 systemu, którego polecenia opierają się na zasadach języka Python.
131 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
132 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
133 w wielu przypadkach.
134
135 Pakiet ten zawiera moduły interaktywnej powłoki języka Python.
136
137 %prep
138 %setup -q -n %{mname}-%{version}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %py3_install
144
145 rm -rf $RPM_BUILD_ROOT%{_docdir}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/*
153 %{_mandir}/man1/i*.1*
154
155 %files -n python3-ipython
156 %defattr(644,root,root,755)
157 %doc docs/README.rst
158 %{py3_sitescriptdir}/%{pname}
159 %{py3_sitescriptdir}/*.egg-info
This page took 0.078192 seconds and 2 git commands to generate.