]> git.pld-linux.org Git - packages/ipython3.git/blob - ipython3.spec
up to 7.25.0
[packages/ipython3.git] / ipython3.spec
1 #
2 # Conditional build:
3 %bcond_with     doc     # Sphinx documentation
4 %bcond_with     tests   # unit tests (need to wait for fulfilling dependencies in PLD)
5
6 Summary:        An enhanced Interactive Python shell
7 Summary(pl.UTF-8):      Interaktywna powłoka języka Python
8 Name:           ipython3
9 Version:        7.25.0
10 Release:        1
11 License:        BSD
12 Group:          Applications/Shells
13 Source0:        http://archive.ipython.org/release/%{version}/ipython-%{version}.tar.gz
14 # Source0-md5:  c83047b581398490b5d83129da73aa89
15 Patch0:         ipython-use-setuptools.patch
16 URL:            http://ipython.org/
17 BuildRequires:  pydoc3 >= 1:3.7
18 BuildRequires:  python3-devel >= 1:3.7
19 BuildRequires:  python3-devel-tools >= 1:3.7
20 BuildRequires:  python3-setuptools >= 18.5
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.747
23 %if %{with tests}
24 BuildRequires:  python3-decorator
25 BuildRequires:  python3-ipykernel
26 BuildRequires:  python3-nbformat
27 BuildRequires:  python3-nose >= 0.10.1
28 BuildRequires:  python3-numpy
29 BuildRequires:  python3-pexpect
30 BuildRequires:  python3-pickleshare
31 BuildRequires:  python3-prompt_toolkit >= 1.0.4
32 BuildRequires:  python3-prompt_toolkit < 2
33 BuildRequires:  python3-pygments < 2.6
34 BuildRequires:  python3-requests
35 BuildRequires:  python3-simplegeneric >= 0.8
36 BuildRequires:  python3-testpath
37 BuildRequires:  python3-traitlets >= 4.2
38 %endif
39 %if %{with doc}
40 BuildRequires:  python3-docutils
41 BuildRequires:  python3-ipykernel
42 BuildRequires:  python3-sphinx_rtd_theme
43 BuildRequires:  sphinx-pdg-3 >= 1.3
44 %endif
45 Requires:       python3-ipython = %{version}-%{release}
46 Suggests:       python3-PyQt5
47 Suggests:       python3-zmq
48 BuildArch:      noarch
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 IPython is a free software project which tries to:
53
54 1. Provide an interactive interpreter superior to Python's default.
55 IPython has many features for object introspection, shell access, and
56 its own special command system for adding functionality when working
57 interactively.
58
59 2. Serve as an embeddable, ready to use interpreter for your own
60 programs. IPython can be started with a single call from inside
61 another program, providing access to the current namespace. This can
62 be very useful both for debugging purposes and for situations where a
63 blend of batch-processing and interactive exploration are needed.
64
65 3. Offer a flexible framework which can be used as the base
66 environment for other systems with Python as the underlying language.
67 Specifically scientific environments like Mathematica, IDL and Mathcad
68 inspired its design, but similar ideas can be useful in many fields.
69
70 This package contains IPython shell.
71
72 %description -l pl.UTF-8
73 IPython jest wolnym oprogramowaniem, którego celem jest:
74
75 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
76 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
77 dostęp do powłoki oraz własny system poleceń, który umożliwia
78 rozszerzanie funkcjonalności podczas pracy interaktywnej.
79
80 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
81 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
82 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
83 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
84 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
85 wymagane połączenie przetwarzania wsadowego z interaktywną
86 introspekcją.
87
88 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
89 systemu, którego polecenia opierają się na zasadach języka Python.
90 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
91 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
92 w wielu przypadkach.
93
94 Pakiet ten zawiera powłokę IPython.
95
96 %package -n python3-ipython
97 Summary:        An enhanced Interactive Python shell modules
98 Summary(pl.UTF-8):      Moduły interaktywnej powłoki języka Python
99 Group:          Libraries/Python
100 Requires:       pydoc3 >= 1:3.7
101 Requires:       python3-devel-tools >= 1:3.7
102
103 %description -n python3-ipython
104 IPython is a free software project which tries to:
105
106 1. Provide an interactive interpreter superior to Python's default.
107 IPython has many features for object introspection, shell access, and
108 its own special command system for adding functionality when working
109 interactively.
110
111 2. Serve as an embeddable, ready to use interpreter for your own
112 programs. IPython can be started with a single call from inside
113 another program, providing access to the current namespace. This can
114 be very useful both for debugging purposes and for situations where a
115 blend of batch-processing and interactive exploration are needed.
116
117 3. Offer a flexible framework which can be used as the base
118 environment for other systems with Python as the underlying language.
119 Specifically scientific environments like Mathematica, IDL and Mathcad
120 inspired its design, but similar ideas can be useful in many fields.
121
122 This package contains IPython modules.
123
124 %description -n python3-ipython -l pl.UTF-8
125 IPython jest wolnym oprogramowaniem, którego celem jest:
126
127 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
128 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
129 dostęp do powłoki oraz własny system poleceń, który umożliwia
130 rozszerzanie funkcjonalności podczas pracy interaktywnej.
131
132 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
133 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
134 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
135 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
136 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
137 wymagane połączenie przetwarzania wsadowego z interaktywną
138 introspekcją.
139
140 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
141 systemu, którego polecenia opierają się na zasadach języka Python.
142 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
143 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
144 w wielu przypadkach.
145
146 Pakiet ten zawiera moduły interaktywnej powłoki języka Python.
147
148 %prep
149 %setup -q -n ipython-%{version}
150 %patch0 -p1
151
152 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' \
153         examples/Embedding/embed_class_long.py \
154         "examples/IPython Kernel/ipython-get-history.py" \
155         "examples/IPython Kernel/gui"/gui-*.py
156
157 %build
158 %py3_build
159
160 %if %{with tests}
161 PYTHONPATH=$(pwd) \
162 %{__python3} IPython/testing/iptest.py IPython
163 %endif
164
165 %if %{with doc}
166 PYTHONPATH=$(pwd) \
167 %{__make} -C docs html \
168         PYTHON=%{__python3} \
169         SPHINXBUILD=sphinx-build-3
170 %endif
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
175
176 %py3_install
177
178 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
179
180 # test suite
181 %{__rm} $RPM_BUILD_ROOT%{_bindir}/iptest*
182 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/IPython/{core/tests,extensions/tests,lib/tests,terminal/tests,testing/tests,utils/tests}
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %files
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/ipython
190 %attr(755,root,root) %{_bindir}/ipython3
191 %{_mandir}/man1/ipython.1*
192
193 %files -n python3-ipython
194 %defattr(644,root,root,755)
195 %doc COPYING.rst README.rst
196 %{py3_sitescriptdir}/IPython
197 %{py3_sitescriptdir}/ipython-%{version}-py*.egg-info
198 %{_examplesdir}/%{name}-%{version}
This page took 0.061937 seconds and 3 git commands to generate.