]> git.pld-linux.org Git - packages/ipython.git/blob - ipython.spec
- up to 1.2.0
[packages/ipython.git] / ipython.spec
1 #
2 # Python3 version in 'ipython3.spec'
3 #
4 # TODO:
5 # - check docs folder for valuable files
6 #
7 %define         pname   IPython
8 Summary:        An enhanced Interactive Python shell
9 Summary(pl.UTF-8):      Interaktywna powłoka języka Python
10 Name:           ipython
11 Version:        1.2.0
12 Release:        1
13 License:        BSD
14 Group:          Applications/Shells
15 Source0:        http://archive.ipython.org/release/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  6b4cb02d5c48ca1776fb6127d37e9319
17 URL:            http://ipython.org
18 BuildRequires:  pydoc
19 BuildRequires:  python-devel >= 2.6
20 BuildRequires:  python-devel-tools
21 BuildRequires:  python-modules-sqlite
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.219
24 Requires:       python-%{name} = %{version}-%{release}
25 Suggests:       python-PyQt4
26 Suggests:       python-zmq
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 IPython is a free software project which tries to:
32
33 1. Provide an interactive interpreter superior to Python's default.
34 IPython has many features for object introspection, shell access, and
35 its own special command system for adding functionality when working
36 interactively.
37
38 2. Serve as an embeddable, ready to use interpreter for your own
39 programs. IPython can be started with a single call from inside
40 another program, providing access to the current namespace. This can
41 be very useful both for debugging purposes and for situations where a
42 blend of batch-processing and interactive exploration are needed.
43
44 3. Offer a flexible framework which can be used as the base
45 environment for other systems with Python as the underlying language.
46 Specifically scientific environments like Mathematica, IDL and Mathcad
47 inspired its design, but similar ideas can be useful in many fields.
48
49 This package contains IPython shell.
50
51 %description -l pl.UTF-8
52 IPython jest wolnym oprogramowaniem, którego celem jest:
53
54 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
55 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
56 dostęp do powłoki oraz własny system poleceń, który umożliwia
57 rozszerzanie funkcjonalności podczas pracy interaktywnej.
58
59 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
60 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
61 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
62 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
63 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
64 wymagane połączenie przetwarzania wsadowego z interaktywną
65 introspekcją.
66
67 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
68 systemu, którego polecenia opierają się na zasadach języka Python.
69 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
70 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
71 w wielu przypadkach.
72
73 Pakiet ten zawiera powłokę IPython.
74
75 %package -n python-ipython
76 Summary:        An enhanced Interactive Python shell modules
77 Summary(pl.UTF-8):      Moduły interaktywnej powłoki języka Python
78 Group:          Libraries/Python
79 %pyrequires_eq  python-devel-tools
80 %pyrequires_eq  pydoc
81
82 %description -n python-ipython
83 IPython is a free software project which tries to:
84
85 1. Provide an interactive interpreter superior to Python's default.
86 IPython has many features for object introspection, shell access, and
87 its own special command system for adding functionality when working
88 interactively.
89
90 2. Serve as an embeddable, ready to use interpreter for your own
91 programs. IPython can be started with a single call from inside
92 another program, providing access to the current namespace. This can
93 be very useful both for debugging purposes and for situations where a
94 blend of batch-processing and interactive exploration are needed.
95
96 3. Offer a flexible framework which can be used as the base
97 environment for other systems with Python as the underlying language.
98 Specifically scientific environments like Mathematica, IDL and Mathcad
99 inspired its design, but similar ideas can be useful in many fields.
100
101 This package contains IPython modules.
102
103 %description -n python-ipython -l pl.UTF-8
104 IPython jest wolnym oprogramowaniem, którego celem jest:
105
106 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
107 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
108 dostęp do powłoki oraz własny system poleceń, który umożliwia
109 rozszerzanie funkcjonalności podczas pracy interaktywnej.
110
111 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
112 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
113 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
114 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
115 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
116 wymagane połączenie przetwarzania wsadowego z interaktywną
117 introspekcją.
118
119 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
120 systemu, którego polecenia opierają się na zasadach języka Python.
121 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
122 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
123 w wielu przypadkach.
124
125 Pakiet ten zawiera moduły interaktywnej powłoki języka Python.
126
127 %prep
128 %setup -q
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
133
134 python ./setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
135
136 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
137
138 %py_postclean
139 rm -rf $RPM_BUILD_ROOT%{_docdir}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %files
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/*
147 %{_mandir}/man1/*
148
149 %files -n python-ipython
150 %defattr(644,root,root,755)
151 %doc docs/README.rst
152 %{py_sitescriptdir}/%{pname}
153 %{py_sitescriptdir}/*.egg-info
154 %{_examplesdir}/*
This page took 0.064486 seconds and 3 git commands to generate.