]> git.pld-linux.org Git - packages/ipython.git/blob - ipython.spec
98a1b553dc8b419630adc85942f6ffb7039435a2
[packages/ipython.git] / ipython.spec
1 #
2 # Python3 version in 'ipython3.spec'
3 #
4 # TODO:
5 # - check docs folder for valuable files
6 #
7 %define         pname   IPython
8 Summary:        An enhanced Interactive Python shell
9 Summary(pl.UTF-8):      Interaktywna powłoka języka Python
10 Name:           ipython
11 Version:        2.0.0
12 Release:        3
13 License:        BSD
14 Group:          Applications/Shells
15 Source0:        http://archive.ipython.org/release/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  dd209ff8c7b08565478e4fc04bdf33ee
17 URL:            http://ipython.org
18 BuildRequires:  pydoc
19 BuildRequires:  python-devel >= 2.6
20 BuildRequires:  python-devel-tools
21 BuildRequires:  python-modules-sqlite
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.219
24 Requires:       python-%{name} = %{version}-%{release}
25 Suggests:       python-PyQt4
26 Suggests:       python-zmq
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 IPython is a free software project which tries to:
32
33 1. Provide an interactive interpreter superior to Python's default.
34 IPython has many features for object introspection, shell access, and
35 its own special command system for adding functionality when working
36 interactively.
37
38 2. Serve as an embeddable, ready to use interpreter for your own
39 programs. IPython can be started with a single call from inside
40 another program, providing access to the current namespace. This can
41 be very useful both for debugging purposes and for situations where a
42 blend of batch-processing and interactive exploration are needed.
43
44 3. Offer a flexible framework which can be used as the base
45 environment for other systems with Python as the underlying language.
46 Specifically scientific environments like Mathematica, IDL and Mathcad
47 inspired its design, but similar ideas can be useful in many fields.
48
49 This package contains IPython shell.
50
51 %description -l pl.UTF-8
52 IPython jest wolnym oprogramowaniem, którego celem jest:
53
54 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
55 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
56 dostęp do powłoki oraz własny system poleceń, który umożliwia
57 rozszerzanie funkcjonalności podczas pracy interaktywnej.
58
59 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
60 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
61 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
62 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
63 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
64 wymagane połączenie przetwarzania wsadowego z interaktywną
65 introspekcją.
66
67 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
68 systemu, którego polecenia opierają się na zasadach języka Python.
69 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
70 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
71 w wielu przypadkach.
72
73 Pakiet ten zawiera powłokę IPython.
74
75 %package -n python-ipython
76 Summary:        An enhanced Interactive Python shell modules
77 Summary(pl.UTF-8):      Moduły interaktywnej powłoki języka Python
78 Group:          Libraries/Python
79 %pyrequires_eq  python-devel-tools
80 %pyrequires_eq  pydoc
81 Requires:       python-jinja2
82
83 %description -n python-ipython
84 IPython is a free software project which tries to:
85
86 1. Provide an interactive interpreter superior to Python's default.
87 IPython has many features for object introspection, shell access, and
88 its own special command system for adding functionality when working
89 interactively.
90
91 2. Serve as an embeddable, ready to use interpreter for your own
92 programs. IPython can be started with a single call from inside
93 another program, providing access to the current namespace. This can
94 be very useful both for debugging purposes and for situations where a
95 blend of batch-processing and interactive exploration are needed.
96
97 3. Offer a flexible framework which can be used as the base
98 environment for other systems with Python as the underlying language.
99 Specifically scientific environments like Mathematica, IDL and Mathcad
100 inspired its design, but similar ideas can be useful in many fields.
101
102 This package contains IPython modules.
103
104 %description -n python-ipython -l pl.UTF-8
105 IPython jest wolnym oprogramowaniem, którego celem jest:
106
107 1. Dostarczenie interaktywnej powłoki lepszej od standardowej
108 dostarczanej z językiem Python. IPython umożliwia badanie obiektów,
109 dostęp do powłoki oraz własny system poleceń, który umożliwia
110 rozszerzanie funkcjonalności podczas pracy interaktywnej.
111
112 2. Dostarczenie gotowego interpretera, który można dołączać do własnej
113 aplikacji. IPython może zostać uruchomiony za pomocą wywołania jednej
114 funkcji z poziomu innego programu umożliwiając jednocześnie dostęp do
115 aktualnej przestrzeni nazw tego programu. Może to być bardzo użyteczne
116 do celów takich jak śledzenie programu czy też sytuacji gdzie jest
117 wymagane połączenie przetwarzania wsadowego z interaktywną
118 introspekcją.
119
120 3. Dostarczenie szkieletu, który może zostać użyty jako podstawa
121 systemu, którego polecenia opierają się na zasadach języka Python.
122 Projekt został zainspirowany przez oprogramowanie naukowe takie jak
123 Mathematica, IDL oraz Mathcad, gdzie podobne idee mogą być realizowane
124 w wielu przypadkach.
125
126 Pakiet ten zawiera moduły interaktywnej powłoki języka Python.
127
128 %prep
129 %setup -q
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
134
135 %py_install
136
137 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
138
139 %py_postclean
140 rm -rf $RPM_BUILD_ROOT%{_docdir}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/*
148 %{_mandir}/man1/*
149
150 %files -n python-ipython
151 %defattr(644,root,root,755)
152 %doc docs/README.rst
153 %{py_sitescriptdir}/%{pname}
154 %{py_sitescriptdir}/*.egg-info
155 %{_examplesdir}/*
This page took 0.059989 seconds and 2 git commands to generate.