]> git.pld-linux.org Git - packages/iptables.git/blob - iptables.spec
- updated to 1.4.16.3
[packages/iptables.git] / iptables.spec
1 #
2 # TODO:
3 # - update BR to real required llh version
4 # - check if kernel-headers are still required to properly build iptabels for dist kernel
5 # - fix makefile (-D_UNKNOWN_KERNEL_POINTER_SIZE issue)
6 # - owner needs rewrite to xt
7 #
8 # Conditional build:
9 %bcond_without  doc             # without documentation (HOWTOS) which needed TeX
10 %bcond_without  dist_kernel     # without distribution kernel
11 %bcond_with     vserver         # build xt_owner module for non-dist kernel with vserver support
12 %bcond_with     batch           # build iptables-batch
13 %bcond_with     static          # build static libraries, no dynamic modules (all linked into binaries)
14 %bcond_with     ipt_IPV4OPTSSTRIP # enable ipt_IPV4OPTSSTRIP for non-dist kernel
15 %bcond_with     ipt_rpc         # enable ipt_rpc for non-dist kernel
16 %bcond_with     xt_layer7       # enable xt_layer7 for non-dist kernel
17 %bcond_with     usekernelsrc    # include kernel headers from %{_kernelsrcdir}
18
19 %if %{with dist_kernel}
20 %define with_ipt_IPV4OPTSSTRIP  1
21 %define with_ipt_rpc            1
22 %define with_xt_layer7          1
23 %define with_vserver            1
24 %define with_usekernelsrc       1
25 %endif
26
27 %define         name6                   ip6tables
28 Summary:        Extensible packet filtering system && extensible NAT system
29 Summary(pl.UTF-8):      System filtrowania pakietów oraz system translacji adresów (NAT)
30 Summary(pt_BR.UTF-8):   Ferramenta para controlar a filtragem de pacotes no kernel-2.6.x
31 Summary(ru.UTF-8):      Утилиты для управления пакетными фильтрами ядра Linux
32 Summary(uk.UTF-8):      Утиліти для керування пакетними фільтрами ядра Linux
33 Summary(zh_CN.UTF-8):   Linux内核包过滤管理工具
34 Name:           iptables
35 Version:        1.4.16.3
36 Release:        1
37 License:        GPL v2
38 Group:          Networking/Admin
39 Source0:        ftp://ftp.netfilter.org/pub/iptables/%{name}-%{version}.tar.bz2
40 # Source0-md5:  6dd40c12fb8f4c4312a0f8434369fbcd
41 Source1:        cvs://cvs.samba.org/netfilter/%{name}-howtos.tar.bz2
42 # Source1-md5:  2ed2b452daefe70ededd75dc0061fd07
43 Source2:        %{name}.init
44 Source3:        %{name6}.init
45 Source4:        %{name}.upstart
46 Source5:        %{name6}.upstart
47 Source6:        %{name}-config
48 Source7:        %{name6}-config
49 Source8:        %{name}.service
50 Source9:        %{name6}.service
51 # --- GENERAL CHANGES (patches<10):
52 Patch0:         %{name}-man.patch
53 # additional utils; off by default
54 Patch1:         %{name}-batch.patch
55 Patch2:         no-libiptc.patch
56 Patch3:         %{name}-aligned_u64.patch
57 # --- ADDITIONAL/CHANGED EXTENSIONS:
58 # just ipt_IPV4OPTSSTRIP now
59 Patch10:        %{name}-20070806.patch
60 # xt_layer7; almost based on iptables-1.4-for-kernel-2.6.20forward-layer7-2.18.patch
61 # http://downloads.sourceforge.net/l7-filter/netfilter-layer7-v2.18.tar.gz
62 Patch11:        %{name}-layer7.patch
63 # ipt_rpc
64 Patch12:        %{name}-old-1.3.7.patch
65 # xt_IMQ; http://linuximq.net/patchs/iptables-1.4.12-IMQ-test4.diff
66 Patch13:        %{name}-imq.patch
67 # enhances ipt_owner/ip6t_owner; http://people.linux-vserver.org/~dhozac/p/m/iptables-1.3.5-owner-xid.patch (currently disabled, needs update for xt_owner)
68 Patch14:        %{name}-1.3.5-owner-xid.patch
69 # adjusts xt_owner for vserver-enabled kernel
70 Patch15:        %{name}-owner-struct-size-vs.patch
71 # ipt_stealth; currently disabled (broken, see below)
72 Patch16:        %{name}-stealth.patch
73 URL:            http://www.netfilter.org/
74 BuildRequires:  autoconf >= 2.50
75 BuildRequires:  automake
76 BuildRequires:  groff
77 BuildRequires:  libnfnetlink-devel >= 1.0
78 BuildRequires:  libtool
79 BuildRequires:  pkgconfig >= 1:0.9.0
80 BuildRequires:  rpmbuild(macros) >= 1.647
81 %if %{with doc}
82 BuildRequires:  sed >= 4.0
83 BuildRequires:  sgml-tools
84 BuildRequires:  sgmls
85 BuildRequires:  tetex-dvips
86 BuildRequires:  tetex-format-latex
87 BuildRequires:  tetex-latex
88 BuildRequires:  tetex-tex-babel
89 BuildRequires:  texlive-fonts-cmsuper
90 BuildRequires:  texlive-fonts-jknappen
91 %endif
92 %if %{with dist_kernel}
93 BuildRequires:  kernel%{_alt_kernel}-headers(netfilter)
94 %endif
95 BuildRequires:  linux-libc-headers >= 7:2.6.22.1
96 Requires:       %{name}-libs = %{version}-%{release}
97 Requires:       libnfnetlink >= 1.0
98 Provides:       firewall-userspace-tool
99 Obsoletes:      ipchains
100 Obsoletes:      iptables24-compat
101 Obsoletes:      netfilter
102 Conflicts:      xtables-addons < 1.25
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %description
106 An extensible NAT system, and an extensible packet filtering system.
107 Replacement of ipchains in 2.4 and higher kernels.
108
109 %description -l pl.UTF-8
110 Wydajny system translacji adresów (NAT) oraz system filtrowania
111 pakietów. Zamiennik ipchains w jądrach 2.4 i nowszych.
112
113 %description -l pt_BR.UTF-8
114 Esta é a ferramenta que controla o código de filtragem de pacotes do
115 kernel 2.4, obsoletando ipchains. Com esta ferramenta você pode
116 configurar filtros de pacotes, NAT, mascaramento (masquerading),
117 regras dinâmicas (stateful inspection), etc.
118
119 %description -l ru.UTF-8
120 iptables управляют кодом фильтрации сетевых пакетов в ядре Linux. Они
121 позволяют вам устанавливать межсетевые экраны (firewalls) и IP
122 маскарадинг, и т.п.
123
124 %description -l uk.UTF-8
125 iptables управляють кодом фільтрації пакетів мережі в ядрі Linux. Вони
126 дозволяють вам встановлювати міжмережеві екрани (firewalls) та IP
127 маскарадинг, тощо.
128
129 %package libs
130 Summary:        iptables libraries
131 Summary(pl.UTF-8):      Biblioteki iptables
132 Group:          Libraries
133 Conflicts:      iptables < 1.4.3-1
134
135 %description libs
136 iptables libraries.
137
138 %description libs -l pl.UTF-8
139 Biblioteki iptables.
140
141 %package devel
142 Summary:        Libraries and headers for developing iptables extensions
143 Summary(pl.UTF-8):      Biblioteki i nagłówki do tworzenia rozszerzeń iptables
144 Group:          Development/Libraries
145 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
146 Obsoletes:      iptables24-devel
147
148 %description devel
149 Libraries and headers for developing iptables extensions.
150
151 %description devel -l pl.UTF-8
152 Biblioteki i pliki nagłówkowe niezbędne do tworzenia rozszerzeń dla
153 iptables.
154
155 %package static
156 Summary:        Static iptables libraries
157 Summary(pl.UTF-8):      Biblioteki statyczne iptables
158 Group:          Development/Libraries
159 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
160
161 %description static
162 Static iptables libraries.
163
164 %description static -l pl.UTF-8
165 Biblioteki statyczne iptables.
166
167 %package init
168 Summary:        Iptables init (RedHat style)
169 Summary(pl.UTF-8):      Iptables init (w stylu RedHata)
170 Group:          Networking/Admin
171 Requires(post,preun):   /sbin/chkconfig
172 Requires(post,preun,postun):    systemd-units >= 38
173 Requires:       %{name}
174 Requires:       rc-scripts >= 0.4.3.0
175 Requires:       systemd-units >= 38
176 Obsoletes:      firewall-init
177 Obsoletes:      firewall-init-ipchains
178 Obsoletes:      iptables24-init
179
180 %description init
181 Iptables-init is meant to provide an alternate way than firewall-init
182 to start and stop packet filtering through iptables(8).
183
184 %description init -l pl.UTF-8
185 Iptables-init ma na celu udostępnienie alternatywnego w stosunku do
186 firewall-init sposobu włączania i wyłączania filtrów IP jądra poprzez
187 iptables(8).
188
189 %prep
190 %setup -q -a1
191 %patch0 -p1
192 %if %{with batch}
193 %patch1 -p1
194 %endif
195 %patch2 -p1
196 %patch3 -p1
197
198 %{?with_ipt_IPV4OPTSSTRIP:%patch10 -p1}
199 %{?with_xt_layer7:%patch11 -p1}
200 %{?with_ipt_rpc:%patch12 -p1}
201 %patch13 -p1
202 %if %{with vserver}
203 #patch14 -p1
204 %patch15 -p1
205 %endif
206 # builds but init() api is broken, see warnings
207 #patch16 -p1
208
209 %build
210 %{__libtoolize}
211 %{__aclocal} -I m4
212 %{__autoconf}
213 %{__autoheader}
214 %{__automake}
215 %configure \
216         CFLAGS="%{rpmcflags} %{rpmcppflags} -D%{!?debug:N}DEBUG" \
217         %{?with_usekernelsrc:--with-kernel=%{_kernelsrcdir}} \
218         --enable-libipq \
219         %{?with_static:--enable-static}
220
221 %{__make} all \
222         V=1
223
224 %if %{with doc}
225 %{__make} -j1 -C iptables-howtos
226 sed -i 's:$(HTML_HOWTOS)::g; s:$(PSUS_HOWTOS)::g' iptables-howtos/Makefile
227 %endif
228
229 %install
230 rm -rf $RPM_BUILD_ROOT
231 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig} \
232         $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_mandir}/man3} \
233         $RPM_BUILD_ROOT%{systemdunitdir}
234
235 %{__make} install \
236         DESTDIR=$RPM_BUILD_ROOT \
237         BINDIR=%{_sbindir} \
238         MANDIR=%{_mandir} \
239         LIBDIR=%{_libdir}
240
241 # upstream solution with empty library with two DT_NEEDED entries doesn't work
242 # with PLD's default LDFLAGS (--as-needed --no-copy-dt-needed-entries);
243 # use ld script instead (see no-libiptc.patch for source)
244 cp -p libiptc/libiptc.ld $RPM_BUILD_ROOT%{_libdir}/libiptc.so
245
246 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
247 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name6}
248 install -d $RPM_BUILD_ROOT/etc/init
249 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/init/%{name}.conf
250 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/init/%{name6}.conf
251
252 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-config
253 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/sysconfig/%{name6}-config
254
255 install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
256 install -p %{SOURCE9} $RPM_BUILD_ROOT%{systemdunitdir}/%{name6}.service
257
258 %clean
259 rm -rf $RPM_BUILD_ROOT
260
261 %post   libs -p /sbin/ldconfig
262 %postun libs -p /sbin/ldconfig
263
264 %post init
265 /sbin/chkconfig --add %{name}
266 /sbin/chkconfig --add %{name6}
267 %systemd_post %{name}.service %{name6}.service
268
269 %preun init
270 if [ "$1" = "0" ]; then
271         /sbin/chkconfig --del %{name}
272         /sbin/chkconfig --del %{name6}
273 fi
274 %systemd_preun %{name}.service %{name6}.service
275
276 %postun init
277 %systemd_reload
278
279 %triggerpostun init -- %{name}-init < 1.4.13-2
280 %systemd_trigger %{name}.service %{name6}.service
281
282 %files
283 %defattr(644,root,root,755)
284 %{?with_doc:%doc iptables-howtos/{NAT,networking-concepts,packet-filtering}-HOWTO*}
285 %attr(755,root,root) %{_bindir}/iptables-xml
286 %attr(755,root,root) %{_sbindir}/iptables
287 %attr(755,root,root) %{_sbindir}/iptables-restore
288 %attr(755,root,root) %{_sbindir}/iptables-save
289 %attr(755,root,root) %{_sbindir}/ip6tables
290 %attr(755,root,root) %{_sbindir}/ip6tables-restore
291 %attr(755,root,root) %{_sbindir}/ip6tables-save
292 %if %{with batch}
293 %attr(755,root,root) %{_sbindir}/iptables-batch
294 %attr(755,root,root) %{_sbindir}/ip6tables-batch
295 %endif
296 %attr(755,root,root) %{_sbindir}/nfnl_osf
297 %attr(755,root,root) %{_sbindir}/xtables-multi
298 %{_datadir}/xtables
299 %dir %{_libdir}/xtables
300 %attr(755,root,root) %{_libdir}/xtables/libip6t_HL.so
301 %attr(755,root,root) %{_libdir}/xtables/libip6t_LOG.so
302 %attr(755,root,root) %{_libdir}/xtables/libip6t_REJECT.so
303 %attr(755,root,root) %{_libdir}/xtables/libip6t_ah.so
304 %attr(755,root,root) %{_libdir}/xtables/libip6t_dst.so
305 %attr(755,root,root) %{_libdir}/xtables/libip6t_eui64.so
306 %attr(755,root,root) %{_libdir}/xtables/libip6t_frag.so
307 %attr(755,root,root) %{_libdir}/xtables/libip6t_hbh.so
308 %attr(755,root,root) %{_libdir}/xtables/libip6t_hl.so
309 %attr(755,root,root) %{_libdir}/xtables/libip6t_icmp6.so
310 %attr(755,root,root) %{_libdir}/xtables/libip6t_ipv6header.so
311 %attr(755,root,root) %{_libdir}/xtables/libip6t_mh.so
312 %attr(755,root,root) %{_libdir}/xtables/libip6t_rt.so
313 %attr(755,root,root) %{_libdir}/xtables/libipt_CLUSTERIP.so
314 %attr(755,root,root) %{_libdir}/xtables/libipt_DNAT.so
315 %attr(755,root,root) %{_libdir}/xtables/libipt_ECN.so
316 %attr(755,root,root) %{_libdir}/xtables/libipt_LOG.so
317 %attr(755,root,root) %{_libdir}/xtables/libipt_MASQUERADE.so
318 %attr(755,root,root) %{_libdir}/xtables/libipt_MIRROR.so
319 %attr(755,root,root) %{_libdir}/xtables/libipt_NETMAP.so
320 %attr(755,root,root) %{_libdir}/xtables/libipt_REDIRECT.so
321 %attr(755,root,root) %{_libdir}/xtables/libipt_REJECT.so
322 %attr(755,root,root) %{_libdir}/xtables/libipt_SAME.so
323 %attr(755,root,root) %{_libdir}/xtables/libipt_SNAT.so
324 %attr(755,root,root) %{_libdir}/xtables/libipt_TTL.so
325 %attr(755,root,root) %{_libdir}/xtables/libipt_ULOG.so
326 %attr(755,root,root) %{_libdir}/xtables/libipt_ah.so
327 %attr(755,root,root) %{_libdir}/xtables/libipt_icmp.so
328 %attr(755,root,root) %{_libdir}/xtables/libipt_realm.so
329 # disabled, see above
330 #%attr(755,root,root) %{_libdir}/xtables/libipt_stealth.so
331 %attr(755,root,root) %{_libdir}/xtables/libipt_ttl.so
332 %attr(755,root,root) %{_libdir}/xtables/libipt_unclean.so
333 %attr(755,root,root) %{_libdir}/xtables/libxt_AUDIT.so
334 %attr(755,root,root) %{_libdir}/xtables/libxt_CHECKSUM.so
335 %attr(755,root,root) %{_libdir}/xtables/libxt_CLASSIFY.so
336 %attr(755,root,root) %{_libdir}/xtables/libxt_CONNMARK.so
337 %attr(755,root,root) %{_libdir}/xtables/libxt_CONNSECMARK.so
338 %attr(755,root,root) %{_libdir}/xtables/libxt_CT.so
339 %attr(755,root,root) %{_libdir}/xtables/libxt_DSCP.so
340 %attr(755,root,root) %{_libdir}/xtables/libxt_HMARK.so
341 %attr(755,root,root) %{_libdir}/xtables/libxt_IDLETIMER.so
342 %attr(755,root,root) %{_libdir}/xtables/libxt_IMQ.so
343 %attr(755,root,root) %{_libdir}/xtables/libxt_LED.so
344 %attr(755,root,root) %{_libdir}/xtables/libxt_MARK.so
345 %attr(755,root,root) %{_libdir}/xtables/libxt_NFLOG.so
346 %attr(755,root,root) %{_libdir}/xtables/libxt_NFQUEUE.so
347 %attr(755,root,root) %{_libdir}/xtables/libxt_NOTRACK.so
348 %attr(755,root,root) %{_libdir}/xtables/libxt_RATEEST.so
349 %attr(755,root,root) %{_libdir}/xtables/libxt_SECMARK.so
350 %attr(755,root,root) %{_libdir}/xtables/libxt_SET.so
351 %attr(755,root,root) %{_libdir}/xtables/libxt_TCPMSS.so
352 %attr(755,root,root) %{_libdir}/xtables/libxt_TCPOPTSTRIP.so
353 %attr(755,root,root) %{_libdir}/xtables/libxt_TEE.so
354 %attr(755,root,root) %{_libdir}/xtables/libxt_TOS.so
355 %attr(755,root,root) %{_libdir}/xtables/libxt_TPROXY.so
356 %attr(755,root,root) %{_libdir}/xtables/libxt_TRACE.so
357 %attr(755,root,root) %{_libdir}/xtables/libxt_addrtype.so
358 %attr(755,root,root) %{_libdir}/xtables/libxt_cluster.so
359 %attr(755,root,root) %{_libdir}/xtables/libxt_comment.so
360 %attr(755,root,root) %{_libdir}/xtables/libxt_connbytes.so
361 %attr(755,root,root) %{_libdir}/xtables/libxt_connlimit.so
362 %attr(755,root,root) %{_libdir}/xtables/libxt_connmark.so
363 %attr(755,root,root) %{_libdir}/xtables/libxt_conntrack.so
364 %attr(755,root,root) %{_libdir}/xtables/libxt_cpu.so
365 %attr(755,root,root) %{_libdir}/xtables/libxt_dccp.so
366 %attr(755,root,root) %{_libdir}/xtables/libxt_devgroup.so
367 %attr(755,root,root) %{_libdir}/xtables/libxt_dscp.so
368 %attr(755,root,root) %{_libdir}/xtables/libxt_ecn.so
369 %attr(755,root,root) %{_libdir}/xtables/libxt_esp.so
370 %attr(755,root,root) %{_libdir}/xtables/libxt_hashlimit.so
371 %attr(755,root,root) %{_libdir}/xtables/libxt_helper.so
372 %attr(755,root,root) %{_libdir}/xtables/libxt_iprange.so
373 %attr(755,root,root) %{_libdir}/xtables/libxt_ipvs.so
374 %attr(755,root,root) %{_libdir}/xtables/libxt_length.so
375 %attr(755,root,root) %{_libdir}/xtables/libxt_limit.so
376 %attr(755,root,root) %{_libdir}/xtables/libxt_mac.so
377 %attr(755,root,root) %{_libdir}/xtables/libxt_mark.so
378 %attr(755,root,root) %{_libdir}/xtables/libxt_multiport.so
379 %attr(755,root,root) %{_libdir}/xtables/libxt_nfacct.so
380 %attr(755,root,root) %{_libdir}/xtables/libxt_osf.so
381 %attr(755,root,root) %{_libdir}/xtables/libxt_owner.so
382 %attr(755,root,root) %{_libdir}/xtables/libxt_physdev.so
383 %attr(755,root,root) %{_libdir}/xtables/libxt_pkttype.so
384 %attr(755,root,root) %{_libdir}/xtables/libxt_policy.so
385 %attr(755,root,root) %{_libdir}/xtables/libxt_quota.so
386 %attr(755,root,root) %{_libdir}/xtables/libxt_rateest.so
387 %attr(755,root,root) %{_libdir}/xtables/libxt_recent.so
388 %attr(755,root,root) %{_libdir}/xtables/libxt_rpfilter.so
389 %attr(755,root,root) %{_libdir}/xtables/libxt_sctp.so
390 %attr(755,root,root) %{_libdir}/xtables/libxt_set.so
391 %attr(755,root,root) %{_libdir}/xtables/libxt_socket.so
392 %attr(755,root,root) %{_libdir}/xtables/libxt_standard.so
393 %attr(755,root,root) %{_libdir}/xtables/libxt_state.so
394 %attr(755,root,root) %{_libdir}/xtables/libxt_statistic.so
395 %attr(755,root,root) %{_libdir}/xtables/libxt_string.so
396 %attr(755,root,root) %{_libdir}/xtables/libxt_tcp.so
397 %attr(755,root,root) %{_libdir}/xtables/libxt_tcpmss.so
398 %attr(755,root,root) %{_libdir}/xtables/libxt_time.so
399 %attr(755,root,root) %{_libdir}/xtables/libxt_tos.so
400 %attr(755,root,root) %{_libdir}/xtables/libxt_u32.so
401 %attr(755,root,root) %{_libdir}/xtables/libxt_udp.so
402 %{?with_ipt_IPV4OPTSSTRIP:%attr(755,root,root) %{_libdir}/xtables/libipt_IPV4OPTSSTRIP.so}
403 %{?with_ipt_rpc:%attr(755,root,root) %{_libdir}/xtables/libipt_rpc.so}
404 %{?with_xt_layer7:%attr(755,root,root) %{_libdir}/xtables/libxt_layer7.so}
405 %{_mandir}/man1/iptables-xml.1*
406 %{_mandir}/man8/ip6tables.8*
407 %{_mandir}/man8/ip6tables-restore.8*
408 %{_mandir}/man8/ip6tables-save.8*
409 %{_mandir}/man8/iptables.8*
410 %{_mandir}/man8/iptables-extensions.8*
411 %{_mandir}/man8/iptables-restore.8*
412 %{_mandir}/man8/iptables-save.8*
413
414 %files libs
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_libdir}/libip4tc.so.*.*.*
417 %attr(755,root,root) %ghost %{_libdir}/libip4tc.so.0
418 %attr(755,root,root) %{_libdir}/libip6tc.so.*.*.*
419 %attr(755,root,root) %ghost %{_libdir}/libip6tc.so.0
420 %attr(755,root,root) %{_libdir}/libipq.so.*.*.*
421 %attr(755,root,root) %ghost %{_libdir}/libipq.so.0
422 %attr(755,root,root) %{_libdir}/libxtables.so.*.*.*
423 %attr(755,root,root) %ghost %{_libdir}/libxtables.so.9
424
425 %files devel
426 %defattr(644,root,root,755)
427 %{?with_doc:%doc iptables-howtos/netfilter-hacking-HOWTO*}
428 %attr(755,root,root) %{_libdir}/libip4tc.so
429 %attr(755,root,root) %{_libdir}/libip6tc.so
430 %attr(755,root,root) %{_libdir}/libipq.so
431 %attr(755,root,root) %{_libdir}/libiptc.so
432 %attr(755,root,root) %{_libdir}/libxtables.so
433 %{_libdir}/libip4tc.la
434 %{_libdir}/libip6tc.la
435 %{_libdir}/libipq.la
436 %{_libdir}/libxtables.la
437 %{_includedir}/libipq.h
438 %{_includedir}/xtables.h
439 %{_includedir}/xtables-version.h
440 %{_includedir}/libiptc
441 %{_pkgconfigdir}/libip4tc.pc
442 %{_pkgconfigdir}/libip6tc.pc
443 %{_pkgconfigdir}/libipq.pc
444 %{_pkgconfigdir}/libiptc.pc
445 %{_pkgconfigdir}/xtables.pc
446 %{_mandir}/man3/ipq_*.3*
447 %{_mandir}/man3/libipq.3*
448
449 %if %{with static}
450 %files static
451 %defattr(644,root,root,755)
452 %{_libdir}/libip4tc.a
453 %{_libdir}/libip6tc.a
454 %{_libdir}/libipq.a
455 %{_libdir}/libxtables.a
456 %endif
457
458 %files init
459 %defattr(644,root,root,755)
460 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}-config
461 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name6}-config
462 %attr(754,root,root) /etc/rc.d/init.d/iptables
463 %attr(754,root,root) /etc/rc.d/init.d/ip6tables
464 %config(noreplace) %verify(not md5 mtime size) /etc/init/%{name}.conf
465 %config(noreplace) %verify(not md5 mtime size) /etc/init/%{name6}.conf
466 %{systemdunitdir}/%{name}.service
467 %{systemdunitdir}/%{name6}.service
This page took 0.056668 seconds and 4 git commands to generate.