]> git.pld-linux.org Git - packages/intel-xed.git/blob - intel-xed.spec
- initial
[packages/intel-xed.git] / intel-xed.spec
1 Summary:        Intel X86 Encoder Decoder (Intel XED)
2 Summary(pl.UTF-8):      Dekoder/koder rozkazów procesorów Intel X86 (Intel XED)
3 Name:           intel-xed
4 Version:        11.0.1
5 Release:        1
6 License:        Apache v2.0
7 Group:          Libraries
8 #Source0Download: https://github.com/intelxed/xed/releases
9 Source0:        https://github.com/intelxed/xed/archive/%{version}/xed-%{version}.tar.gz
10 # Source0-md5:  79d1b08fce1b20042c604df52ac192a5
11 %define mbuild_gitref   f2de5e93ac318e223f6ec61c41f541171db0ada7
12 %define mbuild_snap     20190524
13 Source1:        https://github.com/intelxed/mbuild/archive/%{mbuild_gitref}/mbuild-%{mbuild_snap}.tar.gz
14 # Source1-md5:  ab8443e971e321968390261ddcd4a43f
15 URL:            https://github.com/intelxed/xed
16 BuildRequires:  python3 >= 1:3
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Intel X86 Encoder Decoder (Intel XED).
21
22 %description -l pl.UTF-8
23 Dekoder/koder rozkazów procesorów Intel X86 (Intel XED).
24
25 %package devel
26 Summary:        Header files for Intel XED libraries
27 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Intel XED
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Header files for Intel XED libraries.
33
34 %description devel -l pl.UTF-8
35 Pliki nagłówkowe bibliotek Intel XED.
36
37 %prep
38 %setup -q -n xed-%{version} -a1
39 %{__mv} mbuild-%{mbuild_gitref} mbuild
40
41 %build
42 PYTHONPATH=$(pwd)/mbuild \
43 %{__python3} mfile.py install \
44         CC="%{__cc}" \
45         LINK="%{__cc}" \
46         --extra-ccflags="%{rpmcflags} %{rpmcppflags}" \
47         --extra-linkflags="%{rpmldflags}" \
48         --shared \
49         --verbose 6
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
54
55 kit=$(echo kits/xed-install-base-*)
56 install $kit/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
57 cp -pr $kit/include/xed $RPM_BUILD_ROOT%{_includedir}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post   -p /sbin/ldconfig
63 %postun -p /sbin/ldconfig
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README.md
68 %attr(755,root,root) %{_libdir}/libxed.so
69 %attr(755,root,root) %{_libdir}/libxed-ild.so
70
71 %files devel
72 %defattr(644,root,root,755)
73 %{_includedir}/xed
This page took 0.060612 seconds and 3 git commands to generate.