]> git.pld-linux.org Git - packages/intel-compute-runtime.git/blob - intel-compute-runtime.spec
c515d73dd6556c8f7a255e230ed073e1bdf8b17c
[packages/intel-compute-runtime.git] / intel-compute-runtime.spec
1
2 # versions listed on
3 # https://github.com/intel/compute-runtime/releases
4 %define gmmlib_version  19.2.1
5 %define igc_version 1.0.8
6
7 Summary:        Intel Graphics Compute Runtime for OpenCL
8 Name:           intel-compute-runtime
9 Version:        19.24.13171
10 Release:        2
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        https://github.com/intel/compute-runtime/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  c827cb2987d11e65a0f25befee0bbcb1
15 URL:            https://01.org/compute-runtime
16 BuildRequires:  cmake >= 3.2.0
17 BuildRequires:  intel-gmmlib-devel >= %{gmmlib_version}
18 BuildRequires:  intel-graphics-compiler-devel >= %{igc_version}
19 BuildRequires:  libdrm-devel
20 BuildRequires:  libva-devel
21 BuildRequires:  pkgconfig
22 Provides:       ocl-icd(intel)
23 Provides:       ocl-icd-driver
24 ExclusiveArch:  %{x8664}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Intel(R) Graphics Compute Runtime for OpenCL(TM) is an open source
29 project to converge Intel's development efforts on OpenCL(TM) compute
30 stacks supporting the GEN graphics hardware architecture.
31
32 %prep
33 %setup -qn compute-runtime-%{version}
34
35 %build
36 install -d build
37 cd build
38 %cmake \
39         -DSKIP_ALL_ULT=ON \
40                 ../
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} -C build install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %attr(755,root,root) %{_bindir}/ocloc
55 %{_sysconfdir}/OpenCL/vendors/intel.icd
56 %dir %{_libdir}/intel-opencl
57 %attr(755,root,root) %{_libdir}/intel-opencl/libigdrcl.so
This page took 0.172779 seconds and 2 git commands to generate.