]> git.pld-linux.org Git - packages/insync.git/blob - insync.spec
e49ab1e97ea16ddee2594e6543b4bc29e9ac84dc
[packages/insync.git] / insync.spec
1 # TODO
2 # - use python-gdata?
3 # - todo, gnome, cinnamon, kde subpackages
4 #   https://forums.insynchq.com/discussion/1437/insync-for-linux-beta-4-0-9-19
5 # - if other DE .desktop added, fill them with OnlyShowIn fields
6 # - check over bundled libs -- rpm -qp --provides ..| grep ^lib | sed -e 's,(.*,,' | sort -u | sed -e 's,^,/usr/lib64/,' | xargs rpm -qf | sort -u
7 #   Qt4, flac, x11*, expat, gst*, vorbis, orc
8 Summary:        Insync - Your Google Docs backup and sync tool
9 Name:           insync
10 Version:        0.10.5
11 Release:        0.5
12 License:        ?
13 Group:          X11/Applications
14 # DownloadUrl: https://www.insynchq.com/linux
15 Source0:        http://s.insynchq.com/builds/%{name}-beta_%{version}_i386.deb
16 # NoSource0-md5:        1b5f38aa68c8495d51c83d92202b9ce6
17 NoSource:       0
18 Source1:        http://s.insynchq.com/builds/%{name}-beta_%{version}_amd64.deb
19 # NoSource1-md5:        0397e2edafc3391179c9762254d95789
20 NoSource:       0
21 Source2:        http://s.insynchq.com/builds/%{name}-beta-mate_%{version}_i386.deb
22 # NoSource2-md5:        f6297b2109d2064c8ad95055e5690f66
23 NoSource:       2
24 Source3:        http://s.insynchq.com/builds/%{name}-beta-mate_%{version}_amd64.deb
25 # NoSource3-md5:        5d13065677de9d60eec8050efd5cce5b
26 NoSource:       2
27 URL:            https://www.insynchq.com/
28 BuildRequires:  rpm-utils
29 BuildRequires:  sed >= 4.0
30 Requires:       glib2
31 Requires:       gtk-update-icon-cache
32 Requires:       gvfs
33 Requires:       nautilus-python
34 Requires:       python-gevent
35 Requires:       xdotool
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _appdir                 %{_libdir}/%{name}
39 %define         caja_pyextdir   /usr/share/caja-python/extensions
40
41 # a zip and executable at the same time
42 %define         _noautostrip    .*/library.zip\\|.*/insync\\|.*/py
43
44 # bunch of Python symbols
45 %define         skip_post_check_so libpyglib-gi-2.0-python2.7.so.0
46
47 # Filter GLIBC_PRIVATE Requires
48 %define         _noautoreq      (GLIBC_PRIVATE)
49
50 # we don't want these to be provided as system libraries
51 %define         _noautoprov             libcrypto.so.1.0.0 libz.so.1 libsqlite3.so.0 libreadline.so.6 libdbus-glib-1.so.2
52 # and as we don't provide them, don't require either
53 %define         _noautoreq              %{_noautoprov}
54
55 %description
56 Insync is Google Drive for business and power users that sync and
57 supports multiple accounts and offline Google Docs editing using local
58 applications.
59
60 %package -n caja-insync
61 Summary:        Insync context menu and emblems for Caja
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       mate-file-manager
64
65 %description -n caja-insync
66 Insync context menu and emblems for Mate File Manager (Caja).
67
68 %prep
69 %setup -qcT
70 %ifarch %{ix86}
71 SOURCE1=%{SOURCE0}
72 SOURCE2=%{SOURCE2}
73 %endif
74 %ifarch %{x8664}
75 SOURCE1=%{SOURCE1}
76 SOURCE2=%{SOURCE3}
77 %endif
78 %if 0
79 rpm2cpio $SOURCE | cpio -i -d
80 %else
81 ar x $SOURCE1
82 tar xzf data.tar.gz
83 ar x $SOURCE2
84 tar xzf data.tar.gz
85 %endif
86
87 mv usr/bin .
88 mv usr/lib/insync lib
89 mv usr/share/icons .
90
91 # mate
92 mv usr/share/applications/*.desktop .
93 cp -p insync.desktop insync-mate.desktop
94 mv usr/share/caja-python .
95
96 # make into symlink, looks cleaner than hardlink:
97 # we can attach executable attrs to binary and leave no attrs for symlink in
98 # %files section.
99 cmp lib/{insync,library.zip}
100 ln -sf insync lib/library.zip
101
102 %{__sed} -i -e '
103         1s,/bin/bash,/bin/sh,
104 s,%{_prefix}/lib/insync,%{_appdir},
105 ' bin/%{name}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_bindir},%{_appdir},%{_iconsdir},%{_desktopdir},%{caja_pyextdir}}
110
111 cp -a lib/* $RPM_BUILD_ROOT%{_appdir}
112 install -p bin/* $RPM_BUILD_ROOT%{_bindir}
113 cp -a icons/* $RPM_BUILD_ROOT%{_iconsdir}
114
115 # mate
116 cp -p insync-mate.desktop $RPM_BUILD_ROOT%{_desktopdir}
117 cp -a caja-python/extensions/*  $RPM_BUILD_ROOT%{caja_pyextdir}
118
119 %post
120 %update_icon_cache hicolor
121
122 %postun
123 %update_icon_cache hicolor
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 #%doc README.txt COMMAND_LINE_HELP.txt
131 %attr(755,root,root) %{_bindir}/insync*
132 %dir %{_appdir}
133 %attr(755,root,root) %{_appdir}/*.so*
134 %attr(755,root,root) %{_appdir}/insync
135 %{_appdir}/library.zip
136 #%{_iconsdir}/hicolor/*/emblems/*.png
137 %dir %{_iconsdir}/insync
138 %{_iconsdir}/insync/icons
139 #%{_iconsdir}/insync/Francesco-icons
140
141 %{_appdir}/res
142 %dir %{_appdir}/gevent-0.13.8-py*.egg
143 %{_appdir}/gevent-0.13.8-py*.egg/EGG-INFO
144 %dir %{_appdir}/gevent-0.13.8-py*.egg/gevent
145 %{_appdir}/gevent-0.13.8-py*.egg/gevent/*.py[co]
146 %attr(755,root,root) %{_appdir}/gevent-0.13.8-py*.egg/gevent/core.so
147
148 %dir %{_appdir}/greenlet-0.4.0-py*.egg
149 %{_appdir}/greenlet-0.4.0-py*.egg/EGG-INFO
150 %{_appdir}/greenlet-0.4.0-py*.egg/greenlet.py[co]
151 %attr(755,root,root) %{_appdir}/greenlet-0.4.0-py*.egg/greenlet.so
152
153 %dir %{_appdir}/faulthandler-2.1-py*.egg
154 %{_appdir}/faulthandler-2.1-py*.egg/EGG-INFO
155 %{_appdir}/faulthandler-2.1-py*.egg/*.py[co]
156 %attr(755,root,root) %{_appdir}/faulthandler-2.1-py*.egg/faulthandler.so
157
158 %dir %{_appdir}/notify2-0.3-py*.egg
159 %{_appdir}/notify2-0.3-py*.egg/notify2.py[co]
160 %{_appdir}/notify2-0.3-py*.egg/EGG-INFO
161
162 %dir %{_appdir}/pycrypto-2.6-py*.egg
163 %{_appdir}/pycrypto-2.6-py*.egg/Crypto
164 %{_appdir}/pycrypto-2.6-py*.egg/EGG-INFO
165
166 %dir %{_appdir}/python_ntlm-1.0.1-py*.egg
167 %{_appdir}/python_ntlm-1.0.1-py*.egg/ntlm
168 %{_appdir}/python_ntlm-1.0.1-py*.egg/EGG-INFO
169
170 %dir %{_appdir}/raven-3.1.0-py*.egg
171 %{_appdir}/raven-3.1.0-py*.egg/raven
172 %{_appdir}/raven-3.1.0-py*.egg/EGG-INFO
173
174 %files -n caja-insync
175 %defattr(644,root,root,755)
176 %{_desktopdir}/insync-mate.desktop
177 %{caja_pyextdir}/insync-caja-plugin.py
178 #%dir %{caja_pyextdir}/libgio
179 #%{caja_pyextdir}/libgio/__init__.py
180
181 # FIXME
182 %dir %{caja_pyextdir}
183 %dir %{_datadir}/caja-python
This page took 0.061217 seconds and 2 git commands to generate.