]> git.pld-linux.org Git - packages/insync.git/blob - insync.spec
more
[packages/insync.git] / insync.spec
1 # TODO
2 # - use python-gdata?
3 # - todo, gnome, cinnamon, kde subpackages
4 #   https://forums.insynchq.com/discussion/1437/insync-for-linux-beta-4-0-9-19
5 # - if other DE .desktop added, fill them with OnlyShowIn fields
6 # - check over bundled libs -- rpm -qp --provides ..| grep ^lib | sed -e 's,(.*,,' | sort -u | sed -e 's,^,/usr/lib64/,' | xargs rpm -qf | sort -u
7 #   Qt4, flac, x11*, expat, gst*, vorbis, orc
8 Summary:        Insync - Your Google Docs backup and sync tool
9 Name:           insync
10 Version:        0.10.5
11 Release:        0.5
12 License:        ?
13 Group:          X11/Applications
14 # DownloadUrl: https://www.insynchq.com/linux
15 Source0:        http://s.insynchq.com/builds/%{name}-beta_%{version}_i386.deb
16 # NoSource0-md5:        1b5f38aa68c8495d51c83d92202b9ce6
17 NoSource:       0
18 Source1:        http://s.insynchq.com/builds/%{name}-beta_%{version}_amd64.deb
19 # NoSource1-md5:        0397e2edafc3391179c9762254d95789
20 NoSource:       0
21 Source2:        http://s.insynchq.com/builds/%{name}-beta-mate_%{version}_i386.deb
22 # NoSource2-md5:        f6297b2109d2064c8ad95055e5690f66
23 NoSource:       2
24 Source3:        http://s.insynchq.com/builds/%{name}-beta-mate_%{version}_amd64.deb
25 # NoSource3-md5:        5d13065677de9d60eec8050efd5cce5b
26 NoSource:       2
27 URL:            https://www.insynchq.com/
28 BuildRequires:  rpm-utils
29 BuildRequires:  sed >= 4.0
30 Requires:       glib2
31 Requires:       gtk-update-icon-cache
32 Requires:       gvfs
33 Requires:       nautilus-python
34 Requires:       python-gevent
35 Requires:       xdotool
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _appdir                 %{_libdir}/%{name}
39 %define         caja_pyextdir   /usr/share/caja-python/extensions
40
41 # a zip and executable at the same time
42 %define         _noautostrip    .*/library.zip\\|.*/insync\\|.*/py
43
44 # bunch of Python symbols
45 %define         skip_post_check_so libpyglib-gi-2.0-python2.7.so.0
46
47 # Filter GLIBC_PRIVATE Requires
48 %define         _noautoreq      (GLIBC_PRIVATE)
49
50 # we don't want these to be provided as system libraries
51 %define         _noautoprov             libcrypto.so.1.0.0 libz.so.1 libsqlite3.so.0 libreadline.so.6 libdbus-glib-1.so.2 libgio-2.0.so.0 libICE.so.6 libSM.so.6
52
53 # and as we don't provide them, don't require either
54 %define         _noautoreq              %{_noautoprov}
55
56 %description
57 Insync is Google Drive for business and power users that sync and
58 supports multiple accounts and offline Google Docs editing using local
59 applications.
60
61 %package -n caja-insync
62 Summary:        Insync context menu and emblems for Caja
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       mate-file-manager
65
66 %description -n caja-insync
67 Insync context menu and emblems for Mate File Manager (Caja).
68
69 %prep
70 %setup -qcT
71 %ifarch %{ix86}
72 SOURCE1=%{SOURCE0}
73 SOURCE2=%{SOURCE2}
74 %endif
75 %ifarch %{x8664}
76 SOURCE1=%{SOURCE1}
77 SOURCE2=%{SOURCE3}
78 %endif
79 %if 0
80 rpm2cpio $SOURCE | cpio -i -d
81 %else
82 ar x $SOURCE1
83 tar xzf data.tar.gz
84 ar x $SOURCE2
85 tar xzf data.tar.gz
86 %endif
87
88 mv usr/bin .
89 mv usr/lib/insync lib
90 mv usr/share/icons .
91
92 # mate
93 mv usr/share/applications/*.desktop .
94 cp -p insync.desktop insync-mate.desktop
95 mv usr/share/caja-python .
96
97 # make into symlink, looks cleaner than hardlink:
98 # we can attach executable attrs to binary and leave no attrs for symlink in
99 # %files section.
100 cmp lib/{insync,library.zip}
101 ln -sf insync lib/library.zip
102
103 %{__sed} -i -e '
104         1s,/bin/bash,/bin/sh,
105 s,%{_prefix}/lib/insync,%{_appdir},
106 ' bin/%{name}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_bindir},%{_appdir},%{_iconsdir},%{_desktopdir},%{caja_pyextdir}}
111
112 cp -a lib/* $RPM_BUILD_ROOT%{_appdir}
113 install -p bin/* $RPM_BUILD_ROOT%{_bindir}
114 cp -a icons/* $RPM_BUILD_ROOT%{_iconsdir}
115
116 # mate
117 cp -p insync-mate.desktop $RPM_BUILD_ROOT%{_desktopdir}
118 cp -a caja-python/extensions/*  $RPM_BUILD_ROOT%{caja_pyextdir}
119
120 %post
121 %update_icon_cache hicolor
122
123 %postun
124 %update_icon_cache hicolor
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files
130 %defattr(644,root,root,755)
131 #%doc README.txt COMMAND_LINE_HELP.txt
132 %attr(755,root,root) %{_bindir}/insync*
133 %dir %{_appdir}
134 %attr(755,root,root) %{_appdir}/*.so*
135 %attr(755,root,root) %{_appdir}/insync
136 %{_appdir}/library.zip
137 #%{_iconsdir}/hicolor/*/emblems/*.png
138 %dir %{_iconsdir}/insync
139 %{_iconsdir}/insync/icons
140 #%{_iconsdir}/insync/Francesco-icons
141
142 %{_appdir}/res
143 %dir %{_appdir}/gevent-0.13.8-py*.egg
144 %{_appdir}/gevent-0.13.8-py*.egg/EGG-INFO
145 %dir %{_appdir}/gevent-0.13.8-py*.egg/gevent
146 %{_appdir}/gevent-0.13.8-py*.egg/gevent/*.py[co]
147 %attr(755,root,root) %{_appdir}/gevent-0.13.8-py*.egg/gevent/core.so
148
149 %dir %{_appdir}/greenlet-0.4.0-py*.egg
150 %{_appdir}/greenlet-0.4.0-py*.egg/EGG-INFO
151 %{_appdir}/greenlet-0.4.0-py*.egg/greenlet.py[co]
152 %attr(755,root,root) %{_appdir}/greenlet-0.4.0-py*.egg/greenlet.so
153
154 %dir %{_appdir}/faulthandler-2.1-py*.egg
155 %{_appdir}/faulthandler-2.1-py*.egg/EGG-INFO
156 %{_appdir}/faulthandler-2.1-py*.egg/*.py[co]
157 %attr(755,root,root) %{_appdir}/faulthandler-2.1-py*.egg/faulthandler.so
158
159 %dir %{_appdir}/notify2-0.3-py*.egg
160 %{_appdir}/notify2-0.3-py*.egg/notify2.py[co]
161 %{_appdir}/notify2-0.3-py*.egg/EGG-INFO
162
163 %dir %{_appdir}/pycrypto-2.6-py*.egg
164 %{_appdir}/pycrypto-2.6-py*.egg/Crypto
165 %{_appdir}/pycrypto-2.6-py*.egg/EGG-INFO
166
167 %dir %{_appdir}/python_ntlm-1.0.1-py*.egg
168 %{_appdir}/python_ntlm-1.0.1-py*.egg/ntlm
169 %{_appdir}/python_ntlm-1.0.1-py*.egg/EGG-INFO
170
171 %dir %{_appdir}/raven-3.1.0-py*.egg
172 %{_appdir}/raven-3.1.0-py*.egg/raven
173 %{_appdir}/raven-3.1.0-py*.egg/EGG-INFO
174
175 %files -n caja-insync
176 %defattr(644,root,root,755)
177 %{_desktopdir}/insync-mate.desktop
178 %{caja_pyextdir}/insync-caja-plugin.py
179 #%dir %{caja_pyextdir}/libgio
180 #%{caja_pyextdir}/libgio/__init__.py
181
182 # FIXME
183 %dir %{caja_pyextdir}
184 %dir %{_datadir}/caja-python
This page took 0.083677 seconds and 3 git commands to generate.