]> git.pld-linux.org Git - packages/imlib2.git/blob - imlib2.spec
- updated to 1.10.0
[packages/imlib2.git] / imlib2.spec
1 #
2 # Conditional build:
3 %bcond_with     ps            # enable postscript support
4
5 Summary:        Powerful image loading and rendering library
6 Summary(pl.UTF-8):      Potężna biblioteka wczytująca i renderująca obrazki
7 Name:           imlib2
8 Version:        1.10.0
9 Release:        1
10 License:        BSD-like
11 Group:          X11/Libraries
12 Source0:        https://downloads.sourceforge.net/enlightenment/%{name}-%{version}.tar.xz
13 # Source0-md5:  8f692caffa3069d0da2aa87aa6cf5444
14 URL:            https://docs.enlightenment.org/api/imlib2/html/
15 BuildRequires:  autoconf >= 2.52
16 BuildRequires:  automake >= 1.6
17 BuildRequires:  bzip2-devel
18 BuildRequires:  doxygen
19 BuildRequires:  freetype-devel >= 2.1
20 BuildRequires:  giflib-devel
21 BuildRequires:  libheif-devel
22 BuildRequires:  libid3tag-devel
23 BuildRequires:  libjpeg-devel >= 6b-18
24 BuildRequires:  libjxl-devel
25 BuildRequires:  libpng-devel >= 1.0.8
26 BuildRequires:  librsvg-devel >= 2.46
27 %{?with_ps:BuildRequires:    libspectre-devel}
28 BuildRequires:  libtiff-devel >= 4
29 BuildRequires:  libtool >= 2:2
30 BuildRequires:  libwebp-devel
31 BuildRequires:  libxcb-devel >= 1.9
32 BuildRequires:  openjpeg2-devel >= 2
33 BuildRequires:  pkgconfig
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xorg-lib-libX11-devel
36 BuildRequires:  xorg-lib-libXext-devel
37 BuildRequires:  xz
38 BuildRequires:  xz-devel
39 BuildRequires:  zlib-devel
40 Requires:       freetype >= 2.1
41 Requires:       libjpeg >= 6b-18
42 Requires:       libpng >= 1.0.8
43 Requires:       libxcb >= 1.9
44 Obsoletes:      libimlib2_1 < 2
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Imlib2 is an advanced replacement library for libraries like libXpm
49 that provides many more features with much greater flexibility and
50 speed than standard libraries, including font rasterization, rotation,
51 RGBA space rendering and blending, dynamic binary filters, scripting,
52 and more.
53
54 %description -l pl.UTF-8
55 Imlib2 jest zaawansowaną biblioteką, zamiennikiem takich bibliotek jak
56 libXpm. Imlib2 dostarcza o wiele więcej możliwości przy dużo większej
57 szybkości niż standardowe biblioteki (włączając w to rasteryzację
58 fontów, obracanie, renderowanie przestrzeni RGBA, mieszanie,
59 dynamiczne filtry (w postaci binarnej), obsługa języka skryptowego i
60 wiele więcej.
61
62 %package devel
63 Summary:        Imlib2 header files and development documentation
64 Summary(fr.UTF-8):      Fichiers entête pour Imlib2
65 Summary(pl.UTF-8):      Pliki nagłówkowe oraz dokumentacja do imlib2
66 Group:          X11/Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       freetype-devel
69 Requires:       libltdl-devel
70 Requires:       xorg-lib-libXext-devel
71 Obsoletes:      libimlib2_1-devel < 2
72
73 %description devel
74 Header files and development documentation for Imlib2.
75
76 %description devel -l fr.UTF-8
77 Fichiers entête pour Imlib2.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe oraz dokumentacja do biblioteki Imlib2.
81
82 %package static
83 Summary:        Imlib2 static library
84 Summary(pl.UTF-8):      Biblioteka statyczna imlib2
85 Group:          X11/Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87
88 %description static
89 Imlib2 static library.
90
91 %description static -l pl.UTF-8
92 Biblioteka statyczna imlib2.
93
94 %prep
95 %setup -q
96
97 # missing in dist tarball, make a stub
98 install -d test
99 touch test/Makefile.am
100
101 %build
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure \
108         --disable-silent-rules \
109         --enable-doc-build \
110         %{!?with_ps:--without-ps} \
111 %ifarch i586 i686 pentium3 pentium4 athlon
112         --enable-mmx \
113 %else
114         --disable-mmx \
115 %endif
116 %ifarch %{x8664}
117         --enable-amd64 \
118 %endif
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 # not needed
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/imlib2/*/*.la
130 # obsoleted by pkg-config
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libImlib2.la
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS COPYING COPYING-PLAIN ChangeLog README
142 %attr(755,root,root) %{_bindir}/imlib2_*
143 %attr(755,root,root) %{_libdir}/libImlib2.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libImlib2.so.1
145 %dir %{_libdir}/imlib2
146 %dir %{_libdir}/imlib2/filters
147 %attr(755,root,root) %{_libdir}/imlib2/filters/*.so
148 %dir %{_libdir}/imlib2/loaders
149 %attr(755,root,root) %{_libdir}/imlib2/loaders/*.so
150 %{_datadir}/imlib2
151
152 %files devel
153 %defattr(644,root,root,755)
154 %doc doc/html
155 %attr(755,root,root) %{_libdir}/libImlib2.so
156 %{_includedir}/Imlib2.h
157 %{_includedir}/Imlib2_Loader.h
158 %{_pkgconfigdir}/imlib2.pc
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/libImlib2.a
This page took 0.076121 seconds and 3 git commands to generate.