]> git.pld-linux.org Git - packages/ilixi.git/blob - ilixi.spec
23bbfdd27996b7ea8d25a5bcdad3539c4fb6d32e
[packages/ilixi.git] / ilixi.spec
1 # TODO:
2 # - reflex
3 # - baresip_dale.h for SIP?
4 #
5 # Conditional build:
6 %bcond_without  static_libs     # don't build static libraries
7 %bcond_without  fusiondale      # FusionDale support
8 %bcond_without  fusionsound     # FusionSound support
9 %bcond_with     reflex          # Reflex support [experimantal, BR: libReflex]
10 %bcond_without  sawman          # (SaWMan based) compositor and application manager features
11 %bcond_with     wnn             # Wnn support [experimental]
12 #
13 Summary:        Lightweight C++ user interface toolkit for embedded Linux systems
14 Summary(pl.UTF-8):      Lekki toolkit C++ interfejsu użytkownika dla linuksowych systemów wbudowanych
15 Name:           ilixi
16 Version:        1.0.0
17 Release:        6
18 License:        LGPL v2+
19 Group:          Libraries
20 Source0:        http://www.directfb.org/downloads/Libs/%{name}-%{version}.tar.gz
21 # Source0-md5:  c1cf8c2b0e31870df2970ff2f4a42de2
22 Patch0:         %{name}-link.patch
23 Patch1:         c++98.patch
24 URL:            http://www.ilixi.org/
25 BuildRequires:  DirectFB-devel >= 1:1.6.3
26 %{?with_wnn:BuildRequires:      FreeWnn-devel}
27 %{?with_fusiondale:BuildRequires:       FusionDale-devel >= 0.8.2}
28 %{?with_fusionsound:BuildRequires:      FusionSound-devel >= 1.6.0}
29 %{?with_sawman:BuildRequires:   SaWMan-devel >= 1.6.0}
30 BuildRequires:  autoconf >= 2.65
31 BuildRequires:  automake
32 BuildRequires:  doxygen
33 BuildRequires:  fontconfig-devel >= 1:2.6.0
34 BuildRequires:  libtool >= 2:2
35 BuildRequires:  libsigc++-devel >= 2.2.4.2
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libxml2-devel >= 1:2.7.7
38 BuildRequires:  pkgconfig
39 Requires:       DirectFB >= 1:1.6.3
40 %{?with_fusiondale:Requires:    FusionDale >= 0.8.2}
41 %{?with_fusionsound:Requires:   FusionSound >= 1.6.0}
42 %{?with_sawman:Requires:        SaWMan >= 1.6.0}
43 Requires:       fontconfig-libs >= 1:2.6.0
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 ilixi is an open-source lightweight GUI framework and it is designed
48 with Linux based embedded devices in mind. ilixi uses DirectFB at its
49 core in order to render all graphics content to a Linux framebuffer
50 device. This eliminates the need for X server.
51
52 %description -l pl.UTF-8
53 ilixi to mający otwarte źródła lekki szkielet GUI, zaprojektowany z
54 myślą o urządzeniach z wbudowanym Linuksem. ilixi wykorzystuje
55 DirectFB w celu rysowania grafiki na linuksowym framebufferze, co
56 eliminuje potrzebę serwera X.
57
58 %package devel
59 Summary:        Header files for ilixi library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ilixi
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       DirectFB-devel >= 1:1.6.3
64 %{?with_wnn:Requires:   FreeWnn-devel}
65 %{?with_fusiondale:Requires:    FusionDale-devel >= 0.8.2}
66 %{?with_fusionsound:Requires:   FusionSound-devel >= 1.6.0}
67 %{?with_sawman:Requires:        SaWMan-devel >= 1.6.0}
68 Requires:       fontconfig-devel >= 1:2.6.0
69 Requires:       libsigc++-devel >= 2.2.4.2
70 Requires:       libstdc++-devel
71 Requires:       libxml2-devel >= 1:2.7.7
72
73 %description devel
74 Header files for ilixi library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki ilixi.
78
79 %package static
80 Summary:        Static ilixi library
81 Summary(pl.UTF-8):      Statyczna biblioteka ilixi
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static ilixi library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka ilixi.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95
96 %build
97 %{__libtoolize}
98 %{__aclocal} -I config/m4
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         %{?with_fusiondale:--enable-fusiondale} \
104         %{?with_fusionsound:--enable-fusionsound} \
105         --enable-nls \
106         %{?with_reflex:--enable-reflex} \
107         %{?with_sawman:--enable-sawman} \
108         --disable-silent-rules \
109         %{!?with_static_libs:--disable-static} \
110         %{?with_wnn:--enable-wnn}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 install examples/*.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog NEWS README TODO
131 %attr(755,root,root) %{_bindir}/ilixi_*
132 %attr(755,root,root) %{_libdir}/libilixi-1.0.0-1.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libilixi-1.0.0-1.0.so.0
134 %{_datadir}/ilixi-1.0.0
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libilixi-1.0.0.so
139 %{_libdir}/libilixi-1.0.0.la
140 %{_includedir}/ilixi-1.0.0
141 %{_pkgconfigdir}/ilixi.pc
142 %{_examplesdir}/%{name}-%{version}
143
144 %if %{with static_libs}
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libilixi-1.0.0.a
148 %endif
This page took 0.055317 seconds and 2 git commands to generate.