]> git.pld-linux.org Git - packages/icu.git/blob - icu.spec
- up to 52.1
[packages/icu.git] / icu.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 %define         ver     %(echo %{version} | tr . _)
6 Summary:        International Components for Unicode
7 Summary(pl.UTF-8):      Międzynarodowe komponenty dla unikodu
8 Name:           icu
9 Version:        52.1
10 Release:        1
11 License:        MIT-like
12 Group:          Libraries
13 Source0:        http://download.icu-project.org/files/icu4c/%{version}/%{name}4c-%{ver}-src.tgz
14 # Source0-md5:  9e96ed4c1d99c0d14ac03c140f9f346c
15 Patch0:         ac264-hack.patch
16 URL:            http://www.icu-project.org/
17 BuildRequires:  autoconf >= 2.68
18 BuildRequires:  libstdc++-devel
19 Requires:       libicu = %{version}-%{release}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 ICU is a set of C and C++ libraries that provides robust and
24 full-featured Unicode and locale support. The library provides
25 calendar support, conversions for many character sets, language
26 sensitive collation, date and time formatting, support for many
27 locales, message catalogs and resources, message formatting,
28 normalization, number and currency formatting, time zones support,
29 transliteration, word, line and sentence breaking, etc.
30
31 This package contains the Unicode character database and derived
32 properties, along with converters and time zones data.
33
34 %description -l pl.UTF-8
35 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
36 obsługę Unikodu i lokalizacji. Biblioteka dostarcza obsługę
37 kalendarza, konwersje dla wielu zestawów znaków, sortowanie zależne od
38 języka, formatowanie daty i czasu, wsparcie dla wielu lokalizacji,
39 katalogów komunikatów i zasobów, formatowanie komunikatów,
40 normalizację, formatowanie liczb i walut, obsługę stref czasowych,
41 transliterację, łamanie słów, linii i zdań itp.
42
43 Ten pakiet zawiera bazę znaków unikodowych i pochodne własności wraz z
44 konwerterami i danymi stref czasowych.
45
46 %package -n libicu
47 Summary:        International Components for Unicode (libraries)
48 Summary(pl.UTF-8):      Międzynarodowe Komponenty dla Unikodu (biblioteki)
49 Group:          Libraries
50 Obsoletes:      libicu30
51
52 %description -n libicu
53 ICU is a set of C and C++ libraries that provides robust and
54 full-featured Unicode support. This package contains the runtime
55 libraries for ICU. It does not contain any of the data files needed at
56 runtime and present in the `icu' package.
57
58 %description -n libicu -l pl.UTF-8
59 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
60 obsługę Unikodu i lokalizacji. Ten pakiet zawiera biblioteki
61 uruchomieniowe ICU. Nie zawiera żadnych plików z danymi potrzebnymi w
62 czasie działania i obecnymi w pakietach "icu".
63
64 %package -n libicu-devel
65 Summary:        International Components for Unicode (development files)
66 Summary(pl.UTF-8):      Międzynarodowe komponenty dla Unikodu (pliki dla programistów)
67 Group:          Development/Libraries
68 Requires:       libicu = %{version}-%{release}
69
70 %description -n libicu-devel
71 ICU is a set of C and C++ libraries that provides robust and
72 full-featured Unicode support. This package contains the development
73 files for ICU.
74
75 %description -n libicu-devel -l pl.UTF-8
76 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
77 obsługę Unikodu i lokalizacji. Ten pakiet zawiera pliki
78 programistyczne ICU.
79
80 %package -n libicu-static
81 Summary:        International Components for Unicode (static libraries)
82 Summary(pl.UTF-8):      Międzynarodowe komponenty dla Unikodu (biblioteki statyczne)
83 Group:          Development/Libraries
84 Requires:       libicu-devel = %{version}-%{release}
85
86 %description -n libicu-static
87 ICU is a set of C and C++ libraries that provides robust and
88 full-featured Unicode support. This package contains the static 
89 libraries for ICU.
90
91 %description -n libicu-static -l pl.UTF-8
92 ICU jest grupą bibliotek C i C++, które dostarczają kompletną i pełną
93 obsługę Unikodu i lokalizacji. Ten pakiet zawiera statyczne
94 biblioteki programistyczne ICU.
95
96 %prep
97 %setup -q -n %{name}
98 %patch0 -p1
99
100 %build
101 cd source
102 %{__autoconf}
103 %configure \
104         --sbindir=%{_bindir} \
105         --with-data-packaging=library \
106         %{?with_static_libs:--enable-static} \
107         --disable-samples
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} -C source install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 for f in icu-i18n icu-io icu-le icu-lx icu-uc ; do
118 sed -i \
119         -e 's/\$(THREADSCXXFLAGS)//' \
120         -e 's/\$(THREADSCFLAGS)//' \
121         -e 's/\$(THREADSCPPFLAGS)/-D_REENTRANT/' $RPM_BUILD_ROOT%{_pkgconfigdir}/${f}.pc
122 done
123
124 # help rpm to generate deps
125 chmod +x $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
126
127 # rpm is too stupid sometimes and fails on symlinks to symlinked resources
128 # (reporting unresolved dependency at install time)
129 for f in Makefile.inc pkgdata.inc ; do
130         ln -sf %{version}/${f} $RPM_BUILD_ROOT%{_libdir}/%{name}/${f}
131 done
132
133 %{__rm} $RPM_BUILD_ROOT%{_datadir}/icu/%{version}/license.html
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -n libicu -p /sbin/ldconfig
139 %postun -n libicu -p /sbin/ldconfig
140
141 %files
142 %defattr(644,root,root,755)
143 %doc license.html readme.html
144 %attr(755,root,root) %{_bindir}/derb
145 %attr(755,root,root) %{_bindir}/gen*
146 %attr(755,root,root) %{_bindir}/icuinfo
147 %attr(755,root,root) %{_bindir}/icupkg
148 %attr(755,root,root) %{_bindir}/makeconv
149 %attr(755,root,root) %{_bindir}/pkgdata
150 %attr(755,root,root) %{_bindir}/uconv
151 %{_mandir}/man1/derb.1*
152 %{_mandir}/man1/gen*.1*
153 %{_mandir}/man1/makeconv.1*
154 %{_mandir}/man1/pkgdata.1*
155 %{_mandir}/man1/uconv.1*
156 %{_mandir}/man8/gen*.8*
157 %{_mandir}/man8/icupkg.8*
158
159 %files -n libicu
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libicu*.so.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libicu*.so.52
163
164 %files -n libicu-devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/icu-config
167 %attr(755,root,root) %{_libdir}/libicu*.so
168 %{_pkgconfigdir}/icu-i18n.pc
169 %{_pkgconfigdir}/icu-io.pc
170 %{_pkgconfigdir}/icu-le.pc
171 %{_pkgconfigdir}/icu-lx.pc
172 %{_pkgconfigdir}/icu-uc.pc
173 %{_includedir}/unicode
174 %{_includedir}/layout
175 %dir %{_libdir}/%{name}
176 %{_libdir}/%{name}/*.inc
177 %dir %{_libdir}/%{name}/current
178 %dir %{_libdir}/%{name}/%{version}
179 %{_libdir}/%{name}/%{version}/*.inc
180 %dir %{_datadir}/%{name}
181 %dir %{_datadir}/%{name}/%{version}
182 %{_datadir}/%{name}/%{version}/config
183 %attr(755,root,root) %{_datadir}/%{name}/%{version}/install-sh
184 %attr(755,root,root) %{_datadir}/%{name}/%{version}/mkinstalldirs
185 %{_mandir}/man1/icu-config.1*
186
187 %if %{with static_libs}
188 %files -n libicu-static
189 %defattr(644,root,root,755)
190 %{_libdir}/libicu*.a
191 %endif
This page took 0.097475 seconds and 3 git commands to generate.