]> git.pld-linux.org Git - packages/iceweasel.git/blob - iceweasel.spec
- added system xulrunner TODO
[packages/iceweasel.git] / iceweasel.spec
1 # TODO:
2 #  - fix build with system xulrunner (as of 20.0.1 iceweasel built with system xul doesn't work)
3 #  - provide proper $DISPLAY for PGO (Xvfb, Xdummy...) for unattended builds
4 #
5 # Conditional build:
6 %bcond_with     tests           # enable tests (whatever they check)
7 %bcond_without  gnomeui         # disable gnomeui support
8 %bcond_without  gnome           # synonym for gnomeui (gconf, libnotify and gio are still enabled)
9 %bcond_without  kerberos        # disable krb5 support
10 %bcond_with     xulrunner       # build without system xulrunner
11 %bcond_with     pgo             # PGO-enabled build (requires working $DISPLAY == :100)
12
13 %if %{without gnome}
14 %undefine       with_gnomeui
15 %endif
16
17 # convert firefox release number to platform version: 19.0.x -> 19.0.x
18 %define         xulrunner_main  20.0
19 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#20.0})
20
21 %if %{without xulrunner}
22 # The actual sqlite version (see RHBZ#480989):
23 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24 %endif
25
26 %define         nspr_ver        4.9.5
27 %define         nss_ver         3.14.3
28
29 Summary:        Iceweasel web browser
30 Summary(hu.UTF-8):      Iceweasel web böngésző
31 Summary(pl.UTF-8):      Iceweasel - przeglądarka WWW
32 Name:           iceweasel
33 Version:        20.0.1
34 Release:        3
35 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
36 Group:          X11/Applications/Networking
37 Source0:        http://releases.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
38 # Source0-md5:  b822ff4b2348410587dec563235d9320
39 Source1:        %{name}-branding.tar.bz2
40 # Source1-md5:  816d926bd2c76a5bba5108979ba776ac
41 Source2:        %{name}-rm_nonfree.sh
42 Source3:        %{name}.desktop
43 Source4:        %{name}.sh
44 Source5:        vendor.js
45 Source6:        vendor-ac.js
46 Patch0:         %{name}-branding.patch
47 Patch2:         %{name}-gcc3.patch
48 Patch7:         %{name}-prefs.patch
49 Patch8:         %{name}-pld-branding.patch
50 Patch9:         %{name}-no-subshell.patch
51 Patch10:        system-cairo.patch
52 Patch11:        %{name}-middle_click_paste.patch
53 Patch12:        %{name}-packaging.patch
54 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
55 Patch13:        system-virtualenv.patch
56 Patch14:        gyp-slashism.patch
57 URL:            http://www.pld-linux.org/Packages/Iceweasel
58 BuildRequires:  GConf2-devel >= 1.2.1
59 BuildRequires:  OpenGL-devel
60 BuildRequires:  ImageMagick
61 BuildRequires:  ImageMagick-coder-png
62 BuildRequires:  alsa-lib-devel
63 BuildRequires:  automake
64 BuildRequires:  bzip2-devel
65 BuildRequires:  cairo-devel >= 1.10.2-5
66 BuildRequires:  dbus-glib-devel >= 0.60
67 BuildRequires:  glib2-devel >= 1:2.20
68 BuildRequires:  gtk+2-devel >= 2:2.14
69 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
70 BuildRequires:  hunspell-devel
71 BuildRequires:  libIDL-devel >= 0.8.0
72 BuildRequires:  libdnet-devel
73 BuildRequires:  libevent-devel >= 1.4.7
74 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
75 BuildRequires:  libffi-devel >= 6:3.0.9
76 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
77 BuildRequires:  libiw-devel
78 # requires libjpeg-turbo implementing at least libjpeg 6b API
79 BuildRequires:  libjpeg-devel >= 6b
80 BuildRequires:  libjpeg-turbo-devel
81 BuildRequires:  libnotify-devel >= 0.4
82 BuildRequires:  libpng(APNG)-devel >= 0.10
83 BuildRequires:  libpng-devel >= 1.5.13
84 BuildRequires:  libstdc++-devel
85 BuildRequires:  libvpx-devel >= 1.0.0
86 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
87 BuildRequires:  nss-devel >= 1:%{nss_ver}
88 BuildRequires:  pango-devel >= 1:1.14.0
89 BuildRequires:  perl-modules >= 5.004
90 BuildRequires:  pkgconfig
91 BuildRequires:  pkgconfig(libffi) >= 3.0.9
92 BuildRequires:  python-modules
93 %{?with_pgo:BuildRequires:      python-modules-sqlite}
94 BuildRequires:  python-virtualenv
95 BuildRequires:  rpm >= 4.4.9-56
96 BuildRequires:  rpmbuild(macros) >= 1.601
97 BuildRequires:  sqlite3-devel >= 3.7.15.2
98 BuildRequires:  startup-notification-devel >= 0.8
99 BuildRequires:  xorg-lib-libXScrnSaver-devel
100 BuildRequires:  xorg-lib-libXext-devel
101 BuildRequires:  xorg-lib-libXinerama-devel
102 BuildRequires:  xorg-lib-libXt-devel
103 %if %{with xulrunner}
104 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
105 %endif
106 BuildRequires:  zip
107 BuildRequires:  zlib-devel >= 1.2.3
108 Requires(post): mktemp >= 1.5-18
109 Requires:       desktop-file-utils
110 Requires:       hicolor-icon-theme
111 %if %{with xulrunner}
112 %requires_eq_to xulrunner xulrunner-devel
113 %else
114 Requires:       browser-plugins >= 2.0
115 Requires:       cairo >= 1.10.2-5
116 Requires:       dbus-glib >= 0.60
117 Requires:       glib2 >= 1:2.20
118 Requires:       gtk+2 >= 2:2.14
119 Requires:       libjpeg-turbo
120 Requires:       libpng >= 1.5.13
121 Requires:       libpng(APNG) >= 0.10
122 Requires:       myspell-common
123 Requires:       nspr >= 1:%{nspr_ver}
124 Requires:       nss >= 1:%{nss_ver}
125 Requires:       pango >= 1:1.14.0
126 Requires:       sqlite3 >= %{sqlite_build_version}
127 Requires:       startup-notification >= 0.8
128 %endif
129 Provides:       wwwbrowser
130 Obsoletes:      mozilla-firebird
131 Obsoletes:      mozilla-firefox
132 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
133 Obsoletes:      mozilla-firefox-libs
134 Conflicts:      iceweasel-lang-resources < %{version}
135 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
136
137 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
138
139 # don't satisfy other packages
140 %define         _noautoprovfiles        %{_libdir}/%{name}
141 %if %{without xulrunner}
142 # and as we don't provide them, don't require either
143 %define         _noautoreq      libmozalloc.so libmozjs.so libxpcom.so libxul.so
144 %endif
145
146 %description
147 Iceweasel is an open-source web browser, designed for standards
148 compliance, performance and portability.
149
150 %description -l hu.UTF-8
151 Iceweasel egy nyílt forrású webböngésző, hatékonyságra és
152 hordozhatóságra tervezve.
153
154 %description -l pl.UTF-8
155 Iceweasel jest przeglądarką WWW rozpowszechnianą zgodnie z ideami
156 ruchu otwartego oprogramowania oraz tworzoną z myślą o zgodności ze
157 standardami, wydajnością i przenośnością.
158
159 %prep
160 %setup -qc
161 mv -f mozilla-release mozilla
162 %setup -q -T -D -a1
163 cd mozilla
164 /bin/sh %{SOURCE2}
165
166 %patch0 -p1
167
168 %if "%{cc_version}" < "3.4"
169 %patch2 -p2
170 %endif
171
172 %patch7 -p1
173 %patch8 -p1
174 %patch9 -p2
175 %patch10 -p2
176 %patch11 -p2
177 %patch12 -p2
178 %patch13 -p2
179 %patch14 -p2
180
181 # config/rules.mk is patched by us and js/src/config/rules.mk
182 # is supposed to be exact copy
183 cp -a config/rules.mk js/src/config/rules.mk
184
185 %if %{with pgo}
186 sed -i -e 's@__BROWSER_PATH__@"../../dist/bin/iceweasel-bin"@' build/automation.py.in
187 %endif
188
189 %build
190 cd mozilla
191 cp -f %{_datadir}/automake/config.* build/autoconf
192
193 cat << EOF > .mozconfig
194 . \$topsrcdir/browser/config/mozconfig
195
196 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
197 # parallel build fails on _xpidlgen/
198 %if %{without xulrunner}
199 mk_add_options MOZ_MAKE_FLAGS=%{_smp_mflags}
200 %endif
201 mk_add_options PROFILE_GEN_SCRIPT='@PYTHON@ @MOZ_OBJDIR@/_profile/pgo/profileserver.py'
202
203 # Options for 'configure' (same as command-line options).
204 ac_add_options --prefix=%{_prefix}
205 ac_add_options --exec-prefix=%{_exec_prefix}
206 ac_add_options --bindir=%{_bindir}
207 ac_add_options --sbindir=%{_sbindir}
208 ac_add_options --sysconfdir=%{_sysconfdir}
209 ac_add_options --datadir=%{_datadir}
210 ac_add_options --includedir=%{_includedir}
211 ac_add_options --libdir=%{_libdir}
212 ac_add_options --libexecdir=%{_libexecdir}
213 ac_add_options --localstatedir=%{_localstatedir}
214 ac_add_options --sharedstatedir=%{_sharedstatedir}
215 ac_add_options --mandir=%{_mandir}
216 ac_add_options --infodir=%{_infodir}
217 ac_add_options --disable-elf-hack
218 %if %{?debug:1}0
219 ac_add_options --disable-optimize
220 ac_add_options --enable-debug
221 ac_add_options --enable-debug-modules
222 ac_add_options --enable-debugger-info-modules
223 ac_add_options --enable-crash-on-assert
224 %else
225 ac_add_options --disable-debug
226 ac_add_options --disable-debug-modules
227 ac_add_options --disable-logging
228 ac_add_options --enable-optimize="%{rpmcflags} -Os"
229 %endif
230 ac_add_options --disable-strip
231 ac_add_options --disable-strip-libs
232 %if %{with tests}
233 ac_add_options --enable-tests
234 %else
235 ac_add_options --disable-tests
236 %endif
237 %if %{with gnomeui}
238 ac_add_options --enable-gnomeui
239 %else
240 ac_add_options --disable-gnomeui
241 %endif
242 ac_add_options --disable-gnomevfs
243 ac_add_options --disable-crashreporter
244 ac_add_options --disable-installer
245 ac_add_options --disable-javaxpcom
246 ac_add_options --disable-updater
247 ac_add_options --enable-gio
248 ac_add_options --enable-libxul
249 ac_add_options --enable-pango
250 ac_add_options --enable-shared-js
251 ac_add_options --enable-startup-notification
252 ac_add_options --enable-system-cairo
253 ac_add_options --enable-system-hunspell
254 ac_add_options --enable-system-sqlite
255 ac_add_options --with-distribution-id=org.pld-linux
256 ac_add_options --with-branding=iceweasel/branding
257 %if %{with xulrunner}
258 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
259 %endif
260 ac_add_options --with-pthreads
261 ac_add_options --with-system-bz2
262 ac_add_options --with-system-ffi
263 ac_add_options --with-system-jpeg
264 ac_add_options --with-system-libevent
265 ac_add_options --with-system-libvpx
266 ac_add_options --with-system-nspr
267 ac_add_options --with-system-nss
268 ac_add_options --with-system-png
269 ac_add_options --with-system-zlib
270 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
271 EOF
272
273 %if %{with pgo}
274 export DISPLAY=:100 
275 %{__make} -f client.mk profiledbuild \
276         DESTDIR=obj-%{_target_cpu}/dist \
277         STRIP="/bin/true" \
278         CC="%{__cc}" \
279         CXX="%{__cxx}"
280 %else
281 %{__make} -f client.mk build \
282         STRIP="/bin/true" \
283         CC="%{__cc}" \
284         CXX="%{__cxx}"
285 %endif
286
287 %install
288 rm -rf $RPM_BUILD_ROOT
289 cd mozilla
290 install -d \
291         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
292         $RPM_BUILD_ROOT%{_desktopdir} \
293         $RPM_BUILD_ROOT%{_datadir}/%{name} \
294         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
295
296 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
297
298 cd obj-%{_target_cpu}
299 %{__make} -C browser/installer stage-package \
300         DESTDIR=$RPM_BUILD_ROOT \
301         installdir=%{_libdir}/%{name} \
302         PKG_SKIP_STRIP=1
303
304 %{__make} -C iceweasel/branding install \
305         DESTDIR=$RPM_BUILD_ROOT
306
307 cp -a dist/iceweasel/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
308
309 %if %{with xulrunner}
310 # >= 5.0 seems to require this
311 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
312 %endif
313
314 # move arch independant ones to datadir
315 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
316 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
317 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
318 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
319 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
320 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
321 %if %{without xulrunner}
322 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
323 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
324 %endif
325
326 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
327 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
328 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
329 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
330 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
331 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
332 %if %{without xulrunner}
333 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
334 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
335 %endif
336
337 %if %{without xulrunner}
338 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
339 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
340 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
341 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
342 %endif
343
344 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE4} > $RPM_BUILD_ROOT%{_bindir}/iceweasel
345 chmod 755 $RPM_BUILD_ROOT%{_bindir}/iceweasel
346 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/firefox
347 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
348
349 # install icons and desktop file
350 cp iceweasel/branding/{mozicon,default}128.png
351 for i in 16 32 48 64 128; do
352         install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
353         cp -a iceweasel/branding/default${i}.png \
354                 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/iceweasel.png
355 done
356
357 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
358
359 # install our settings
360 %if %{without xulrunner}
361 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/pref/vendor.js
362 %else
363 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
364 %endif
365
366 %if "%{pld_release}" == "ac"
367 %if %{without xulrunner}
368 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/pref/vendor.js
369 %else
370 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
371 %endif
372 %endif
373
374 # files created by iceweasel -register
375 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
376 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
377
378 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
379 #!/bin/sh
380 umask 022
381 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
382
383 # it attempts to touch files in $HOME/.mozilla
384 # beware if you run this with sudo!!!
385 export HOME=$(mktemp -d)
386 # also TMPDIR could be pointing to sudo user's homedir
387 unset TMPDIR TMP || :
388
389 %{_libdir}/%{name}/iceweasel -register
390
391 rm -rf $HOME
392 EOF
393 chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
394
395 %clean
396 rm -rf $RPM_BUILD_ROOT
397
398 %pretrans
399 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
400         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
401 fi
402 for d in chrome defaults extensions greprefs.js icons res searchplugins; do
403         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
404                 install -d %{_datadir}/%{name}
405                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
406         fi
407 done
408 exit 0
409
410 %post
411 %{_sbindir}/%{name}-chrome+xpcom-generate
412 %update_browser_plugins
413 %update_icon_cache hicolor
414 %update_desktop_database
415
416 %postun
417 if [ "$1" = 0 ]; then
418         %update_browser_plugins
419         %update_icon_cache hicolor
420 fi
421
422 %files
423 %defattr(644,root,root,755)
424 %attr(755,root,root) %{_bindir}/%{name}
425 %attr(755,root,root) %{_bindir}/firefox
426 %attr(755,root,root) %{_bindir}/mozilla-firefox
427 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
428
429 # browser plugins v2
430 %{_browserpluginsconfdir}/browsers.d/%{name}.*
431 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
432
433 %dir %{_libdir}/%{name}
434 %if %{without xulrunner}
435 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
436 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
437 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
438 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
439 %endif
440 %{_libdir}/%{name}/blocklist.xml
441
442 %if %{with crashreporter}
443 %{_libdir}/%{name}/crashreporter
444 %{_libdir}/%{name}/crashreporter-override.ini
445 %{_libdir}/%{name}/crashreporter.ini
446 %{_libdir}/%{name}/Throbber-small.gif
447 %endif
448
449 # config?
450 %{_libdir}/%{name}/application.ini
451 %{_libdir}/%{name}/chrome.manifest
452
453 %dir %{_libdir}/%{name}/components
454
455 %{_libdir}/%{name}/components/ChromeProfileMigrator.js
456 %{_libdir}/%{name}/components/DownloadsStartup.js
457 %{_libdir}/%{name}/components/DownloadsUI.js
458 %{_libdir}/%{name}/components/FeedConverter.js
459 %{_libdir}/%{name}/components/FeedWriter.js
460 %{_libdir}/%{name}/components/FirefoxProfileMigrator.js
461 %{_libdir}/%{name}/components/PageThumbsProtocol.js
462 %{_libdir}/%{name}/components/PlacesProtocolHandler.js
463 %{_libdir}/%{name}/components/ProfileMigrator.js
464 %{_libdir}/%{name}/components/WebContentConverter.js
465 %{_libdir}/%{name}/components/browser.xpt
466 %{_libdir}/%{name}/components/fuelApplication.js
467 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
468 %{_libdir}/%{name}/components/nsBrowserGlue.js
469 %{_libdir}/%{name}/components/nsPrivateBrowsingServiceObsolete.js
470 %{_libdir}/%{name}/components/nsSessionStartup.js
471 %{_libdir}/%{name}/components/nsSessionStore.js
472 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
473 %{_libdir}/%{name}/components/nsSidebar.js
474
475 %{_libdir}/%{name}/components/components.manifest
476 %{_libdir}/%{name}/components/interfaces.manifest
477
478 %if %{without xulrunner}
479 %{_libdir}/%{name}/dependentlibs.list
480 %{_libdir}/%{name}/platform.ini
481 %{_libdir}/%{name}/components/addonManager.js
482 %{_libdir}/%{name}/components/Aitc.js
483 %{_libdir}/%{name}/components/AlarmsManager.js
484 %{_libdir}/%{name}/components/amContentHandler.js
485 %{_libdir}/%{name}/components/amWebInstallListener.js
486 %{_libdir}/%{name}/components/AppsService.js
487 %{_libdir}/%{name}/components/BrowserElementParent.js
488 %{_libdir}/%{name}/components/ColorAnalyzer.js
489 %{_libdir}/%{name}/components/ConsoleAPI.js
490 %{_libdir}/%{name}/components/ContactManager.js
491 %{_libdir}/%{name}/components/contentAreaDropListener.js
492 %{_libdir}/%{name}/components/contentSecurityPolicy.js
493 %{_libdir}/%{name}/components/crypto-SDR.js
494 %{_libdir}/%{name}/components/FeedProcessor.js
495 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
496 %{_libdir}/%{name}/components/jsconsole-clhandler.js
497 %{_libdir}/%{name}/components/messageWakeupService.js
498 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
499 %{_libdir}/%{name}/components/nsBadCertHandler.js
500 %{_libdir}/%{name}/components/nsBlocklistService.js
501 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
502 %{_libdir}/%{name}/components/nsContentPrefService.js
503 %{_libdir}/%{name}/components/nsDefaultCLH.js
504 %{_libdir}/%{name}/components/nsDOMIdentity.js
505 %{_libdir}/%{name}/components/nsDownloadManagerUI.js
506 %{_libdir}/%{name}/components/nsFilePicker.js
507 %{_libdir}/%{name}/components/nsFormAutoComplete.js
508 %{_libdir}/%{name}/components/nsFormHistory.js
509 %{_libdir}/%{name}/components/nsHandlerService.js
510 %{_libdir}/%{name}/components/nsHelperAppDlg.js
511 %{_libdir}/%{name}/components/nsIDService.js
512 %{_libdir}/%{name}/components/nsINIProcessor.js
513 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
514 %{_libdir}/%{name}/components/nsLivemarkService.js
515 %{_libdir}/%{name}/components/nsLoginInfo.js
516 %{_libdir}/%{name}/components/nsLoginManager.js
517 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
518 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
519 %{_libdir}/%{name}/components/nsPlacesExpiration.js
520 %{_libdir}/%{name}/components/nsPrompter.js
521 %{_libdir}/%{name}/components/nsSearchService.js
522 %{_libdir}/%{name}/components/nsSearchSuggestions.js
523 %{_libdir}/%{name}/components/nsTaggingService.js
524 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
525 %{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
526 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
527 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
528 %{_libdir}/%{name}/components/nsURLFormatter.js
529 %{_libdir}/%{name}/components/nsWebHandlerApp.js
530 %{_libdir}/%{name}/components/PeerConnection.js
531 %{_libdir}/%{name}/components/PermissionSettings.js
532 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
533 %{_libdir}/%{name}/components/SettingsManager.js
534 %{_libdir}/%{name}/components/SiteSpecificUserAgent.js
535 %{_libdir}/%{name}/components/storage-Legacy.js
536 %{_libdir}/%{name}/components/storage-mozStorage.js
537 %{_libdir}/%{name}/components/TCPSocket.js
538 %{_libdir}/%{name}/components/TCPSocketParentIntermediary.js
539 %{_libdir}/%{name}/components/TelemetryPing.js
540 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
541 %{_libdir}/%{name}/components/Weave.js
542 %{_libdir}/%{name}/components/Webapps.js
543 %endif
544
545 %{_libdir}/%{name}/webapprt
546 %attr(755,root,root) %{_libdir}/%{name}/webapprt-stub
547
548 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
549 %if %{without xulrunner}
550 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
551 %endif
552
553 %if %{without xulrunner}
554 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
555 %endif
556
557 %attr(755,root,root) %{_libdir}/%{name}/iceweasel
558 %dir %{_libdir}/%{name}/plugins
559 %if %{without xulrunner}
560 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
561 %attr(755,root,root) %{_libdir}/%{name}/iceweasel-bin
562 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
563 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
564 %endif
565
566 %{_iconsdir}/hicolor/*/*/iceweasel.png
567 %{_desktopdir}/iceweasel.desktop
568
569 # symlinks
570 %{_libdir}/%{name}/chrome
571 %{_libdir}/%{name}/defaults
572 %{_libdir}/%{name}/extensions
573 %{_libdir}/%{name}/icons
574 %{_libdir}/%{name}/modules
575 %{_libdir}/%{name}/searchplugins
576 %if %{with xulrunner}
577 %{_libdir}/%{name}/xulrunner
578 %else
579 %{_libdir}/%{name}/dictionaries
580 %{_libdir}/%{name}/hyphenation
581 %{_libdir}/%{name}/greprefs.js
582 %{_libdir}/%{name}/res
583 %endif
584
585 %dir %{_datadir}/%{name}
586 %{_datadir}/%{name}/chrome
587 %{_datadir}/%{name}/defaults
588 %{_datadir}/%{name}/icons
589 %{_datadir}/%{name}/modules
590 %{_datadir}/%{name}/searchplugins
591 %if %{without xulrunner}
592 %{_datadir}/%{name}/greprefs.js
593 %{_datadir}/%{name}/res
594 %endif
595
596 %dir %{_datadir}/%{name}/extensions
597 # the signature of the default theme
598 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
599
600 # files created by iceweasel -register
601 %ghost %{_libdir}/%{name}/components/compreg.dat
602 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.06551 seconds and 4 git commands to generate.