]> git.pld-linux.org Git - packages/iceweasel.git/blob - iceweasel.spec
- disabled system xulrunner due to iceweasel not working with it
[packages/iceweasel.git] / iceweasel.spec
1 # TODO:
2 #  - provide proper $DISPLAY for PGO (Xvfb, Xdummy...) for unattended builds
3 #
4 # Conditional build:
5 %bcond_with     tests           # enable tests (whatever they check)
6 %bcond_without  gnomeui         # disable gnomeui support
7 %bcond_without  gnome           # synonym for gnomeui (gconf, libnotify and gio are still enabled)
8 %bcond_without  kerberos        # disable krb5 support
9 %bcond_with     xulrunner       # build without system xulrunner
10 %bcond_with     pgo             # PGO-enabled build (requires working $DISPLAY == :100)
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 # convert firefox release number to platform version: 19.0.x -> 19.0.x
17 %define         xulrunner_main  20.0
18 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#20.0})
19
20 %if %{without xulrunner}
21 # The actual sqlite version (see RHBZ#480989):
22 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
23 %endif
24
25 %define         nspr_ver        4.9.5
26 %define         nss_ver         3.14.3
27
28 Summary:        Iceweasel web browser
29 Summary(hu.UTF-8):      Iceweasel web böngésző
30 Summary(pl.UTF-8):      Iceweasel - przeglądarka WWW
31 Name:           iceweasel
32 Version:        20.0.1
33 Release:        2
34 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
35 Group:          X11/Applications/Networking
36 Source0:        http://releases.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
37 # Source0-md5:  b822ff4b2348410587dec563235d9320
38 Source1:        %{name}-branding.tar.bz2
39 # Source1-md5:  816d926bd2c76a5bba5108979ba776ac
40 Source2:        %{name}-rm_nonfree.sh
41 Source3:        %{name}.desktop
42 Source4:        %{name}.sh
43 Source5:        vendor.js
44 Source6:        vendor-ac.js
45 Patch0:         %{name}-branding.patch
46 Patch2:         %{name}-gcc3.patch
47 Patch7:         %{name}-prefs.patch
48 Patch8:         %{name}-pld-branding.patch
49 Patch9:         %{name}-no-subshell.patch
50 Patch10:        system-cairo.patch
51 Patch11:        %{name}-middle_click_paste.patch
52 Patch12:        %{name}-packaging.patch
53 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
54 Patch13:        system-virtualenv.patch
55 URL:            http://www.pld-linux.org/Packages/Iceweasel
56 BuildRequires:  GConf2-devel >= 1.2.1
57 BuildRequires:  OpenGL-devel
58 BuildRequires:  ImageMagick
59 BuildRequires:  ImageMagick-coder-png
60 BuildRequires:  alsa-lib-devel
61 BuildRequires:  automake
62 BuildRequires:  bzip2-devel
63 BuildRequires:  cairo-devel >= 1.10.2-5
64 BuildRequires:  dbus-glib-devel >= 0.60
65 BuildRequires:  glib2-devel >= 1:2.20
66 BuildRequires:  gtk+2-devel >= 2:2.14
67 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
68 BuildRequires:  hunspell-devel
69 BuildRequires:  libIDL-devel >= 0.8.0
70 BuildRequires:  libdnet-devel
71 BuildRequires:  libevent-devel >= 1.4.7
72 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
73 BuildRequires:  libffi-devel >= 6:3.0.9
74 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
75 BuildRequires:  libiw-devel
76 # requires libjpeg-turbo implementing at least libjpeg 6b API
77 BuildRequires:  libjpeg-devel >= 6b
78 BuildRequires:  libjpeg-turbo-devel
79 BuildRequires:  libnotify-devel >= 0.4
80 BuildRequires:  libpng(APNG)-devel >= 0.10
81 BuildRequires:  libpng-devel >= 1.5.13
82 BuildRequires:  libstdc++-devel
83 BuildRequires:  libvpx-devel >= 1.0.0
84 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
85 BuildRequires:  nss-devel >= 1:%{nss_ver}
86 BuildRequires:  pango-devel >= 1:1.14.0
87 BuildRequires:  perl-modules >= 5.004
88 BuildRequires:  pkgconfig
89 BuildRequires:  pkgconfig(libffi) >= 3.0.9
90 BuildRequires:  python-modules
91 %{?with_pgo:BuildRequires:      python-modules-sqlite}
92 BuildRequires:  python-virtualenv
93 BuildRequires:  rpm >= 4.4.9-56
94 BuildRequires:  rpmbuild(macros) >= 1.601
95 BuildRequires:  sqlite3-devel >= 3.7.15.2
96 BuildRequires:  startup-notification-devel >= 0.8
97 BuildRequires:  xorg-lib-libXScrnSaver-devel
98 BuildRequires:  xorg-lib-libXext-devel
99 BuildRequires:  xorg-lib-libXinerama-devel
100 BuildRequires:  xorg-lib-libXt-devel
101 %if %{with xulrunner}
102 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
103 %endif
104 BuildRequires:  zip
105 BuildRequires:  zlib-devel >= 1.2.3
106 Requires(post): mktemp >= 1.5-18
107 Requires:       desktop-file-utils
108 Requires:       hicolor-icon-theme
109 %if %{with xulrunner}
110 %requires_eq_to xulrunner xulrunner-devel
111 %else
112 Requires:       browser-plugins >= 2.0
113 Requires:       cairo >= 1.10.2-5
114 Requires:       dbus-glib >= 0.60
115 Requires:       glib2 >= 1:2.20
116 Requires:       gtk+2 >= 2:2.14
117 Requires:       libjpeg-turbo
118 Requires:       libpng >= 1.5.13
119 Requires:       libpng(APNG) >= 0.10
120 Requires:       myspell-common
121 Requires:       nspr >= 1:%{nspr_ver}
122 Requires:       nss >= 1:%{nss_ver}
123 Requires:       pango >= 1:1.14.0
124 Requires:       sqlite3 >= %{sqlite_build_version}
125 Requires:       startup-notification >= 0.8
126 %endif
127 Provides:       wwwbrowser
128 Obsoletes:      mozilla-firebird
129 Obsoletes:      mozilla-firefox
130 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
131 Obsoletes:      mozilla-firefox-libs
132 Conflicts:      iceweasel-lang-resources < %{version}
133 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
134
135 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
136
137 # don't satisfy other packages
138 %define         _noautoprovfiles        %{_libdir}/%{name}
139 %if %{without xulrunner}
140 # and as we don't provide them, don't require either
141 %define         _noautoreq      libmozalloc.so libmozjs.so libxpcom.so libxul.so
142 %endif
143
144 %description
145 Iceweasel is an open-source web browser, designed for standards
146 compliance, performance and portability.
147
148 %description -l hu.UTF-8
149 Iceweasel egy nyílt forrású webböngésző, hatékonyságra és
150 hordozhatóságra tervezve.
151
152 %description -l pl.UTF-8
153 Iceweasel jest przeglądarką WWW rozpowszechnianą zgodnie z ideami
154 ruchu otwartego oprogramowania oraz tworzoną z myślą o zgodności ze
155 standardami, wydajnością i przenośnością.
156
157 %prep
158 %setup -qc
159 mv -f mozilla-release mozilla
160 %setup -q -T -D -a1
161 cd mozilla
162 /bin/sh %{SOURCE2}
163
164 %patch0 -p1
165
166 %if "%{cc_version}" < "3.4"
167 %patch2 -p2
168 %endif
169
170 %patch7 -p1
171 %patch8 -p1
172 %patch9 -p2
173 %patch10 -p2
174 %patch11 -p2
175 %patch12 -p2
176 %patch13 -p2
177
178 # config/rules.mk is patched by us and js/src/config/rules.mk
179 # is supposed to be exact copy
180 cp -a config/rules.mk js/src/config/rules.mk
181
182 %if %{with pgo}
183 sed -i -e 's@__BROWSER_PATH__@"../../dist/bin/iceweasel-bin"@' build/automation.py.in
184 %endif
185
186 %build
187 cd mozilla
188 cp -f %{_datadir}/automake/config.* build/autoconf
189
190 cat << EOF > .mozconfig
191 . \$topsrcdir/browser/config/mozconfig
192
193 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
194 # parallel build fails on _xpidlgen/
195 %if %{without xulrunner}
196 mk_add_options MOZ_MAKE_FLAGS=%{_smp_mflags}
197 %endif
198 mk_add_options PROFILE_GEN_SCRIPT='@PYTHON@ @MOZ_OBJDIR@/_profile/pgo/profileserver.py'
199
200 # Options for 'configure' (same as command-line options).
201 ac_add_options --prefix=%{_prefix}
202 ac_add_options --exec-prefix=%{_exec_prefix}
203 ac_add_options --bindir=%{_bindir}
204 ac_add_options --sbindir=%{_sbindir}
205 ac_add_options --sysconfdir=%{_sysconfdir}
206 ac_add_options --datadir=%{_datadir}
207 ac_add_options --includedir=%{_includedir}
208 ac_add_options --libdir=%{_libdir}
209 ac_add_options --libexecdir=%{_libexecdir}
210 ac_add_options --localstatedir=%{_localstatedir}
211 ac_add_options --sharedstatedir=%{_sharedstatedir}
212 ac_add_options --mandir=%{_mandir}
213 ac_add_options --infodir=%{_infodir}
214 ac_add_options --disable-elf-hack
215 %if %{?debug:1}0
216 ac_add_options --disable-optimize
217 ac_add_options --enable-debug
218 ac_add_options --enable-debug-modules
219 ac_add_options --enable-debugger-info-modules
220 ac_add_options --enable-crash-on-assert
221 %else
222 ac_add_options --disable-debug
223 ac_add_options --disable-debug-modules
224 ac_add_options --disable-logging
225 ac_add_options --enable-optimize="%{rpmcflags} -Os"
226 %endif
227 ac_add_options --disable-strip
228 ac_add_options --disable-strip-libs
229 %if %{with tests}
230 ac_add_options --enable-tests
231 %else
232 ac_add_options --disable-tests
233 %endif
234 %if %{with gnomeui}
235 ac_add_options --enable-gnomeui
236 %else
237 ac_add_options --disable-gnomeui
238 %endif
239 ac_add_options --disable-gnomevfs
240 ac_add_options --disable-crashreporter
241 ac_add_options --disable-installer
242 ac_add_options --disable-javaxpcom
243 ac_add_options --disable-updater
244 ac_add_options --enable-gio
245 ac_add_options --enable-libxul
246 ac_add_options --enable-pango
247 ac_add_options --enable-shared-js
248 ac_add_options --enable-startup-notification
249 ac_add_options --enable-system-cairo
250 ac_add_options --enable-system-hunspell
251 ac_add_options --enable-system-sqlite
252 ac_add_options --with-distribution-id=org.pld-linux
253 ac_add_options --with-branding=iceweasel/branding
254 %if %{with xulrunner}
255 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
256 %endif
257 ac_add_options --with-pthreads
258 ac_add_options --with-system-bz2
259 ac_add_options --with-system-ffi
260 ac_add_options --with-system-jpeg
261 ac_add_options --with-system-libevent
262 ac_add_options --with-system-libvpx
263 ac_add_options --with-system-nspr
264 ac_add_options --with-system-nss
265 ac_add_options --with-system-png
266 ac_add_options --with-system-zlib
267 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
268 EOF
269
270 %if %{with pgo}
271 export DISPLAY=:100 
272 %{__make} -f client.mk profiledbuild \
273         DESTDIR=obj-%{_target_cpu}/dist \
274         STRIP="/bin/true" \
275         CC="%{__cc}" \
276         CXX="%{__cxx}"
277 %else
278 %{__make} -f client.mk build \
279         STRIP="/bin/true" \
280         CC="%{__cc}" \
281         CXX="%{__cxx}"
282 %endif
283
284 %install
285 rm -rf $RPM_BUILD_ROOT
286 cd mozilla
287 install -d \
288         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
289         $RPM_BUILD_ROOT%{_desktopdir} \
290         $RPM_BUILD_ROOT%{_datadir}/%{name} \
291         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
292
293 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
294
295 cd obj-%{_target_cpu}
296 %{__make} -C browser/installer stage-package \
297         DESTDIR=$RPM_BUILD_ROOT \
298         installdir=%{_libdir}/%{name} \
299         PKG_SKIP_STRIP=1
300
301 %{__make} -C iceweasel/branding install \
302         DESTDIR=$RPM_BUILD_ROOT
303
304 cp -a dist/iceweasel/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
305
306 %if %{with xulrunner}
307 # >= 5.0 seems to require this
308 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
309 %endif
310
311 # move arch independant ones to datadir
312 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
313 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
314 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
315 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
316 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
317 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
318 %if %{without xulrunner}
319 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
320 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
321 %endif
322
323 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
324 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
325 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
326 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
327 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
328 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
329 %if %{without xulrunner}
330 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
331 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
332 %endif
333
334 %if %{without xulrunner}
335 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
336 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
337 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
338 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
339 %endif
340
341 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE4} > $RPM_BUILD_ROOT%{_bindir}/iceweasel
342 chmod 755 $RPM_BUILD_ROOT%{_bindir}/iceweasel
343 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/firefox
344 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
345
346 # install icons and desktop file
347 cp iceweasel/branding/{mozicon,default}128.png
348 for i in 16 32 48 64 128; do
349         install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
350         cp -a iceweasel/branding/default${i}.png \
351                 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/iceweasel.png
352 done
353
354 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
355
356 # install our settings
357 #cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
358 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/pref/vendor.js
359
360 %if "%{pld_release}" == "ac"
361 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
362 %endif
363
364 # files created by iceweasel -register
365 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
366 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
367
368 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
369 #!/bin/sh
370 umask 022
371 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
372
373 # it attempts to touch files in $HOME/.mozilla
374 # beware if you run this with sudo!!!
375 export HOME=$(mktemp -d)
376 # also TMPDIR could be pointing to sudo user's homedir
377 unset TMPDIR TMP || :
378
379 %{_libdir}/%{name}/iceweasel -register
380
381 rm -rf $HOME
382 EOF
383 chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
384
385 %clean
386 rm -rf $RPM_BUILD_ROOT
387
388 %pretrans
389 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
390         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
391 fi
392 for d in chrome defaults extensions greprefs.js icons res searchplugins; do
393         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
394                 install -d %{_datadir}/%{name}
395                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
396         fi
397 done
398 exit 0
399
400 %post
401 %{_sbindir}/%{name}-chrome+xpcom-generate
402 %update_browser_plugins
403 %update_icon_cache hicolor
404 %update_desktop_database
405
406 %postun
407 if [ "$1" = 0 ]; then
408         %update_browser_plugins
409         %update_icon_cache hicolor
410 fi
411
412 %files
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_bindir}/%{name}
415 %attr(755,root,root) %{_bindir}/firefox
416 %attr(755,root,root) %{_bindir}/mozilla-firefox
417 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
418
419 # browser plugins v2
420 %{_browserpluginsconfdir}/browsers.d/%{name}.*
421 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
422
423 %dir %{_libdir}/%{name}
424 %if %{without xulrunner}
425 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
426 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
427 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
428 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
429 %endif
430 %{_libdir}/%{name}/blocklist.xml
431
432 %if %{with crashreporter}
433 %{_libdir}/%{name}/crashreporter
434 %{_libdir}/%{name}/crashreporter-override.ini
435 %{_libdir}/%{name}/crashreporter.ini
436 %{_libdir}/%{name}/Throbber-small.gif
437 %endif
438
439 # config?
440 %{_libdir}/%{name}/application.ini
441 %{_libdir}/%{name}/chrome.manifest
442
443 %dir %{_libdir}/%{name}/components
444
445 %{_libdir}/%{name}/components/ChromeProfileMigrator.js
446 %{_libdir}/%{name}/components/DownloadsStartup.js
447 %{_libdir}/%{name}/components/DownloadsUI.js
448 %{_libdir}/%{name}/components/FeedConverter.js
449 %{_libdir}/%{name}/components/FeedWriter.js
450 %{_libdir}/%{name}/components/FirefoxProfileMigrator.js
451 %{_libdir}/%{name}/components/PageThumbsProtocol.js
452 %{_libdir}/%{name}/components/PlacesProtocolHandler.js
453 %{_libdir}/%{name}/components/ProfileMigrator.js
454 %{_libdir}/%{name}/components/WebContentConverter.js
455 %{_libdir}/%{name}/components/browser.xpt
456 %{_libdir}/%{name}/components/fuelApplication.js
457 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
458 %{_libdir}/%{name}/components/nsBrowserGlue.js
459 %{_libdir}/%{name}/components/nsPrivateBrowsingServiceObsolete.js
460 %{_libdir}/%{name}/components/nsSessionStartup.js
461 %{_libdir}/%{name}/components/nsSessionStore.js
462 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
463 %{_libdir}/%{name}/components/nsSidebar.js
464
465 %{_libdir}/%{name}/components/components.manifest
466 %{_libdir}/%{name}/components/interfaces.manifest
467
468 %if %{without xulrunner}
469 %{_libdir}/%{name}/dependentlibs.list
470 %{_libdir}/%{name}/platform.ini
471 %{_libdir}/%{name}/components/addonManager.js
472 %{_libdir}/%{name}/components/Aitc.js
473 %{_libdir}/%{name}/components/AlarmsManager.js
474 %{_libdir}/%{name}/components/amContentHandler.js
475 %{_libdir}/%{name}/components/amWebInstallListener.js
476 %{_libdir}/%{name}/components/AppsService.js
477 %{_libdir}/%{name}/components/BrowserElementParent.js
478 %{_libdir}/%{name}/components/ColorAnalyzer.js
479 %{_libdir}/%{name}/components/ConsoleAPI.js
480 %{_libdir}/%{name}/components/ContactManager.js
481 %{_libdir}/%{name}/components/contentAreaDropListener.js
482 %{_libdir}/%{name}/components/contentSecurityPolicy.js
483 %{_libdir}/%{name}/components/crypto-SDR.js
484 %{_libdir}/%{name}/components/FeedProcessor.js
485 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
486 %{_libdir}/%{name}/components/jsconsole-clhandler.js
487 %{_libdir}/%{name}/components/messageWakeupService.js
488 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
489 %{_libdir}/%{name}/components/nsBadCertHandler.js
490 %{_libdir}/%{name}/components/nsBlocklistService.js
491 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
492 %{_libdir}/%{name}/components/nsContentPrefService.js
493 %{_libdir}/%{name}/components/nsDefaultCLH.js
494 %{_libdir}/%{name}/components/nsDOMIdentity.js
495 %{_libdir}/%{name}/components/nsDownloadManagerUI.js
496 %{_libdir}/%{name}/components/nsFilePicker.js
497 %{_libdir}/%{name}/components/nsFormAutoComplete.js
498 %{_libdir}/%{name}/components/nsFormHistory.js
499 %{_libdir}/%{name}/components/nsHandlerService.js
500 %{_libdir}/%{name}/components/nsHelperAppDlg.js
501 %{_libdir}/%{name}/components/nsIDService.js
502 %{_libdir}/%{name}/components/nsINIProcessor.js
503 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
504 %{_libdir}/%{name}/components/nsLivemarkService.js
505 %{_libdir}/%{name}/components/nsLoginInfo.js
506 %{_libdir}/%{name}/components/nsLoginManager.js
507 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
508 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
509 %{_libdir}/%{name}/components/nsPlacesExpiration.js
510 %{_libdir}/%{name}/components/nsPrompter.js
511 %{_libdir}/%{name}/components/nsSearchService.js
512 %{_libdir}/%{name}/components/nsSearchSuggestions.js
513 %{_libdir}/%{name}/components/nsTaggingService.js
514 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
515 %{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
516 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
517 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
518 %{_libdir}/%{name}/components/nsURLFormatter.js
519 %{_libdir}/%{name}/components/nsWebHandlerApp.js
520 %{_libdir}/%{name}/components/PeerConnection.js
521 %{_libdir}/%{name}/components/PermissionSettings.js
522 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
523 %{_libdir}/%{name}/components/SettingsManager.js
524 %{_libdir}/%{name}/components/SiteSpecificUserAgent.js
525 %{_libdir}/%{name}/components/storage-Legacy.js
526 %{_libdir}/%{name}/components/storage-mozStorage.js
527 %{_libdir}/%{name}/components/TCPSocket.js
528 %{_libdir}/%{name}/components/TCPSocketParentIntermediary.js
529 %{_libdir}/%{name}/components/TelemetryPing.js
530 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
531 %{_libdir}/%{name}/components/Weave.js
532 %{_libdir}/%{name}/components/Webapps.js
533 %endif
534
535 %{_libdir}/%{name}/webapprt
536 %attr(755,root,root) %{_libdir}/%{name}/webapprt-stub
537
538 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
539 %if %{without xulrunner}
540 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
541 %endif
542
543 %if %{without xulrunner}
544 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
545 %endif
546
547 %attr(755,root,root) %{_libdir}/%{name}/iceweasel
548 %dir %{_libdir}/%{name}/plugins
549 %if %{without xulrunner}
550 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
551 %attr(755,root,root) %{_libdir}/%{name}/iceweasel-bin
552 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
553 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
554 %endif
555
556 %{_iconsdir}/hicolor/*/*/iceweasel.png
557 %{_desktopdir}/iceweasel.desktop
558
559 # symlinks
560 %{_libdir}/%{name}/chrome
561 %{_libdir}/%{name}/defaults
562 %{_libdir}/%{name}/extensions
563 %{_libdir}/%{name}/icons
564 %{_libdir}/%{name}/modules
565 %{_libdir}/%{name}/searchplugins
566 %if %{with xulrunner}
567 %{_libdir}/%{name}/xulrunner
568 %else
569 %{_libdir}/%{name}/dictionaries
570 %{_libdir}/%{name}/hyphenation
571 %{_libdir}/%{name}/greprefs.js
572 %{_libdir}/%{name}/res
573 %endif
574
575 %dir %{_datadir}/%{name}
576 %{_datadir}/%{name}/chrome
577 %{_datadir}/%{name}/defaults
578 %{_datadir}/%{name}/icons
579 %{_datadir}/%{name}/modules
580 %{_datadir}/%{name}/searchplugins
581 %if %{without xulrunner}
582 %{_datadir}/%{name}/greprefs.js
583 %{_datadir}/%{name}/res
584 %endif
585
586 %dir %{_datadir}/%{name}/extensions
587 # the signature of the default theme
588 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
589
590 # files created by iceweasel -register
591 %ghost %{_libdir}/%{name}/components/compreg.dat
592 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.076553 seconds and 4 git commands to generate.