]> git.pld-linux.org Git - packages/iceweasel.git/blob - iceweasel.spec
- updated nspr and nss versions requirements
[packages/iceweasel.git] / iceweasel.spec
1 # TODO:
2 #  - provide proper $DISPLAY for PGO (Xvfb, Xdummy...) for unattended builds
3 #
4 # Conditional build:
5 %bcond_with     tests           # enable tests (whatever they check)
6 %bcond_without  gnomeui         # disable gnomeui support
7 %bcond_without  gnome           # synonym for gnomeui (gconf, libnotify and gio are still enabled)
8 %bcond_without  kerberos        # disable krb5 support
9 %bcond_without  xulrunner       # build without system xulrunner
10 %bcond_with     pgo             # PGO-enabled build (requires working $DISPLAY == :100)
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 # convert firefox release number to platform version: 9.0.x -> 9.0.x
17 %define         xulrunner_main  17.0
18 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#17.0})
19
20 %if %{without xulrunner}
21 # The actual sqlite version (see RHBZ#480989):
22 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
23 %endif
24
25 %define         nspr_ver        4.9.3
26 %define         nss_ver         3.14.1
27
28 Summary:        Iceweasel web browser
29 Summary(hu.UTF-8):      Iceweasel web böngésző
30 Summary(pl.UTF-8):      Iceweasel - przeglądarka WWW
31 Name:           iceweasel
32 Version:        18.0
33 Release:        1
34 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
35 Group:          X11/Applications/Networking
36 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
37 # Source0-md5:  485d02563854c20a3788d89db07b0687
38 Source1:        %{name}-branding.tar.bz2
39 # Source1-md5:  266f006f33249f7562f71dacac67157b
40 Source2:        %{name}-rm_nonfree.sh
41 Source3:        %{name}.desktop
42 Source4:        %{name}.sh
43 Source5:        vendor.js
44 Source6:        vendor-ac.js
45 Patch0:         %{name}-branding.patch
46 Patch1:         %{name}-install.patch
47 Patch2:         %{name}-gcc3.patch
48 Patch7:         %{name}-prefs.patch
49 Patch8:         %{name}-pld-branding.patch
50 Patch9:         %{name}-no-subshell.patch
51 Patch10:        system-cairo.patch
52 Patch11:        %{name}-middle_click_paste.patch
53 Patch12:        %{name}-packaging.patch
54 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
55 Patch13:        system-virtualenv.patch
56 URL:            http://www.pld-linux.org/Packages/Iceweasel
57 BuildRequires:  GConf2-devel >= 1.2.1
58 BuildRequires:  OpenGL-devel
59 BuildRequires:  alsa-lib-devel
60 BuildRequires:  automake
61 BuildRequires:  bzip2-devel
62 BuildRequires:  cairo-devel >= 1.10.2-5
63 BuildRequires:  dbus-glib-devel >= 0.60
64 BuildRequires:  glib2-devel >= 1:2.18
65 BuildRequires:  gtk+2-devel >= 2:2.14
66 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
67 BuildRequires:  hunspell-devel
68 BuildRequires:  libIDL-devel >= 0.8.0
69 BuildRequires:  libdnet-devel
70 BuildRequires:  libevent-devel >= 1.4.7
71 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
72 BuildRequires:  libffi-devel >= 6:3.0.9
73 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
74 BuildRequires:  libiw-devel
75 BuildRequires:  libjpeg-devel >= 6b
76 BuildRequires:  libnotify-devel >= 0.4
77 BuildRequires:  libpng(APNG)-devel >= 0.10
78 BuildRequires:  libpng-devel >= 1.4.1
79 BuildRequires:  libstdc++-devel
80 BuildRequires:  libvpx-devel >= 1.0.0
81 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
82 BuildRequires:  nss-devel >= 1:%{nss_ver}
83 BuildRequires:  pango-devel >= 1:1.14.0
84 BuildRequires:  perl-modules >= 5.004
85 BuildRequires:  pkgconfig
86 BuildRequires:  pkgconfig(libffi) >= 3.0.9
87 BuildRequires:  python-modules
88 %{?with_pgo:BuildRequires:      python-modules-sqlite}
89 BuildRequires:  python-virtualenv
90 BuildRequires:  rpm >= 4.4.9-56
91 BuildRequires:  rpmbuild(macros) >= 1.601
92 BuildRequires:  sqlite3-devel >= 3.7.10
93 BuildRequires:  startup-notification-devel >= 0.8
94 BuildRequires:  xorg-lib-libXScrnSaver-devel
95 BuildRequires:  xorg-lib-libXext-devel
96 BuildRequires:  xorg-lib-libXinerama-devel
97 BuildRequires:  xorg-lib-libXt-devel
98 %if %{with xulrunner}
99 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
100 %endif
101 BuildRequires:  zip
102 BuildRequires:  zlib-devel >= 1.2.3
103 Requires(post): mktemp >= 1.5-18
104 Requires:       desktop-file-utils
105 Requires:       hicolor-icon-theme
106 %if %{with xulrunner}
107 %requires_eq_to xulrunner xulrunner-devel
108 %else
109 Requires:       browser-plugins >= 2.0
110 Requires:       cairo >= 1.10.2-5
111 Requires:       dbus-glib >= 0.60
112 Requires:       glib2 >= 1:2.18
113 Requires:       gtk+2 >= 2:2.14
114 Requires:       libpng >= 1.4.1
115 Requires:       libpng(APNG) >= 0.10
116 Requires:       myspell-common
117 Requires:       nspr >= 1:%{nspr_ver}
118 Requires:       nss >= 1:%{nss_ver}
119 Requires:       pango >= 1:1.14.0
120 Requires:       sqlite3 >= %{sqlite_build_version}
121 Requires:       startup-notification >= 0.8
122 %endif
123 Provides:       wwwbrowser
124 Obsoletes:      mozilla-firebird
125 Obsoletes:      mozilla-firefox
126 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
127 Obsoletes:      mozilla-firefox-libs
128 Conflicts:      iceweasel-lang-resources < %{version}
129 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
130
131 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
132
133 # don't satisfy other packages
134 %define         _noautoprovfiles        %{_libdir}/%{name}
135 %if %{without xulrunner}
136 # and as we don't provide them, don't require either
137 %define         _noautoreq      libmozalloc.so libmozjs.so libxpcom.so libxul.so
138 %endif
139
140 %description
141 Iceweasel is an open-source web browser, designed for standards
142 compliance, performance and portability.
143
144 %description -l hu.UTF-8
145 Iceweasel egy nyílt forrású webböngésző, hatékonyságra és
146 hordozhatóságra tervezve.
147
148 %description -l pl.UTF-8
149 Iceweasel jest przeglądarką WWW rozpowszechnianą zgodnie z ideami
150 ruchu otwartego oprogramowania oraz tworzoną z myślą o zgodności ze
151 standardami, wydajnością i przenośnością.
152
153 %prep
154 %setup -qc
155 mv -f mozilla-release mozilla
156 %setup -q -T -D -a1
157 cd mozilla
158 /bin/sh %{SOURCE2}
159
160 %patch0 -p1
161 %patch1 -p1
162
163 %if "%{cc_version}" < "3.4"
164 %patch2 -p2
165 %endif
166
167 %patch7 -p1
168 %patch8 -p1
169 %patch9 -p2
170 %patch10 -p2
171 %patch11 -p2
172 %patch12 -p2
173 %patch13 -p2
174
175 # config/rules.mk is patched by us and js/src/config/rules.mk
176 # is supposed to be exact copy
177 cp -a config/rules.mk js/src/config/rules.mk
178
179 %if %{with pgo}
180 sed -i -e 's@__BROWSER_PATH__@"../../dist/bin/iceweasel-bin"@' build/automation.py.in
181 %endif
182
183 %build
184 cd mozilla
185 cp -f %{_datadir}/automake/config.* build/autoconf
186
187 cat << EOF > .mozconfig
188 . \$topsrcdir/browser/config/mozconfig
189
190 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
191 # parallel build fails on _xpidlgen/
192 %if %{without xulrunner}
193 mk_add_options MOZ_MAKE_FLAGS=%{_smp_mflags}
194 %endif
195 mk_add_options PROFILE_GEN_SCRIPT='@PYTHON@ @MOZ_OBJDIR@/_profile/pgo/profileserver.py'
196
197 # Options for 'configure' (same as command-line options).
198 ac_add_options --prefix=%{_prefix}
199 ac_add_options --exec-prefix=%{_exec_prefix}
200 ac_add_options --bindir=%{_bindir}
201 ac_add_options --sbindir=%{_sbindir}
202 ac_add_options --sysconfdir=%{_sysconfdir}
203 ac_add_options --datadir=%{_datadir}
204 ac_add_options --includedir=%{_includedir}
205 ac_add_options --libdir=%{_libdir}
206 ac_add_options --libexecdir=%{_libexecdir}
207 ac_add_options --localstatedir=%{_localstatedir}
208 ac_add_options --sharedstatedir=%{_sharedstatedir}
209 ac_add_options --mandir=%{_mandir}
210 ac_add_options --infodir=%{_infodir}
211 ac_add_options --disable-elf-hack
212 %if %{?debug:1}0
213 ac_add_options --disable-optimize
214 ac_add_options --enable-debug
215 ac_add_options --enable-debug-modules
216 ac_add_options --enable-debugger-info-modules
217 ac_add_options --enable-crash-on-assert
218 %else
219 ac_add_options --disable-debug
220 ac_add_options --disable-debug-modules
221 ac_add_options --disable-logging
222 ac_add_options --enable-optimize="%{rpmcflags} -Os"
223 %endif
224 ac_add_options --disable-strip
225 ac_add_options --disable-strip-libs
226 %if %{with tests}
227 ac_add_options --enable-tests
228 %else
229 ac_add_options --disable-tests
230 %endif
231 %if %{with gnomeui}
232 ac_add_options --enable-gnomeui
233 %else
234 ac_add_options --disable-gnomeui
235 %endif
236 ac_add_options --disable-gnomevfs
237 ac_add_options --disable-crashreporter
238 ac_add_options --disable-installer
239 ac_add_options --disable-javaxpcom
240 ac_add_options --disable-updater
241 ac_add_options --enable-gio
242 ac_add_options --enable-libxul
243 ac_add_options --enable-pango
244 ac_add_options --enable-shared-js
245 ac_add_options --enable-startup-notification
246 ac_add_options --enable-system-cairo
247 ac_add_options --enable-system-hunspell
248 ac_add_options --enable-system-sqlite
249 ac_add_options --with-distribution-id=org.pld-linux
250 ac_add_options --with-branding=iceweasel/branding
251 %if %{with xulrunner}
252 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
253 %endif
254 ac_add_options --with-pthreads
255 ac_add_options --with-system-bz2
256 ac_add_options --with-system-ffi
257 ac_add_options --with-system-jpeg
258 ac_add_options --with-system-libevent
259 ac_add_options --with-system-libvpx
260 ac_add_options --with-system-nspr
261 ac_add_options --with-system-nss
262 ac_add_options --with-system-png
263 ac_add_options --with-system-zlib
264 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
265 EOF
266
267 %if %{with pgo}
268 export DISPLAY=:100 
269 %{__make} -f client.mk profiledbuild \
270         DESTDIR=obj-%{_target_cpu}/dist \
271         STRIP="/bin/true" \
272         CC="%{__cc}" \
273         CXX="%{__cxx}"
274 %else
275 %{__make} -f client.mk build \
276         STRIP="/bin/true" \
277         CC="%{__cc}" \
278         CXX="%{__cxx}"
279 %endif
280
281 %install
282 rm -rf $RPM_BUILD_ROOT
283 cd mozilla
284 install -d \
285         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
286         $RPM_BUILD_ROOT%{_desktopdir} \
287         $RPM_BUILD_ROOT%{_datadir}/%{name}
288
289 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
290
291 %{__make} -C obj-%{_target_cpu}/browser/installer stage-package \
292         DESTDIR=$RPM_BUILD_ROOT \
293         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
294         MOZ_PKG_DIR=%{_libdir}/%{name} \
295         PKG_SKIP_STRIP=1
296
297 install -d \
298         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
299
300 %if %{with xulrunner}
301 # >= 5.0 seems to require this
302 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
303 %endif
304
305 # move arch independant ones to datadir
306 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
307 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
308 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
309 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
310 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
311 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
312 %if %{without xulrunner}
313 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
314 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
315 %endif
316
317 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
318 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
319 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
320 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
321 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
322 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
323 %if %{without xulrunner}
324 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
325 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
326 %endif
327
328 %if %{without xulrunner}
329 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
330 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
331 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
332 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
333 %endif
334
335 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE4} > $RPM_BUILD_ROOT%{_bindir}/iceweasel
336 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/iceweasel
337 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/firefox
338 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
339
340 # install icons and desktop file
341 cp obj-%{_target_cpu}/iceweasel/branding/{mozicon,default}128.png
342 for i in 16 32 48 64 128; do
343         install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
344         cp -a obj-%{_target_cpu}/iceweasel/branding/default${i}.png \
345                 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/iceweasel.png
346 done
347
348 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
349
350 # install our settings
351 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
352
353 %if "%{pld_release}" == "ac"
354 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
355 %endif
356
357 # files created by iceweasel -register
358 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
359 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
360
361 %if %{with xulrunner}
362 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/run-mozilla.sh
363 %endif
364
365 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
366 #!/bin/sh
367 umask 022
368 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
369
370 # it attempts to touch files in $HOME/.mozilla
371 # beware if you run this with sudo!!!
372 export HOME=$(mktemp -d)
373 # also TMPDIR could be pointing to sudo user's homedir
374 unset TMPDIR TMP || :
375
376 %{_libdir}/%{name}/iceweasel -register
377
378 rm -rf $HOME
379 EOF
380 chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
381
382 %clean
383 rm -rf $RPM_BUILD_ROOT
384
385 %pretrans
386 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
387         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
388 fi
389 for d in chrome defaults extensions greprefs.js icons res searchplugins; do
390         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
391                 install -d %{_datadir}/%{name}
392                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
393         fi
394 done
395 exit 0
396
397 %post
398 %{_sbindir}/%{name}-chrome+xpcom-generate
399 %update_browser_plugins
400 %update_icon_cache hicolor
401 %update_desktop_database
402
403 %postun
404 if [ "$1" = 0 ]; then
405         %update_browser_plugins
406         %update_icon_cache hicolor
407 fi
408
409 %files
410 %defattr(644,root,root,755)
411 %attr(755,root,root) %{_bindir}/%{name}
412 %attr(755,root,root) %{_bindir}/firefox
413 %attr(755,root,root) %{_bindir}/mozilla-firefox
414 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
415
416 # browser plugins v2
417 %{_browserpluginsconfdir}/browsers.d/%{name}.*
418 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
419
420 %dir %{_libdir}/%{name}
421 %if %{without xulrunner}
422 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
423 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
424 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
425 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
426 %endif
427 %{_libdir}/%{name}/blocklist.xml
428
429 %if %{with crashreporter}
430 %{_libdir}/%{name}/crashreporter
431 %{_libdir}/%{name}/crashreporter-override.ini
432 %{_libdir}/%{name}/crashreporter.ini
433 %{_libdir}/%{name}/Throbber-small.gif
434 %endif
435
436 # config?
437 %{_libdir}/%{name}/application.ini
438 %{_libdir}/%{name}/chrome.manifest
439
440 %dir %{_libdir}/%{name}/components
441
442 %{_libdir}/%{name}/components/ChromeProfileMigrator.js
443 %{_libdir}/%{name}/components/FeedConverter.js
444 %{_libdir}/%{name}/components/FeedWriter.js
445 %{_libdir}/%{name}/components/FirefoxProfileMigrator.js
446 %{_libdir}/%{name}/components/PlacesProtocolHandler.js
447 %{_libdir}/%{name}/components/Weave.js
448 %{_libdir}/%{name}/components/Aitc.js
449 %{_libdir}/%{name}/components/WebContentConverter.js
450 %{_libdir}/%{name}/components/browser.xpt
451 %{_libdir}/%{name}/components/fuelApplication.js
452 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
453 %{_libdir}/%{name}/components/nsBrowserGlue.js
454 %{_libdir}/%{name}/components/nsPrivateBrowsingService.js
455 %{_libdir}/%{name}/components/nsSessionStartup.js
456 %{_libdir}/%{name}/components/nsSessionStore.js
457 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
458 %{_libdir}/%{name}/components/nsSidebar.js
459 %{_libdir}/%{name}/components/PageThumbsProtocol.js
460 %{_libdir}/%{name}/components/ProfileMigrator.js
461 %{_libdir}/%{name}/components/DownloadsStartup.js
462 %{_libdir}/%{name}/components/DownloadsUI.js
463
464 %{_libdir}/%{name}/components/components.manifest
465 %{_libdir}/%{name}/components/interfaces.manifest
466
467 %if %{without xulrunner}
468 %{_libdir}/%{name}/dependentlibs.list
469 %{_libdir}/%{name}/platform.ini
470 %{_libdir}/%{name}/components/AppsService.js
471 %{_libdir}/%{name}/components/BrowserElementParent.js
472 %{_libdir}/%{name}/components/ConsoleAPI.js
473 %{_libdir}/%{name}/components/ContactManager.js
474 %{_libdir}/%{name}/components/FeedProcessor.js
475 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
476 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
477 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
478 %{_libdir}/%{name}/components/SettingsManager.js
479 %{_libdir}/%{name}/components/TelemetryPing.js
480 %{_libdir}/%{name}/components/addonManager.js
481 %{_libdir}/%{name}/components/amContentHandler.js
482 %{_libdir}/%{name}/components/amWebInstallListener.js
483 %{_libdir}/%{name}/components/contentAreaDropListener.js
484 %{_libdir}/%{name}/components/contentSecurityPolicy.js
485 %{_libdir}/%{name}/components/crypto-SDR.js
486 %{_libdir}/%{name}/components/jsconsole-clhandler.js
487 %{_libdir}/%{name}/components/messageWakeupService.js
488 %{_libdir}/%{name}/components/nsBadCertHandler.js
489 %{_libdir}/%{name}/components/nsBlocklistService.js
490 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
491 %{_libdir}/%{name}/components/nsContentPrefService.js
492 %{_libdir}/%{name}/components/nsDefaultCLH.js
493 %{_libdir}/%{name}/components/nsDownloadManagerUI.js
494 %{_libdir}/%{name}/components/nsFilePicker.js
495 %{_libdir}/%{name}/components/nsFormAutoComplete.js
496 %{_libdir}/%{name}/components/nsFormHistory.js
497 %{_libdir}/%{name}/components/nsHandlerService.js
498 %{_libdir}/%{name}/components/nsHelperAppDlg.js
499 %{_libdir}/%{name}/components/nsINIProcessor.js
500 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
501 %{_libdir}/%{name}/components/nsLivemarkService.js
502 %{_libdir}/%{name}/components/nsLoginInfo.js
503 %{_libdir}/%{name}/components/nsLoginManager.js
504 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
505 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
506 %{_libdir}/%{name}/components/nsPlacesExpiration.js
507 %{_libdir}/%{name}/components/nsPrompter.js
508 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
509 %{_libdir}/%{name}/components/nsSearchService.js
510 %{_libdir}/%{name}/components/nsSearchSuggestions.js
511 %{_libdir}/%{name}/components/nsTaggingService.js
512 %{_libdir}/%{name}/components/nsURLFormatter.js
513 %{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
514 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
515 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
516 %{_libdir}/%{name}/components/nsWebHandlerApp.js
517 %{_libdir}/%{name}/components/storage-Legacy.js
518 %{_libdir}/%{name}/components/storage-mozStorage.js
519 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
520 %endif
521
522 %{_libdir}/%{name}/webapprt
523 %attr(755,root,root) %{_libdir}/%{name}/webapprt-stub
524
525 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
526 %if %{without xulrunner}
527 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
528 %endif
529
530 %if %{without xulrunner}
531 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
532 %endif
533
534 %attr(755,root,root) %{_libdir}/%{name}/iceweasel
535 %dir %{_libdir}/%{name}/plugins
536 %if %{without xulrunner}
537 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
538 %attr(755,root,root) %{_libdir}/%{name}/iceweasel-bin
539 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
540 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
541 %endif
542
543 %{_iconsdir}/hicolor/*/*/iceweasel.png
544 %{_desktopdir}/iceweasel.desktop
545
546 # symlinks
547 %{_libdir}/%{name}/chrome
548 %{_libdir}/%{name}/defaults
549 %{_libdir}/%{name}/extensions
550 %{_libdir}/%{name}/icons
551 %{_libdir}/%{name}/modules
552 %{_libdir}/%{name}/searchplugins
553 %if %{with xulrunner}
554 %{_libdir}/%{name}/xulrunner
555 %else
556 %{_libdir}/%{name}/dictionaries
557 %{_libdir}/%{name}/hyphenation
558 %{_libdir}/%{name}/greprefs.js
559 %{_libdir}/%{name}/res
560 %endif
561
562 %dir %{_datadir}/%{name}
563 %{_datadir}/%{name}/chrome
564 %{_datadir}/%{name}/defaults
565 %{_datadir}/%{name}/icons
566 %{_datadir}/%{name}/modules
567 %{_datadir}/%{name}/searchplugins
568 %if %{without xulrunner}
569 %{_datadir}/%{name}/greprefs.js
570 %{_datadir}/%{name}/res
571 %endif
572
573 %dir %{_datadir}/%{name}/extensions
574 # the signature of the default theme
575 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
576
577 # files created by iceweasel -register
578 %ghost %{_libdir}/%{name}/components/compreg.dat
579 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.177162 seconds and 3 git commands to generate.