]> git.pld-linux.org Git - packages/iceweasel.git/blob - iceweasel.spec
- up to 18.0.1
[packages/iceweasel.git] / iceweasel.spec
1 # TODO:
2 #  - provide proper $DISPLAY for PGO (Xvfb, Xdummy...) for unattended builds
3 #
4 # Conditional build:
5 %bcond_with     tests           # enable tests (whatever they check)
6 %bcond_without  gnomeui         # disable gnomeui support
7 %bcond_without  gnome           # synonym for gnomeui (gconf, libnotify and gio are still enabled)
8 %bcond_without  kerberos        # disable krb5 support
9 %bcond_without  xulrunner       # build without system xulrunner
10 %bcond_with     pgo             # PGO-enabled build (requires working $DISPLAY == :100)
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 # convert firefox release number to platform version: 9.0.x -> 9.0.x
17 %define         xulrunner_main  17.0
18 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#17.0})
19
20 %if %{without xulrunner}
21 # The actual sqlite version (see RHBZ#480989):
22 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
23 %endif
24
25 %define         nspr_ver        4.9.3
26 %define         nss_ver         3.14.1
27
28 Summary:        Iceweasel web browser
29 Summary(hu.UTF-8):      Iceweasel web böngésző
30 Summary(pl.UTF-8):      Iceweasel - przeglądarka WWW
31 Name:           iceweasel
32 Version:        18.0.1
33 Release:        1
34 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
35 Group:          X11/Applications/Networking
36 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
37 # Source0-md5:  8b400555fc7063163e3b99472d0c92a1
38 Source1:        %{name}-branding.tar.bz2
39 # Source1-md5:  816d926bd2c76a5bba5108979ba776ac
40 Source2:        %{name}-rm_nonfree.sh
41 Source3:        %{name}.desktop
42 Source4:        %{name}.sh
43 Source5:        vendor.js
44 Source6:        vendor-ac.js
45 Patch0:         %{name}-branding.patch
46 Patch1:         %{name}-install.patch
47 Patch2:         %{name}-gcc3.patch
48 Patch7:         %{name}-prefs.patch
49 Patch8:         %{name}-pld-branding.patch
50 Patch9:         %{name}-no-subshell.patch
51 Patch10:        system-cairo.patch
52 Patch11:        %{name}-middle_click_paste.patch
53 Patch12:        %{name}-packaging.patch
54 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
55 Patch13:        system-virtualenv.patch
56 URL:            http://www.pld-linux.org/Packages/Iceweasel
57 BuildRequires:  GConf2-devel >= 1.2.1
58 BuildRequires:  OpenGL-devel
59 BuildRequires:  alsa-lib-devel
60 BuildRequires:  automake
61 BuildRequires:  bzip2-devel
62 BuildRequires:  cairo-devel >= 1.10.2-5
63 BuildRequires:  dbus-glib-devel >= 0.60
64 BuildRequires:  glib2-devel >= 1:2.18
65 BuildRequires:  gtk+2-devel >= 2:2.14
66 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
67 BuildRequires:  hunspell-devel
68 BuildRequires:  libIDL-devel >= 0.8.0
69 BuildRequires:  libdnet-devel
70 BuildRequires:  libevent-devel >= 1.4.7
71 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
72 BuildRequires:  libffi-devel >= 6:3.0.9
73 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
74 BuildRequires:  libiw-devel
75 # requires libjpeg-turbo implementing at least libjpeg 6b API
76 BuildRequires:  libjpeg-devel >= 6b
77 BuildRequires:  libjpeg-turbo-devel
78 BuildRequires:  libnotify-devel >= 0.4
79 BuildRequires:  libpng(APNG)-devel >= 0.10
80 BuildRequires:  libpng-devel >= 1.4.1
81 BuildRequires:  libstdc++-devel
82 BuildRequires:  libvpx-devel >= 1.0.0
83 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
84 BuildRequires:  nss-devel >= 1:%{nss_ver}
85 BuildRequires:  pango-devel >= 1:1.14.0
86 BuildRequires:  perl-modules >= 5.004
87 BuildRequires:  pkgconfig
88 BuildRequires:  pkgconfig(libffi) >= 3.0.9
89 BuildRequires:  python-modules
90 %{?with_pgo:BuildRequires:      python-modules-sqlite}
91 BuildRequires:  python-virtualenv
92 BuildRequires:  rpm >= 4.4.9-56
93 BuildRequires:  rpmbuild(macros) >= 1.601
94 BuildRequires:  sqlite3-devel >= 3.7.10
95 BuildRequires:  startup-notification-devel >= 0.8
96 BuildRequires:  xorg-lib-libXScrnSaver-devel
97 BuildRequires:  xorg-lib-libXext-devel
98 BuildRequires:  xorg-lib-libXinerama-devel
99 BuildRequires:  xorg-lib-libXt-devel
100 %if %{with xulrunner}
101 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
102 %endif
103 BuildRequires:  zip
104 BuildRequires:  zlib-devel >= 1.2.3
105 Requires(post): mktemp >= 1.5-18
106 Requires:       desktop-file-utils
107 Requires:       hicolor-icon-theme
108 %if %{with xulrunner}
109 %requires_eq_to xulrunner xulrunner-devel
110 %else
111 Requires:       browser-plugins >= 2.0
112 Requires:       cairo >= 1.10.2-5
113 Requires:       dbus-glib >= 0.60
114 Requires:       glib2 >= 1:2.18
115 Requires:       gtk+2 >= 2:2.14
116 Requires:       libjpeg-turbo
117 Requires:       libpng >= 1.4.1
118 Requires:       libpng(APNG) >= 0.10
119 Requires:       myspell-common
120 Requires:       nspr >= 1:%{nspr_ver}
121 Requires:       nss >= 1:%{nss_ver}
122 Requires:       pango >= 1:1.14.0
123 Requires:       sqlite3 >= %{sqlite_build_version}
124 Requires:       startup-notification >= 0.8
125 %endif
126 Provides:       wwwbrowser
127 Obsoletes:      mozilla-firebird
128 Obsoletes:      mozilla-firefox
129 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
130 Obsoletes:      mozilla-firefox-libs
131 Conflicts:      iceweasel-lang-resources < %{version}
132 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
133
134 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
135
136 # don't satisfy other packages
137 %define         _noautoprovfiles        %{_libdir}/%{name}
138 %if %{without xulrunner}
139 # and as we don't provide them, don't require either
140 %define         _noautoreq      libmozalloc.so libmozjs.so libxpcom.so libxul.so
141 %endif
142
143 %description
144 Iceweasel is an open-source web browser, designed for standards
145 compliance, performance and portability.
146
147 %description -l hu.UTF-8
148 Iceweasel egy nyílt forrású webböngésző, hatékonyságra és
149 hordozhatóságra tervezve.
150
151 %description -l pl.UTF-8
152 Iceweasel jest przeglądarką WWW rozpowszechnianą zgodnie z ideami
153 ruchu otwartego oprogramowania oraz tworzoną z myślą o zgodności ze
154 standardami, wydajnością i przenośnością.
155
156 %prep
157 %setup -qc
158 mv -f mozilla-release mozilla
159 %setup -q -T -D -a1
160 cd mozilla
161 /bin/sh %{SOURCE2}
162
163 %patch0 -p1
164 %patch1 -p1
165
166 %if "%{cc_version}" < "3.4"
167 %patch2 -p2
168 %endif
169
170 %patch7 -p1
171 %patch8 -p1
172 %patch9 -p2
173 %patch10 -p2
174 %patch11 -p2
175 %patch12 -p2
176 %patch13 -p2
177
178 # config/rules.mk is patched by us and js/src/config/rules.mk
179 # is supposed to be exact copy
180 cp -a config/rules.mk js/src/config/rules.mk
181
182 %if %{with pgo}
183 sed -i -e 's@__BROWSER_PATH__@"../../dist/bin/iceweasel-bin"@' build/automation.py.in
184 %endif
185
186 %build
187 cd mozilla
188 cp -f %{_datadir}/automake/config.* build/autoconf
189
190 cat << EOF > .mozconfig
191 . \$topsrcdir/browser/config/mozconfig
192
193 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
194 # parallel build fails on _xpidlgen/
195 %if %{without xulrunner}
196 mk_add_options MOZ_MAKE_FLAGS=%{_smp_mflags}
197 %endif
198 mk_add_options PROFILE_GEN_SCRIPT='@PYTHON@ @MOZ_OBJDIR@/_profile/pgo/profileserver.py'
199
200 # Options for 'configure' (same as command-line options).
201 ac_add_options --prefix=%{_prefix}
202 ac_add_options --exec-prefix=%{_exec_prefix}
203 ac_add_options --bindir=%{_bindir}
204 ac_add_options --sbindir=%{_sbindir}
205 ac_add_options --sysconfdir=%{_sysconfdir}
206 ac_add_options --datadir=%{_datadir}
207 ac_add_options --includedir=%{_includedir}
208 ac_add_options --libdir=%{_libdir}
209 ac_add_options --libexecdir=%{_libexecdir}
210 ac_add_options --localstatedir=%{_localstatedir}
211 ac_add_options --sharedstatedir=%{_sharedstatedir}
212 ac_add_options --mandir=%{_mandir}
213 ac_add_options --infodir=%{_infodir}
214 ac_add_options --disable-elf-hack
215 %if %{?debug:1}0
216 ac_add_options --disable-optimize
217 ac_add_options --enable-debug
218 ac_add_options --enable-debug-modules
219 ac_add_options --enable-debugger-info-modules
220 ac_add_options --enable-crash-on-assert
221 %else
222 ac_add_options --disable-debug
223 ac_add_options --disable-debug-modules
224 ac_add_options --disable-logging
225 ac_add_options --enable-optimize="%{rpmcflags} -Os"
226 %endif
227 ac_add_options --disable-strip
228 ac_add_options --disable-strip-libs
229 %if %{with tests}
230 ac_add_options --enable-tests
231 %else
232 ac_add_options --disable-tests
233 %endif
234 %if %{with gnomeui}
235 ac_add_options --enable-gnomeui
236 %else
237 ac_add_options --disable-gnomeui
238 %endif
239 ac_add_options --disable-gnomevfs
240 ac_add_options --disable-crashreporter
241 ac_add_options --disable-installer
242 ac_add_options --disable-javaxpcom
243 ac_add_options --disable-updater
244 ac_add_options --enable-gio
245 ac_add_options --enable-libxul
246 ac_add_options --enable-pango
247 ac_add_options --enable-shared-js
248 ac_add_options --enable-startup-notification
249 ac_add_options --enable-system-cairo
250 ac_add_options --enable-system-hunspell
251 ac_add_options --enable-system-sqlite
252 ac_add_options --with-distribution-id=org.pld-linux
253 ac_add_options --with-branding=iceweasel/branding
254 %if %{with xulrunner}
255 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
256 %endif
257 ac_add_options --with-pthreads
258 ac_add_options --with-system-bz2
259 ac_add_options --with-system-ffi
260 ac_add_options --with-system-jpeg
261 ac_add_options --with-system-libevent
262 ac_add_options --with-system-libvpx
263 ac_add_options --with-system-nspr
264 ac_add_options --with-system-nss
265 ac_add_options --with-system-png
266 ac_add_options --with-system-zlib
267 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
268 EOF
269
270 %if %{with pgo}
271 export DISPLAY=:100 
272 %{__make} -f client.mk profiledbuild \
273         DESTDIR=obj-%{_target_cpu}/dist \
274         STRIP="/bin/true" \
275         CC="%{__cc}" \
276         CXX="%{__cxx}"
277 %else
278 %{__make} -f client.mk build \
279         STRIP="/bin/true" \
280         CC="%{__cc}" \
281         CXX="%{__cxx}"
282 %endif
283
284 %install
285 rm -rf $RPM_BUILD_ROOT
286 cd mozilla
287 install -d \
288         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
289         $RPM_BUILD_ROOT%{_desktopdir} \
290         $RPM_BUILD_ROOT%{_datadir}/%{name}
291
292 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
293
294 %{__make} -C obj-%{_target_cpu}/browser/installer stage-package \
295         DESTDIR=$RPM_BUILD_ROOT \
296         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
297         MOZ_PKG_DIR=%{_libdir}/%{name} \
298         PKG_SKIP_STRIP=1
299
300 install -d \
301         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
302
303 %if %{with xulrunner}
304 # >= 5.0 seems to require this
305 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
306 %endif
307
308 # move arch independant ones to datadir
309 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
310 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
311 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
312 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
313 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
314 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
315 %if %{without xulrunner}
316 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
317 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
318 %endif
319
320 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
321 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
322 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
323 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
324 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
325 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
326 %if %{without xulrunner}
327 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
328 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
329 %endif
330
331 %if %{without xulrunner}
332 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
333 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
334 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
335 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
336 %endif
337
338 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE4} > $RPM_BUILD_ROOT%{_bindir}/iceweasel
339 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/iceweasel
340 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/firefox
341 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
342
343 # install icons and desktop file
344 cp obj-%{_target_cpu}/iceweasel/branding/{mozicon,default}128.png
345 for i in 16 32 48 64 128; do
346         install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
347         cp -a obj-%{_target_cpu}/iceweasel/branding/default${i}.png \
348                 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/iceweasel.png
349 done
350
351 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
352
353 # install our settings
354 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
355
356 %if "%{pld_release}" == "ac"
357 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
358 %endif
359
360 # files created by iceweasel -register
361 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
362 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
363
364 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
365 #!/bin/sh
366 umask 022
367 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
368
369 # it attempts to touch files in $HOME/.mozilla
370 # beware if you run this with sudo!!!
371 export HOME=$(mktemp -d)
372 # also TMPDIR could be pointing to sudo user's homedir
373 unset TMPDIR TMP || :
374
375 %{_libdir}/%{name}/iceweasel -register
376
377 rm -rf $HOME
378 EOF
379 chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
380
381 %clean
382 rm -rf $RPM_BUILD_ROOT
383
384 %pretrans
385 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
386         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
387 fi
388 for d in chrome defaults extensions greprefs.js icons res searchplugins; do
389         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
390                 install -d %{_datadir}/%{name}
391                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
392         fi
393 done
394 exit 0
395
396 %post
397 %{_sbindir}/%{name}-chrome+xpcom-generate
398 %update_browser_plugins
399 %update_icon_cache hicolor
400 %update_desktop_database
401
402 %postun
403 if [ "$1" = 0 ]; then
404         %update_browser_plugins
405         %update_icon_cache hicolor
406 fi
407
408 %files
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{_bindir}/%{name}
411 %attr(755,root,root) %{_bindir}/firefox
412 %attr(755,root,root) %{_bindir}/mozilla-firefox
413 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
414
415 # browser plugins v2
416 %{_browserpluginsconfdir}/browsers.d/%{name}.*
417 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
418
419 %dir %{_libdir}/%{name}
420 %if %{without xulrunner}
421 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
422 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
423 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
424 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
425 %endif
426 %{_libdir}/%{name}/blocklist.xml
427
428 %if %{with crashreporter}
429 %{_libdir}/%{name}/crashreporter
430 %{_libdir}/%{name}/crashreporter-override.ini
431 %{_libdir}/%{name}/crashreporter.ini
432 %{_libdir}/%{name}/Throbber-small.gif
433 %endif
434
435 # config?
436 %{_libdir}/%{name}/application.ini
437 %{_libdir}/%{name}/chrome.manifest
438
439 %dir %{_libdir}/%{name}/components
440
441 %{_libdir}/%{name}/components/ChromeProfileMigrator.js
442 %{_libdir}/%{name}/components/FeedConverter.js
443 %{_libdir}/%{name}/components/FeedWriter.js
444 %{_libdir}/%{name}/components/FirefoxProfileMigrator.js
445 %{_libdir}/%{name}/components/PlacesProtocolHandler.js
446 %{_libdir}/%{name}/components/Weave.js
447 %{_libdir}/%{name}/components/Aitc.js
448 %{_libdir}/%{name}/components/WebContentConverter.js
449 %{_libdir}/%{name}/components/browser.xpt
450 %{_libdir}/%{name}/components/fuelApplication.js
451 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
452 %{_libdir}/%{name}/components/nsBrowserGlue.js
453 %{_libdir}/%{name}/components/nsPrivateBrowsingService.js
454 %{_libdir}/%{name}/components/nsSessionStartup.js
455 %{_libdir}/%{name}/components/nsSessionStore.js
456 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
457 %{_libdir}/%{name}/components/nsSidebar.js
458 %{_libdir}/%{name}/components/PageThumbsProtocol.js
459 %{_libdir}/%{name}/components/ProfileMigrator.js
460 %{_libdir}/%{name}/components/DownloadsStartup.js
461 %{_libdir}/%{name}/components/DownloadsUI.js
462
463 %{_libdir}/%{name}/components/components.manifest
464 %{_libdir}/%{name}/components/interfaces.manifest
465
466 %if %{without xulrunner}
467 %{_libdir}/%{name}/dependentlibs.list
468 %{_libdir}/%{name}/platform.ini
469 %{_libdir}/%{name}/components/AppsService.js
470 %{_libdir}/%{name}/components/BrowserElementParent.js
471 %{_libdir}/%{name}/components/ConsoleAPI.js
472 %{_libdir}/%{name}/components/ContactManager.js
473 %{_libdir}/%{name}/components/FeedProcessor.js
474 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
475 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
476 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
477 %{_libdir}/%{name}/components/SettingsManager.js
478 %{_libdir}/%{name}/components/TelemetryPing.js
479 %{_libdir}/%{name}/components/addonManager.js
480 %{_libdir}/%{name}/components/amContentHandler.js
481 %{_libdir}/%{name}/components/amWebInstallListener.js
482 %{_libdir}/%{name}/components/contentAreaDropListener.js
483 %{_libdir}/%{name}/components/contentSecurityPolicy.js
484 %{_libdir}/%{name}/components/crypto-SDR.js
485 %{_libdir}/%{name}/components/jsconsole-clhandler.js
486 %{_libdir}/%{name}/components/messageWakeupService.js
487 %{_libdir}/%{name}/components/nsBadCertHandler.js
488 %{_libdir}/%{name}/components/nsBlocklistService.js
489 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
490 %{_libdir}/%{name}/components/nsContentPrefService.js
491 %{_libdir}/%{name}/components/nsDefaultCLH.js
492 %{_libdir}/%{name}/components/nsDownloadManagerUI.js
493 %{_libdir}/%{name}/components/nsFilePicker.js
494 %{_libdir}/%{name}/components/nsFormAutoComplete.js
495 %{_libdir}/%{name}/components/nsFormHistory.js
496 %{_libdir}/%{name}/components/nsHandlerService.js
497 %{_libdir}/%{name}/components/nsHelperAppDlg.js
498 %{_libdir}/%{name}/components/nsINIProcessor.js
499 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
500 %{_libdir}/%{name}/components/nsLivemarkService.js
501 %{_libdir}/%{name}/components/nsLoginInfo.js
502 %{_libdir}/%{name}/components/nsLoginManager.js
503 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
504 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
505 %{_libdir}/%{name}/components/nsPlacesExpiration.js
506 %{_libdir}/%{name}/components/nsPrompter.js
507 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
508 %{_libdir}/%{name}/components/nsSearchService.js
509 %{_libdir}/%{name}/components/nsSearchSuggestions.js
510 %{_libdir}/%{name}/components/nsTaggingService.js
511 %{_libdir}/%{name}/components/nsURLFormatter.js
512 %{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
513 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
514 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
515 %{_libdir}/%{name}/components/nsWebHandlerApp.js
516 %{_libdir}/%{name}/components/storage-Legacy.js
517 %{_libdir}/%{name}/components/storage-mozStorage.js
518 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
519 %endif
520
521 %{_libdir}/%{name}/webapprt
522 %attr(755,root,root) %{_libdir}/%{name}/webapprt-stub
523
524 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
525 %if %{without xulrunner}
526 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
527 %endif
528
529 %if %{without xulrunner}
530 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
531 %endif
532
533 %attr(755,root,root) %{_libdir}/%{name}/iceweasel
534 %dir %{_libdir}/%{name}/plugins
535 %if %{without xulrunner}
536 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
537 %attr(755,root,root) %{_libdir}/%{name}/iceweasel-bin
538 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
539 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
540 %endif
541
542 %{_iconsdir}/hicolor/*/*/iceweasel.png
543 %{_desktopdir}/iceweasel.desktop
544
545 # symlinks
546 %{_libdir}/%{name}/chrome
547 %{_libdir}/%{name}/defaults
548 %{_libdir}/%{name}/extensions
549 %{_libdir}/%{name}/icons
550 %{_libdir}/%{name}/modules
551 %{_libdir}/%{name}/searchplugins
552 %if %{with xulrunner}
553 %{_libdir}/%{name}/xulrunner
554 %else
555 %{_libdir}/%{name}/dictionaries
556 %{_libdir}/%{name}/hyphenation
557 %{_libdir}/%{name}/greprefs.js
558 %{_libdir}/%{name}/res
559 %endif
560
561 %dir %{_datadir}/%{name}
562 %{_datadir}/%{name}/chrome
563 %{_datadir}/%{name}/defaults
564 %{_datadir}/%{name}/icons
565 %{_datadir}/%{name}/modules
566 %{_datadir}/%{name}/searchplugins
567 %if %{without xulrunner}
568 %{_datadir}/%{name}/greprefs.js
569 %{_datadir}/%{name}/res
570 %endif
571
572 %dir %{_datadir}/%{name}/extensions
573 # the signature of the default theme
574 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
575
576 # files created by iceweasel -register
577 %ghost %{_libdir}/%{name}/components/compreg.dat
578 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.100811 seconds and 3 git commands to generate.