]> git.pld-linux.org Git - packages/iceweasel.git/blob - iceweasel.spec
8ab419cb611efa6663acfaf3a7645b4aa96e97cc
[packages/iceweasel.git] / iceweasel.spec
1 # TODO:
2 #  - provide proper $DISPLAY for PGO (Xvfb, Xdummy...) for unattended builds
3 #
4 # Conditional build:
5 %bcond_with     tests           # enable tests (whatever they check)
6 %bcond_without  gnomeui         # disable gnomeui support
7 %bcond_without  gnome           # synonym for gnomeui (gconf, libnotify and gio are still enabled)
8 %bcond_without  kerberos        # disable krb5 support
9 %bcond_with     xulrunner       # build without system xulrunner
10 %bcond_with     pgo             # PGO-enabled build (requires working $DISPLAY == :100)
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 # convert firefox release number to platform version: 19.0.x -> 19.0.x
17 %define         xulrunner_main  20.0
18 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#20.0})
19
20 %if %{without xulrunner}
21 # The actual sqlite version (see RHBZ#480989):
22 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
23 %endif
24
25 %define         nspr_ver        4.9.5
26 %define         nss_ver         3.14.3
27
28 Summary:        Iceweasel web browser
29 Summary(hu.UTF-8):      Iceweasel web böngésző
30 Summary(pl.UTF-8):      Iceweasel - przeglądarka WWW
31 Name:           iceweasel
32 Version:        20.0.1
33 Release:        3
34 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
35 Group:          X11/Applications/Networking
36 Source0:        http://releases.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
37 # Source0-md5:  b822ff4b2348410587dec563235d9320
38 Source1:        %{name}-branding.tar.bz2
39 # Source1-md5:  816d926bd2c76a5bba5108979ba776ac
40 Source2:        %{name}-rm_nonfree.sh
41 Source3:        %{name}.desktop
42 Source4:        %{name}.sh
43 Source5:        vendor.js
44 Source6:        vendor-ac.js
45 Patch0:         %{name}-branding.patch
46 Patch2:         %{name}-gcc3.patch
47 Patch7:         %{name}-prefs.patch
48 Patch8:         %{name}-pld-branding.patch
49 Patch9:         %{name}-no-subshell.patch
50 Patch10:        system-cairo.patch
51 Patch11:        %{name}-middle_click_paste.patch
52 Patch12:        %{name}-packaging.patch
53 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
54 Patch13:        system-virtualenv.patch
55 Patch14:        gyp-slashism.patch
56 URL:            http://www.pld-linux.org/Packages/Iceweasel
57 BuildRequires:  GConf2-devel >= 1.2.1
58 BuildRequires:  OpenGL-devel
59 BuildRequires:  ImageMagick
60 BuildRequires:  ImageMagick-coder-png
61 BuildRequires:  alsa-lib-devel
62 BuildRequires:  automake
63 BuildRequires:  bzip2-devel
64 BuildRequires:  cairo-devel >= 1.10.2-5
65 BuildRequires:  dbus-glib-devel >= 0.60
66 BuildRequires:  glib2-devel >= 1:2.20
67 BuildRequires:  gtk+2-devel >= 2:2.14
68 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
69 BuildRequires:  hunspell-devel
70 BuildRequires:  libIDL-devel >= 0.8.0
71 BuildRequires:  libdnet-devel
72 BuildRequires:  libevent-devel >= 1.4.7
73 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
74 BuildRequires:  libffi-devel >= 6:3.0.9
75 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
76 BuildRequires:  libiw-devel
77 # requires libjpeg-turbo implementing at least libjpeg 6b API
78 BuildRequires:  libjpeg-devel >= 6b
79 BuildRequires:  libjpeg-turbo-devel
80 BuildRequires:  libnotify-devel >= 0.4
81 BuildRequires:  libpng(APNG)-devel >= 0.10
82 BuildRequires:  libpng-devel >= 1.5.13
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libvpx-devel >= 1.0.0
85 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
86 BuildRequires:  nss-devel >= 1:%{nss_ver}
87 BuildRequires:  pango-devel >= 1:1.14.0
88 BuildRequires:  perl-modules >= 5.004
89 BuildRequires:  pkgconfig
90 BuildRequires:  pkgconfig(libffi) >= 3.0.9
91 BuildRequires:  python-modules
92 %{?with_pgo:BuildRequires:      python-modules-sqlite}
93 BuildRequires:  python-virtualenv
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.601
96 BuildRequires:  sqlite3-devel >= 3.7.15.2
97 BuildRequires:  startup-notification-devel >= 0.8
98 BuildRequires:  xorg-lib-libXScrnSaver-devel
99 BuildRequires:  xorg-lib-libXext-devel
100 BuildRequires:  xorg-lib-libXinerama-devel
101 BuildRequires:  xorg-lib-libXt-devel
102 %if %{with xulrunner}
103 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
104 %endif
105 BuildRequires:  zip
106 BuildRequires:  zlib-devel >= 1.2.3
107 Requires(post): mktemp >= 1.5-18
108 Requires:       desktop-file-utils
109 Requires:       hicolor-icon-theme
110 %if %{with xulrunner}
111 %requires_eq_to xulrunner xulrunner-devel
112 %else
113 Requires:       browser-plugins >= 2.0
114 Requires:       cairo >= 1.10.2-5
115 Requires:       dbus-glib >= 0.60
116 Requires:       glib2 >= 1:2.20
117 Requires:       gtk+2 >= 2:2.14
118 Requires:       libjpeg-turbo
119 Requires:       libpng >= 1.5.13
120 Requires:       libpng(APNG) >= 0.10
121 Requires:       myspell-common
122 Requires:       nspr >= 1:%{nspr_ver}
123 Requires:       nss >= 1:%{nss_ver}
124 Requires:       pango >= 1:1.14.0
125 Requires:       sqlite3 >= %{sqlite_build_version}
126 Requires:       startup-notification >= 0.8
127 %endif
128 Provides:       wwwbrowser
129 Obsoletes:      mozilla-firebird
130 Obsoletes:      mozilla-firefox
131 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
132 Obsoletes:      mozilla-firefox-libs
133 Conflicts:      iceweasel-lang-resources < %{version}
134 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
135
136 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
137
138 # don't satisfy other packages
139 %define         _noautoprovfiles        %{_libdir}/%{name}
140 %if %{without xulrunner}
141 # and as we don't provide them, don't require either
142 %define         _noautoreq      libmozalloc.so libmozjs.so libxpcom.so libxul.so
143 %endif
144
145 %description
146 Iceweasel is an open-source web browser, designed for standards
147 compliance, performance and portability.
148
149 %description -l hu.UTF-8
150 Iceweasel egy nyílt forrású webböngésző, hatékonyságra és
151 hordozhatóságra tervezve.
152
153 %description -l pl.UTF-8
154 Iceweasel jest przeglądarką WWW rozpowszechnianą zgodnie z ideami
155 ruchu otwartego oprogramowania oraz tworzoną z myślą o zgodności ze
156 standardami, wydajnością i przenośnością.
157
158 %prep
159 %setup -qc
160 mv -f mozilla-release mozilla
161 %setup -q -T -D -a1
162 cd mozilla
163 /bin/sh %{SOURCE2}
164
165 %patch0 -p1
166
167 %if "%{cc_version}" < "3.4"
168 %patch2 -p2
169 %endif
170
171 %patch7 -p1
172 %patch8 -p1
173 %patch9 -p2
174 %patch10 -p2
175 %patch11 -p2
176 %patch12 -p2
177 %patch13 -p2
178 %patch14 -p2
179
180 # config/rules.mk is patched by us and js/src/config/rules.mk
181 # is supposed to be exact copy
182 cp -a config/rules.mk js/src/config/rules.mk
183
184 %if %{with pgo}
185 sed -i -e 's@__BROWSER_PATH__@"../../dist/bin/iceweasel-bin"@' build/automation.py.in
186 %endif
187
188 %build
189 cd mozilla
190 cp -f %{_datadir}/automake/config.* build/autoconf
191
192 cat << EOF > .mozconfig
193 . \$topsrcdir/browser/config/mozconfig
194
195 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
196 # parallel build fails on _xpidlgen/
197 %if %{without xulrunner}
198 mk_add_options MOZ_MAKE_FLAGS=%{_smp_mflags}
199 %endif
200 mk_add_options PROFILE_GEN_SCRIPT='@PYTHON@ @MOZ_OBJDIR@/_profile/pgo/profileserver.py'
201
202 # Options for 'configure' (same as command-line options).
203 ac_add_options --prefix=%{_prefix}
204 ac_add_options --exec-prefix=%{_exec_prefix}
205 ac_add_options --bindir=%{_bindir}
206 ac_add_options --sbindir=%{_sbindir}
207 ac_add_options --sysconfdir=%{_sysconfdir}
208 ac_add_options --datadir=%{_datadir}
209 ac_add_options --includedir=%{_includedir}
210 ac_add_options --libdir=%{_libdir}
211 ac_add_options --libexecdir=%{_libexecdir}
212 ac_add_options --localstatedir=%{_localstatedir}
213 ac_add_options --sharedstatedir=%{_sharedstatedir}
214 ac_add_options --mandir=%{_mandir}
215 ac_add_options --infodir=%{_infodir}
216 ac_add_options --disable-elf-hack
217 %if %{?debug:1}0
218 ac_add_options --disable-optimize
219 ac_add_options --enable-debug
220 ac_add_options --enable-debug-modules
221 ac_add_options --enable-debugger-info-modules
222 ac_add_options --enable-crash-on-assert
223 %else
224 ac_add_options --disable-debug
225 ac_add_options --disable-debug-modules
226 ac_add_options --disable-logging
227 ac_add_options --enable-optimize="%{rpmcflags} -Os"
228 %endif
229 ac_add_options --disable-strip
230 ac_add_options --disable-strip-libs
231 %if %{with tests}
232 ac_add_options --enable-tests
233 %else
234 ac_add_options --disable-tests
235 %endif
236 %if %{with gnomeui}
237 ac_add_options --enable-gnomeui
238 %else
239 ac_add_options --disable-gnomeui
240 %endif
241 ac_add_options --disable-gnomevfs
242 ac_add_options --disable-crashreporter
243 ac_add_options --disable-installer
244 ac_add_options --disable-javaxpcom
245 ac_add_options --disable-updater
246 ac_add_options --enable-gio
247 ac_add_options --enable-libxul
248 ac_add_options --enable-pango
249 ac_add_options --enable-shared-js
250 ac_add_options --enable-startup-notification
251 ac_add_options --enable-system-cairo
252 ac_add_options --enable-system-hunspell
253 ac_add_options --enable-system-sqlite
254 ac_add_options --with-distribution-id=org.pld-linux
255 ac_add_options --with-branding=iceweasel/branding
256 %if %{with xulrunner}
257 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
258 %endif
259 ac_add_options --with-pthreads
260 ac_add_options --with-system-bz2
261 ac_add_options --with-system-ffi
262 ac_add_options --with-system-jpeg
263 ac_add_options --with-system-libevent
264 ac_add_options --with-system-libvpx
265 ac_add_options --with-system-nspr
266 ac_add_options --with-system-nss
267 ac_add_options --with-system-png
268 ac_add_options --with-system-zlib
269 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
270 EOF
271
272 %if %{with pgo}
273 export DISPLAY=:100 
274 %{__make} -f client.mk profiledbuild \
275         DESTDIR=obj-%{_target_cpu}/dist \
276         STRIP="/bin/true" \
277         CC="%{__cc}" \
278         CXX="%{__cxx}"
279 %else
280 %{__make} -f client.mk build \
281         STRIP="/bin/true" \
282         CC="%{__cc}" \
283         CXX="%{__cxx}"
284 %endif
285
286 %install
287 rm -rf $RPM_BUILD_ROOT
288 cd mozilla
289 install -d \
290         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
291         $RPM_BUILD_ROOT%{_desktopdir} \
292         $RPM_BUILD_ROOT%{_datadir}/%{name} \
293         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
294
295 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
296
297 cd obj-%{_target_cpu}
298 %{__make} -C browser/installer stage-package \
299         DESTDIR=$RPM_BUILD_ROOT \
300         installdir=%{_libdir}/%{name} \
301         PKG_SKIP_STRIP=1
302
303 %{__make} -C iceweasel/branding install \
304         DESTDIR=$RPM_BUILD_ROOT
305
306 cp -a dist/iceweasel/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
307
308 %if %{with xulrunner}
309 # >= 5.0 seems to require this
310 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
311 %endif
312
313 # move arch independant ones to datadir
314 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
315 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
316 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
317 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
318 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
319 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
320 %if %{without xulrunner}
321 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
322 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
323 %endif
324
325 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
326 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
327 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
328 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
329 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
330 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
331 %if %{without xulrunner}
332 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
333 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
334 %endif
335
336 %if %{without xulrunner}
337 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
338 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
339 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
340 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
341 %endif
342
343 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE4} > $RPM_BUILD_ROOT%{_bindir}/iceweasel
344 chmod 755 $RPM_BUILD_ROOT%{_bindir}/iceweasel
345 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/firefox
346 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
347
348 # install icons and desktop file
349 cp iceweasel/branding/{mozicon,default}128.png
350 for i in 16 32 48 64 128; do
351         install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
352         cp -a iceweasel/branding/default${i}.png \
353                 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/iceweasel.png
354 done
355
356 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
357
358 # install our settings
359 #cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
360 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/pref/vendor.js
361
362 %if "%{pld_release}" == "ac"
363 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
364 %endif
365
366 # files created by iceweasel -register
367 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
368 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
369
370 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
371 #!/bin/sh
372 umask 022
373 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
374
375 # it attempts to touch files in $HOME/.mozilla
376 # beware if you run this with sudo!!!
377 export HOME=$(mktemp -d)
378 # also TMPDIR could be pointing to sudo user's homedir
379 unset TMPDIR TMP || :
380
381 %{_libdir}/%{name}/iceweasel -register
382
383 rm -rf $HOME
384 EOF
385 chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
386
387 %clean
388 rm -rf $RPM_BUILD_ROOT
389
390 %pretrans
391 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
392         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
393 fi
394 for d in chrome defaults extensions greprefs.js icons res searchplugins; do
395         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
396                 install -d %{_datadir}/%{name}
397                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
398         fi
399 done
400 exit 0
401
402 %post
403 %{_sbindir}/%{name}-chrome+xpcom-generate
404 %update_browser_plugins
405 %update_icon_cache hicolor
406 %update_desktop_database
407
408 %postun
409 if [ "$1" = 0 ]; then
410         %update_browser_plugins
411         %update_icon_cache hicolor
412 fi
413
414 %files
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_bindir}/%{name}
417 %attr(755,root,root) %{_bindir}/firefox
418 %attr(755,root,root) %{_bindir}/mozilla-firefox
419 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
420
421 # browser plugins v2
422 %{_browserpluginsconfdir}/browsers.d/%{name}.*
423 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
424
425 %dir %{_libdir}/%{name}
426 %if %{without xulrunner}
427 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
428 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
429 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
430 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
431 %endif
432 %{_libdir}/%{name}/blocklist.xml
433
434 %if %{with crashreporter}
435 %{_libdir}/%{name}/crashreporter
436 %{_libdir}/%{name}/crashreporter-override.ini
437 %{_libdir}/%{name}/crashreporter.ini
438 %{_libdir}/%{name}/Throbber-small.gif
439 %endif
440
441 # config?
442 %{_libdir}/%{name}/application.ini
443 %{_libdir}/%{name}/chrome.manifest
444
445 %dir %{_libdir}/%{name}/components
446
447 %{_libdir}/%{name}/components/ChromeProfileMigrator.js
448 %{_libdir}/%{name}/components/DownloadsStartup.js
449 %{_libdir}/%{name}/components/DownloadsUI.js
450 %{_libdir}/%{name}/components/FeedConverter.js
451 %{_libdir}/%{name}/components/FeedWriter.js
452 %{_libdir}/%{name}/components/FirefoxProfileMigrator.js
453 %{_libdir}/%{name}/components/PageThumbsProtocol.js
454 %{_libdir}/%{name}/components/PlacesProtocolHandler.js
455 %{_libdir}/%{name}/components/ProfileMigrator.js
456 %{_libdir}/%{name}/components/WebContentConverter.js
457 %{_libdir}/%{name}/components/browser.xpt
458 %{_libdir}/%{name}/components/fuelApplication.js
459 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
460 %{_libdir}/%{name}/components/nsBrowserGlue.js
461 %{_libdir}/%{name}/components/nsPrivateBrowsingServiceObsolete.js
462 %{_libdir}/%{name}/components/nsSessionStartup.js
463 %{_libdir}/%{name}/components/nsSessionStore.js
464 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
465 %{_libdir}/%{name}/components/nsSidebar.js
466
467 %{_libdir}/%{name}/components/components.manifest
468 %{_libdir}/%{name}/components/interfaces.manifest
469
470 %if %{without xulrunner}
471 %{_libdir}/%{name}/dependentlibs.list
472 %{_libdir}/%{name}/platform.ini
473 %{_libdir}/%{name}/components/addonManager.js
474 %{_libdir}/%{name}/components/Aitc.js
475 %{_libdir}/%{name}/components/AlarmsManager.js
476 %{_libdir}/%{name}/components/amContentHandler.js
477 %{_libdir}/%{name}/components/amWebInstallListener.js
478 %{_libdir}/%{name}/components/AppsService.js
479 %{_libdir}/%{name}/components/BrowserElementParent.js
480 %{_libdir}/%{name}/components/ColorAnalyzer.js
481 %{_libdir}/%{name}/components/ConsoleAPI.js
482 %{_libdir}/%{name}/components/ContactManager.js
483 %{_libdir}/%{name}/components/contentAreaDropListener.js
484 %{_libdir}/%{name}/components/contentSecurityPolicy.js
485 %{_libdir}/%{name}/components/crypto-SDR.js
486 %{_libdir}/%{name}/components/FeedProcessor.js
487 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
488 %{_libdir}/%{name}/components/jsconsole-clhandler.js
489 %{_libdir}/%{name}/components/messageWakeupService.js
490 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
491 %{_libdir}/%{name}/components/nsBadCertHandler.js
492 %{_libdir}/%{name}/components/nsBlocklistService.js
493 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
494 %{_libdir}/%{name}/components/nsContentPrefService.js
495 %{_libdir}/%{name}/components/nsDefaultCLH.js
496 %{_libdir}/%{name}/components/nsDOMIdentity.js
497 %{_libdir}/%{name}/components/nsDownloadManagerUI.js
498 %{_libdir}/%{name}/components/nsFilePicker.js
499 %{_libdir}/%{name}/components/nsFormAutoComplete.js
500 %{_libdir}/%{name}/components/nsFormHistory.js
501 %{_libdir}/%{name}/components/nsHandlerService.js
502 %{_libdir}/%{name}/components/nsHelperAppDlg.js
503 %{_libdir}/%{name}/components/nsIDService.js
504 %{_libdir}/%{name}/components/nsINIProcessor.js
505 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
506 %{_libdir}/%{name}/components/nsLivemarkService.js
507 %{_libdir}/%{name}/components/nsLoginInfo.js
508 %{_libdir}/%{name}/components/nsLoginManager.js
509 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
510 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
511 %{_libdir}/%{name}/components/nsPlacesExpiration.js
512 %{_libdir}/%{name}/components/nsPrompter.js
513 %{_libdir}/%{name}/components/nsSearchService.js
514 %{_libdir}/%{name}/components/nsSearchSuggestions.js
515 %{_libdir}/%{name}/components/nsTaggingService.js
516 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
517 %{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
518 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
519 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
520 %{_libdir}/%{name}/components/nsURLFormatter.js
521 %{_libdir}/%{name}/components/nsWebHandlerApp.js
522 %{_libdir}/%{name}/components/PeerConnection.js
523 %{_libdir}/%{name}/components/PermissionSettings.js
524 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
525 %{_libdir}/%{name}/components/SettingsManager.js
526 %{_libdir}/%{name}/components/SiteSpecificUserAgent.js
527 %{_libdir}/%{name}/components/storage-Legacy.js
528 %{_libdir}/%{name}/components/storage-mozStorage.js
529 %{_libdir}/%{name}/components/TCPSocket.js
530 %{_libdir}/%{name}/components/TCPSocketParentIntermediary.js
531 %{_libdir}/%{name}/components/TelemetryPing.js
532 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
533 %{_libdir}/%{name}/components/Weave.js
534 %{_libdir}/%{name}/components/Webapps.js
535 %endif
536
537 %{_libdir}/%{name}/webapprt
538 %attr(755,root,root) %{_libdir}/%{name}/webapprt-stub
539
540 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
541 %if %{without xulrunner}
542 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
543 %endif
544
545 %if %{without xulrunner}
546 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
547 %endif
548
549 %attr(755,root,root) %{_libdir}/%{name}/iceweasel
550 %dir %{_libdir}/%{name}/plugins
551 %if %{without xulrunner}
552 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
553 %attr(755,root,root) %{_libdir}/%{name}/iceweasel-bin
554 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
555 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
556 %endif
557
558 %{_iconsdir}/hicolor/*/*/iceweasel.png
559 %{_desktopdir}/iceweasel.desktop
560
561 # symlinks
562 %{_libdir}/%{name}/chrome
563 %{_libdir}/%{name}/defaults
564 %{_libdir}/%{name}/extensions
565 %{_libdir}/%{name}/icons
566 %{_libdir}/%{name}/modules
567 %{_libdir}/%{name}/searchplugins
568 %if %{with xulrunner}
569 %{_libdir}/%{name}/xulrunner
570 %else
571 %{_libdir}/%{name}/dictionaries
572 %{_libdir}/%{name}/hyphenation
573 %{_libdir}/%{name}/greprefs.js
574 %{_libdir}/%{name}/res
575 %endif
576
577 %dir %{_datadir}/%{name}
578 %{_datadir}/%{name}/chrome
579 %{_datadir}/%{name}/defaults
580 %{_datadir}/%{name}/icons
581 %{_datadir}/%{name}/modules
582 %{_datadir}/%{name}/searchplugins
583 %if %{without xulrunner}
584 %{_datadir}/%{name}/greprefs.js
585 %{_datadir}/%{name}/res
586 %endif
587
588 %dir %{_datadir}/%{name}/extensions
589 # the signature of the default theme
590 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
591
592 # files created by iceweasel -register
593 %ghost %{_libdir}/%{name}/components/compreg.dat
594 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.074826 seconds and 2 git commands to generate.