]> git.pld-linux.org Git - packages/iceweasel.git/blob - iceweasel.spec
4660f3834aefd1a6335ea18fcc29f2f00c41bae9
[packages/iceweasel.git] / iceweasel.spec
1 # TODO:
2 #  - provide proper $DISPLAY for PGO (Xvfb, Xdummy...) for unattended builds
3 #
4 # Conditional build:
5 %bcond_with     tests           # enable tests (whatever they check)
6 %bcond_without  gnomeui         # disable gnomeui support
7 %bcond_without  gnome           # synonym for gnomeui (gconf, libnotify and gio are still enabled)
8 %bcond_without  kerberos        # disable krb5 support
9 %bcond_without  xulrunner       # build without system xulrunner
10 %bcond_with     pgo             # PGO-enabled build (requires working $DISPLAY == :100)
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 # convert firefox release number to platform version: 9.0.x -> 9.0.x
17 %define         xulrunner_main  17.0
18 %define         xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#17.0})
19
20 %if %{without xulrunner}
21 # The actual sqlite version (see RHBZ#480989):
22 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
23 %endif
24
25 Summary:        Iceweasel web browser
26 Summary(hu.UTF-8):      Iceweasel web böngésző
27 Summary(pl.UTF-8):      Iceweasel - przeglądarka WWW
28 Name:           iceweasel
29 Version:        18.0
30 Release:        1
31 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
32 Group:          X11/Applications/Networking
33 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/%{version}/source/firefox-%{version}.source.tar.bz2
34 # Source0-md5:  485d02563854c20a3788d89db07b0687
35 Source1:        %{name}-branding.tar.bz2
36 # Source1-md5:  266f006f33249f7562f71dacac67157b
37 Source2:        %{name}-rm_nonfree.sh
38 Source3:        %{name}.desktop
39 Source4:        %{name}.sh
40 Source5:        vendor.js
41 Source6:        vendor-ac.js
42 Patch0:         %{name}-branding.patch
43 Patch1:         %{name}-install.patch
44 Patch2:         %{name}-gcc3.patch
45 Patch7:         %{name}-prefs.patch
46 Patch8:         %{name}-pld-branding.patch
47 Patch9:         %{name}-no-subshell.patch
48 Patch10:        system-cairo.patch
49 Patch11:        %{name}-middle_click_paste.patch
50 Patch12:        %{name}-packaging.patch
51 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
52 Patch13:        system-virtualenv.patch
53 URL:            http://www.pld-linux.org/Packages/Iceweasel
54 BuildRequires:  GConf2-devel >= 1.2.1
55 BuildRequires:  OpenGL-devel
56 BuildRequires:  alsa-lib-devel
57 BuildRequires:  automake
58 BuildRequires:  bzip2-devel
59 BuildRequires:  cairo-devel >= 1.10.2-5
60 BuildRequires:  dbus-glib-devel >= 0.60
61 BuildRequires:  glib2-devel >= 1:2.18
62 BuildRequires:  gtk+2-devel >= 2:2.14
63 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
64 BuildRequires:  hunspell-devel
65 BuildRequires:  libIDL-devel >= 0.8.0
66 BuildRequires:  libdnet-devel
67 BuildRequires:  libevent-devel >= 1.4.7
68 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
69 BuildRequires:  libffi-devel >= 6:3.0.9
70 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
71 BuildRequires:  libiw-devel
72 BuildRequires:  libjpeg-devel >= 6b
73 BuildRequires:  libnotify-devel >= 0.4
74 BuildRequires:  libpng(APNG)-devel >= 0.10
75 BuildRequires:  libpng-devel >= 1.4.1
76 BuildRequires:  libstdc++-devel
77 BuildRequires:  libvpx-devel >= 1.0.0
78 BuildRequires:  nspr-devel >= 1:4.9
79 BuildRequires:  nss-devel >= 1:3.13.3
80 BuildRequires:  pango-devel >= 1:1.14.0
81 BuildRequires:  perl-modules >= 5.004
82 BuildRequires:  pkgconfig
83 BuildRequires:  pkgconfig(libffi) >= 3.0.9
84 BuildRequires:  python-modules
85 %{?with_pgo:BuildRequires:      python-modules-sqlite}
86 BuildRequires:  python-virtualenv
87 BuildRequires:  rpm >= 4.4.9-56
88 BuildRequires:  rpmbuild(macros) >= 1.601
89 BuildRequires:  sqlite3-devel >= 3.7.10
90 BuildRequires:  startup-notification-devel >= 0.8
91 BuildRequires:  xorg-lib-libXScrnSaver-devel
92 BuildRequires:  xorg-lib-libXext-devel
93 BuildRequires:  xorg-lib-libXinerama-devel
94 BuildRequires:  xorg-lib-libXt-devel
95 %if %{with xulrunner}
96 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
97 %endif
98 BuildRequires:  zip
99 BuildRequires:  zlib-devel >= 1.2.3
100 Requires(post): mktemp >= 1.5-18
101 Requires:       desktop-file-utils
102 Requires:       hicolor-icon-theme
103 %if %{with xulrunner}
104 %requires_eq_to xulrunner xulrunner-devel
105 %else
106 Requires:       browser-plugins >= 2.0
107 Requires:       cairo >= 1.10.2-5
108 Requires:       dbus-glib >= 0.60
109 Requires:       glib2 >= 1:2.18
110 Requires:       gtk+2 >= 2:2.14
111 Requires:       libpng >= 1.4.1
112 Requires:       libpng(APNG) >= 0.10
113 Requires:       myspell-common
114 Requires:       nspr >= 1:4.8.9
115 Requires:       nss >= 1:3.13.1
116 Requires:       pango >= 1:1.14.0
117 Requires:       sqlite3 >= %{sqlite_build_version}
118 Requires:       startup-notification >= 0.8
119 %endif
120 Provides:       wwwbrowser
121 Obsoletes:      mozilla-firebird
122 Obsoletes:      mozilla-firefox
123 Obsoletes:      mozilla-firefox-lang-en < 2.0.0.8-3
124 Obsoletes:      mozilla-firefox-libs
125 Conflicts:      iceweasel-lang-resources < %{version}
126 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
127
128 %define         filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
129
130 # don't satisfy other packages
131 %define         _noautoprovfiles        %{_libdir}/%{name}
132 %if %{without xulrunner}
133 # and as we don't provide them, don't require either
134 %define         _noautoreq      libmozalloc.so libmozjs.so libxpcom.so libxul.so
135 %endif
136
137 %description
138 Iceweasel is an open-source web browser, designed for standards
139 compliance, performance and portability.
140
141 %description -l hu.UTF-8
142 Iceweasel egy nyílt forrású webböngésző, hatékonyságra és
143 hordozhatóságra tervezve.
144
145 %description -l pl.UTF-8
146 Iceweasel jest przeglądarką WWW rozpowszechnianą zgodnie z ideami
147 ruchu otwartego oprogramowania oraz tworzoną z myślą o zgodności ze
148 standardami, wydajnością i przenośnością.
149
150 %prep
151 %setup -qc
152 mv -f mozilla-release mozilla
153 %setup -q -T -D -a1
154 cd mozilla
155 /bin/sh %{SOURCE2}
156
157 %patch0 -p1
158 %patch1 -p1
159
160 %if "%{cc_version}" < "3.4"
161 %patch2 -p2
162 %endif
163
164 %patch7 -p1
165 %patch8 -p1
166 %patch9 -p2
167 %patch10 -p2
168 %patch11 -p2
169 %patch12 -p2
170 %patch13 -p2
171
172 # config/rules.mk is patched by us and js/src/config/rules.mk
173 # is supposed to be exact copy
174 cp -a config/rules.mk js/src/config/rules.mk
175
176 %if %{with pgo}
177 sed -i -e 's@__BROWSER_PATH__@"../../dist/bin/iceweasel-bin"@' build/automation.py.in
178 %endif
179
180 %build
181 cd mozilla
182 cp -f %{_datadir}/automake/config.* build/autoconf
183
184 cat << EOF > .mozconfig
185 . \$topsrcdir/browser/config/mozconfig
186
187 mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-%{_target_cpu}
188 # parallel build fails on _xpidlgen/
189 %if %{without xulrunner}
190 mk_add_options MOZ_MAKE_FLAGS=%{_smp_mflags}
191 %endif
192 mk_add_options PROFILE_GEN_SCRIPT='@PYTHON@ @MOZ_OBJDIR@/_profile/pgo/profileserver.py'
193
194 # Options for 'configure' (same as command-line options).
195 ac_add_options --prefix=%{_prefix}
196 ac_add_options --exec-prefix=%{_exec_prefix}
197 ac_add_options --bindir=%{_bindir}
198 ac_add_options --sbindir=%{_sbindir}
199 ac_add_options --sysconfdir=%{_sysconfdir}
200 ac_add_options --datadir=%{_datadir}
201 ac_add_options --includedir=%{_includedir}
202 ac_add_options --libdir=%{_libdir}
203 ac_add_options --libexecdir=%{_libexecdir}
204 ac_add_options --localstatedir=%{_localstatedir}
205 ac_add_options --sharedstatedir=%{_sharedstatedir}
206 ac_add_options --mandir=%{_mandir}
207 ac_add_options --infodir=%{_infodir}
208 ac_add_options --disable-elf-hack
209 %if %{?debug:1}0
210 ac_add_options --disable-optimize
211 ac_add_options --enable-debug
212 ac_add_options --enable-debug-modules
213 ac_add_options --enable-debugger-info-modules
214 ac_add_options --enable-crash-on-assert
215 %else
216 ac_add_options --disable-debug
217 ac_add_options --disable-debug-modules
218 ac_add_options --disable-logging
219 ac_add_options --enable-optimize="%{rpmcflags} -Os"
220 %endif
221 ac_add_options --disable-strip
222 ac_add_options --disable-strip-libs
223 %if %{with tests}
224 ac_add_options --enable-tests
225 %else
226 ac_add_options --disable-tests
227 %endif
228 %if %{with gnomeui}
229 ac_add_options --enable-gnomeui
230 %else
231 ac_add_options --disable-gnomeui
232 %endif
233 ac_add_options --disable-gnomevfs
234 ac_add_options --disable-crashreporter
235 ac_add_options --disable-installer
236 ac_add_options --disable-javaxpcom
237 ac_add_options --disable-updater
238 ac_add_options --enable-gio
239 ac_add_options --enable-libxul
240 ac_add_options --enable-pango
241 ac_add_options --enable-shared-js
242 ac_add_options --enable-startup-notification
243 ac_add_options --enable-system-cairo
244 ac_add_options --enable-system-hunspell
245 ac_add_options --enable-system-sqlite
246 ac_add_options --with-distribution-id=org.pld-linux
247 ac_add_options --with-branding=iceweasel/branding
248 %if %{with xulrunner}
249 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
250 %endif
251 ac_add_options --with-pthreads
252 ac_add_options --with-system-bz2
253 ac_add_options --with-system-ffi
254 ac_add_options --with-system-jpeg
255 ac_add_options --with-system-libevent
256 ac_add_options --with-system-libvpx
257 ac_add_options --with-system-nspr
258 ac_add_options --with-system-nss
259 ac_add_options --with-system-png
260 ac_add_options --with-system-zlib
261 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
262 EOF
263
264 %if %{with pgo}
265 export DISPLAY=:100 
266 %{__make} -f client.mk profiledbuild \
267         DESTDIR=obj-%{_target_cpu}/dist \
268         STRIP="/bin/true" \
269         CC="%{__cc}" \
270         CXX="%{__cxx}"
271 %else
272 %{__make} -f client.mk build \
273         STRIP="/bin/true" \
274         CC="%{__cc}" \
275         CXX="%{__cxx}"
276 %endif
277
278 %install
279 rm -rf $RPM_BUILD_ROOT
280 cd mozilla
281 install -d \
282         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}} \
283         $RPM_BUILD_ROOT%{_desktopdir} \
284         $RPM_BUILD_ROOT%{_datadir}/%{name}
285
286 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
287
288 %{__make} -C obj-%{_target_cpu}/browser/installer stage-package \
289         DESTDIR=$RPM_BUILD_ROOT \
290         MOZ_PKG_APPDIR=%{_libdir}/%{name} \
291         MOZ_PKG_DIR=%{_libdir}/%{name} \
292         PKG_SKIP_STRIP=1
293
294 install -d \
295         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
296
297 %if %{with xulrunner}
298 # >= 5.0 seems to require this
299 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
300 %endif
301
302 # move arch independant ones to datadir
303 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
304 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
305 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
306 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/icons $RPM_BUILD_ROOT%{_datadir}/%{name}/icons
307 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
308 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
309 %if %{without xulrunner}
310 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
311 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
312 %endif
313
314 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
315 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
316 ln -s ../../share/%{name}/extensions $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
317 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
318 ln -s ../../share/%{name}/icons $RPM_BUILD_ROOT%{_libdir}/%{name}/icons
319 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
320 %if %{without xulrunner}
321 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
322 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
323 %endif
324
325 %if %{without xulrunner}
326 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
327 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
328 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
329 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
330 %endif
331
332 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE4} > $RPM_BUILD_ROOT%{_bindir}/iceweasel
333 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/iceweasel
334 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/firefox
335 ln -s iceweasel $RPM_BUILD_ROOT%{_bindir}/mozilla-firefox
336
337 # install icons and desktop file
338 cp obj-%{_target_cpu}/iceweasel/branding/{mozicon,default}128.png
339 for i in 16 32 48 64 128; do
340         install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
341         cp -a obj-%{_target_cpu}/iceweasel/branding/default${i}.png \
342                 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/iceweasel.png
343 done
344
345 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
346
347 # install our settings
348 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
349
350 %if "%{pld_release}" == "ac"
351 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults/preferences/vendor.js
352 %endif
353
354 # files created by iceweasel -register
355 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
356 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
357
358 %if %{with xulrunner}
359 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/run-mozilla.sh
360 %endif
361
362 cat << 'EOF' > $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
363 #!/bin/sh
364 umask 022
365 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
366
367 # it attempts to touch files in $HOME/.mozilla
368 # beware if you run this with sudo!!!
369 export HOME=$(mktemp -d)
370 # also TMPDIR could be pointing to sudo user's homedir
371 unset TMPDIR TMP || :
372
373 %{_libdir}/%{name}/iceweasel -register
374
375 rm -rf $HOME
376 EOF
377 chmod 755 $RPM_BUILD_ROOT%{_sbindir}/%{name}-chrome+xpcom-generate
378
379 %clean
380 rm -rf $RPM_BUILD_ROOT
381
382 %pretrans
383 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
384         mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
385 fi
386 for d in chrome defaults extensions greprefs.js icons res searchplugins; do
387         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
388                 install -d %{_datadir}/%{name}
389                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
390         fi
391 done
392 exit 0
393
394 %post
395 %{_sbindir}/%{name}-chrome+xpcom-generate
396 %update_browser_plugins
397 %update_icon_cache hicolor
398 %update_desktop_database
399
400 %postun
401 if [ "$1" = 0 ]; then
402         %update_browser_plugins
403         %update_icon_cache hicolor
404 fi
405
406 %files
407 %defattr(644,root,root,755)
408 %attr(755,root,root) %{_bindir}/%{name}
409 %attr(755,root,root) %{_bindir}/firefox
410 %attr(755,root,root) %{_bindir}/mozilla-firefox
411 %attr(755,root,root) %{_sbindir}/%{name}-chrome+xpcom-generate
412
413 # browser plugins v2
414 %{_browserpluginsconfdir}/browsers.d/%{name}.*
415 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
416
417 %dir %{_libdir}/%{name}
418 %if %{without xulrunner}
419 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
420 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
421 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
422 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
423 %endif
424 %{_libdir}/%{name}/blocklist.xml
425
426 %if %{with crashreporter}
427 %{_libdir}/%{name}/crashreporter
428 %{_libdir}/%{name}/crashreporter-override.ini
429 %{_libdir}/%{name}/crashreporter.ini
430 %{_libdir}/%{name}/Throbber-small.gif
431 %endif
432
433 # config?
434 %{_libdir}/%{name}/application.ini
435 %{_libdir}/%{name}/chrome.manifest
436
437 %dir %{_libdir}/%{name}/components
438
439 %{_libdir}/%{name}/components/ChromeProfileMigrator.js
440 %{_libdir}/%{name}/components/FeedConverter.js
441 %{_libdir}/%{name}/components/FeedWriter.js
442 %{_libdir}/%{name}/components/FirefoxProfileMigrator.js
443 %{_libdir}/%{name}/components/PlacesProtocolHandler.js
444 %{_libdir}/%{name}/components/Weave.js
445 %{_libdir}/%{name}/components/Aitc.js
446 %{_libdir}/%{name}/components/WebContentConverter.js
447 %{_libdir}/%{name}/components/browser.xpt
448 %{_libdir}/%{name}/components/fuelApplication.js
449 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
450 %{_libdir}/%{name}/components/nsBrowserGlue.js
451 %{_libdir}/%{name}/components/nsPrivateBrowsingService.js
452 %{_libdir}/%{name}/components/nsSessionStartup.js
453 %{_libdir}/%{name}/components/nsSessionStore.js
454 %{_libdir}/%{name}/components/nsSetDefaultBrowser.js
455 %{_libdir}/%{name}/components/nsSidebar.js
456 %{_libdir}/%{name}/components/PageThumbsProtocol.js
457 %{_libdir}/%{name}/components/ProfileMigrator.js
458 %{_libdir}/%{name}/components/DownloadsStartup.js
459 %{_libdir}/%{name}/components/DownloadsUI.js
460
461 %{_libdir}/%{name}/components/components.manifest
462 %{_libdir}/%{name}/components/interfaces.manifest
463
464 %if %{without xulrunner}
465 %{_libdir}/%{name}/dependentlibs.list
466 %{_libdir}/%{name}/platform.ini
467 %{_libdir}/%{name}/components/AppsService.js
468 %{_libdir}/%{name}/components/BrowserElementParent.js
469 %{_libdir}/%{name}/components/ConsoleAPI.js
470 %{_libdir}/%{name}/components/ContactManager.js
471 %{_libdir}/%{name}/components/FeedProcessor.js
472 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
473 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
474 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
475 %{_libdir}/%{name}/components/SettingsManager.js
476 %{_libdir}/%{name}/components/TelemetryPing.js
477 %{_libdir}/%{name}/components/addonManager.js
478 %{_libdir}/%{name}/components/amContentHandler.js
479 %{_libdir}/%{name}/components/amWebInstallListener.js
480 %{_libdir}/%{name}/components/contentAreaDropListener.js
481 %{_libdir}/%{name}/components/contentSecurityPolicy.js
482 %{_libdir}/%{name}/components/crypto-SDR.js
483 %{_libdir}/%{name}/components/jsconsole-clhandler.js
484 %{_libdir}/%{name}/components/messageWakeupService.js
485 %{_libdir}/%{name}/components/nsBadCertHandler.js
486 %{_libdir}/%{name}/components/nsBlocklistService.js
487 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
488 %{_libdir}/%{name}/components/nsContentPrefService.js
489 %{_libdir}/%{name}/components/nsDefaultCLH.js
490 %{_libdir}/%{name}/components/nsDownloadManagerUI.js
491 %{_libdir}/%{name}/components/nsFilePicker.js
492 %{_libdir}/%{name}/components/nsFormAutoComplete.js
493 %{_libdir}/%{name}/components/nsFormHistory.js
494 %{_libdir}/%{name}/components/nsHandlerService.js
495 %{_libdir}/%{name}/components/nsHelperAppDlg.js
496 %{_libdir}/%{name}/components/nsINIProcessor.js
497 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
498 %{_libdir}/%{name}/components/nsLivemarkService.js
499 %{_libdir}/%{name}/components/nsLoginInfo.js
500 %{_libdir}/%{name}/components/nsLoginManager.js
501 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
502 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
503 %{_libdir}/%{name}/components/nsPlacesExpiration.js
504 %{_libdir}/%{name}/components/nsPrompter.js
505 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
506 %{_libdir}/%{name}/components/nsSearchService.js
507 %{_libdir}/%{name}/components/nsSearchSuggestions.js
508 %{_libdir}/%{name}/components/nsTaggingService.js
509 %{_libdir}/%{name}/components/nsURLFormatter.js
510 %{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
511 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
512 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
513 %{_libdir}/%{name}/components/nsWebHandlerApp.js
514 %{_libdir}/%{name}/components/storage-Legacy.js
515 %{_libdir}/%{name}/components/storage-mozStorage.js
516 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
517 %endif
518
519 %{_libdir}/%{name}/webapprt
520 %attr(755,root,root) %{_libdir}/%{name}/webapprt-stub
521
522 %attr(755,root,root) %{_libdir}/%{name}/components/libbrowsercomps.so
523 %if %{without xulrunner}
524 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
525 %endif
526
527 %if %{without xulrunner}
528 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
529 %endif
530
531 %attr(755,root,root) %{_libdir}/%{name}/iceweasel
532 %dir %{_libdir}/%{name}/plugins
533 %if %{without xulrunner}
534 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
535 %attr(755,root,root) %{_libdir}/%{name}/iceweasel-bin
536 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
537 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
538 %endif
539
540 %{_iconsdir}/hicolor/*/*/iceweasel.png
541 %{_desktopdir}/iceweasel.desktop
542
543 # symlinks
544 %{_libdir}/%{name}/chrome
545 %{_libdir}/%{name}/defaults
546 %{_libdir}/%{name}/extensions
547 %{_libdir}/%{name}/icons
548 %{_libdir}/%{name}/modules
549 %{_libdir}/%{name}/searchplugins
550 %if %{with xulrunner}
551 %{_libdir}/%{name}/xulrunner
552 %else
553 %{_libdir}/%{name}/dictionaries
554 %{_libdir}/%{name}/hyphenation
555 %{_libdir}/%{name}/greprefs.js
556 %{_libdir}/%{name}/res
557 %endif
558
559 %dir %{_datadir}/%{name}
560 %{_datadir}/%{name}/chrome
561 %{_datadir}/%{name}/defaults
562 %{_datadir}/%{name}/icons
563 %{_datadir}/%{name}/modules
564 %{_datadir}/%{name}/searchplugins
565 %if %{without xulrunner}
566 %{_datadir}/%{name}/greprefs.js
567 %{_datadir}/%{name}/res
568 %endif
569
570 %dir %{_datadir}/%{name}/extensions
571 # the signature of the default theme
572 %{_datadir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
573
574 # files created by iceweasel -register
575 %ghost %{_libdir}/%{name}/components/compreg.dat
576 %ghost %{_libdir}/%{name}/components/xpti.dat
This page took 0.096434 seconds and 2 git commands to generate.