]> git.pld-linux.org Git - packages/icedtea6.git/blob - icedtea6.spec
baee150f0286c8768cf764d4a14f728c84f15081
[packages/icedtea6.git] / icedtea6.spec
1 # TODO:
2 # - install .ttf fonts (same as in sun-java-base-jre-X11 package) or configure
3 #   it to use system fonts (is it possible?).
4
5 %bcond_with bootstrap   # don't use an installed icedtea6, use ecj instead
6 %bcond_without nss      # don't use NSS
7
8 %if %{with bootstrap}
9 %define         use_jdk java-gcj-compat
10 %else
11 %define         use_jdk icedtea6
12 %endif
13
14 # class data version seen with file(1) that this jvm is able to load
15 %define         _classdataversion 50.0
16 # JDK/JRE version, as returned with `java -version`, '_' replaced with '.'
17 %define         _jdkversion 1.6.0.24
18
19 Summary:        OpenJDK and GNU Classpath code
20 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath
21 Name:           icedtea6
22 Version:        1.12.4
23 Release:        1
24 License:        GPL v2
25 Group:          Development/Languages/Java
26 Source0:        http://icedtea.classpath.org/download/source/%{name}-%{version}.tar.gz
27 # Source0-md5:  85bfc656c20fb762b72b71d3492a326c
28 # following sources should match those in Makefile.am
29 Source1:        http://download.java.net/openjdk/jdk6/promoted/b24/openjdk-6-src-b27-26_oct_2012.tar.gz
30 # Source1-md5:  3a0963158e07c8829c8bd31a698bd23d
31 Source2:        http://icedtea.classpath.org/download/drops/jdk6-jaxws2_1_6-2011_06_13.zip
32 # Source2-md5:  8fd91b09b643a19a912b8a75e7a7a9d5
33 Source3:        http://icedtea.classpath.org/download/drops/jdk6-jaf-b20.zip
34 # Source3-md5:  bc95c133620bd68c161cac9891592901
35 Source4:        http://icedtea.classpath.org/download/drops/jaxp144_04.zip
36 # Source4-md5:  0ace787aa12177d201947e8ba0ba9bdd
37 Patch0:         %{name}-i486.patch
38 Patch1:         %{name}-libpath.patch
39 URL:            http://icedtea.classpath.org/wiki/Main_Page
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  ant
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  bash
45 BuildRequires:  cups-devel
46 BuildRequires:  /usr/bin/jar
47 BuildRequires:  freetype-devel >= 2.3
48 BuildRequires:  gawk
49 %{?with_bootstrap:BuildRequires:        gcc-java >= 6:4.3}
50 BuildRequires:  giflib-devel
51 BuildRequires:  glib2-devel
52 BuildRequires:  glibc-misc
53 BuildRequires:  gtk+2-devel
54 BuildRequires:  java-rhino
55 BuildRequires:  java-xalan
56 %{?with_bootstrap:BuildRequires:        java-xerces}
57 %buildrequires_jdk
58 BuildRequires:  libffi-devel
59 # for /usr/share/java/ecj.jar:
60 BuildRequires:  libgcj
61 BuildRequires:  libjpeg-devel
62 BuildRequires:  libpng-devel
63 BuildRequires:  libstdc++-static
64 BuildRequires:  lsb-release
65 %{?with_nss:BuildRequires:      nss-devel}
66 BuildRequires:  pkgconfig
67 BuildRequires:  rpmbuild(macros) >= 1.557
68 BuildRequires:  unzip
69 BuildRequires:  util-linux
70 BuildRequires:  xorg-lib-libX11-devel
71 BuildRequires:  xorg-lib-libXinerama-devel
72 BuildRequires:  xorg-lib-libXp-devel
73 BuildRequires:  xorg-lib-libXrender-devel
74 BuildRequires:  xorg-lib-libXt-devel
75 BuildRequires:  xorg-lib-libXtst-devel
76 BuildRequires:  xorg-proto-printproto-devel
77 BuildRequires:  xorg-proto-xproto-devel
78 BuildRequires:  zip
79 BuildRequires:  zlib-devel
80 Requires:       %{name}-appletviewer = %{version}-%{release}
81 Requires:       %{name}-jdk = %{version}-%{release}
82 Suggests:       %{name}-jre-X11
83 Suggests:       icedtea-web
84 Obsoletes:      java5-sun
85 Obsoletes:      java5-sun-jre
86 Obsoletes:      java5-sun-jre-jdbc
87 Obsoletes:      java5-sun-jre-X11
88 Obsoletes:      java5-sun-tools
89 Obsoletes:      java-gcj-compat
90 Obsoletes:      java-gcj-compat-devel
91 Obsoletes:      java-sun
92 Obsoletes:      java-sun-demos
93 Obsoletes:      java-sun-jre
94 Obsoletes:      java-sun-jre-alsa
95 Obsoletes:      java-sun-jre-jdbc
96 Obsoletes:      java-sun-jre-X11
97 Obsoletes:      java-sun-tools
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         dstreldir       %{name}-%{version}
101 %define         dstdir          %{_jvmdir}/%{dstreldir}
102 %define         jrereldir       %{dstreldir}/jre
103 %define         jredir          %{_jvmdir}/%{jrereldir}
104 %define         jvmjardir       %{_jvmjardir}/%{name}-%{version}
105
106 %ifarch x86_64 amd64
107 %define         jre_arch        amd64
108 %else
109 %define         jre_arch        i386
110 %endif
111
112 # to break artificial subpackage dependency loops
113 %define         _noautoreq      'libmawt.so' 'java(ClassDataVersion)'
114
115 %description
116 The IcedTea project provides a harness to build the source code from
117 http://openjdk.java.net/ using Free Software build tools and provides
118 replacements libraries for the binary plugs with code from the GNU
119 Classpath project.
120
121 This is a meta-package which provides, by its dependencies, all the
122 IcedTea6 components including the OpenJDK, Java 6 developement kit and
123 runtime environment.
124
125 %description -l pl.UTF-8
126 Projekt IcedTea daje możliwość kompilacji kodu źródłowego z
127 http://openjdk.java.net/ przy użyciu wolnodostępnych narzędzi oraz
128 dostarcza zamienniki biblioteczne binarnych wtyczek pochodzące z
129 projektu GNU Classpath.
130
131 To jest meta-pakiet, który, za pośrednictwem zależności, dostarcza
132 wszystkie komponenty IcedTea6, w tym środowisko programistyczne
133 (OpenJDK) i uruchomieniowe (JRE).
134
135 %package jdk
136 Summary:        OpenJDK and GNU Classpath code - software development kit
137 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko programistyczne
138 Group:          Development/Languages/Java
139 Requires:       %{name}-jar = %{version}-%{release}
140 Requires:       %{name}-jdk-base = %{version}-%{release}
141 Requires:       %{name}-jre = %{version}-%{release}
142 Provides:       j2sdk = %{_jdkversion}
143 Provides:       jdk = %{_jdkversion}
144 Obsoletes:      blackdown-java-sdk
145 Obsoletes:      ibm-java
146 Obsoletes:      java-blackdown
147 Obsoletes:      java-gcj-compat-devel
148 Obsoletes:      java-sun
149 Obsoletes:      java5-sun
150 Obsoletes:      jdk
151 Obsoletes:      kaffe
152
153 %description jdk
154 This package symlinks OpenJDK development tools provided by
155 %{name}-jdk-base to system-wide directories like %{_bindir}, making
156 IcedTea6 default JDK.
157
158 %description jdk -l pl.UTF-8
159 Ten pakiet tworzy symboliczne dowiązania do narzędzi programistycznych
160 OpenJDK, dostarczanych przez pakiet %{name}-jdk-base, w standardowych
161 systemowych ścieżkach takich jak %{_bindir}, sprawiając tym samym, że
162 IcedTea6 staje się domyślnym JDK w systemie.
163
164 %package jdk-base
165 Summary:        OpenJDK and GNU Classpath code - software development kit
166 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko programistyczne
167 Group:          Development/Languages/Java
168 Requires:       %{name}-jre-base = %{version}-%{release}
169 Requires:       jpackage-utils >= 0:1.6.6-14
170 Provides:       jdk(%{name})
171
172 %description jdk-base
173 OpenJDK development tools built using free software only.
174
175 %description jdk-base -l pl.UTF-8
176 OpenJDK skompilowane wyłącznie przy użyciu wolnego oprogramowania.
177
178 %package jre
179 Summary:        OpenJDK and GNU Classpath code - runtime environment
180 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko uruchomieniowe
181 Group:          Development/Languages/Java
182 Requires:       %{name}-jre-base = %{version}-%{release}
183 Provides:       java
184 Provides:       java(ClassDataVersion) = %{_classdataversion}
185 Provides:       java(jaas) = %{version}
186 Provides:       java(jaf) = 1.1.1
187 Provides:       java(jaxp) = 1.3
188 Provides:       java(jaxp_parser_impl)
189 Provides:       java(jce) = %{version}
190 Provides:       java(jdbc-stdext) = %{version}
191 Provides:       java(jdbc-stdext) = 3.0
192 Provides:       java(jmx) = 1.4
193 Provides:       java(jndi) = %{version}
194 Provides:       java(jsse) = %{version}
195 Provides:       java1.4
196 Provides:       jre = %{_jdkversion}
197 Obsoletes:      java(jaas)
198 Obsoletes:      java(jaf)
199 Obsoletes:      java(jaxp)
200 Obsoletes:      java(jce)
201 Obsoletes:      java(jdbc-stdext)
202 Obsoletes:      java(jdbc-stdext)
203 Obsoletes:      java(jmx)
204 Obsoletes:      java(jndi)
205 Obsoletes:      java(jsse)
206 Obsoletes:      java-gcj-compat
207 Obsoletes:      java-sun-jre
208 Obsoletes:      java5-sun-jre
209 Obsoletes:      jre
210
211 %description jre
212 This package symlinks OpenJDK runtime environment tools provided by
213 %{name}-jre-base to system-wide directories like %{_bindir}, making
214 IcedTea6 default JRE.
215
216 %description jre -l pl.UTF-8
217 Ten pakiet tworzy symboliczne dowiązania do środowiska
218 uruchomieniowego OpenJDK, dostarczanych przez pakiet %{name}-jre-base,
219 w standardowych systemowych ścieżkach takich jak %{_bindir},
220 sprawiając tym samym, że IcedTea6 staje się domyślnym JRE w systemie.
221
222 %package jre-X11
223 Summary:        IcedTea6 OpenJDK - runtime environment - X11 support
224 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa X11
225 Group:          Development/Languages/Java
226 Requires:       %{name}-jre = %{version}-%{release}
227 Requires:       %{name}-jre-base-X11 = %{version}-%{release}
228 Provides:       jre-X11 = %{_jdkversion}
229
230 %description jre-X11
231 X11 support for OpenJDK runtime environment built using free software
232 only.
233
234 %description jre-X11 -l pl.UTF-8
235 Biblioteki X11 dla środowiska OpenJDK zbudowany wyłocznie przy uzyciu
236 wolnego oprogramowania.
237
238 %package jre-base
239 Summary:        OpenJDK and GNU Classpath code - runtime environment
240 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko uruchomieniowe
241 Group:          Development/Languages/Java
242 Requires:       jpackage-utils >= 0:1.6.6-14
243 Provides:       jre(%{name})
244
245 %description jre-base
246 OpenJDK runtime environment built using free software only.
247
248 %description jre-base -l pl.UTF-8
249 Środowisko uruchomieniowe OpenJDK zbudowany wyłącznie przy użyciu
250 wolnego oprogramowania.
251
252 %package jre-base-X11
253 Summary:        IcedTea6 OpenJDK - runtime environment - X11 support
254 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa X11
255 Group:          Development/Languages/Java
256 Requires:       %{name}-jre-base = %{version}-%{release}
257 Requires:       %{name}-jre-base-freetype = %{version}-%{release}
258
259 %description jre-base-X11
260 X11 support for OpenJDK runtime environment built using free software
261 only.
262
263 %description jre-base-X11 -l pl.UTF-8
264 Biblioteki X11 dla środowiska OpenJDK zbudowany wyłocznie przy uzyciu
265 wolnego oprogramowania.
266
267 %package jre-base-alsa
268 Summary:        IcedTea6 OpenJDK - runtime environment - ALSA support
269 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa ALSA
270 Group:          Development/Languages/Java
271 Requires:       %{name}-jre-base = %{version}-%{release}
272
273 %description jre-base-alsa
274 ALSA sound support for OpenJDK runtime environment build using free
275 software only.
276
277 %description jre-base-alsa -l pl.UTF-8
278 Biblioteki ALSA rozszerzające środowisko OpenJDK o obsługę dźwięku
279 zbudowane przy uzyciu wyłącznie wolnego oprogramowania.
280
281 %package jre-base-freetype
282 Summary:        IcedTea6 OpenJDK - runtime environment - font support
283 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa fontów
284 Group:          Development/Languages/Java
285 Requires:       %{name}-jre-base = %{version}-%{release}
286
287 %description jre-base-freetype
288 Font handling library for OpenJDK runtime environment built using free
289 software only.
290
291 %description jre-base-freetype -l pl.UTF-8
292 Biblioteki obsługi czcionek dla OpenJDK zbudowane wyłącznie przy
293 użyciu wolnego oprogramowania.
294
295 %package jar
296 Summary:        OpenJDK and GNU Classpath code - JAR tool
297 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - narzędzie JAR
298 Group:          Development/Languages/Java
299 Requires:       %{name}-jdk-base = %{version}-%{release}
300 Provides:       jar
301 Obsoletes:      fastjar
302 Obsoletes:      jar
303
304 %description jar
305 JAR tool from OpenJDK built using free software only.
306
307 JAR is an archiver used to merge Java classes into a single library.
308
309 %description jar -l pl.UTF-8
310 Narzędzie jar z OpenJDK zbudowane przy uzyciu wyłącznie wolnego
311 oprogramowania.
312
313 JAR jest narzędziem pozwalającym wykonywać podstawowe operacje na
314 archiwach javy .jar takie jak na przykład tworzenie lub rozpakowywanie
315 archiwów.
316
317 %package appletviewer
318 Summary:        OpenJDK and GNU Classpath code - appletviewer tool
319 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - narzędzie appletviewer
320 Group:          Development/Languages/Java
321 Requires:       %{name}-jdk-base = %{version}-%{release}
322 Requires:       %{name}-jre-X11 = %{version}-%{release}
323 Obsoletes:      java-sun-appletviewer
324
325 %description appletviewer
326 Appletviewer from OpenJDK build using free software only.
327
328 %description appletviewer -l pl.UTF-8
329 Appletviewer pozwala uruchamiać aplety javy niezależnie od
330 przeglądarki www. Ten appletviewer pochodzi z zestawu narzędzi OpenJDK
331 i został zbudowany wyłącznie przy użyciu wolnego oprogramowania.
332
333 %package jdk-sources
334 Summary:        OpenJDK and GNU Classpath code - sources
335 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - kod źródłowy
336 Group:          Documentation
337
338 %description jdk-sources
339 Source code for the OpenJDK development kit and Java standard library.
340
341 %description jdk-sources -l pl.UTF-8
342 Kod źródłowy narzędzi programistycznych OpenJDK oraz standardowej
343 biblioteki Javy.
344
345 %package examples
346 Summary:        OpenJDK and GNU Classpath code - examples
347 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - przykłady
348 Group:          Documentation
349
350 %description examples
351 Code examples for OpenJDK.
352
353 %description examples -l pl.UTF-8
354 Przykłady dla OpenJDK.
355
356 %prep
357 %setup -q
358 %patch0 -p1
359
360 # patches to applied to the extracted sources
361 install -d pld-patches
362 cp -p %{PATCH1} pld-patches
363
364 # let the build system extract the sources where it wants them
365 install -d drops
366 ln -s %{SOURCE1} .
367 ln -s %{SOURCE2} drops
368 ln -s %{SOURCE3} drops
369 ln -s %{SOURCE4} drops
370
371 %build
372 # Make sure we have /proc mounted - otherwise idlc will fail later.
373 if [ ! -f /proc/self/stat ]; then
374         echo "You need to have /proc mounted in order to build this package!"
375         exit 1
376 fi
377
378 export JAVA_HOME=%{java_home}
379 export PATH="$JAVA_HOME/bin:$PATH"
380
381 %{__aclocal}
382 %{__autoconf}
383 %{__automake}
384
385 %configure \
386         WGET=%{_bindir}/wget \
387 %if %{with bootstrap}
388         --with-gcj-home=%{java_home} \
389         --with-ecj-jar=%{_javadir}/ecj.jar \
390 %else
391         --with-jdk-home=%{java_home} \
392 %endif
393         %{!?with_nss:--disable-nss} \
394         --with-xalan2-jar=%{_javadir}/xalan.jar \
395         --with-xalan2-serializer-jar=%{_javadir}/serializer.jar \
396         --with-rhino=%{_javadir}/js.jar
397
398 %{__make} extract extract-ecj \
399         DISTRIBUTION_PATCHES="$(echo pld-patches/*.patch)"
400
401 %if %{with bootstrap}
402 # Cannot do that as patch, as the sources are prepared by make
403 %{__sed} -i -e's/CORBA_BUILD_ARGUMENTS = \\/CORBA_BUILD_ARGUMENTS = JVMLIB="" \\/' openjdk-ecj/make/corba-rules.gmk
404 %endif
405 # if dpkg-architecure is installed (like on carme) it will break the build
406 # unless we disable using it somehow. As patching is difficult here:
407 %{__sed} -i -e's/dpkg-architecture/dpkg-architecture__/' openjdk*/*/make/common/shared/Platform.gmk
408
409 %{__make} -j1 \
410         DISABLE_HOTSPOT_OS_VERSION_CHECK=ok \
411         DISTRIBUTION_PATCHES="$(echo pld-patches/*.patch)" \
412         PRINTF=/bin/printf
413
414 %install
415 rm -rf $RPM_BUILD_ROOT
416 install -d $RPM_BUILD_ROOT{%{_bindir},%{dstdir},%{_mandir}/ja} \
417         $RPM_BUILD_ROOT{%{jvmjardir},%{_examplesdir}/%{name}-%{version},%{_javasrcdir}} \
418         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
419
420 # install the 'JDK image', it contains the JRE too
421 cp -a openjdk.build/j2sdk-image/* $RPM_BUILD_ROOT%{dstdir}
422
423 # convenience symlinks without version number
424 ln -s %{dstreldir} $RPM_BUILD_ROOT%{_jvmdir}/%{name}
425 ln -s %{jrereldir} $RPM_BUILD_ROOT%{_jvmdir}/%{name}-jre
426
427 ln -s %{dstreldir} $RPM_BUILD_ROOT%{_jvmdir}/java
428
429 # move JDK sources and demo to /usr/src
430 mv $RPM_BUILD_ROOT%{dstdir}/demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
431 mv $RPM_BUILD_ROOT%{dstdir}/sample $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
432 mv $RPM_BUILD_ROOT%{dstdir}/src.zip $RPM_BUILD_ROOT%{_javasrcdir}/%{name}-jdk.zip
433
434 # move manual pages to its place
435 mv $RPM_BUILD_ROOT%{dstdir}/man/ja_JP.eucJP/man1 $RPM_BUILD_ROOT%{_mandir}/ja/man1
436 rmdir $RPM_BUILD_ROOT%{dstdir}/man/ja_JP.eucJP
437 rm $RPM_BUILD_ROOT%{dstdir}/man/ja
438 mv $RPM_BUILD_ROOT%{dstdir}/man/man1 $RPM_BUILD_ROOT%{_mandir}/man1
439 rmdir $RPM_BUILD_ROOT%{dstdir}/man
440
441 # replace duplicates with symlinks, link to %{_bindir}
442 for path in $RPM_BUILD_ROOT%{dstdir}/bin/*; do
443         filename=$(basename $path)
444         if diff -q "$path" "$RPM_BUILD_ROOT%{jredir}/bin/$filename" > /dev/null; then
445                 ln -sf "../jre/bin/$filename" "$path"
446                 ln -sf "%{jredir}/bin/$filename" $RPM_BUILD_ROOT%{_bindir}
447         else
448                 ln -sf "%{dstdir}/bin/$filename" $RPM_BUILD_ROOT%{_bindir}
449         fi
450 done
451 ln -sf ../jre/lib/jexec $RPM_BUILD_ROOT%{dstdir}/lib/jexec
452
453 # keep configuration in /etc (not all *.properties go there)
454 for config in management security content-types.properties \
455                 logging.properties net.properties sound.properties; do
456
457         mv $RPM_BUILD_ROOT%{jredir}/lib/$config $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/$config
458         ln -s %{_sysconfdir}/%{name}/$config $RPM_BUILD_ROOT%{jredir}/lib/$config
459 done
460
461 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jsse.jar
462 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jcert.jar
463 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jnet.jar
464 ln -sf %{jredir}/lib/jce.jar $RPM_BUILD_ROOT%{jvmjardir}/jce.jar
465 for f in jndi jndi-ldap jndi-cos jndi-rmi jaas jdbc-stdext jdbc-stdext-3.0 \
466         sasl jaxp_parser_impl jaxp_transform_impl jaxp jmx activation xml-commons-apis \
467         jndi-dns jndi-rmi; do
468         ln -sf %{jredir}/lib/rt.jar $RPM_BUILD_ROOT%{jvmjardir}/$f.jar
469 done
470
471 # some apps (like opera) looks for it in different place
472 ln -s server/libjvm.so $RPM_BUILD_ROOT%{jredir}/lib/%{jre_arch}/libjvm.so
473
474 %{__rm} $RPM_BUILD_ROOT%{dstdir}/{,jre/}{ASSEMBLY_EXCEPTION,LICENSE,THIRD_PARTY_README}
475
476 %clean
477 rm -rf $RPM_BUILD_ROOT
478
479 %files
480 %defattr(644,root,root,755)
481 %doc AUTHORS ChangeLog HACKING NEWS README THANKYOU
482
483 %files jdk
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_bindir}/apt
486 %attr(755,root,root) %{_bindir}/extcheck
487 %attr(755,root,root) %{_bindir}/idlj
488 %attr(755,root,root) %{_bindir}/jarsigner
489 %attr(755,root,root) %{_bindir}/java-rmi.cgi
490 %attr(755,root,root) %{_bindir}/javac
491 %attr(755,root,root) %{_bindir}/javadoc
492 %attr(755,root,root) %{_bindir}/javah
493 %attr(755,root,root) %{_bindir}/javap
494 %attr(755,root,root) %{_bindir}/jconsole
495 %attr(755,root,root) %{_bindir}/jdb
496 %attr(755,root,root) %{_bindir}/jhat
497 %attr(755,root,root) %{_bindir}/jinfo
498 %attr(755,root,root) %{_bindir}/jmap
499 %attr(755,root,root) %{_bindir}/jps
500 %attr(755,root,root) %{_bindir}/jrunscript
501 %attr(755,root,root) %{_bindir}/jsadebugd
502 %attr(755,root,root) %{_bindir}/jstack
503 %attr(755,root,root) %{_bindir}/jstat
504 %attr(755,root,root) %{_bindir}/jstatd
505 %attr(755,root,root) %{_bindir}/native2ascii
506 %attr(755,root,root) %{_bindir}/rmic
507 %attr(755,root,root) %{_bindir}/schemagen
508 %attr(755,root,root) %{_bindir}/serialver
509 %attr(755,root,root) %{_bindir}/wsgen
510 %attr(755,root,root) %{_bindir}/wsimport
511 %attr(755,root,root) %{_bindir}/xjc
512 %{_jvmdir}/java
513 %{_mandir}/man1/apt.1*
514 %{_mandir}/man1/extcheck.1*
515 %{_mandir}/man1/idlj.1*
516 %{_mandir}/man1/jarsigner.1*
517 %{_mandir}/man1/javac.1*
518 %{_mandir}/man1/javadoc.1*
519 %{_mandir}/man1/javah.1*
520 %{_mandir}/man1/javap.1*
521 %{_mandir}/man1/jconsole.1*
522 %{_mandir}/man1/jdb.1*
523 %{_mandir}/man1/jhat.1*
524 %{_mandir}/man1/jinfo.1*
525 %{_mandir}/man1/jmap.1*
526 %{_mandir}/man1/jps.1*
527 %{_mandir}/man1/jrunscript.1*
528 %{_mandir}/man1/jsadebugd.1*
529 %{_mandir}/man1/jstack.1*
530 %{_mandir}/man1/jstat.1*
531 %{_mandir}/man1/jstatd.1*
532 %{_mandir}/man1/native2ascii.1*
533 %{_mandir}/man1/schemagen.1*
534 %{_mandir}/man1/serialver.1*
535 %{_mandir}/man1/rmic.1*
536 %{_mandir}/man1/wsgen.1*
537 %{_mandir}/man1/wsimport.1*
538 %{_mandir}/man1/xjc.1*
539 %lang(ja) %{_mandir}/ja/man1/apt.1*
540 %lang(ja) %{_mandir}/ja/man1/extcheck.1*
541 %lang(ja) %{_mandir}/ja/man1/idlj.1*
542 %lang(ja) %{_mandir}/ja/man1/jarsigner.1*
543 %lang(ja) %{_mandir}/ja/man1/javac.1*
544 %lang(ja) %{_mandir}/ja/man1/javadoc.1*
545 %lang(ja) %{_mandir}/ja/man1/javah.1*
546 %lang(ja) %{_mandir}/ja/man1/javap.1*
547 %lang(ja) %{_mandir}/ja/man1/jconsole.1*
548 %lang(ja) %{_mandir}/ja/man1/jdb.1*
549 %lang(ja) %{_mandir}/ja/man1/jhat.1*
550 %lang(ja) %{_mandir}/ja/man1/jinfo.1*
551 %lang(ja) %{_mandir}/ja/man1/jmap.1*
552 %lang(ja) %{_mandir}/ja/man1/jps.1*
553 %lang(ja) %{_mandir}/ja/man1/jrunscript.1*
554 %lang(ja) %{_mandir}/ja/man1/jsadebugd.1*
555 %lang(ja) %{_mandir}/ja/man1/jstack.1*
556 %lang(ja) %{_mandir}/ja/man1/jstat.1*
557 %lang(ja) %{_mandir}/ja/man1/jstatd.1*
558 %lang(ja) %{_mandir}/ja/man1/native2ascii.1*
559 %lang(ja) %{_mandir}/ja/man1/schemagen.1*
560 %lang(ja) %{_mandir}/ja/man1/serialver.1*
561 %lang(ja) %{_mandir}/ja/man1/rmic.1*
562 %lang(ja) %{_mandir}/ja/man1/wsgen.1*
563 %lang(ja) %{_mandir}/ja/man1/wsimport.1*
564 %lang(ja) %{_mandir}/ja/man1/xjc.1*
565
566 %files jdk-base
567 %defattr(644,root,root,755)
568 %doc openjdk.build/j2sdk-image/THIRD_PARTY_README
569 %doc openjdk.build/j2sdk-image/ASSEMBLY_EXCEPTION
570 %dir %{dstdir}
571 %{_jvmdir}/%{name}
572 %attr(755,root,root) %{dstdir}/bin/appletviewer
573 %attr(755,root,root) %{dstdir}/bin/apt
574 %attr(755,root,root) %{dstdir}/bin/extcheck
575 %attr(755,root,root) %{dstdir}/bin/idlj
576 %attr(755,root,root) %{dstdir}/bin/jar
577 %attr(755,root,root) %{dstdir}/bin/jarsigner
578 %attr(755,root,root) %{dstdir}/bin/java-rmi.cgi
579 %attr(755,root,root) %{dstdir}/bin/javac
580 %attr(755,root,root) %{dstdir}/bin/javadoc
581 %attr(755,root,root) %{dstdir}/bin/javah
582 %attr(755,root,root) %{dstdir}/bin/javap
583 %attr(755,root,root) %{dstdir}/bin/jconsole
584 %attr(755,root,root) %{dstdir}/bin/jdb
585 %attr(755,root,root) %{dstdir}/bin/jhat
586 %attr(755,root,root) %{dstdir}/bin/jinfo
587 %attr(755,root,root) %{dstdir}/bin/jmap
588 %attr(755,root,root) %{dstdir}/bin/jps
589 %attr(755,root,root) %{dstdir}/bin/jrunscript
590 %attr(755,root,root) %{dstdir}/bin/jsadebugd
591 %attr(755,root,root) %{dstdir}/bin/jstack
592 %attr(755,root,root) %{dstdir}/bin/jstat
593 %attr(755,root,root) %{dstdir}/bin/jstatd
594 %attr(755,root,root) %{dstdir}/bin/native2ascii
595 %attr(755,root,root) %{dstdir}/bin/rmic
596 %attr(755,root,root) %{dstdir}/bin/schemagen
597 %attr(755,root,root) %{dstdir}/bin/serialver
598 %attr(755,root,root) %{dstdir}/bin/wsgen
599 %attr(755,root,root) %{dstdir}/bin/wsimport
600 %attr(755,root,root) %{dstdir}/bin/xjc
601 %{dstdir}/include
602 %dir %{dstdir}/lib
603 %{dstdir}/lib/ct.sym
604 %{dstdir}/lib/dt.jar
605 %{dstdir}/lib/ir.idl
606 %{dstdir}/lib/jconsole.jar
607 %attr(755,root,root) %{dstdir}/lib/jexec
608 %{dstdir}/lib/orb.idl
609 %ifnarch i486
610 %{dstdir}/lib/sa-jdi.jar
611 %endif
612 %{dstdir}/lib/tools.jar
613
614 %files jre
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_bindir}/java
617 %attr(755,root,root) %{_bindir}/keytool
618 %attr(755,root,root) %{_bindir}/orbd
619 %attr(755,root,root) %{_bindir}/pack200
620 %attr(755,root,root) %{_bindir}/rmid
621 %attr(755,root,root) %{_bindir}/rmiregistry
622 %attr(755,root,root) %{_bindir}/servertool
623 %attr(755,root,root) %{_bindir}/tnameserv
624 %attr(755,root,root) %{_bindir}/unpack200
625 %{_mandir}/man1/java.1*
626 %{_mandir}/man1/keytool.1*
627 %{_mandir}/man1/orbd.1*
628 %{_mandir}/man1/pack200.1*
629 %{_mandir}/man1/rmid.1*
630 %{_mandir}/man1/rmiregistry.1*
631 %{_mandir}/man1/servertool.1*
632 %{_mandir}/man1/tnameserv.1*
633 %{_mandir}/man1/unpack200.1*
634 %lang(ja) %{_mandir}/ja/man1/java.1*
635 %ifnarch x86_64
636 %endif
637 %lang(ja) %{_mandir}/ja/man1/keytool.1*
638 %lang(ja) %{_mandir}/ja/man1/orbd.1*
639 %lang(ja) %{_mandir}/ja/man1/pack200.1*
640 %lang(ja) %{_mandir}/ja/man1/rmid.1*
641 %lang(ja) %{_mandir}/ja/man1/rmiregistry.1*
642 %lang(ja) %{_mandir}/ja/man1/servertool.1*
643 %lang(ja) %{_mandir}/ja/man1/tnameserv.1*
644 %lang(ja) %{_mandir}/ja/man1/unpack200.1*
645
646 %files jre-base
647 %defattr(644,root,root,755)
648 %doc openjdk.build/j2sdk-image/THIRD_PARTY_README
649 %doc openjdk.build/j2sdk-image/ASSEMBLY_EXCEPTION
650 %dir %{_sysconfdir}/%{name}
651 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
652 %dir %{dstdir}
653 %dir %{jredir}
654 %{_jvmdir}/%{name}-jre
655 %dir %{jredir}/bin
656 %dir %{dstdir}/bin
657 %attr(755,root,root) %{jredir}/bin/java
658 %attr(755,root,root) %{dstdir}/bin/java
659 %attr(755,root,root) %{jredir}/bin/keytool
660 %attr(755,root,root) %{dstdir}/bin/keytool
661 %attr(755,root,root) %{jredir}/bin/orbd
662 %attr(755,root,root) %{dstdir}/bin/orbd
663 %attr(755,root,root) %{jredir}/bin/pack200
664 %attr(755,root,root) %{dstdir}/bin/pack200
665 %attr(755,root,root) %{jredir}/bin/rmid
666 %attr(755,root,root) %{dstdir}/bin/rmid
667 %attr(755,root,root) %{jredir}/bin/rmiregistry
668 %attr(755,root,root) %{dstdir}/bin/rmiregistry
669 %attr(755,root,root) %{jredir}/bin/servertool
670 %attr(755,root,root) %{dstdir}/bin/servertool
671 %attr(755,root,root) %{jredir}/bin/tnameserv
672 %attr(755,root,root) %{dstdir}/bin/tnameserv
673 %attr(755,root,root) %{jredir}/bin/unpack200
674 %attr(755,root,root) %{dstdir}/bin/unpack200
675 %dir %{jredir}/lib
676 %dir %{jredir}/lib/applet
677 %{jredir}/lib/cmm
678 %{jredir}/lib/ext
679 %dir %{jredir}/lib/%{jre_arch}
680 %ifnarch x86_64 i486
681 %dir %{jredir}/lib/%{jre_arch}/client
682 %{jredir}/lib/%{jre_arch}/client/Xusage.txt
683 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/client/*.so
684 %endif
685 %dir %{jredir}/lib/%{jre_arch}/headless
686 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/headless/*.so
687 %dir %{jredir}/lib/%{jre_arch}/jli
688 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/jli/*.so
689 %dir %{jredir}/lib/%{jre_arch}/native_threads
690 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/native_threads/*.so
691 %dir %{jredir}/lib/%{jre_arch}/server
692 %{jredir}/lib/%{jre_arch}/server/Xusage.txt
693 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/server/*.so
694 %{jredir}/lib/%{jre_arch}/jvm.cfg
695 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libattach.so
696 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libawt.so
697 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libdt_socket.so
698 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libhprof.so
699 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libinstrument.so
700 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2gss.so
701 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2pcsc.so
702 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2pkcs11.so
703 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjaas_unix.so
704 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava.so
705 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava_crw_demo.so
706 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjawt.so
707 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjdwp.so
708 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjpeg.so
709 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsig.so
710 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsound.so
711 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjvm.so
712 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/liblcms.so
713 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libmanagement.so
714 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libmlib_image.so
715 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnet.so
716 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnio.so
717 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnpt.so
718 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/librmi.so
719 %ifnarch i486
720 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsaproc.so
721 %endif
722 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libunpack.so
723 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libverify.so
724 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libzip.so
725 %{jredir}/lib/im
726 %{jredir}/lib/images
727 %{jredir}/lib/management
728 %{jredir}/lib/security
729 %{jredir}/lib/zi
730 #
731 %if %{with webstart}
732 %{jredir}/lib/about.jar
733 %{jredir}/lib/about.jnlp
734 %endif
735 %{jredir}/lib/calendars.properties
736 %{jredir}/lib/charsets.jar
737 %{jredir}/lib/classlist
738 %{jredir}/lib/content-types.properties
739 %{jredir}/lib/currency.data
740 %{jredir}/lib/flavormap.properties
741 %{jredir}/lib/fontconfig.*
742 %{jredir}/lib/jce.jar
743 %attr(755, root, root) %{jredir}/lib/jexec
744 %{jredir}/lib/jsse.jar
745 %{jredir}/lib/jvm.hprof.txt
746 %{jredir}/lib/logging.properties
747 %{jredir}/lib/management-agent.jar
748 %{jredir}/lib/meta-index
749 %{jredir}/lib/net.properties
750 %{jredir}/lib/psfont.properties.ja
751 %{jredir}/lib/psfontj2d.properties
752 %{jredir}/lib/resources.jar
753 %{jredir}/lib/rhino.jar
754 %{jredir}/lib/rt.jar
755 %{jredir}/lib/sound.properties
756 %{jredir}/lib/tz.properties
757 %{jvmjardir}
758
759 %files jre-X11
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_bindir}/policytool
762 %{_mandir}/man1/policytool.1*
763 %lang(ja) %{_mandir}/ja/man1/policytool.1*
764
765 %files jre-base-X11
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{jredir}/bin/policytool
768 %attr(755,root,root) %{dstdir}/bin/policytool
769 %dir %{jredir}/lib/%{jre_arch}/xawt
770 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/xawt/*.so
771 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsplashscreen.so
772
773 %files jre-base-alsa
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsoundalsa.so
776
777 %files jre-base-freetype
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libfontmanager.so
780
781 %files jar
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_bindir}/jar
784 %{_mandir}/man1/jar.1*
785 %lang(ja) %{_mandir}/ja/man1/jar.1*
786
787 %files appletviewer
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_bindir}/appletviewer
790 %{_mandir}/man1/appletviewer.1*
791 %lang(ja) %{_mandir}/ja/man1/appletviewer.1*
792
793 %files jdk-sources
794 %defattr(644,root,root,755)
795 %{_javasrcdir}/%{name}-jdk.zip
796
797 %files examples
798 %defattr(644,root,root,755)
799 %{_examplesdir}/%{name}-%{version}
This page took 0.106276 seconds and 2 git commands to generate.