]> git.pld-linux.org Git - packages/icedtea6.git/blob - icedtea6.spec
5221c9ec4dd08515f412a5f05013851d1ec5b318
[packages/icedtea6.git] / icedtea6.spec
1 # TODO:
2 # - install .ttf fonts (same as in sun-java-base-jre-X11 package) or configure
3 #   it to use system fonts (is it possible?).
4
5 %bcond_with bootstrap   # don't use an installed icedtea6, use ecj instead
6 %bcond_without nss      # don't use NSS
7
8 %if %{with bootstrap}
9 %define         use_jdk java-gcj-compat
10 %else
11 %define         use_jdk icedtea6
12 %endif
13
14 # class data version seen with file(1) that this jvm is able to load
15 %define         _classdataversion 50.0
16 # JDK/JRE version, as returned with `java -version`, '_' replaced with '.'
17 %define         _jdkversion 1.6.0.27
18
19 Summary:        OpenJDK and GNU Classpath code
20 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath
21 Name:           icedtea6
22 Version:        1.12.4
23 Release:        1
24 License:        GPL v2
25 Group:          Development/Languages/Java
26 Source0:        http://icedtea.classpath.org/download/source/%{name}-%{version}.tar.gz
27 # Source0-md5:  85bfc656c20fb762b72b71d3492a326c
28 # following sources should match those in Makefile.am
29 Source1:        http://download.java.net/openjdk/jdk6/promoted/b27/openjdk-6-src-b27-26_oct_2012.tar.gz
30 # Source1-md5:  3a0963158e07c8829c8bd31a698bd23d
31 Source2:        http://icedtea.classpath.org/download/drops/jdk6-jaxws2_1_6-2011_06_13.zip
32 # Source2-md5:  8fd91b09b643a19a912b8a75e7a7a9d5
33 Source3:        http://icedtea.classpath.org/download/drops/jdk6-jaf-b20.zip
34 # Source3-md5:  bc95c133620bd68c161cac9891592901
35 Source4:        http://icedtea.classpath.org/download/drops/jaxp144_04.zip
36 # Source4-md5:  0ace787aa12177d201947e8ba0ba9bdd
37 Patch0:         %{name}-i486.patch
38 Patch1:         %{name}-libpath.patch
39 URL:            http://icedtea.classpath.org/wiki/Main_Page
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  ant
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  bash
45 BuildRequires:  cups-devel
46 BuildRequires:  /usr/bin/jar
47 BuildRequires:  freetype-devel >= 2.3
48 BuildRequires:  gawk
49 %{?with_bootstrap:BuildRequires:        gcc-java >= 6:4.3}
50 BuildRequires:  giflib-devel
51 BuildRequires:  glib2-devel
52 BuildRequires:  glibc-misc
53 BuildRequires:  gtk+2-devel
54 BuildRequires:  java-rhino
55 BuildRequires:  java-xalan
56 %{?with_bootstrap:BuildRequires:        java-xerces}
57 %buildrequires_jdk
58 BuildRequires:  libffi-devel
59 # for /usr/share/java/ecj.jar:
60 BuildRequires:  libgcj
61 BuildRequires:  libjpeg-devel
62 BuildRequires:  libpng-devel
63 BuildRequires:  libstdc++-static
64 BuildRequires:  lsb-release
65 %{?with_nss:BuildRequires:      nss-devel}
66 BuildRequires:  pkgconfig
67 BuildRequires:  rpmbuild(macros) >= 1.557
68 BuildRequires:  unzip
69 BuildRequires:  util-linux
70 BuildRequires:  xorg-lib-libX11-devel
71 BuildRequires:  xorg-lib-libXinerama-devel
72 BuildRequires:  xorg-lib-libXp-devel
73 BuildRequires:  xorg-lib-libXrender-devel
74 BuildRequires:  xorg-lib-libXt-devel
75 BuildRequires:  xorg-lib-libXtst-devel
76 BuildRequires:  xorg-proto-printproto-devel
77 BuildRequires:  xorg-proto-xproto-devel
78 BuildRequires:  zip
79 BuildRequires:  zlib-devel
80 Requires:       %{name}-appletviewer = %{version}-%{release}
81 Requires:       %{name}-jdk = %{version}-%{release}
82 Suggests:       %{name}-jre-X11
83 Suggests:       icedtea-web
84 Obsoletes:      java5-sun
85 Obsoletes:      java5-sun-jre
86 Obsoletes:      java5-sun-jre-jdbc
87 Obsoletes:      java5-sun-jre-X11
88 Obsoletes:      java5-sun-tools
89 Obsoletes:      java-gcj-compat
90 Obsoletes:      java-gcj-compat-devel
91 Obsoletes:      java-sun
92 Obsoletes:      java-sun-demos
93 Obsoletes:      java-sun-jre
94 Obsoletes:      java-sun-jre-alsa
95 Obsoletes:      java-sun-jre-jdbc
96 Obsoletes:      java-sun-jre-X11
97 Obsoletes:      java-sun-tools
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         dstreldir       %{name}-%{version}
101 %define         dstdir          %{_jvmdir}/%{dstreldir}
102 %define         jrereldir       %{dstreldir}/jre
103 %define         jredir          %{_jvmdir}/%{jrereldir}
104 %define         jvmjardir       %{_jvmjardir}/%{name}-%{version}
105
106 %ifarch x86_64 amd64
107 %define         jre_arch        amd64
108 %else
109 %define         jre_arch        i386
110 %endif
111
112 # to break artificial subpackage dependency loops
113 %define         _noautoreq      'libmawt.so' 'java(ClassDataVersion)'
114
115 %description
116 The IcedTea project provides a harness to build the source code from
117 http://openjdk.java.net/ using Free Software build tools and provides
118 replacements libraries for the binary plugs with code from the GNU
119 Classpath project.
120
121 This is a meta-package which provides, by its dependencies, all the
122 IcedTea6 components including the OpenJDK, Java 6 developement kit and
123 runtime environment.
124
125 %description -l pl.UTF-8
126 Projekt IcedTea daje możliwość kompilacji kodu źródłowego z
127 http://openjdk.java.net/ przy użyciu wolnodostępnych narzędzi oraz
128 dostarcza zamienniki biblioteczne binarnych wtyczek pochodzące z
129 projektu GNU Classpath.
130
131 To jest meta-pakiet, który, za pośrednictwem zależności, dostarcza
132 wszystkie komponenty IcedTea6, w tym środowisko programistyczne
133 (OpenJDK) i uruchomieniowe (JRE).
134
135 %package jdk
136 Summary:        OpenJDK and GNU Classpath code - software development kit
137 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko programistyczne
138 Group:          Development/Languages/Java
139 Requires:       %{name}-jar = %{version}-%{release}
140 Requires:       %{name}-jdk-base = %{version}-%{release}
141 Requires:       %{name}-jre = %{version}-%{release}
142 Provides:       j2sdk = %{_jdkversion}
143 Provides:       jdk = %{_jdkversion}
144 Obsoletes:      blackdown-java-sdk
145 Obsoletes:      ibm-java
146 Obsoletes:      java-blackdown
147 Obsoletes:      java-gcj-compat-devel
148 Obsoletes:      java-sun
149 Obsoletes:      java5-sun
150 Obsoletes:      jdk
151 Obsoletes:      kaffe
152
153 %description jdk
154 This package symlinks OpenJDK development tools provided by
155 %{name}-jdk-base to system-wide directories like %{_bindir}, making
156 IcedTea6 default JDK.
157
158 %description jdk -l pl.UTF-8
159 Ten pakiet tworzy symboliczne dowiązania do narzędzi programistycznych
160 OpenJDK, dostarczanych przez pakiet %{name}-jdk-base, w standardowych
161 systemowych ścieżkach takich jak %{_bindir}, sprawiając tym samym, że
162 IcedTea6 staje się domyślnym JDK w systemie.
163
164 %package jdk-base
165 Summary:        OpenJDK and GNU Classpath code - software development kit
166 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko programistyczne
167 Group:          Development/Languages/Java
168 Requires:       %{name}-jre-base = %{version}-%{release}
169 Requires:       jpackage-utils >= 0:1.6.6-14
170 Provides:       jdk(%{name})
171
172 %description jdk-base
173 OpenJDK development tools built using free software only.
174
175 %description jdk-base -l pl.UTF-8
176 OpenJDK skompilowane wyłącznie przy użyciu wolnego oprogramowania.
177
178 %package jre
179 Summary:        OpenJDK and GNU Classpath code - runtime environment
180 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko uruchomieniowe
181 Group:          Development/Languages/Java
182 Requires:       %{name}-jre-base = %{version}-%{release}
183 Provides:       java
184 Provides:       java(ClassDataVersion) = %{_classdataversion}
185 Provides:       java(jaas) = %{version}
186 Provides:       java(jaf) = 1.1.1
187 Provides:       java(jaxp) = 1.3
188 Provides:       java(jaxp_parser_impl)
189 Provides:       java(jce) = %{version}
190 Provides:       java(jdbc-stdext) = %{version}
191 Provides:       java(jdbc-stdext) = 3.0
192 Provides:       java(jmx) = 1.4
193 Provides:       java(jndi) = %{version}
194 Provides:       java(jsse) = %{version}
195 Provides:       java1.4
196 Provides:       jre = %{_jdkversion}
197 Obsoletes:      java(jaas)
198 Obsoletes:      java(jaf)
199 Obsoletes:      java(jaxp)
200 Obsoletes:      java(jce)
201 Obsoletes:      java(jdbc-stdext)
202 Obsoletes:      java(jdbc-stdext)
203 Obsoletes:      java(jmx)
204 Obsoletes:      java(jndi)
205 Obsoletes:      java(jsse)
206 Obsoletes:      java-gcj-compat
207 Obsoletes:      java-sun-jre
208 Obsoletes:      java5-sun-jre
209 Obsoletes:      jre
210
211 %description jre
212 This package symlinks OpenJDK runtime environment tools provided by
213 %{name}-jre-base to system-wide directories like %{_bindir}, making
214 IcedTea6 default JRE.
215
216 %description jre -l pl.UTF-8
217 Ten pakiet tworzy symboliczne dowiązania do środowiska
218 uruchomieniowego OpenJDK, dostarczanych przez pakiet %{name}-jre-base,
219 w standardowych systemowych ścieżkach takich jak %{_bindir},
220 sprawiając tym samym, że IcedTea6 staje się domyślnym JRE w systemie.
221
222 %package jre-X11
223 Summary:        IcedTea6 OpenJDK - runtime environment - X11 support
224 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa X11
225 Group:          Development/Languages/Java
226 Requires:       %{name}-jre = %{version}-%{release}
227 Requires:       %{name}-jre-base-X11 = %{version}-%{release}
228 Provides:       jre-X11 = %{_jdkversion}
229
230 %description jre-X11
231 X11 support for OpenJDK runtime environment built using free software
232 only.
233
234 %description jre-X11 -l pl.UTF-8
235 Biblioteki X11 dla środowiska OpenJDK zbudowany wyłocznie przy uzyciu
236 wolnego oprogramowania.
237
238 %package jre-base
239 Summary:        OpenJDK and GNU Classpath code - runtime environment
240 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko uruchomieniowe
241 Group:          Development/Languages/Java
242 Requires:       jpackage-utils >= 0:1.6.6-14
243 Provides:       jre(%{name})
244
245 %description jre-base
246 OpenJDK runtime environment built using free software only.
247
248 %description jre-base -l pl.UTF-8
249 Środowisko uruchomieniowe OpenJDK zbudowany wyłącznie przy użyciu
250 wolnego oprogramowania.
251
252 %package jre-base-X11
253 Summary:        IcedTea6 OpenJDK - runtime environment - X11 support
254 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa X11
255 Group:          Development/Languages/Java
256 Requires:       %{name}-jre-base = %{version}-%{release}
257 Requires:       %{name}-jre-base-freetype = %{version}-%{release}
258
259 %description jre-base-X11
260 X11 support for OpenJDK runtime environment built using free software
261 only.
262
263 %description jre-base-X11 -l pl.UTF-8
264 Biblioteki X11 dla środowiska OpenJDK zbudowany wyłocznie przy uzyciu
265 wolnego oprogramowania.
266
267 %package jre-base-alsa
268 Summary:        IcedTea6 OpenJDK - runtime environment - ALSA support
269 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa ALSA
270 Group:          Development/Languages/Java
271 Requires:       %{name}-jre-base = %{version}-%{release}
272
273 %description jre-base-alsa
274 ALSA sound support for OpenJDK runtime environment build using free
275 software only.
276
277 %description jre-base-alsa -l pl.UTF-8
278 Biblioteki ALSA rozszerzające środowisko OpenJDK o obsługę dźwięku
279 zbudowane przy uzyciu wyłącznie wolnego oprogramowania.
280
281 %package jre-base-freetype
282 Summary:        IcedTea6 OpenJDK - runtime environment - font support
283 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa fontów
284 Group:          Development/Languages/Java
285 Requires:       %{name}-jre-base = %{version}-%{release}
286
287 %description jre-base-freetype
288 Font handling library for OpenJDK runtime environment built using free
289 software only.
290
291 %description jre-base-freetype -l pl.UTF-8
292 Biblioteki obsługi czcionek dla OpenJDK zbudowane wyłącznie przy
293 użyciu wolnego oprogramowania.
294
295 %package jar
296 Summary:        OpenJDK and GNU Classpath code - JAR tool
297 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - narzędzie JAR
298 Group:          Development/Languages/Java
299 Requires:       %{name}-jdk-base = %{version}-%{release}
300 Provides:       jar
301 Obsoletes:      fastjar
302 Obsoletes:      jar
303
304 %description jar
305 JAR tool from OpenJDK built using free software only.
306
307 JAR is an archiver used to merge Java classes into a single library.
308
309 %description jar -l pl.UTF-8
310 Narzędzie jar z OpenJDK zbudowane przy uzyciu wyłącznie wolnego
311 oprogramowania.
312
313 JAR jest narzędziem pozwalającym wykonywać podstawowe operacje na
314 archiwach javy .jar takie jak na przykład tworzenie lub rozpakowywanie
315 archiwów.
316
317 %package appletviewer
318 Summary:        OpenJDK and GNU Classpath code - appletviewer tool
319 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - narzędzie appletviewer
320 Group:          Development/Languages/Java
321 Requires:       %{name}-jdk-base = %{version}-%{release}
322 Requires:       %{name}-jre-X11 = %{version}-%{release}
323 Obsoletes:      java-sun-appletviewer
324
325 %description appletviewer
326 Appletviewer from OpenJDK build using free software only.
327
328 %description appletviewer -l pl.UTF-8
329 Appletviewer pozwala uruchamiać aplety javy niezależnie od
330 przeglądarki www. Ten appletviewer pochodzi z zestawu narzędzi OpenJDK
331 i został zbudowany wyłącznie przy użyciu wolnego oprogramowania.
332
333 %package jdk-sources
334 Summary:        OpenJDK and GNU Classpath code - sources
335 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - kod źródłowy
336 Group:          Documentation
337
338 %description jdk-sources
339 Source code for the OpenJDK development kit and Java standard library.
340
341 %description jdk-sources -l pl.UTF-8
342 Kod źródłowy narzędzi programistycznych OpenJDK oraz standardowej
343 biblioteki Javy.
344
345 %package examples
346 Summary:        OpenJDK and GNU Classpath code - examples
347 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - przykłady
348 Group:          Documentation
349
350 %description examples
351 Code examples for OpenJDK.
352
353 %description examples -l pl.UTF-8
354 Przykłady dla OpenJDK.
355
356 %prep
357 %setup -q
358 %patch0 -p1
359
360 # patches to applied to the extracted sources
361 install -d pld-patches
362 cp -p %{PATCH1} pld-patches
363
364 # let the build system extract the sources where it wants them
365 install -d drops
366 ln -s %{SOURCE1} .
367 ln -s %{SOURCE2} drops
368 ln -s %{SOURCE3} drops
369 ln -s %{SOURCE4} drops
370
371 %build
372 # Make sure we have /proc mounted - otherwise idlc will fail later.
373 if [ ! -f /proc/self/stat ]; then
374         echo "You need to have /proc mounted in order to build this package!"
375         exit 1
376 fi
377
378 export JAVA_HOME=%{java_home}
379 export PATH="$JAVA_HOME/bin:$PATH"
380
381 %{__aclocal}
382 %{__autoconf}
383 %{__automake}
384
385 %configure \
386         WGET=%{_bindir}/wget \
387 %if %{with bootstrap}
388         --with-gcj-home=%{java_home} \
389         --with-ecj-jar=%{_javadir}/ecj.jar \
390 %else
391         --with-jdk-home=%{java_home} \
392 %endif
393         %{!?with_nss:--disable-nss} \
394         --with-xalan2-jar=%{_javadir}/xalan.jar \
395         --with-xalan2-serializer-jar=%{_javadir}/serializer.jar \
396         --with-rhino=%{_javadir}/js.jar
397
398 %{__make} extract extract-ecj \
399         SHELL=/bin/bash \
400         DISTRIBUTION_PATCHES="$(echo pld-patches/*.patch)"
401
402 %if %{with bootstrap}
403 # Cannot do that as patch, as the sources are prepared by make
404 %{__sed} -i -e's/CORBA_BUILD_ARGUMENTS = \\/CORBA_BUILD_ARGUMENTS = JVMLIB="" \\/' openjdk-ecj/make/corba-rules.gmk
405 %endif
406 # if dpkg-architecure is installed (like on carme) it will break the build
407 # unless we disable using it somehow. As patching is difficult here:
408 %{__sed} -i -e's/dpkg-architecture/dpkg-architecture__/' openjdk*/*/make/common/shared/Platform.gmk
409
410 %{__make} -j1 \
411         SHELL=/bin/bash \
412         DISABLE_HOTSPOT_OS_VERSION_CHECK=ok \
413         DISTRIBUTION_PATCHES="$(echo pld-patches/*.patch)" \
414         PRINTF=/bin/printf
415
416 %install
417 rm -rf $RPM_BUILD_ROOT
418 install -d $RPM_BUILD_ROOT{%{_bindir},%{dstdir},%{_mandir}/ja} \
419         $RPM_BUILD_ROOT{%{jvmjardir},%{_examplesdir}/%{name}-%{version},%{_javasrcdir}} \
420         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
421
422 # install the 'JDK image', it contains the JRE too
423 cp -a openjdk.build/j2sdk-image/* $RPM_BUILD_ROOT%{dstdir}
424
425 # convenience symlinks without version number
426 ln -s %{dstreldir} $RPM_BUILD_ROOT%{_jvmdir}/%{name}
427 ln -s %{jrereldir} $RPM_BUILD_ROOT%{_jvmdir}/%{name}-jre
428
429 ln -s %{dstreldir} $RPM_BUILD_ROOT%{_jvmdir}/java
430
431 # move JDK sources and demo to /usr/src
432 mv $RPM_BUILD_ROOT%{dstdir}/demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
433 mv $RPM_BUILD_ROOT%{dstdir}/sample $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
434 mv $RPM_BUILD_ROOT%{dstdir}/src.zip $RPM_BUILD_ROOT%{_javasrcdir}/%{name}-jdk.zip
435
436 # move manual pages to its place
437 mv $RPM_BUILD_ROOT%{dstdir}/man/ja_JP.eucJP/man1 $RPM_BUILD_ROOT%{_mandir}/ja/man1
438 rmdir $RPM_BUILD_ROOT%{dstdir}/man/ja_JP.eucJP
439 rm $RPM_BUILD_ROOT%{dstdir}/man/ja
440 mv $RPM_BUILD_ROOT%{dstdir}/man/man1 $RPM_BUILD_ROOT%{_mandir}/man1
441 rmdir $RPM_BUILD_ROOT%{dstdir}/man
442
443 # replace duplicates with symlinks, link to %{_bindir}
444 for path in $RPM_BUILD_ROOT%{dstdir}/bin/*; do
445         filename=$(basename $path)
446         if diff -q "$path" "$RPM_BUILD_ROOT%{jredir}/bin/$filename" > /dev/null; then
447                 ln -sf "../jre/bin/$filename" "$path"
448                 ln -sf "%{jredir}/bin/$filename" $RPM_BUILD_ROOT%{_bindir}
449         else
450                 ln -sf "%{dstdir}/bin/$filename" $RPM_BUILD_ROOT%{_bindir}
451         fi
452 done
453 ln -sf ../jre/lib/jexec $RPM_BUILD_ROOT%{dstdir}/lib/jexec
454
455 # keep configuration in /etc (not all *.properties go there)
456 for config in management security content-types.properties \
457                 logging.properties net.properties sound.properties; do
458
459         mv $RPM_BUILD_ROOT%{jredir}/lib/$config $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/$config
460         ln -s %{_sysconfdir}/%{name}/$config $RPM_BUILD_ROOT%{jredir}/lib/$config
461 done
462
463 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jsse.jar
464 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jcert.jar
465 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jnet.jar
466 ln -sf %{jredir}/lib/jce.jar $RPM_BUILD_ROOT%{jvmjardir}/jce.jar
467 for f in jndi jndi-ldap jndi-cos jndi-rmi jaas jdbc-stdext jdbc-stdext-3.0 \
468         sasl jaxp_parser_impl jaxp_transform_impl jaxp jmx activation xml-commons-apis \
469         jndi-dns jndi-rmi; do
470         ln -sf %{jredir}/lib/rt.jar $RPM_BUILD_ROOT%{jvmjardir}/$f.jar
471 done
472
473 # some apps (like opera) looks for it in different place
474 ln -s server/libjvm.so $RPM_BUILD_ROOT%{jredir}/lib/%{jre_arch}/libjvm.so
475
476 %{__rm} $RPM_BUILD_ROOT%{dstdir}/{,jre/}{ASSEMBLY_EXCEPTION,LICENSE,THIRD_PARTY_README}
477
478 %clean
479 rm -rf $RPM_BUILD_ROOT
480
481 %files
482 %defattr(644,root,root,755)
483 %doc AUTHORS ChangeLog HACKING NEWS README THANKYOU
484
485 %files jdk
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_bindir}/apt
488 %attr(755,root,root) %{_bindir}/extcheck
489 %attr(755,root,root) %{_bindir}/idlj
490 %attr(755,root,root) %{_bindir}/jarsigner
491 %attr(755,root,root) %{_bindir}/java-rmi.cgi
492 %attr(755,root,root) %{_bindir}/javac
493 %attr(755,root,root) %{_bindir}/javadoc
494 %attr(755,root,root) %{_bindir}/javah
495 %attr(755,root,root) %{_bindir}/javap
496 %attr(755,root,root) %{_bindir}/jconsole
497 %attr(755,root,root) %{_bindir}/jdb
498 %attr(755,root,root) %{_bindir}/jhat
499 %attr(755,root,root) %{_bindir}/jinfo
500 %attr(755,root,root) %{_bindir}/jmap
501 %attr(755,root,root) %{_bindir}/jps
502 %attr(755,root,root) %{_bindir}/jrunscript
503 %attr(755,root,root) %{_bindir}/jsadebugd
504 %attr(755,root,root) %{_bindir}/jstack
505 %attr(755,root,root) %{_bindir}/jstat
506 %attr(755,root,root) %{_bindir}/jstatd
507 %attr(755,root,root) %{_bindir}/native2ascii
508 %attr(755,root,root) %{_bindir}/rmic
509 %attr(755,root,root) %{_bindir}/schemagen
510 %attr(755,root,root) %{_bindir}/serialver
511 %attr(755,root,root) %{_bindir}/wsgen
512 %attr(755,root,root) %{_bindir}/wsimport
513 %attr(755,root,root) %{_bindir}/xjc
514 %{_jvmdir}/java
515 %{_mandir}/man1/apt.1*
516 %{_mandir}/man1/extcheck.1*
517 %{_mandir}/man1/idlj.1*
518 %{_mandir}/man1/jarsigner.1*
519 %{_mandir}/man1/javac.1*
520 %{_mandir}/man1/javadoc.1*
521 %{_mandir}/man1/javah.1*
522 %{_mandir}/man1/javap.1*
523 %{_mandir}/man1/jconsole.1*
524 %{_mandir}/man1/jdb.1*
525 %{_mandir}/man1/jhat.1*
526 %{_mandir}/man1/jinfo.1*
527 %{_mandir}/man1/jmap.1*
528 %{_mandir}/man1/jps.1*
529 %{_mandir}/man1/jrunscript.1*
530 %{_mandir}/man1/jsadebugd.1*
531 %{_mandir}/man1/jstack.1*
532 %{_mandir}/man1/jstat.1*
533 %{_mandir}/man1/jstatd.1*
534 %{_mandir}/man1/native2ascii.1*
535 %{_mandir}/man1/schemagen.1*
536 %{_mandir}/man1/serialver.1*
537 %{_mandir}/man1/rmic.1*
538 %{_mandir}/man1/wsgen.1*
539 %{_mandir}/man1/wsimport.1*
540 %{_mandir}/man1/xjc.1*
541 %lang(ja) %{_mandir}/ja/man1/apt.1*
542 %lang(ja) %{_mandir}/ja/man1/extcheck.1*
543 %lang(ja) %{_mandir}/ja/man1/idlj.1*
544 %lang(ja) %{_mandir}/ja/man1/jarsigner.1*
545 %lang(ja) %{_mandir}/ja/man1/javac.1*
546 %lang(ja) %{_mandir}/ja/man1/javadoc.1*
547 %lang(ja) %{_mandir}/ja/man1/javah.1*
548 %lang(ja) %{_mandir}/ja/man1/javap.1*
549 %lang(ja) %{_mandir}/ja/man1/jconsole.1*
550 %lang(ja) %{_mandir}/ja/man1/jdb.1*
551 %lang(ja) %{_mandir}/ja/man1/jhat.1*
552 %lang(ja) %{_mandir}/ja/man1/jinfo.1*
553 %lang(ja) %{_mandir}/ja/man1/jmap.1*
554 %lang(ja) %{_mandir}/ja/man1/jps.1*
555 %lang(ja) %{_mandir}/ja/man1/jrunscript.1*
556 %lang(ja) %{_mandir}/ja/man1/jsadebugd.1*
557 %lang(ja) %{_mandir}/ja/man1/jstack.1*
558 %lang(ja) %{_mandir}/ja/man1/jstat.1*
559 %lang(ja) %{_mandir}/ja/man1/jstatd.1*
560 %lang(ja) %{_mandir}/ja/man1/native2ascii.1*
561 %lang(ja) %{_mandir}/ja/man1/schemagen.1*
562 %lang(ja) %{_mandir}/ja/man1/serialver.1*
563 %lang(ja) %{_mandir}/ja/man1/rmic.1*
564 %lang(ja) %{_mandir}/ja/man1/wsgen.1*
565 %lang(ja) %{_mandir}/ja/man1/wsimport.1*
566 %lang(ja) %{_mandir}/ja/man1/xjc.1*
567
568 %files jdk-base
569 %defattr(644,root,root,755)
570 %doc openjdk.build/j2sdk-image/THIRD_PARTY_README
571 %doc openjdk.build/j2sdk-image/ASSEMBLY_EXCEPTION
572 %dir %{dstdir}
573 %{_jvmdir}/%{name}
574 %attr(755,root,root) %{dstdir}/bin/appletviewer
575 %attr(755,root,root) %{dstdir}/bin/apt
576 %attr(755,root,root) %{dstdir}/bin/extcheck
577 %attr(755,root,root) %{dstdir}/bin/idlj
578 %attr(755,root,root) %{dstdir}/bin/jar
579 %attr(755,root,root) %{dstdir}/bin/jarsigner
580 %attr(755,root,root) %{dstdir}/bin/java-rmi.cgi
581 %attr(755,root,root) %{dstdir}/bin/javac
582 %attr(755,root,root) %{dstdir}/bin/javadoc
583 %attr(755,root,root) %{dstdir}/bin/javah
584 %attr(755,root,root) %{dstdir}/bin/javap
585 %attr(755,root,root) %{dstdir}/bin/jconsole
586 %attr(755,root,root) %{dstdir}/bin/jdb
587 %attr(755,root,root) %{dstdir}/bin/jhat
588 %attr(755,root,root) %{dstdir}/bin/jinfo
589 %attr(755,root,root) %{dstdir}/bin/jmap
590 %attr(755,root,root) %{dstdir}/bin/jps
591 %attr(755,root,root) %{dstdir}/bin/jrunscript
592 %attr(755,root,root) %{dstdir}/bin/jsadebugd
593 %attr(755,root,root) %{dstdir}/bin/jstack
594 %attr(755,root,root) %{dstdir}/bin/jstat
595 %attr(755,root,root) %{dstdir}/bin/jstatd
596 %attr(755,root,root) %{dstdir}/bin/native2ascii
597 %attr(755,root,root) %{dstdir}/bin/rmic
598 %attr(755,root,root) %{dstdir}/bin/schemagen
599 %attr(755,root,root) %{dstdir}/bin/serialver
600 %attr(755,root,root) %{dstdir}/bin/wsgen
601 %attr(755,root,root) %{dstdir}/bin/wsimport
602 %attr(755,root,root) %{dstdir}/bin/xjc
603 %{dstdir}/include
604 %dir %{dstdir}/lib
605 %{dstdir}/lib/ct.sym
606 %{dstdir}/lib/dt.jar
607 %{dstdir}/lib/ir.idl
608 %{dstdir}/lib/jconsole.jar
609 %attr(755,root,root) %{dstdir}/lib/jexec
610 %{dstdir}/lib/orb.idl
611 %ifnarch i486
612 %{dstdir}/lib/sa-jdi.jar
613 %endif
614 %{dstdir}/lib/tools.jar
615
616 %files jre
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_bindir}/java
619 %attr(755,root,root) %{_bindir}/keytool
620 %attr(755,root,root) %{_bindir}/orbd
621 %attr(755,root,root) %{_bindir}/pack200
622 %attr(755,root,root) %{_bindir}/rmid
623 %attr(755,root,root) %{_bindir}/rmiregistry
624 %attr(755,root,root) %{_bindir}/servertool
625 %attr(755,root,root) %{_bindir}/tnameserv
626 %attr(755,root,root) %{_bindir}/unpack200
627 %{_mandir}/man1/java.1*
628 %{_mandir}/man1/keytool.1*
629 %{_mandir}/man1/orbd.1*
630 %{_mandir}/man1/pack200.1*
631 %{_mandir}/man1/rmid.1*
632 %{_mandir}/man1/rmiregistry.1*
633 %{_mandir}/man1/servertool.1*
634 %{_mandir}/man1/tnameserv.1*
635 %{_mandir}/man1/unpack200.1*
636 %lang(ja) %{_mandir}/ja/man1/java.1*
637 %ifnarch x86_64
638 %endif
639 %lang(ja) %{_mandir}/ja/man1/keytool.1*
640 %lang(ja) %{_mandir}/ja/man1/orbd.1*
641 %lang(ja) %{_mandir}/ja/man1/pack200.1*
642 %lang(ja) %{_mandir}/ja/man1/rmid.1*
643 %lang(ja) %{_mandir}/ja/man1/rmiregistry.1*
644 %lang(ja) %{_mandir}/ja/man1/servertool.1*
645 %lang(ja) %{_mandir}/ja/man1/tnameserv.1*
646 %lang(ja) %{_mandir}/ja/man1/unpack200.1*
647
648 %files jre-base
649 %defattr(644,root,root,755)
650 %doc openjdk.build/j2sdk-image/THIRD_PARTY_README
651 %doc openjdk.build/j2sdk-image/ASSEMBLY_EXCEPTION
652 %dir %{_sysconfdir}/%{name}
653 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
654 %dir %{dstdir}
655 %dir %{jredir}
656 %{_jvmdir}/%{name}-jre
657 %dir %{jredir}/bin
658 %dir %{dstdir}/bin
659 %attr(755,root,root) %{jredir}/bin/java
660 %attr(755,root,root) %{dstdir}/bin/java
661 %attr(755,root,root) %{jredir}/bin/keytool
662 %attr(755,root,root) %{dstdir}/bin/keytool
663 %attr(755,root,root) %{jredir}/bin/orbd
664 %attr(755,root,root) %{dstdir}/bin/orbd
665 %attr(755,root,root) %{jredir}/bin/pack200
666 %attr(755,root,root) %{dstdir}/bin/pack200
667 %attr(755,root,root) %{jredir}/bin/rmid
668 %attr(755,root,root) %{dstdir}/bin/rmid
669 %attr(755,root,root) %{jredir}/bin/rmiregistry
670 %attr(755,root,root) %{dstdir}/bin/rmiregistry
671 %attr(755,root,root) %{jredir}/bin/servertool
672 %attr(755,root,root) %{dstdir}/bin/servertool
673 %attr(755,root,root) %{jredir}/bin/tnameserv
674 %attr(755,root,root) %{dstdir}/bin/tnameserv
675 %attr(755,root,root) %{jredir}/bin/unpack200
676 %attr(755,root,root) %{dstdir}/bin/unpack200
677 %dir %{jredir}/lib
678 %dir %{jredir}/lib/applet
679 %{jredir}/lib/cmm
680 %{jredir}/lib/ext
681 %dir %{jredir}/lib/%{jre_arch}
682 %ifnarch x86_64 i486
683 %dir %{jredir}/lib/%{jre_arch}/client
684 %{jredir}/lib/%{jre_arch}/client/Xusage.txt
685 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/client/*.so
686 %endif
687 %dir %{jredir}/lib/%{jre_arch}/headless
688 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/headless/*.so
689 %dir %{jredir}/lib/%{jre_arch}/jli
690 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/jli/*.so
691 %dir %{jredir}/lib/%{jre_arch}/native_threads
692 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/native_threads/*.so
693 %dir %{jredir}/lib/%{jre_arch}/server
694 %{jredir}/lib/%{jre_arch}/server/Xusage.txt
695 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/server/*.so
696 %{jredir}/lib/%{jre_arch}/server/classes.jsa
697 %{jredir}/lib/%{jre_arch}/jvm.cfg
698 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libattach.so
699 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libawt.so
700 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libdt_socket.so
701 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libhprof.so
702 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libinstrument.so
703 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2gss.so
704 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2pcsc.so
705 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2pkcs11.so
706 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjaas_unix.so
707 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava.so
708 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava_crw_demo.so
709 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjawt.so
710 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjdwp.so
711 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjpeg.so
712 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsig.so
713 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsound.so
714 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjvm.so
715 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/liblcms.so
716 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libmanagement.so
717 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libmlib_image.so
718 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnet.so
719 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnio.so
720 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnpt.so
721 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/librmi.so
722 %ifnarch i486
723 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsaproc.so
724 %endif
725 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libunpack.so
726 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libverify.so
727 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libzip.so
728 %{jredir}/lib/im
729 %{jredir}/lib/images
730 %{jredir}/lib/management
731 %{jredir}/lib/security
732 %{jredir}/lib/zi
733 #
734 %if %{with webstart}
735 %{jredir}/lib/about.jar
736 %{jredir}/lib/about.jnlp
737 %endif
738 %{jredir}/lib/calendars.properties
739 %{jredir}/lib/charsets.jar
740 %{jredir}/lib/classlist
741 %{jredir}/lib/content-types.properties
742 %{jredir}/lib/currency.data
743 %{jredir}/lib/flavormap.properties
744 %{jredir}/lib/fontconfig.*
745 %{jredir}/lib/jce.jar
746 %attr(755, root, root) %{jredir}/lib/jexec
747 %{jredir}/lib/jsse.jar
748 %{jredir}/lib/jvm.hprof.txt
749 %{jredir}/lib/logging.properties
750 %{jredir}/lib/management-agent.jar
751 %{jredir}/lib/meta-index
752 %{jredir}/lib/net.properties
753 %{jredir}/lib/psfont.properties.ja
754 %{jredir}/lib/psfontj2d.properties
755 %{jredir}/lib/resources.jar
756 %{jredir}/lib/rhino.jar
757 %{jredir}/lib/rt.jar
758 %{jredir}/lib/sound.properties
759 %{jredir}/lib/tz.properties
760 %{jvmjardir}
761
762 %files jre-X11
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{_bindir}/policytool
765 %{_mandir}/man1/policytool.1*
766 %lang(ja) %{_mandir}/ja/man1/policytool.1*
767
768 %files jre-base-X11
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{jredir}/bin/policytool
771 %attr(755,root,root) %{dstdir}/bin/policytool
772 %dir %{jredir}/lib/%{jre_arch}/xawt
773 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/xawt/*.so
774 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsplashscreen.so
775
776 %files jre-base-alsa
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsoundalsa.so
779
780 %files jre-base-freetype
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libfontmanager.so
783
784 %files jar
785 %defattr(644,root,root,755)
786 %attr(755,root,root) %{_bindir}/jar
787 %{_mandir}/man1/jar.1*
788 %lang(ja) %{_mandir}/ja/man1/jar.1*
789
790 %files appletviewer
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_bindir}/appletviewer
793 %{_mandir}/man1/appletviewer.1*
794 %lang(ja) %{_mandir}/ja/man1/appletviewer.1*
795
796 %files jdk-sources
797 %defattr(644,root,root,755)
798 %{_javasrcdir}/%{name}-jdk.zip
799
800 %files examples
801 %defattr(644,root,root,755)
802 %{_examplesdir}/%{name}-%{version}
This page took 0.138285 seconds and 2 git commands to generate.