]> git.pld-linux.org Git - packages/icedtea6.git/blob - icedtea6.spec
classes.jsa file is not present on i486
[packages/icedtea6.git] / icedtea6.spec
1 # TODO:
2 # - install .ttf fonts (same as in sun-java-base-jre-X11 package) or configure
3 #   it to use system fonts (is it possible?).
4
5 %bcond_with bootstrap   # don't use an installed icedtea6, use ecj instead
6 %bcond_without nss      # don't use NSS
7 %bcond_without cacerts  # don't include the default CA certificates
8
9 %if %{with bootstrap}
10 %define         use_jdk java-gcj-compat
11 %else
12 %define         use_jdk icedtea6
13 %endif
14
15 # class data version seen with file(1) that this jvm is able to load
16 %define         _classdataversion 50.0
17 # JDK/JRE version, as returned with `java -version`, '_' replaced with '.'
18 %define         _jdkversion 1.6.0.27
19
20 Summary:        OpenJDK and GNU Classpath code
21 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath
22 Name:           icedtea6
23 Version:        1.12.4
24 Release:        2
25 License:        GPL v2
26 Group:          Development/Languages/Java
27 Source0:        http://icedtea.classpath.org/download/source/%{name}-%{version}.tar.gz
28 # Source0-md5:  85bfc656c20fb762b72b71d3492a326c
29 # following sources should match those in Makefile.am
30 Source1:        http://download.java.net/openjdk/jdk6/promoted/b27/openjdk-6-src-b27-26_oct_2012.tar.gz
31 # Source1-md5:  3a0963158e07c8829c8bd31a698bd23d
32 Source2:        http://icedtea.classpath.org/download/drops/jdk6-jaxws2_1_6-2011_06_13.zip
33 # Source2-md5:  8fd91b09b643a19a912b8a75e7a7a9d5
34 Source3:        http://icedtea.classpath.org/download/drops/jdk6-jaf-b20.zip
35 # Source3-md5:  bc95c133620bd68c161cac9891592901
36 Source4:        http://icedtea.classpath.org/download/drops/jaxp144_04.zip
37 # Source4-md5:  0ace787aa12177d201947e8ba0ba9bdd
38 Source10:       make-cacerts.sh
39 Patch0:         %{name}-i486.patch
40 Patch1:         %{name}-libpath.patch
41 URL:            http://icedtea.classpath.org/wiki/Main_Page
42 BuildRequires:  alsa-lib-devel
43 BuildRequires:  ant
44 BuildRequires:  autoconf
45 BuildRequires:  automake
46 BuildRequires:  bash
47 %{?with_cacerts:BuildRequires:  ca-certificates-update}
48 BuildRequires:  cups-devel
49 BuildRequires:  /usr/bin/jar
50 BuildRequires:  freetype-devel >= 2.3
51 BuildRequires:  gawk
52 %{?with_bootstrap:BuildRequires:        gcc-java >= 6:4.3}
53 BuildRequires:  giflib-devel
54 BuildRequires:  glib2-devel
55 BuildRequires:  glibc-misc
56 BuildRequires:  gtk+2-devel
57 BuildRequires:  java-rhino
58 BuildRequires:  java-xalan
59 %{?with_bootstrap:BuildRequires:        java-xerces}
60 %buildrequires_jdk
61 BuildRequires:  libffi-devel
62 # for /usr/share/java/ecj.jar:
63 BuildRequires:  libgcj
64 BuildRequires:  libjpeg-devel
65 BuildRequires:  libpng-devel
66 BuildRequires:  libstdc++-static
67 BuildRequires:  lsb-release
68 %{?with_nss:BuildRequires:      nss-devel}
69 BuildRequires:  pkgconfig
70 BuildRequires:  rpmbuild(macros) >= 1.557
71 BuildRequires:  unzip
72 BuildRequires:  util-linux
73 BuildRequires:  xorg-lib-libX11-devel
74 BuildRequires:  xorg-lib-libXinerama-devel
75 BuildRequires:  xorg-lib-libXp-devel
76 BuildRequires:  xorg-lib-libXrender-devel
77 BuildRequires:  xorg-lib-libXt-devel
78 BuildRequires:  xorg-lib-libXtst-devel
79 BuildRequires:  xorg-proto-printproto-devel
80 BuildRequires:  xorg-proto-xproto-devel
81 BuildRequires:  zip
82 BuildRequires:  zlib-devel
83 Requires:       %{name}-appletviewer = %{version}-%{release}
84 Requires:       %{name}-jdk = %{version}-%{release}
85 Suggests:       %{name}-jre-X11
86 Suggests:       icedtea-web
87 Obsoletes:      java5-sun
88 Obsoletes:      java5-sun-jre
89 Obsoletes:      java5-sun-jre-jdbc
90 Obsoletes:      java5-sun-jre-X11
91 Obsoletes:      java5-sun-tools
92 Obsoletes:      java-gcj-compat
93 Obsoletes:      java-gcj-compat-devel
94 Obsoletes:      java-sun
95 Obsoletes:      java-sun-demos
96 Obsoletes:      java-sun-jre
97 Obsoletes:      java-sun-jre-alsa
98 Obsoletes:      java-sun-jre-jdbc
99 Obsoletes:      java-sun-jre-X11
100 Obsoletes:      java-sun-tools
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         dstreldir       %{name}-%{version}
104 %define         dstdir          %{_jvmdir}/%{dstreldir}
105 %define         jrereldir       %{dstreldir}/jre
106 %define         jredir          %{_jvmdir}/%{jrereldir}
107 %define         jvmjardir       %{_jvmjardir}/%{name}-%{version}
108
109 %ifarch x86_64 amd64
110 %define         jre_arch        amd64
111 %else
112 %define         jre_arch        i386
113 %endif
114
115 # to break artificial subpackage dependency loops
116 %define         _noautoreq      'libmawt.so' 'java(ClassDataVersion)'
117
118 %description
119 The IcedTea project provides a harness to build the source code from
120 http://openjdk.java.net/ using Free Software build tools and provides
121 replacements libraries for the binary plugs with code from the GNU
122 Classpath project.
123
124 This is a meta-package which provides, by its dependencies, all the
125 IcedTea6 components including the OpenJDK, Java 6 developement kit and
126 runtime environment.
127
128 %description -l pl.UTF-8
129 Projekt IcedTea daje możliwość kompilacji kodu źródłowego z
130 http://openjdk.java.net/ przy użyciu wolnodostępnych narzędzi oraz
131 dostarcza zamienniki biblioteczne binarnych wtyczek pochodzące z
132 projektu GNU Classpath.
133
134 To jest meta-pakiet, który, za pośrednictwem zależności, dostarcza
135 wszystkie komponenty IcedTea6, w tym środowisko programistyczne
136 (OpenJDK) i uruchomieniowe (JRE).
137
138 %package jdk
139 Summary:        OpenJDK and GNU Classpath code - software development kit
140 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko programistyczne
141 Group:          Development/Languages/Java
142 Requires:       %{name}-jar = %{version}-%{release}
143 Requires:       %{name}-jdk-base = %{version}-%{release}
144 Requires:       %{name}-jre = %{version}-%{release}
145 Provides:       j2sdk = %{_jdkversion}
146 Provides:       jdk = %{_jdkversion}
147 Obsoletes:      blackdown-java-sdk
148 Obsoletes:      ibm-java
149 Obsoletes:      java-blackdown
150 Obsoletes:      java-gcj-compat-devel
151 Obsoletes:      java-sun
152 Obsoletes:      java5-sun
153 Obsoletes:      jdk
154 Obsoletes:      kaffe
155
156 %description jdk
157 This package symlinks OpenJDK development tools provided by
158 %{name}-jdk-base to system-wide directories like %{_bindir}, making
159 IcedTea6 default JDK.
160
161 %description jdk -l pl.UTF-8
162 Ten pakiet tworzy symboliczne dowiązania do narzędzi programistycznych
163 OpenJDK, dostarczanych przez pakiet %{name}-jdk-base, w standardowych
164 systemowych ścieżkach takich jak %{_bindir}, sprawiając tym samym, że
165 IcedTea6 staje się domyślnym JDK w systemie.
166
167 %package jdk-base
168 Summary:        OpenJDK and GNU Classpath code - software development kit
169 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko programistyczne
170 Group:          Development/Languages/Java
171 Requires:       %{name}-jre-base = %{version}-%{release}
172 Requires:       jpackage-utils >= 0:1.6.6-14
173 Provides:       jdk(%{name})
174
175 %description jdk-base
176 OpenJDK development tools built using free software only.
177
178 %description jdk-base -l pl.UTF-8
179 OpenJDK skompilowane wyłącznie przy użyciu wolnego oprogramowania.
180
181 %package jre
182 Summary:        OpenJDK and GNU Classpath code - runtime environment
183 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko uruchomieniowe
184 Group:          Development/Languages/Java
185 Requires:       %{name}-jre-base = %{version}-%{release}
186 Provides:       java
187 Provides:       java(ClassDataVersion) = %{_classdataversion}
188 Provides:       java(jaas) = %{version}
189 Provides:       java(jaf) = 1.1.1
190 Provides:       java(jaxp) = 1.3
191 Provides:       java(jaxp_parser_impl)
192 Provides:       java(jce) = %{version}
193 Provides:       java(jdbc-stdext) = %{version}
194 Provides:       java(jdbc-stdext) = 3.0
195 Provides:       java(jmx) = 1.4
196 Provides:       java(jndi) = %{version}
197 Provides:       java(jsse) = %{version}
198 Provides:       java1.4
199 Provides:       jre = %{_jdkversion}
200 Obsoletes:      java(jaas)
201 Obsoletes:      java(jaf)
202 Obsoletes:      java(jaxp)
203 Obsoletes:      java(jce)
204 Obsoletes:      java(jdbc-stdext)
205 Obsoletes:      java(jdbc-stdext)
206 Obsoletes:      java(jmx)
207 Obsoletes:      java(jndi)
208 Obsoletes:      java(jsse)
209 Obsoletes:      java-gcj-compat
210 Obsoletes:      java-sun-jre
211 Obsoletes:      java5-sun-jre
212 Obsoletes:      jre
213
214 %description jre
215 This package symlinks OpenJDK runtime environment tools provided by
216 %{name}-jre-base to system-wide directories like %{_bindir}, making
217 IcedTea6 default JRE.
218
219 %description jre -l pl.UTF-8
220 Ten pakiet tworzy symboliczne dowiązania do środowiska
221 uruchomieniowego OpenJDK, dostarczanych przez pakiet %{name}-jre-base,
222 w standardowych systemowych ścieżkach takich jak %{_bindir},
223 sprawiając tym samym, że IcedTea6 staje się domyślnym JRE w systemie.
224
225 %package jre-X11
226 Summary:        IcedTea6 OpenJDK - runtime environment - X11 support
227 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa X11
228 Group:          Development/Languages/Java
229 Requires:       %{name}-jre = %{version}-%{release}
230 Requires:       %{name}-jre-base-X11 = %{version}-%{release}
231 Provides:       jre-X11 = %{_jdkversion}
232
233 %description jre-X11
234 X11 support for OpenJDK runtime environment built using free software
235 only.
236
237 %description jre-X11 -l pl.UTF-8
238 Biblioteki X11 dla środowiska OpenJDK zbudowany wyłocznie przy uzyciu
239 wolnego oprogramowania.
240
241 %package jre-base
242 Summary:        OpenJDK and GNU Classpath code - runtime environment
243 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - środowisko uruchomieniowe
244 Group:          Development/Languages/Java
245 Requires:       jpackage-utils >= 0:1.6.6-14
246 Provides:       jre(%{name})
247
248 %description jre-base
249 OpenJDK runtime environment built using free software only.
250
251 %description jre-base -l pl.UTF-8
252 Środowisko uruchomieniowe OpenJDK zbudowany wyłącznie przy użyciu
253 wolnego oprogramowania.
254
255 %package jre-base-X11
256 Summary:        IcedTea6 OpenJDK - runtime environment - X11 support
257 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa X11
258 Group:          Development/Languages/Java
259 Requires:       %{name}-jre-base = %{version}-%{release}
260 Requires:       %{name}-jre-base-freetype = %{version}-%{release}
261
262 %description jre-base-X11
263 X11 support for OpenJDK runtime environment built using free software
264 only.
265
266 %description jre-base-X11 -l pl.UTF-8
267 Biblioteki X11 dla środowiska OpenJDK zbudowany wyłocznie przy uzyciu
268 wolnego oprogramowania.
269
270 %package jre-base-alsa
271 Summary:        IcedTea6 OpenJDK - runtime environment - ALSA support
272 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa ALSA
273 Group:          Development/Languages/Java
274 Requires:       %{name}-jre-base = %{version}-%{release}
275
276 %description jre-base-alsa
277 ALSA sound support for OpenJDK runtime environment build using free
278 software only.
279
280 %description jre-base-alsa -l pl.UTF-8
281 Biblioteki ALSA rozszerzające środowisko OpenJDK o obsługę dźwięku
282 zbudowane przy uzyciu wyłącznie wolnego oprogramowania.
283
284 %package jre-base-freetype
285 Summary:        IcedTea6 OpenJDK - runtime environment - font support
286 Summary(pl.UTF-8):      IcedTea6 OpenJDK - środowisko uruchomieniowe - obsługa fontów
287 Group:          Development/Languages/Java
288 Requires:       %{name}-jre-base = %{version}-%{release}
289
290 %description jre-base-freetype
291 Font handling library for OpenJDK runtime environment built using free
292 software only.
293
294 %description jre-base-freetype -l pl.UTF-8
295 Biblioteki obsługi czcionek dla OpenJDK zbudowane wyłącznie przy
296 użyciu wolnego oprogramowania.
297
298 %package jar
299 Summary:        OpenJDK and GNU Classpath code - JAR tool
300 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - narzędzie JAR
301 Group:          Development/Languages/Java
302 Requires:       %{name}-jdk-base = %{version}-%{release}
303 Provides:       jar
304 Obsoletes:      fastjar
305 Obsoletes:      jar
306
307 %description jar
308 JAR tool from OpenJDK built using free software only.
309
310 JAR is an archiver used to merge Java classes into a single library.
311
312 %description jar -l pl.UTF-8
313 Narzędzie jar z OpenJDK zbudowane przy uzyciu wyłącznie wolnego
314 oprogramowania.
315
316 JAR jest narzędziem pozwalającym wykonywać podstawowe operacje na
317 archiwach javy .jar takie jak na przykład tworzenie lub rozpakowywanie
318 archiwów.
319
320 %package appletviewer
321 Summary:        OpenJDK and GNU Classpath code - appletviewer tool
322 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - narzędzie appletviewer
323 Group:          Development/Languages/Java
324 Requires:       %{name}-jdk-base = %{version}-%{release}
325 Requires:       %{name}-jre-X11 = %{version}-%{release}
326 Obsoletes:      java-sun-appletviewer
327
328 %description appletviewer
329 Appletviewer from OpenJDK build using free software only.
330
331 %description appletviewer -l pl.UTF-8
332 Appletviewer pozwala uruchamiać aplety javy niezależnie od
333 przeglądarki www. Ten appletviewer pochodzi z zestawu narzędzi OpenJDK
334 i został zbudowany wyłącznie przy użyciu wolnego oprogramowania.
335
336 %package jdk-sources
337 Summary:        OpenJDK and GNU Classpath code - sources
338 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - kod źródłowy
339 Group:          Documentation
340
341 %description jdk-sources
342 Source code for the OpenJDK development kit and Java standard library.
343
344 %description jdk-sources -l pl.UTF-8
345 Kod źródłowy narzędzi programistycznych OpenJDK oraz standardowej
346 biblioteki Javy.
347
348 %package examples
349 Summary:        OpenJDK and GNU Classpath code - examples
350 Summary(pl.UTF-8):      Kod OpenJDK i GNU Classpath - przykłady
351 Group:          Documentation
352
353 %description examples
354 Code examples for OpenJDK.
355
356 %description examples -l pl.UTF-8
357 Przykłady dla OpenJDK.
358
359 %prep
360 %setup -q
361 %patch0 -p1
362
363 # patches to applied to the extracted sources
364 install -d pld-patches
365 cp -p %{PATCH1} pld-patches
366
367 # let the build system extract the sources where it wants them
368 install -d drops
369 ln -s %{SOURCE1} .
370 ln -s %{SOURCE2} drops
371 ln -s %{SOURCE3} drops
372 ln -s %{SOURCE4} drops
373
374 %build
375 # Make sure we have /proc mounted - otherwise idlc will fail later.
376 if [ ! -f /proc/self/stat ]; then
377         echo "You need to have /proc mounted in order to build this package!"
378         exit 1
379 fi
380
381 export JAVA_HOME=%{java_home}
382 export PATH="$JAVA_HOME/bin:$PATH"
383
384 %{__aclocal}
385 %{__autoconf}
386 %{__automake}
387
388 %configure \
389         WGET=%{_bindir}/wget \
390 %if %{with bootstrap}
391         --with-gcj-home=%{java_home} \
392         --with-ecj-jar=%{_javadir}/ecj.jar \
393 %else
394         --with-jdk-home=%{java_home} \
395 %endif
396         %{!?with_nss:--disable-nss} \
397         --with-xalan2-jar=%{_javadir}/xalan.jar \
398         --with-xalan2-serializer-jar=%{_javadir}/serializer.jar \
399         --with-rhino=%{_javadir}/js.jar
400
401 %{__make} extract extract-ecj \
402         SHELL=/bin/bash \
403         DISTRIBUTION_PATCHES="$(echo pld-patches/*.patch)"
404
405 %if %{with bootstrap}
406 # Cannot do that as patch, as the sources are prepared by make
407 %{__sed} -i -e's/CORBA_BUILD_ARGUMENTS = \\/CORBA_BUILD_ARGUMENTS = JVMLIB="" \\/' openjdk-ecj/make/corba-rules.gmk
408 %endif
409 # if dpkg-architecure is installed (like on carme) it will break the build
410 # unless we disable using it somehow. As patching is difficult here:
411 %{__sed} -i -e's/dpkg-architecture/dpkg-architecture__/' openjdk*/*/make/common/shared/Platform.gmk
412
413 %{__make} -j1 \
414         SHELL=/bin/bash \
415         DISABLE_HOTSPOT_OS_VERSION_CHECK=ok \
416         DISTRIBUTION_PATCHES="$(echo pld-patches/*.patch)" \
417         PRINTF=/bin/printf
418
419 %{?with_cacerts:%{__sh} %{SOURCE10}}
420
421 %install
422 rm -rf $RPM_BUILD_ROOT
423 install -d $RPM_BUILD_ROOT{%{_bindir},%{dstdir},%{_mandir}/ja} \
424         $RPM_BUILD_ROOT{%{jvmjardir},%{_examplesdir}/%{name}-%{version},%{_javasrcdir}} \
425         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
426
427 # install the 'JDK image', it contains the JRE too
428 cp -a openjdk.build/j2sdk-image/* $RPM_BUILD_ROOT%{dstdir}
429
430 # convenience symlinks without version number
431 ln -s %{dstreldir} $RPM_BUILD_ROOT%{_jvmdir}/%{name}
432 ln -s %{jrereldir} $RPM_BUILD_ROOT%{_jvmdir}/%{name}-jre
433
434 ln -s %{dstreldir} $RPM_BUILD_ROOT%{_jvmdir}/java
435
436 # move JDK sources and demo to /usr/src
437 mv $RPM_BUILD_ROOT%{dstdir}/demo $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
438 mv $RPM_BUILD_ROOT%{dstdir}/sample $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
439 mv $RPM_BUILD_ROOT%{dstdir}/src.zip $RPM_BUILD_ROOT%{_javasrcdir}/%{name}-jdk.zip
440
441 # move manual pages to its place
442 mv $RPM_BUILD_ROOT%{dstdir}/man/ja_JP.eucJP/man1 $RPM_BUILD_ROOT%{_mandir}/ja/man1
443 rmdir $RPM_BUILD_ROOT%{dstdir}/man/ja_JP.eucJP
444 rm $RPM_BUILD_ROOT%{dstdir}/man/ja
445 mv $RPM_BUILD_ROOT%{dstdir}/man/man1 $RPM_BUILD_ROOT%{_mandir}/man1
446 rmdir $RPM_BUILD_ROOT%{dstdir}/man
447
448 # replace duplicates with symlinks, link to %{_bindir}
449 for path in $RPM_BUILD_ROOT%{dstdir}/bin/*; do
450         filename=$(basename $path)
451         if diff -q "$path" "$RPM_BUILD_ROOT%{jredir}/bin/$filename" > /dev/null; then
452                 ln -sf "../jre/bin/$filename" "$path"
453                 ln -sf "%{jredir}/bin/$filename" $RPM_BUILD_ROOT%{_bindir}
454         else
455                 ln -sf "%{dstdir}/bin/$filename" $RPM_BUILD_ROOT%{_bindir}
456         fi
457 done
458 ln -sf ../jre/lib/jexec $RPM_BUILD_ROOT%{dstdir}/lib/jexec
459
460 # keep configuration in /etc (not all *.properties go there)
461 for config in management security content-types.properties \
462                 logging.properties net.properties sound.properties; do
463
464         mv $RPM_BUILD_ROOT%{jredir}/lib/$config $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/$config
465         ln -s %{_sysconfdir}/%{name}/$config $RPM_BUILD_ROOT%{jredir}/lib/$config
466 done
467
468 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jsse.jar
469 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jcert.jar
470 ln -sf %{jredir}/lib/jsse.jar $RPM_BUILD_ROOT%{jvmjardir}/jnet.jar
471 ln -sf %{jredir}/lib/jce.jar $RPM_BUILD_ROOT%{jvmjardir}/jce.jar
472 for f in jndi jndi-ldap jndi-cos jndi-rmi jaas jdbc-stdext jdbc-stdext-3.0 \
473         sasl jaxp_parser_impl jaxp_transform_impl jaxp jmx activation xml-commons-apis \
474         jndi-dns jndi-rmi; do
475         ln -sf %{jredir}/lib/rt.jar $RPM_BUILD_ROOT%{jvmjardir}/$f.jar
476 done
477
478 # some apps (like opera) looks for it in different place
479 ln -s server/libjvm.so $RPM_BUILD_ROOT%{jredir}/lib/%{jre_arch}/libjvm.so
480
481 %{__rm} $RPM_BUILD_ROOT%{dstdir}/{,jre/}{ASSEMBLY_EXCEPTION,LICENSE,THIRD_PARTY_README}
482
483 %{?with_cacerts:install cacerts $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/security}
484
485 %clean
486 rm -rf $RPM_BUILD_ROOT
487
488 %files
489 %defattr(644,root,root,755)
490 %doc AUTHORS ChangeLog HACKING NEWS README THANKYOU
491
492 %files jdk
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_bindir}/apt
495 %attr(755,root,root) %{_bindir}/extcheck
496 %attr(755,root,root) %{_bindir}/idlj
497 %attr(755,root,root) %{_bindir}/jarsigner
498 %attr(755,root,root) %{_bindir}/java-rmi.cgi
499 %attr(755,root,root) %{_bindir}/javac
500 %attr(755,root,root) %{_bindir}/javadoc
501 %attr(755,root,root) %{_bindir}/javah
502 %attr(755,root,root) %{_bindir}/javap
503 %attr(755,root,root) %{_bindir}/jconsole
504 %attr(755,root,root) %{_bindir}/jdb
505 %attr(755,root,root) %{_bindir}/jhat
506 %attr(755,root,root) %{_bindir}/jinfo
507 %attr(755,root,root) %{_bindir}/jmap
508 %attr(755,root,root) %{_bindir}/jps
509 %attr(755,root,root) %{_bindir}/jrunscript
510 %attr(755,root,root) %{_bindir}/jsadebugd
511 %attr(755,root,root) %{_bindir}/jstack
512 %attr(755,root,root) %{_bindir}/jstat
513 %attr(755,root,root) %{_bindir}/jstatd
514 %attr(755,root,root) %{_bindir}/native2ascii
515 %attr(755,root,root) %{_bindir}/rmic
516 %attr(755,root,root) %{_bindir}/schemagen
517 %attr(755,root,root) %{_bindir}/serialver
518 %attr(755,root,root) %{_bindir}/wsgen
519 %attr(755,root,root) %{_bindir}/wsimport
520 %attr(755,root,root) %{_bindir}/xjc
521 %{_jvmdir}/java
522 %{_mandir}/man1/apt.1*
523 %{_mandir}/man1/extcheck.1*
524 %{_mandir}/man1/idlj.1*
525 %{_mandir}/man1/jarsigner.1*
526 %{_mandir}/man1/javac.1*
527 %{_mandir}/man1/javadoc.1*
528 %{_mandir}/man1/javah.1*
529 %{_mandir}/man1/javap.1*
530 %{_mandir}/man1/jconsole.1*
531 %{_mandir}/man1/jdb.1*
532 %{_mandir}/man1/jhat.1*
533 %{_mandir}/man1/jinfo.1*
534 %{_mandir}/man1/jmap.1*
535 %{_mandir}/man1/jps.1*
536 %{_mandir}/man1/jrunscript.1*
537 %{_mandir}/man1/jsadebugd.1*
538 %{_mandir}/man1/jstack.1*
539 %{_mandir}/man1/jstat.1*
540 %{_mandir}/man1/jstatd.1*
541 %{_mandir}/man1/native2ascii.1*
542 %{_mandir}/man1/schemagen.1*
543 %{_mandir}/man1/serialver.1*
544 %{_mandir}/man1/rmic.1*
545 %{_mandir}/man1/wsgen.1*
546 %{_mandir}/man1/wsimport.1*
547 %{_mandir}/man1/xjc.1*
548 %lang(ja) %{_mandir}/ja/man1/apt.1*
549 %lang(ja) %{_mandir}/ja/man1/extcheck.1*
550 %lang(ja) %{_mandir}/ja/man1/idlj.1*
551 %lang(ja) %{_mandir}/ja/man1/jarsigner.1*
552 %lang(ja) %{_mandir}/ja/man1/javac.1*
553 %lang(ja) %{_mandir}/ja/man1/javadoc.1*
554 %lang(ja) %{_mandir}/ja/man1/javah.1*
555 %lang(ja) %{_mandir}/ja/man1/javap.1*
556 %lang(ja) %{_mandir}/ja/man1/jconsole.1*
557 %lang(ja) %{_mandir}/ja/man1/jdb.1*
558 %lang(ja) %{_mandir}/ja/man1/jhat.1*
559 %lang(ja) %{_mandir}/ja/man1/jinfo.1*
560 %lang(ja) %{_mandir}/ja/man1/jmap.1*
561 %lang(ja) %{_mandir}/ja/man1/jps.1*
562 %lang(ja) %{_mandir}/ja/man1/jrunscript.1*
563 %lang(ja) %{_mandir}/ja/man1/jsadebugd.1*
564 %lang(ja) %{_mandir}/ja/man1/jstack.1*
565 %lang(ja) %{_mandir}/ja/man1/jstat.1*
566 %lang(ja) %{_mandir}/ja/man1/jstatd.1*
567 %lang(ja) %{_mandir}/ja/man1/native2ascii.1*
568 %lang(ja) %{_mandir}/ja/man1/schemagen.1*
569 %lang(ja) %{_mandir}/ja/man1/serialver.1*
570 %lang(ja) %{_mandir}/ja/man1/rmic.1*
571 %lang(ja) %{_mandir}/ja/man1/wsgen.1*
572 %lang(ja) %{_mandir}/ja/man1/wsimport.1*
573 %lang(ja) %{_mandir}/ja/man1/xjc.1*
574
575 %files jdk-base
576 %defattr(644,root,root,755)
577 %doc openjdk.build/j2sdk-image/THIRD_PARTY_README
578 %doc openjdk.build/j2sdk-image/ASSEMBLY_EXCEPTION
579 %dir %{dstdir}
580 %{_jvmdir}/%{name}
581 %attr(755,root,root) %{dstdir}/bin/appletviewer
582 %attr(755,root,root) %{dstdir}/bin/apt
583 %attr(755,root,root) %{dstdir}/bin/extcheck
584 %attr(755,root,root) %{dstdir}/bin/idlj
585 %attr(755,root,root) %{dstdir}/bin/jar
586 %attr(755,root,root) %{dstdir}/bin/jarsigner
587 %attr(755,root,root) %{dstdir}/bin/java-rmi.cgi
588 %attr(755,root,root) %{dstdir}/bin/javac
589 %attr(755,root,root) %{dstdir}/bin/javadoc
590 %attr(755,root,root) %{dstdir}/bin/javah
591 %attr(755,root,root) %{dstdir}/bin/javap
592 %attr(755,root,root) %{dstdir}/bin/jconsole
593 %attr(755,root,root) %{dstdir}/bin/jdb
594 %attr(755,root,root) %{dstdir}/bin/jhat
595 %attr(755,root,root) %{dstdir}/bin/jinfo
596 %attr(755,root,root) %{dstdir}/bin/jmap
597 %attr(755,root,root) %{dstdir}/bin/jps
598 %attr(755,root,root) %{dstdir}/bin/jrunscript
599 %attr(755,root,root) %{dstdir}/bin/jsadebugd
600 %attr(755,root,root) %{dstdir}/bin/jstack
601 %attr(755,root,root) %{dstdir}/bin/jstat
602 %attr(755,root,root) %{dstdir}/bin/jstatd
603 %attr(755,root,root) %{dstdir}/bin/native2ascii
604 %attr(755,root,root) %{dstdir}/bin/rmic
605 %attr(755,root,root) %{dstdir}/bin/schemagen
606 %attr(755,root,root) %{dstdir}/bin/serialver
607 %attr(755,root,root) %{dstdir}/bin/wsgen
608 %attr(755,root,root) %{dstdir}/bin/wsimport
609 %attr(755,root,root) %{dstdir}/bin/xjc
610 %{dstdir}/include
611 %dir %{dstdir}/lib
612 %{dstdir}/lib/ct.sym
613 %{dstdir}/lib/dt.jar
614 %{dstdir}/lib/ir.idl
615 %{dstdir}/lib/jconsole.jar
616 %attr(755,root,root) %{dstdir}/lib/jexec
617 %{dstdir}/lib/orb.idl
618 %ifnarch i486
619 %{dstdir}/lib/sa-jdi.jar
620 %endif
621 %{dstdir}/lib/tools.jar
622
623 %files jre
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_bindir}/java
626 %attr(755,root,root) %{_bindir}/keytool
627 %attr(755,root,root) %{_bindir}/orbd
628 %attr(755,root,root) %{_bindir}/pack200
629 %attr(755,root,root) %{_bindir}/rmid
630 %attr(755,root,root) %{_bindir}/rmiregistry
631 %attr(755,root,root) %{_bindir}/servertool
632 %attr(755,root,root) %{_bindir}/tnameserv
633 %attr(755,root,root) %{_bindir}/unpack200
634 %{_mandir}/man1/java.1*
635 %{_mandir}/man1/keytool.1*
636 %{_mandir}/man1/orbd.1*
637 %{_mandir}/man1/pack200.1*
638 %{_mandir}/man1/rmid.1*
639 %{_mandir}/man1/rmiregistry.1*
640 %{_mandir}/man1/servertool.1*
641 %{_mandir}/man1/tnameserv.1*
642 %{_mandir}/man1/unpack200.1*
643 %lang(ja) %{_mandir}/ja/man1/java.1*
644 %ifnarch x86_64
645 %endif
646 %lang(ja) %{_mandir}/ja/man1/keytool.1*
647 %lang(ja) %{_mandir}/ja/man1/orbd.1*
648 %lang(ja) %{_mandir}/ja/man1/pack200.1*
649 %lang(ja) %{_mandir}/ja/man1/rmid.1*
650 %lang(ja) %{_mandir}/ja/man1/rmiregistry.1*
651 %lang(ja) %{_mandir}/ja/man1/servertool.1*
652 %lang(ja) %{_mandir}/ja/man1/tnameserv.1*
653 %lang(ja) %{_mandir}/ja/man1/unpack200.1*
654
655 %files jre-base
656 %defattr(644,root,root,755)
657 %doc openjdk.build/j2sdk-image/THIRD_PARTY_README
658 %doc openjdk.build/j2sdk-image/ASSEMBLY_EXCEPTION
659 %dir %{_sysconfdir}/%{name}
660 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
661 %dir %{dstdir}
662 %dir %{jredir}
663 %{_jvmdir}/%{name}-jre
664 %dir %{jredir}/bin
665 %dir %{dstdir}/bin
666 %attr(755,root,root) %{jredir}/bin/java
667 %attr(755,root,root) %{dstdir}/bin/java
668 %attr(755,root,root) %{jredir}/bin/keytool
669 %attr(755,root,root) %{dstdir}/bin/keytool
670 %attr(755,root,root) %{jredir}/bin/orbd
671 %attr(755,root,root) %{dstdir}/bin/orbd
672 %attr(755,root,root) %{jredir}/bin/pack200
673 %attr(755,root,root) %{dstdir}/bin/pack200
674 %attr(755,root,root) %{jredir}/bin/rmid
675 %attr(755,root,root) %{dstdir}/bin/rmid
676 %attr(755,root,root) %{jredir}/bin/rmiregistry
677 %attr(755,root,root) %{dstdir}/bin/rmiregistry
678 %attr(755,root,root) %{jredir}/bin/servertool
679 %attr(755,root,root) %{dstdir}/bin/servertool
680 %attr(755,root,root) %{jredir}/bin/tnameserv
681 %attr(755,root,root) %{dstdir}/bin/tnameserv
682 %attr(755,root,root) %{jredir}/bin/unpack200
683 %attr(755,root,root) %{dstdir}/bin/unpack200
684 %dir %{jredir}/lib
685 %dir %{jredir}/lib/applet
686 %{jredir}/lib/cmm
687 %{jredir}/lib/ext
688 %dir %{jredir}/lib/%{jre_arch}
689 %ifnarch x86_64 i486
690 %dir %{jredir}/lib/%{jre_arch}/client
691 %{jredir}/lib/%{jre_arch}/client/Xusage.txt
692 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/client/*.so
693 %endif
694 %dir %{jredir}/lib/%{jre_arch}/headless
695 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/headless/*.so
696 %dir %{jredir}/lib/%{jre_arch}/jli
697 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/jli/*.so
698 %dir %{jredir}/lib/%{jre_arch}/native_threads
699 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/native_threads/*.so
700 %dir %{jredir}/lib/%{jre_arch}/server
701 %{jredir}/lib/%{jre_arch}/server/Xusage.txt
702 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/server/*.so
703 %ifnarch i486
704 %{jredir}/lib/%{jre_arch}/server/classes.jsa
705 %endif
706 %{jredir}/lib/%{jre_arch}/jvm.cfg
707 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libattach.so
708 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libawt.so
709 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libdt_socket.so
710 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libhprof.so
711 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libinstrument.so
712 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2gss.so
713 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2pcsc.so
714 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libj2pkcs11.so
715 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjaas_unix.so
716 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava.so
717 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjava_crw_demo.so
718 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjawt.so
719 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjdwp.so
720 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjpeg.so
721 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsig.so
722 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsound.so
723 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjvm.so
724 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/liblcms.so
725 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libmanagement.so
726 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libmlib_image.so
727 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnet.so
728 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnio.so
729 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libnpt.so
730 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/librmi.so
731 %ifnarch i486
732 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsaproc.so
733 %endif
734 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libunpack.so
735 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libverify.so
736 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libzip.so
737 %{jredir}/lib/im
738 %{jredir}/lib/images
739 %{jredir}/lib/management
740 %{jredir}/lib/security
741 %{jredir}/lib/zi
742 #
743 %if %{with webstart}
744 %{jredir}/lib/about.jar
745 %{jredir}/lib/about.jnlp
746 %endif
747 %{jredir}/lib/calendars.properties
748 %{jredir}/lib/charsets.jar
749 %{jredir}/lib/classlist
750 %{jredir}/lib/content-types.properties
751 %{jredir}/lib/currency.data
752 %{jredir}/lib/flavormap.properties
753 %{jredir}/lib/fontconfig.*
754 %{jredir}/lib/jce.jar
755 %attr(755, root, root) %{jredir}/lib/jexec
756 %{jredir}/lib/jsse.jar
757 %{jredir}/lib/jvm.hprof.txt
758 %{jredir}/lib/logging.properties
759 %{jredir}/lib/management-agent.jar
760 %{jredir}/lib/meta-index
761 %{jredir}/lib/net.properties
762 %{jredir}/lib/psfont.properties.ja
763 %{jredir}/lib/psfontj2d.properties
764 %{jredir}/lib/resources.jar
765 %{jredir}/lib/rhino.jar
766 %{jredir}/lib/rt.jar
767 %{jredir}/lib/sound.properties
768 %{jredir}/lib/tz.properties
769 %{jvmjardir}
770
771 %files jre-X11
772 %defattr(644,root,root,755)
773 %attr(755,root,root) %{_bindir}/policytool
774 %{_mandir}/man1/policytool.1*
775 %lang(ja) %{_mandir}/ja/man1/policytool.1*
776
777 %files jre-base-X11
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{jredir}/bin/policytool
780 %attr(755,root,root) %{dstdir}/bin/policytool
781 %dir %{jredir}/lib/%{jre_arch}/xawt
782 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/xawt/*.so
783 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libsplashscreen.so
784
785 %files jre-base-alsa
786 %defattr(644,root,root,755)
787 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libjsoundalsa.so
788
789 %files jre-base-freetype
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{jredir}/lib/%{jre_arch}/libfontmanager.so
792
793 %files jar
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_bindir}/jar
796 %{_mandir}/man1/jar.1*
797 %lang(ja) %{_mandir}/ja/man1/jar.1*
798
799 %files appletviewer
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{_bindir}/appletviewer
802 %{_mandir}/man1/appletviewer.1*
803 %lang(ja) %{_mandir}/ja/man1/appletviewer.1*
804
805 %files jdk-sources
806 %defattr(644,root,root,755)
807 %{_javasrcdir}/%{name}-jdk.zip
808
809 %files examples
810 %defattr(644,root,root,755)
811 %{_examplesdir}/%{name}-%{version}
This page took 0.096266 seconds and 3 git commands to generate.