]> git.pld-linux.org Git - packages/icedtea8.git/blob - icedtea.spec
- starts building
[packages/icedtea8.git] / icedtea.spec
1 # TODO:
2 # - fix bash substitution
3 #
4 Summary:        OpenJDK and GNU Classpath code
5 SummarY(pl.UTF-8):      Kod OpenJDK i GNU Classpath
6 Name:           icedtea
7 Version:        1.8
8 Release:        0.1
9 License:        GPL
10 Group:          Development/Languages/Java
11 Source0:        http://icedtea.classpath.org/download/source/%{name}-%{version}.tar.gz
12 # Source0-md5:  b165d877e0f9824a2b492541be945874
13 # Create this one by running make dist-openjdk (needs mercurial + mercurial forest extension)
14 Source1:        openjdk-b26.zip
15 # Source1-md5:  7a5d2da503fde6ba09df9773d7df27ca
16 URL:            http://icedtea.classpath.org/wiki/Main_Page
17 BuildRequires:  alsa-lib-devel
18 BuildRequires:  bash
19 BuildRequires:  cups-devel
20 BuildRequires:  eclipse-ecj
21 BuildRequires:  freetype-devel >= 2.3
22 BuildRequires:  gcc-java >= 6:4.3
23 BuildRequires:  giflib-devel
24 BuildRequires:  glib2-devel
25 BuildRequires:  gtk+2-devel
26 BuildRequires:  gdk-pixbuf-devel
27 BuildRequires:  jdk
28 BuildRequires:  libgcj
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  libpng-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  motif-devel
33 BuildRequires:  rhino
34 BuildRequires:  unzip
35 BuildRequires:  xalan-j
36 BuildRequires:  xerces-j
37 BuildRequires:  xorg-lib-libX11-devel
38 BuildRequires:  xorg-lib-libXinerama-devel
39 BuildRequires:  xorg-lib-libXp-devel
40 BuildRequires:  xorg-lib-libXt-devel
41 BuildRequires:  xorg-lib-libXtst-devel
42 BuildRequires:  xorg-proto-printproto-devel
43 BuildRequires:  xorg-proto-xproto-devel
44 BuildRequires:  xulrunner-devel
45 BuildRequires:  zlib-devel
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 The IcedTea project provides a harness to build the source code from
50 http://openjdk.java.net/ using Free Software build tools and provides
51 replacements libraries for the binary plugs with code from the GNU
52 Classpath project.
53
54 %description -l pl.UTF-8
55 Projekt IcedTea daje możliwość kompilacji kodu źródłowego z
56 http://openjdk.java.net/ przy użyciu wolnodostępnych narzędzi oraz
57 dostarcza zamienniki biblioteczne binarnych wtyczek pochodzące z
58 projektu GNU Classpath.
59
60 %prep
61 # source1 should unpack itself into the same dir
62 # as specified in --with-openjdk-src=
63 %setup -q -a1
64
65 sed -i -e 's#^PRINTF.*=.*#PRINTF = /bin/printf#g' \
66         openjdk/*/make/common/shared/Defs-utils.gmk
67
68 mv openjdk openjdk-src
69
70 %build
71 unset JAVA_HOME || :
72 %configure \
73         --with-gcj-home=%{_prefix} \
74         --with-ecj=%{_bindir}/ecj \
75         --with-ecj-jar=%{_javadir}/ecj.jar \
76         --with-libgcj-jar=%{_javadir}/libgcj.jar \
77         --with-xalan2-jar=%{_javadir}/xalan.jar \
78         --with-xalan2-serializer-jar=%{_javadir}/serializer.jar \
79         --with-xerces2-jar=%{_javadir}/xerces.jar \
80         --with-openjdk-src-dir=${PWD}/openjdk-src \
81         --with-rhino=%{_javadir}/js.jar
82
83 %{__make} -j1 \
84         SHELL=/bin/bash
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
This page took 0.026192 seconds and 3 git commands to generate.