]> git.pld-linux.org Git - packages/iceape.git/blob - iceape.spec
- rel 2
[packages/iceape.git] / iceape.spec
1 #
2 # Conditional build:
3 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
4 %bcond_without  gnomeui         # disable gnomeui support
5 %bcond_without  gnome           # disable gnomeui (alias)
6 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
7 %bcond_without  lightning       # disable Sunbird/Lightning calendar
8 %bcond_with     xulrunner       # build with system xulrunner
9 %bcond_with     tests           # enable tests (whatever they check)
10 %bcond_without  kerberos        # disable krb5 support
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 %define         enigmail_ver    1.4.2
17 %define         nspr_ver        4.9
18 %define         nss_ver         3.13.3
19 %define         xulrunner_ver   13.0
20
21 %if %{without xulrunner}
22 # The actual sqlite version (see RHBZ#480989):
23 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24 %endif
25
26 Summary:        Iceape - web browser
27 Summary(es.UTF-8):      Navegador de Internet Iceape
28 Summary(pl.UTF-8):      Iceape - przeglądarka WWW
29 Summary(pt_BR.UTF-8):   Navegador Iceape
30 Name:           iceape
31 Version:        2.10.1
32 Release:        2
33 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
34 Group:          X11/Applications/Networking
35 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/seamonkey-%{version}.source.tar.bz2
36 # Source0-md5:  1c89d3657b5e2e9765391208c5f9bfda
37 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
38 # Source1-md5:  ed608e1cd4cd20b96f7f5afdbf081141
39 Source2:        %{name}-branding.tar.bz2
40 # Source2-md5:  a18e5112591404f3feb358d410c08c53
41 Source3:        %{name}-rm_nonfree.sh
42 Source4:        %{name}.desktop
43 Source5:        %{name}-composer.desktop
44 Source6:        %{name}-chat.desktop
45 Source7:        %{name}-mail.desktop
46 Source8:        %{name}-venkman.desktop
47 Source9:        %{name}.sh
48 Patch0:         %{name}-branding.patch
49 Patch1:         %{name}-pld-branding.patch
50 Patch2:         %{name}-agent.patch
51 Patch3:         %{name}-glueload-fix.patch
52 Patch4:         system-mozldap.patch
53 Patch5:         makefile.patch
54 Patch6:         system-cairo.patch
55 URL:            http://www.pld-linux.org/Packages/Iceape
56 BuildRequires:  GConf2-devel >= 1.2.1
57 BuildRequires:  OpenGL-devel
58 BuildRequires:  alsa-lib-devel
59 BuildRequires:  automake
60 BuildRequires:  bzip2-devel
61 BuildRequires:  cairo-devel >= 1.10.2-5
62 BuildRequires:  dbus-glib-devel >= 0.60
63 BuildRequires:  freetype-devel >= 1:2.1.8
64 BuildRequires:  glib2-devel >= 1:2.18
65 BuildRequires:  gtk+2-devel >= 2:2.10
66 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
67 BuildRequires:  hunspell-devel
68 BuildRequires:  libIDL-devel >= 0.8.0
69 BuildRequires:  libdnet-devel
70 BuildRequires:  libevent-devel >= 1.4.7
71 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
72 BuildRequires:  libffi-devel >= 6:3.0.9
73 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
74 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
75 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
76 BuildRequires:  libiw-devel
77 BuildRequires:  libjpeg-devel >= 6b
78 BuildRequires:  libnotify-devel >= 0.4
79 BuildRequires:  libpng(APNG)-devel >= 0.10
80 BuildRequires:  libpng-devel >= 1.4.1
81 # rsvg-convert for iceape/branding
82 BuildRequires:  librsvg
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libvpx-devel >= 1.0.0
85 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
86 BuildRequires:  nss-devel >= 1:%{nss_ver}
87 BuildRequires:  pango-devel >= 1:1.14.0
88 BuildRequires:  perl-base >= 1:5.6
89 BuildRequires:  perl-modules >= 5.004
90 BuildRequires:  pkgconfig
91 BuildRequires:  python >= 1:2.5
92 BuildRequires:  python-modules
93 BuildRequires:  rpm >= 4.4.9-56
94 BuildRequires:  rpmbuild(macros) >= 1.601
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  sqlite3-devel >= 3.7.10
97 BuildRequires:  startup-notification-devel >= 0.8
98 BuildRequires:  xorg-lib-libXScrnSaver-devel
99 BuildRequires:  xorg-lib-libXext-devel
100 BuildRequires:  xorg-lib-libXinerama-devel
101 BuildRequires:  xorg-lib-libXt-devel
102 %if %{with xulrunner}
103 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
104 %endif
105 BuildRequires:  yasm
106 BuildRequires:  zip
107 BuildRequires:  zlib-devel >= 1.2.3
108 Requires(post): mktemp >= 1.5-18
109 Requires:       desktop-file-utils
110 Requires:       hicolor-icon-theme
111 %if %{with xulrunner}
112 %requires_eq_to xulrunner xulrunner-devel
113 %else
114 Requires:       browser-plugins >= 2.0
115 Requires:       cairo >= 1.10.2-5
116 Requires:       dbus-glib >= 0.60
117 Requires:       gtk+2 >= 2:2.18
118 Requires:       libpng >= 1.4.1
119 Requires:       libpng(APNG) >= 0.10
120 Requires:       myspell-common
121 Requires:       nspr >= 1:%{nspr_ver}
122 Requires:       nss >= 1:%{nss_ver}
123 Requires:       pango >= 1:1.14.0
124 Requires:       sqlite3 >= %{sqlite_build_version}
125 Requires:       startup-notification >= 0.8
126 %endif
127 Provides:       iceape-embedded = %{epoch}:%{version}-%{release}
128 Provides:       wwwbrowser
129 Obsoletes:      light
130 Obsoletes:      mozilla
131 Obsoletes:      mozilla-gnomevfs
132 Obsoletes:      seamonkey
133 Obsoletes:      seamonkey-calendar
134 Obsoletes:      seamonkey-libs
135 Obsoletes:      seamonkey-mailnews
136 Obsoletes:      seamonkey-gnomevfs
137 Conflicts:      iceape-lang-resources < %{version}
138 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
139
140 %define         topdir          %{_builddir}/%{name}-%{version}
141 %define         objdir          %{topdir}/obj-%{_target_cpu}
142
143 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
144
145 # don't satisfy other packages
146 %define         _noautoprovfiles        %{_libdir}/%{name}
147 # and as we don't provide them, don't require either
148 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
149 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
150
151 %description
152 Iceape is an open-source web browser, designed for standards
153 compliance, performance and portability.
154
155 %description -l es.UTF-8
156 Iceape es un navegador de Internet que se basa en una versión inicial
157 de Netscape Communicator.
158
159 %description -l pl.UTF-8
160 Iceape jest potężną graficzną przeglądarką WWW, która jest następcą
161 Mozilli, która następnie była następczynią Netscape Communikatora.
162
163 %description -l pt_BR.UTF-8
164 O Iceape é um web browser baseado numa versão inicial do Netscape
165 Communicator.
166
167 %description -l ru.UTF-8
168 Iceape - полнофункциональный web-browser с открытыми исходными
169 текстами, разработанный для максимального соотвествия стандартам,
170 максмимальной переносимости и скорости работы
171
172 %package addon-lightning
173 Summary:        An integrated calendar for Iceape
174 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Iceape
175 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
176 Group:          Applications/Networking
177 Requires:       %{name} = %{version}-%{release}
178 Obsoletes:      seamonkey-addon-lightning
179
180 %description addon-lightning
181 Lightning is an calendar extension to Icedove email client.
182
183 %description addon-lightning -l pl.UTF-8
184 Lightning to rozszerzenie do klienta poczty Icedove dodające
185 funkcjonalność kalendarza.
186
187 %package addon-enigmail
188 Summary:        Enigmail %{enigmail_ver} - PGP/GPG support for Iceape
189 Summary(pl.UTF-8):      Enigmail %{enigmail_ver} - obsługa PGP/GPG dla Iceape
190 Group:          X11/Applications/Networking
191 Requires:       %{name} = %{epoch}:%{version}-%{release}
192 Requires:       gnupg >= 1.4.2.2
193 Obsoletes:      seamonkey-addon-enigmail
194
195 %description addon-enigmail
196 Enigmail is an extension to the mail client of Iceape / SeaMonkey /
197 Mozilla / Netscape and Mozilla Thunderbird which allows users to
198 access the authentication and encryption features provided by GnuPG.
199
200 %description addon-enigmail -l pl.UTF-8
201 Enigmail jest rozszerzeniem dla klienta pocztowego Iceape, SeaMonkey,
202 Mozilla i Mozilla Thunderdbird pozwalającym użytkownikowi korzystać z
203 funkcjonalności GnuPG.
204
205 %package chat
206 Summary:        Iceape Chat - integrated IRC client
207 Summary(pl.UTF-8):      Iceape Chat - zintegrowany klient IRC-a
208 Group:          X11/Applications/Networking
209 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
210 Requires:       %{name} = %{epoch}:%{version}-%{release}
211 Obsoletes:      mozilla-chat
212 Obsoletes:      seamonkey-chat
213
214 %description chat
215 Iceape Chat - IRC client that is integrated with the Iceape web
216 browser.
217
218 %description chat -l pl.UTF-8
219 Iceape - klient IRC-a zintegrowany z przeglądarką Iceape.
220
221 %package js-debugger
222 Summary:        JavaScript debugger for use with Iceape
223 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z Iceape
224 Group:          X11/Applications/Networking
225 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
226 Requires:       %{name} = %{epoch}:%{version}-%{release}
227 Obsoletes:      mozilla-js-debugger
228 Obsoletes:      seamonkey-js-debugger
229
230 %description js-debugger
231 JavaScript debugger for use with Iceape.
232
233 %description js-debugger -l pl.UTF-8
234 Odpluskwiacz JavaScriptu do używania z Iceape.
235
236 %package dom-inspector
237 Summary:        A tool for inspecting the DOM of pages in Iceape
238 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w Iceape
239 Group:          X11/Applications/Networking
240 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
241 Requires:       %{name} = %{epoch}:%{version}-%{release}
242 Obsoletes:      mozilla-dom-inspector
243 Obsoletes:      seamonkey-dom-inspector
244
245 %description dom-inspector
246 This is a tool that allows you to inspect the DOM for web pages in
247 Iceape. This is of great use to people who are doing Iceape chrome
248 development or web page development.
249
250 %description dom-inspector -l pl.UTF-8
251 To narzędzie pozwala na oglądanie DOM dla stron WWW w Iceape. Jest
252 bardzo przydatne dla ludzi rozwijających chrome w Iceape lub
253 tworzących strony WWW.
254
255 %prep
256 %setup -qc
257 cd comm-release
258 tar -C mailnews/extensions -zxf %{SOURCE1}
259 tar -jxf %{SOURCE2}
260 %patch0 -p1
261 %patch1 -p1
262 %patch2 -p1
263 %patch3 -p1
264 %patch4 -p1
265 %patch5 -p1
266 %patch6 -p1
267
268 %build
269 cd comm-release
270 %if %{with xulrunner}
271 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
272         echo >&2
273         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
274         echo >&2
275         exit 1
276 fi
277 %endif
278
279 cp -f %{_datadir}/automake/config.* build/autoconf
280 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
281 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
282 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
283
284 cat << EOF > .mozconfig
285 mk_add_options MOZ_OBJDIR=%{objdir}
286
287 export CFLAGS="%{rpmcflags}"
288 export CXXFLAGS="%{rpmcflags}"
289
290 %if %{with crashreporter}
291 export MOZ_DEBUG_SYMBOLS=1
292 %endif
293
294 # Options for 'configure' (same as command-line options).
295 ac_add_options --prefix=%{_prefix}
296 ac_add_options --exec-prefix=%{_exec_prefix}
297 ac_add_options --bindir=%{_bindir}
298 ac_add_options --sbindir=%{_sbindir}
299 ac_add_options --sysconfdir=%{_sysconfdir}
300 ac_add_options --datadir=%{_datadir}
301 ac_add_options --includedir=%{_includedir}
302 ac_add_options --libdir=%{_libdir}
303 ac_add_options --libexecdir=%{_libexecdir}
304 ac_add_options --localstatedir=%{_localstatedir}
305 ac_add_options --sharedstatedir=%{_sharedstatedir}
306 ac_add_options --mandir=%{_mandir}
307 ac_add_options --infodir=%{_infodir}
308 ac_add_options --disable-elf-hack
309 %if %{?debug:1}0
310 ac_add_options --disable-optimize
311 ac_add_options --enable-debug
312 ac_add_options --enable-debug-modules
313 ac_add_options --enable-debugger-info-modules
314 ac_add_options --enable-crash-on-assert
315 %else
316 ac_add_options --disable-debug
317 ac_add_options --disable-debug-modules
318 ac_add_options --disable-logging
319 ac_add_options --enable-optimize="%{rpmcflags} -Os"
320 %endif
321 ac_add_options --disable-strip
322 ac_add_options --disable-strip-libs
323 %if %{with tests}
324 ac_add_options --enable-tests
325 %else
326 ac_add_options --disable-tests
327 %endif
328 ac_add_options --enable-gio
329 %if %{with gnomeui}
330 ac_add_options --enable-gnomeui
331 %else
332 ac_add_options --disable-gnomeui
333 %endif
334 ac_add_options --disable-gnomevfs
335 %if %{with ldap}
336 ac_add_options --enable-ldap
337 ac_add_options --with-system-ldap
338 %else
339 ac_add_options --disable-ldap
340 %endif
341 %if %{with crashreporter}
342 ac_add_options --enable-crashreporter
343 %else
344 ac_add_options --disable-crashreporter
345 %endif
346 ac_add_options --disable-xterm-updates
347 ac_add_options --enable-postscript
348 %if %{with lightning}
349 ac_add_options --enable-calendar
350 %else
351 ac_add_options --disable-calendar
352 %endif
353 ac_add_options --disable-installer
354 ac_add_options --disable-javaxpcom
355 ac_add_options --disable-updater
356 ac_add_options --enable-crypto
357 ac_add_options --enable-libxul
358 ac_add_options --enable-pango
359 ac_add_options --enable-shared-js
360 ac_add_options --enable-startup-notification
361 ac_add_options --enable-system-cairo
362 ac_add_options --enable-system-hunspell
363 ac_add_options --enable-system-sqlite
364 ac_add_options --enable-application=suite
365 ac_add_options --with-distribution-id=org.pld-linux
366 ac_add_options --with-branding=iceape/branding
367 %if %{with xulrunner}
368 ac_add_options --with-system-libxul
369 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
370 %endif
371 ac_add_options --with-pthreads
372 ac_add_options --with-system-bz2
373 ac_add_options --with-system-ffi
374 ac_add_options --with-system-jpeg
375 ac_add_options --with-system-libevent
376 ac_add_options --with-system-libvpx
377 ac_add_options --with-system-nspr
378 ac_add_options --with-system-nss
379 ac_add_options --with-system-png
380 ac_add_options --with-system-zlib
381 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
382 EOF
383
384 %{__make} -j1 -f client.mk build \
385         STRIP="/bin/true" \
386         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
387         installdir=%{_libdir}/%{name} \
388         CC="%{__cc}" \
389         CXX="%{__cxx}"
390
391 %if %{with crashreporter}
392 # create debuginfo for crash-stats.mozilla.com
393 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
394 %endif
395
396 %if %{with enigmail}
397 cd mailnews/extensions/enigmail
398 ./makemake -r -o %{objdir}
399 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
400         STRIP="/bin/true" \
401         CC="%{__cc}" \
402         CXX="%{__cxx}"
403
404 %{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
405         STRIP="/bin/true" \
406         CC="%{__cc}" \
407         CXX="%{__cxx}"
408 %endif
409
410 %install
411 rm -rf $RPM_BUILD_ROOT
412 cd comm-release
413 install -d \
414         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
415         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
416         $RPM_BUILD_ROOT%{_datadir}/%{name} \
417         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
418
419 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
420
421 cd %{objdir}
422 %{__make} -C suite/installer stage-package \
423         DESTDIR=$RPM_BUILD_ROOT \
424         installdir=%{_libdir}/%{name} \
425         PKG_SKIP_STRIP=1
426
427 %{__make} -C iceape/branding install \
428         DESTDIR=$RPM_BUILD_ROOT
429
430 cp -a mozilla/dist/iceape/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
431
432 %if %{with xulrunner}
433 # >= 5.0 seems to require this
434 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
435 %endif
436
437 # Enable crash reporter for Thunderbird application
438 %if %{with crashreporter}
439 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
440
441 # Add debuginfo for crash-stats.mozilla.com
442 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
443 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
444 %endif
445
446 # copy manually lightning files, somewhy they are not installed by make
447 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
448         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
449         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
450                 
451 # move arch independant ones to datadir
452 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
453 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
454 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
455 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
456 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
457 %if %{without xulrunner}
458 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
459 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
460 %endif
461
462 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
463 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
464 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
465 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
466 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
467 %if %{without xulrunner}
468 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
469 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
470 %endif
471
472 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
473         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
474
475 # dir for arch independant extensions besides arch dependant extensions
476 # see mozilla/xpcom/build/nsXULAppAPI.h
477 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
478 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
479  
480 %if %{without xulrunner}
481 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
482 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
483 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
484 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
485 %endif
486
487 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
488          -e "s|%MOZ_APP_DISPLAYNAME%|Iceape|" \
489         %{topdir}/comm-release/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/iceape
490
491 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE9} > $RPM_BUILD_ROOT%{_bindir}/iceape
492 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/iceape
493
494 install %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
495         $RPM_BUILD_ROOT%{_desktopdir}
496
497 # files created by iceape -register
498 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
499 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
500
501 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
502 #!/bin/sh
503 umask 022
504 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
505
506 # it attempts to touch files in $HOME/.mozilla
507 # beware if you run this with sudo!!!
508 export HOME=$(mktemp -d)
509 # also TMPDIR could be pointing to sudo user's homedir
510 unset TMPDIR TMP || :
511
512 %{_libdir}/%{name}/iceape -register
513
514 rm -rf $HOME
515 EOF
516 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
517
518 %if %{with enigmail}
519 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
520 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
521 cd mozilla/dist/bin
522 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
523 cp -rfLp components/enig* $ext_dir/components
524 cp -rfLp components/libenigmime.so $ext_dir/components
525 cp -rfLp components/libipc.so $ext_dir/components
526 cp -rfLp components/ipc.xpt $ext_dir/components
527 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
528 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,pipeTransport,subprocess}.jsm $ext_dir/modules
529 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
530 cd -
531 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/install.rdf $ext_dir
532 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
533 %endif
534
535 # never package these. always remove
536 # nss
537 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
538 # nspr
539 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
540 # mozldap
541 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
542 # testpilot quiz
543 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
544
545 %clean
546 rm -rf $RPM_BUILD_ROOT
547
548 %post
549 %{_libdir}/%{name}/register || :
550 %update_browser_plugins
551 %update_icon_cache hicolor
552 %update_desktop_database
553
554 %postun
555 if [ "$1" = 0 ]; then
556         %update_browser_plugins
557         %update_icon_cache hicolor
558 fi
559
560 %files
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_bindir}/iceape
563
564 # browser plugins v2
565 %{_browserpluginsconfdir}/browsers.d/%{name}.*
566 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
567
568 %dir %{_libdir}/%{name}
569 %if %{without xulrunner}
570 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
571 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
572 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
573 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
574 %endif
575
576 %{_libdir}/%{name}/blocklist.xml
577 %attr(755,root,root) %{_libdir}/%{name}/register
578
579 %if %{with crashreporter}
580 %{_libdir}/%{name}/crashreporter
581 %{_libdir}/%{name}/crashreporter-override.ini
582 %{_libdir}/%{name}/crashreporter.ini
583 %{_libdir}/%{name}/Throbber-small.gif
584 %endif
585
586 # config?
587 %{_libdir}/%{name}/application.ini
588 %{_libdir}/%{name}/chrome.manifest
589
590 %dir %{_libdir}/%{name}/components
591
592 %{_libdir}/%{name}/components/FeedConverter.js
593 %{_libdir}/%{name}/components/FeedWriter.js
594 %{_libdir}/%{name}/components/Weave.js
595 %{_libdir}/%{name}/components/WebContentConverter.js
596 %{_libdir}/%{name}/components/browser.xpt
597 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
598 %{_libdir}/%{name}/components/nsSessionStartup.js
599 %{_libdir}/%{name}/components/nsSessionStore.js
600 %{_libdir}/%{name}/components/nsSidebar.js
601
602 %{_libdir}/%{name}/components/components.manifest
603 %{_libdir}/%{name}/components/interfaces.manifest
604
605 %if %{without xulrunner}
606 %{_libdir}/%{name}/platform.ini
607 %{_libdir}/%{name}/components/ConsoleAPI.js
608 %{_libdir}/%{name}/components/FeedProcessor.js
609 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
610 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
611 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
612 %{_libdir}/%{name}/components/TelemetryPing.js
613 %{_libdir}/%{name}/components/addonManager.js
614 %{_libdir}/%{name}/components/amContentHandler.js
615 %{_libdir}/%{name}/components/amWebInstallListener.js
616 %{_libdir}/%{name}/components/contentAreaDropListener.js
617 %{_libdir}/%{name}/components/contentSecurityPolicy.js
618 %{_libdir}/%{name}/components/crypto-SDR.js
619 %{_libdir}/%{name}/components/jsconsole-clhandler.js
620 %{_libdir}/%{name}/components/nsBadCertHandler.js
621 %{_libdir}/%{name}/components/nsBlocklistService.js
622 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
623 %{_libdir}/%{name}/components/nsContentPrefService.js
624 %{_libdir}/%{name}/components/nsDefaultCLH.js
625 %{_libdir}/%{name}/components/nsFilePicker.js
626 %{_libdir}/%{name}/components/nsFormAutoComplete.js
627 %{_libdir}/%{name}/components/nsFormHistory.js
628 %{_libdir}/%{name}/components/nsHandlerService.js
629 %{_libdir}/%{name}/components/nsHelperAppDlg.js
630 %{_libdir}/%{name}/components/nsINIProcessor.js
631 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
632 %{_libdir}/%{name}/components/nsLivemarkService.js
633 %{_libdir}/%{name}/components/nsLoginInfo.js
634 %{_libdir}/%{name}/components/nsLoginManager.js
635 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
636 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
637 %{_libdir}/%{name}/components/nsPlacesExpiration.js
638 %{_libdir}/%{name}/components/nsPrompter.js
639 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
640 %{_libdir}/%{name}/components/nsSearchService.js
641 %{_libdir}/%{name}/components/nsSearchSuggestions.js
642 %{_libdir}/%{name}/components/nsTaggingService.js
643 %{_libdir}/%{name}/components/nsURLFormatter.js
644 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
645 %{_libdir}/%{name}/components/nsWebHandlerApp.js
646 %{_libdir}/%{name}/components/storage-Legacy.js
647 %{_libdir}/%{name}/components/storage-mozStorage.js
648 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
649 %endif
650
651 %{_libdir}/%{name}/components/nsAbout.js
652 %{_libdir}/%{name}/components/nsComposerCmdLineHandler.js
653 %{_libdir}/%{name}/components/nsSuiteDownloadManagerUI.js
654 %{_libdir}/%{name}/components/nsSuiteGlue.js
655 %{_libdir}/%{name}/components/nsTypeAheadFind.js
656 %{_libdir}/%{name}/components/smileApplication.js
657 %{_libdir}/%{name}/components/ContactManager.js
658 %{_libdir}/%{name}/components/messageWakeupService.js
659
660 %if %{without xulrunner}
661 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
662 %endif
663
664 %if %{without xulrunner}
665 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
666 %endif
667
668 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
669
670 %attr(755,root,root) %{_libdir}/%{name}/iceape
671 %dir %{_libdir}/%{name}/plugins
672 %if %{without xulrunner}
673 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
674 %attr(755,root,root) %{_libdir}/%{name}/iceape-bin
675 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
676 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
677 %endif
678
679 # symlinks
680 %{_libdir}/%{name}/chrome
681 %{_libdir}/%{name}/defaults
682 %{_libdir}/%{name}/modules
683 %{_libdir}/%{name}/searchplugins
684 %if %{with xulrunner}
685 %{_libdir}/%{name}/xulrunner
686 %else
687 %{_libdir}/%{name}/dictionaries
688 %{_libdir}/%{name}/hyphenation
689 %{_libdir}/%{name}/greprefs.js
690 %{_libdir}/%{name}/res
691 %endif
692
693 %dir %{_datadir}/%{name}
694 %{_datadir}/%{name}/chrome
695 %{_datadir}/%{name}/defaults
696 %{_datadir}/%{name}/modules
697 %if %{with enigmail}
698 %exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
699 %exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
700 %exclude %{_datadir}/%{name}/modules/keyManagement.jsm
701 %exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
702 %exclude %{_datadir}/%{name}/modules/pipeTransport.jsm
703 %exclude %{_datadir}/%{name}/modules/subprocess.jsm
704 %exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
705 %exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
706 %endif
707 %{_datadir}/%{name}/searchplugins
708 %if %{without xulrunner}
709 %{_datadir}/%{name}/greprefs.js
710 %{_datadir}/%{name}/res
711 %endif
712
713 %dir %{_datadir}/%{name}/extensions
714 %dir %{_libdir}/%{name}/extensions
715 # the signature of the default theme
716 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
717 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
718
719 # files created by iceape -register
720 %ghost %{_libdir}/%{name}/components/compreg.dat
721 %ghost %{_libdir}/%{name}/components/xpti.dat
722
723 %{_libdir}/%{name}/components/glautocomp.js
724 %{_libdir}/%{name}/components/jsmimeemitter.js
725 %{_libdir}/%{name}/components/mail.xpt
726 %{_libdir}/%{name}/components/mdn-service.js
727 %{_libdir}/%{name}/components/msgAsyncPrompter.js
728 %{_libdir}/%{name}/components/newsblog.js
729 %{_libdir}/%{name}/components/nsAbAutoCompleteMyDomain.js
730 %{_libdir}/%{name}/components/nsAbAutoCompleteSearch.js
731 %{_libdir}/%{name}/components/nsAbLDAPAttributeMap.js
732 %{_libdir}/%{name}/components/nsLDAPProtocolHandler.js
733 %{_libdir}/%{name}/components/nsMailNewsCommandLineHandler.js
734 %{_libdir}/%{name}/components/nsMsgTraitService.js
735 %{_libdir}/%{name}/components/nsSMTPProtocolHandler.js
736 %{_libdir}/%{name}/components/offlineStartup.js
737 %{_libdir}/%{name}/components/smime-service.js
738
739 %{_libdir}/%{name}/isp
740 %dir %{_datadir}/%{name}/isp
741 %{_datadir}/%{name}/isp/Bogofilter.sfd
742 %{_datadir}/%{name}/isp/DSPAM.sfd
743 %{_datadir}/%{name}/isp/POPFile.sfd
744 %{_datadir}/%{name}/isp/SpamAssassin.sfd
745 %{_datadir}/%{name}/isp/SpamPal.sfd
746 %{_datadir}/%{name}/isp/movemail.rdf
747 %{_datadir}/%{name}/isp/rss.rdf
748
749 %{_iconsdir}/hicolor/*/apps/iceape.png
750 %{_iconsdir}/hicolor/scalable/apps/iceape.svg
751 %{_desktopdir}/%{name}.desktop
752 %{_desktopdir}/%{name}-composer.desktop
753 %{_desktopdir}/%{name}-mail.desktop
754
755 %if %{with lightning}
756 %files addon-lightning
757 %defattr(644,root,root,755)
758 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
759 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
760 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
761 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
762 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
763 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
764 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
765 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
766 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
767 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
768 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
769 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
770 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
771 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
772 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
773 %endif
774
775 %if %{with enigmail}
776 %files addon-enigmail
777 %defattr(644,root,root,755)
778 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
779 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
780 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
781 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
782 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
783 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
784 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
785 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
786 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
787 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
788 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
789 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
790 %endif
791
792 %files chat
793 %defattr(644,root,root,755)
794 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
795 %{_desktopdir}/%{name}-chat.desktop
796
797 %files js-debugger
798 %defattr(644,root,root,755)
799 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
800 %{_desktopdir}/%{name}-venkman.desktop
801
802 %files dom-inspector
803 %defattr(644,root,root,755)
804 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.27001 seconds and 4 git commands to generate.