]> git.pld-linux.org Git - packages/iceape.git/blob - iceape.spec
- enigmail 1.4.2
[packages/iceape.git] / iceape.spec
1 #
2 # Conditional build:
3 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
4 %bcond_without  gnomeui         # disable gnomeui support
5 %bcond_without  gnome           # disable gnomeui (alias)
6 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
7 %bcond_without  lightning       # disable Sunbird/Lightning calendar
8 %bcond_with     xulrunner       # build with system xulrunner
9 %bcond_with     tests           # enable tests (whatever they check)
10 %bcond_without  kerberos        # disable krb5 support
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 %define         enigmail_ver    1.4.2
17 %define         nspr_ver        4.9
18 %define         nss_ver         3.13.3
19 %define         xulrunner_ver   12.0
20
21 %if %{without xulrunner}
22 # The actual sqlite version (see RHBZ#480989):
23 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24 %endif
25
26 Summary:        Iceape - web browser
27 Summary(es.UTF-8):      Navegador de Internet Iceape
28 Summary(pl.UTF-8):      Iceape - przeglądarka WWW
29 Summary(pt_BR.UTF-8):   Navegador Iceape
30 Name:           iceape
31 Version:        2.9.1
32 Release:        0.1
33 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
34 Group:          X11/Applications/Networking
35 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/seamonkey-%{version}.source.tar.bz2
36 # Source0-md5:  8dd18d93a6570c3c9f3873bb177ccc6b
37 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
38 # Source1-md5:  ed608e1cd4cd20b96f7f5afdbf081141
39 Source2:        %{name}-branding.tar.bz2
40 # Source2-md5:  6cbf2f0e62c042946bf351f1e2d1b256
41 Source3:        %{name}-rm_nonfree.sh
42 Source4:        %{name}.desktop
43 Source5:        %{name}-composer.desktop
44 Source6:        %{name}-chat.desktop
45 Source7:        %{name}-mail.desktop
46 Source8:        %{name}-venkman.desktop
47 Source9:        %{name}.sh
48 Patch0:         %{name}-branding.patch
49 Patch1:         %{name}-pld-branding.patch
50 Patch2:         %{name}-agent.patch
51 Patch3:         %{name}-glueload-fix.patch
52 Patch4:         system-mozldap.patch
53 Patch5:         makefile.patch
54 Patch6:         system-cairo.patch
55 URL:            http://www.pld-linux.org/Packages/Iceape
56 BuildRequires:  GConf2-devel >= 1.2.1
57 BuildRequires:  OpenGL-devel
58 BuildRequires:  alsa-lib-devel
59 BuildRequires:  automake
60 BuildRequires:  bzip2-devel
61 BuildRequires:  cairo-devel >= 1.10.2-5
62 BuildRequires:  dbus-glib-devel >= 0.60
63 BuildRequires:  freetype-devel >= 1:2.1.8
64 BuildRequires:  glib2-devel >= 1:2.18
65 BuildRequires:  gtk+2-devel >= 2:2.10
66 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
67 BuildRequires:  hunspell-devel
68 BuildRequires:  libIDL-devel >= 0.8.0
69 BuildRequires:  libdnet-devel
70 BuildRequires:  libevent-devel >= 1.4.7
71 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
72 BuildRequires:  libffi-devel >= 6:3.0.9
73 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
74 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
75 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
76 BuildRequires:  libiw-devel
77 BuildRequires:  libjpeg-devel >= 6b
78 BuildRequires:  libnotify-devel >= 0.4
79 BuildRequires:  libpng(APNG)-devel >= 0.10
80 BuildRequires:  libpng-devel >= 1.4.1
81 # rsvg-convert for iceape/branding
82 BuildRequires:  librsvg
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libvpx-devel >= 1.0.0
85 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
86 BuildRequires:  nss-devel >= 1:%{nss_ver}
87 BuildRequires:  pango-devel >= 1:1.14.0
88 BuildRequires:  perl-base >= 1:5.6
89 BuildRequires:  perl-modules >= 5.004
90 BuildRequires:  pkgconfig
91 BuildRequires:  python >= 1:2.5
92 BuildRequires:  python-modules
93 BuildRequires:  rpm >= 4.4.9-56
94 BuildRequires:  rpmbuild(macros) >= 1.601
95 BuildRequires:  sed >= 4.0
96 BuildRequires:  sqlite3-devel >= 3.7.10
97 BuildRequires:  startup-notification-devel >= 0.8
98 BuildRequires:  xorg-lib-libXScrnSaver-devel
99 BuildRequires:  xorg-lib-libXext-devel
100 BuildRequires:  xorg-lib-libXinerama-devel
101 BuildRequires:  xorg-lib-libXt-devel
102 %if %{with xulrunner}
103 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
104 %endif
105 BuildRequires:  yasm
106 BuildRequires:  zip
107 BuildRequires:  zlib-devel >= 1.2.3
108 Requires(post): mktemp >= 1.5-18
109 Requires:       desktop-file-utils
110 Requires:       hicolor-icon-theme
111 %if %{with xulrunner}
112 %requires_eq_to xulrunner xulrunner-devel
113 %else
114 Requires:       browser-plugins >= 2.0
115 Requires:       cairo >= 1.10.2-5
116 Requires:       dbus-glib >= 0.60
117 Requires:       gtk+2 >= 2:2.18
118 Requires:       libpng >= 1.4.1
119 Requires:       libpng(APNG) >= 0.10
120 Requires:       myspell-common
121 Requires:       nspr >= 1:%{nspr_ver}
122 Requires:       nss >= 1:%{nss_ver}
123 Requires:       pango >= 1:1.14.0
124 Requires:       sqlite3 >= %{sqlite_build_version}
125 Requires:       startup-notification >= 0.8
126 %endif
127 Provides:       iceape-embedded = %{epoch}:%{version}-%{release}
128 Provides:       wwwbrowser
129 Obsoletes:      light
130 Obsoletes:      mozilla
131 Obsoletes:      mozilla-gnomevfs
132 Obsoletes:      seamonkey
133 Obsoletes:      seamonkey-calendar
134 Obsoletes:      seamonkey-libs
135 Obsoletes:      seamonkey-mailnews
136 Obsoletes:      seamonkey-gnomevfs
137 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
138
139 %define         topdir          %{_builddir}/%{name}-%{version}
140 %define         objdir          %{topdir}/obj-%{_target_cpu}
141
142 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
143
144 # don't satisfy other packages
145 %define         _noautoprovfiles        %{_libdir}/%{name}
146 # and as we don't provide them, don't require either
147 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
148 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
149
150 %description
151 Iceape is an open-source web browser, designed for standards
152 compliance, performance and portability.
153
154 %description -l es.UTF-8
155 Iceape es un navegador de Internet que se basa en una versión inicial
156 de Netscape Communicator.
157
158 %description -l pl.UTF-8
159 Iceape jest potężną graficzną przeglądarką WWW, która jest następcą
160 Mozilli, która następnie była następczynią Netscape Communikatora.
161
162 %description -l pt_BR.UTF-8
163 O Iceape é um web browser baseado numa versão inicial do Netscape
164 Communicator.
165
166 %description -l ru.UTF-8
167 Iceape - полнофункциональный web-browser с открытыми исходными
168 текстами, разработанный для максимального соотвествия стандартам,
169 максмимальной переносимости и скорости работы
170
171 %package addon-lightning
172 Summary:        An integrated calendar for Iceape
173 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Iceape
174 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
175 Group:          Applications/Networking
176 Requires:       %{name} = %{version}-%{release}
177 Obsoletes:      seamonkey-addon-lightning
178
179 %description addon-lightning
180 Lightning is an calendar extension to Icedove email client.
181
182 %description addon-lightning -l pl.UTF-8
183 Lightning to rozszerzenie do klienta poczty Icedove dodające
184 funkcjonalność kalendarza.
185
186 %package addon-enigmail
187 Summary:        Enigmail %{enigmail_ver} - PGP/GPG support for Iceape
188 Summary(pl.UTF-8):      Enigmail %{enigmail_ver} - obsługa PGP/GPG dla Iceape
189 Group:          X11/Applications/Networking
190 Requires:       %{name} = %{epoch}:%{version}-%{release}
191 Requires:       gnupg >= 1.4.2.2
192 Obsoletes:      seamonkey-addon-enigmail
193
194 %description addon-enigmail
195 Enigmail is an extension to the mail client of Iceape / SeaMonkey /
196 Mozilla / Netscape and Mozilla Thunderbird which allows users to
197 access the authentication and encryption features provided by GnuPG.
198
199 %description addon-enigmail -l pl.UTF-8
200 Enigmail jest rozszerzeniem dla klienta pocztowego Iceape, SeaMonkey,
201 Mozilla i Mozilla Thunderdbird pozwalającym użytkownikowi korzystać z
202 funkcjonalności GnuPG.
203
204 %package chat
205 Summary:        Iceape Chat - integrated IRC client
206 Summary(pl.UTF-8):      Iceape Chat - zintegrowany klient IRC-a
207 Group:          X11/Applications/Networking
208 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
209 Requires:       %{name} = %{epoch}:%{version}-%{release}
210 Obsoletes:      mozilla-chat
211 Obsoletes:      seamonkey-chat
212
213 %description chat
214 Iceape Chat - IRC client that is integrated with the Iceape web
215 browser.
216
217 %description chat -l pl.UTF-8
218 Iceape - klient IRC-a zintegrowany z przeglądarką Iceape.
219
220 %package js-debugger
221 Summary:        JavaScript debugger for use with Iceape
222 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z Iceape
223 Group:          X11/Applications/Networking
224 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
225 Requires:       %{name} = %{epoch}:%{version}-%{release}
226 Obsoletes:      mozilla-js-debugger
227 Obsoletes:      seamonkey-js-debugger
228
229 %description js-debugger
230 JavaScript debugger for use with Iceape.
231
232 %description js-debugger -l pl.UTF-8
233 Odpluskwiacz JavaScriptu do używania z Iceape.
234
235 %package dom-inspector
236 Summary:        A tool for inspecting the DOM of pages in Iceape
237 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w Iceape
238 Group:          X11/Applications/Networking
239 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
240 Requires:       %{name} = %{epoch}:%{version}-%{release}
241 Obsoletes:      mozilla-dom-inspector
242 Obsoletes:      seamonkey-dom-inspector
243
244 %description dom-inspector
245 This is a tool that allows you to inspect the DOM for web pages in
246 Iceape. This is of great use to people who are doing Iceape chrome
247 development or web page development.
248
249 %description dom-inspector -l pl.UTF-8
250 To narzędzie pozwala na oglądanie DOM dla stron WWW w Iceape. Jest
251 bardzo przydatne dla ludzi rozwijających chrome w Iceape lub
252 tworzących strony WWW.
253
254 %prep
255 %setup -qc
256 cd comm-release
257 tar -C mailnews/extensions -zxf %{SOURCE1}
258 tar -jxf %{SOURCE2}
259 %patch0 -p1
260 %patch1 -p1
261 %patch2 -p1
262 %patch3 -p1
263 %patch4 -p1
264 %patch5 -p1
265 %patch6 -p1
266
267 %build
268 cd comm-release
269 %if %{with xulrunner}
270 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
271         echo >&2
272         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
273         echo >&2
274         exit 1
275 fi
276 %endif
277
278 cp -f %{_datadir}/automake/config.* build/autoconf
279 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
280 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
281 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
282
283 cat << EOF > .mozconfig
284 mk_add_options MOZ_OBJDIR=%{objdir}
285
286 export CFLAGS="%{rpmcflags}"
287 export CXXFLAGS="%{rpmcflags}"
288
289 %if %{with crashreporter}
290 export MOZ_DEBUG_SYMBOLS=1
291 %endif
292
293 # Options for 'configure' (same as command-line options).
294 ac_add_options --prefix=%{_prefix}
295 ac_add_options --exec-prefix=%{_exec_prefix}
296 ac_add_options --bindir=%{_bindir}
297 ac_add_options --sbindir=%{_sbindir}
298 ac_add_options --sysconfdir=%{_sysconfdir}
299 ac_add_options --datadir=%{_datadir}
300 ac_add_options --includedir=%{_includedir}
301 ac_add_options --libdir=%{_libdir}
302 ac_add_options --libexecdir=%{_libexecdir}
303 ac_add_options --localstatedir=%{_localstatedir}
304 ac_add_options --sharedstatedir=%{_sharedstatedir}
305 ac_add_options --mandir=%{_mandir}
306 ac_add_options --infodir=%{_infodir}
307 ac_add_options --disable-elf-hack
308 %if %{?debug:1}0
309 ac_add_options --disable-optimize
310 ac_add_options --enable-debug
311 ac_add_options --enable-debug-modules
312 ac_add_options --enable-debugger-info-modules
313 ac_add_options --enable-crash-on-assert
314 %else
315 ac_add_options --disable-debug
316 ac_add_options --disable-debug-modules
317 ac_add_options --disable-logging
318 ac_add_options --enable-optimize="%{rpmcflags} -Os"
319 %endif
320 ac_add_options --disable-strip
321 ac_add_options --disable-strip-libs
322 %if %{with tests}
323 ac_add_options --enable-tests
324 %else
325 ac_add_options --disable-tests
326 %endif
327 ac_add_options --enable-gio
328 %if %{with gnomeui}
329 ac_add_options --enable-gnomeui
330 %else
331 ac_add_options --disable-gnomeui
332 %endif
333 ac_add_options --disable-gnomevfs
334 %if %{with ldap}
335 ac_add_options --enable-ldap
336 ac_add_options --with-system-ldap
337 %else
338 ac_add_options --disable-ldap
339 %endif
340 %if %{with crashreporter}
341 ac_add_options --enable-crashreporter
342 %else
343 ac_add_options --disable-crashreporter
344 %endif
345 ac_add_options --disable-xterm-updates
346 ac_add_options --enable-postscript
347 %if %{with lightning}
348 ac_add_options --enable-calendar
349 %else
350 ac_add_options --disable-calendar
351 %endif
352 ac_add_options --disable-installer
353 ac_add_options --disable-javaxpcom
354 ac_add_options --disable-updater
355 ac_add_options --enable-crypto
356 ac_add_options --enable-libxul
357 ac_add_options --enable-pango
358 ac_add_options --enable-shared-js
359 ac_add_options --enable-startup-notification
360 ac_add_options --enable-system-cairo
361 ac_add_options --enable-system-hunspell
362 ac_add_options --enable-system-sqlite
363 ac_add_options --enable-application=suite
364 ac_add_options --with-distribution-id=org.pld-linux
365 ac_add_options --with-branding=iceape/branding
366 %if %{with xulrunner}
367 ac_add_options --with-system-libxul
368 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
369 %endif
370 ac_add_options --with-pthreads
371 ac_add_options --with-system-bz2
372 ac_add_options --with-system-ffi
373 ac_add_options --with-system-jpeg
374 ac_add_options --with-system-libevent
375 ac_add_options --with-system-libvpx
376 ac_add_options --with-system-nspr
377 ac_add_options --with-system-nss
378 ac_add_options --with-system-png
379 ac_add_options --with-system-zlib
380 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
381 EOF
382
383 %{__make} -j1 -f client.mk build \
384         STRIP="/bin/true" \
385         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
386         installdir=%{_libdir}/%{name} \
387         CC="%{__cc}" \
388         CXX="%{__cxx}"
389
390 %if %{with crashreporter}
391 # create debuginfo for crash-stats.mozilla.com
392 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
393 %endif
394
395 %if %{with enigmail}
396 cd mailnews/extensions/enigmail
397 ./makemake -r -o %{objdir}
398 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
399         STRIP="/bin/true" \
400         CC="%{__cc}" \
401         CXX="%{__cxx}"
402 %endif
403
404 %install
405 rm -rf $RPM_BUILD_ROOT
406 cd comm-release
407 install -d \
408         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
409         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
410         $RPM_BUILD_ROOT%{_datadir}/%{name} \
411         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
412
413 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
414
415 cd %{objdir}
416 %{__make} -C suite/installer stage-package \
417         DESTDIR=$RPM_BUILD_ROOT \
418         installdir=%{_libdir}/%{name} \
419         PKG_SKIP_STRIP=1
420
421 %{__make} -C iceape/branding install \
422         DESTDIR=$RPM_BUILD_ROOT
423
424 cp -a mozilla/dist/iceape/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
425
426 %if %{with xulrunner}
427 # >= 5.0 seems to require this
428 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
429 %endif
430
431 # Enable crash reporter for Thunderbird application
432 %if %{with crashreporter}
433 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
434
435 # Add debuginfo for crash-stats.mozilla.com
436 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
437 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
438 %endif
439
440 # copy manually lightning files, somewhy they are not installed by make
441 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
442         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
443         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
444                 
445 # move arch independant ones to datadir
446 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
447 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
448 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
449 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
450 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
451 %if %{without xulrunner}
452 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
453 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
454 %endif
455
456 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
457 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
458 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
459 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
460 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
461 %if %{without xulrunner}
462 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
463 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
464 %endif
465
466 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
467         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
468
469 # dir for arch independant extensions besides arch dependant extensions
470 # see mozilla/xpcom/build/nsXULAppAPI.h
471 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
472 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
473  
474 %if %{without xulrunner}
475 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
476 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
477 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
478 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
479 %endif
480
481 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE9} > $RPM_BUILD_ROOT%{_bindir}/iceape
482 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/iceape
483
484 install %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
485         $RPM_BUILD_ROOT%{_desktopdir}
486
487 # files created by iceape -register
488 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
489 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
490
491 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
492 #!/bin/sh
493 umask 022
494 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
495
496 # it attempts to touch files in $HOME/.mozilla
497 # beware if you run this with sudo!!!
498 export HOME=$(mktemp -d)
499 # also TMPDIR could be pointing to sudo user's homedir
500 unset TMPDIR TMP || :
501
502 %{_libdir}/%{name}/iceape -register
503
504 rm -rf $HOME
505 EOF
506 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
507
508 %if %{with enigmail}
509 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
510 install -d $ext_dir/{chrome,components,defaults/preferences}
511 cd mozilla/dist/bin
512 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
513 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
514 cp -rfLp components/enig* $ext_dir/components
515 cp -rfLp components/libenigmime.so $ext_dir/components
516 cp -rfLp components/libipc.so $ext_dir/components
517 cp -rfLp components/ipc.xpt $ext_dir/components
518 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
519 cd -
520 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/install.rdf $ext_dir
521 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
522 %endif
523
524 # never package these. always remove
525 # nss
526 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
527 # nspr
528 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
529 # mozldap
530 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
531 # testpilot quiz
532 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
533
534 %clean
535 rm -rf $RPM_BUILD_ROOT
536
537 %post
538 %{_libdir}/%{name}/register || :
539 %update_browser_plugins
540 %update_icon_cache hicolor
541 %update_desktop_database
542
543 %postun
544 if [ "$1" = 0 ]; then
545         %update_browser_plugins
546         %update_icon_cache hicolor
547 fi
548
549 %files
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_bindir}/iceape
552
553 # browser plugins v2
554 %{_browserpluginsconfdir}/browsers.d/%{name}.*
555 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
556
557 %dir %{_libdir}/%{name}
558 %if %{without xulrunner}
559 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
560 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
561 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
562 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
563 %endif
564
565 %{_libdir}/%{name}/blocklist.xml
566 %attr(755,root,root) %{_libdir}/%{name}/register
567
568 %if %{with crashreporter}
569 %{_libdir}/%{name}/crashreporter
570 %{_libdir}/%{name}/crashreporter-override.ini
571 %{_libdir}/%{name}/crashreporter.ini
572 %{_libdir}/%{name}/Throbber-small.gif
573 %endif
574
575 # config?
576 %{_libdir}/%{name}/application.ini
577 %{_libdir}/%{name}/chrome.manifest
578
579 %dir %{_libdir}/%{name}/components
580
581 %{_libdir}/%{name}/components/FeedConverter.js
582 %{_libdir}/%{name}/components/FeedWriter.js
583 %{_libdir}/%{name}/components/Weave.js
584 %{_libdir}/%{name}/components/WebContentConverter.js
585 %{_libdir}/%{name}/components/browser.xpt
586 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
587 %{_libdir}/%{name}/components/nsSessionStartup.js
588 %{_libdir}/%{name}/components/nsSessionStore.js
589 %{_libdir}/%{name}/components/nsSidebar.js
590
591 %{_libdir}/%{name}/components/components.manifest
592 %{_libdir}/%{name}/components/interfaces.manifest
593
594 %if %{without xulrunner}
595 %{_libdir}/%{name}/platform.ini
596 %{_libdir}/%{name}/components/ConsoleAPI.js
597 %{_libdir}/%{name}/components/FeedProcessor.js
598 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
599 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
600 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
601 %{_libdir}/%{name}/components/TelemetryPing.js
602 %{_libdir}/%{name}/components/addonManager.js
603 %{_libdir}/%{name}/components/amContentHandler.js
604 %{_libdir}/%{name}/components/amWebInstallListener.js
605 %{_libdir}/%{name}/components/contentAreaDropListener.js
606 %{_libdir}/%{name}/components/contentSecurityPolicy.js
607 %{_libdir}/%{name}/components/crypto-SDR.js
608 %{_libdir}/%{name}/components/jsconsole-clhandler.js
609 %{_libdir}/%{name}/components/nsBadCertHandler.js
610 %{_libdir}/%{name}/components/nsBlocklistService.js
611 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
612 %{_libdir}/%{name}/components/nsContentPrefService.js
613 %{_libdir}/%{name}/components/nsDefaultCLH.js
614 %{_libdir}/%{name}/components/nsFilePicker.js
615 %{_libdir}/%{name}/components/nsFormAutoComplete.js
616 %{_libdir}/%{name}/components/nsFormHistory.js
617 %{_libdir}/%{name}/components/nsHandlerService.js
618 %{_libdir}/%{name}/components/nsHelperAppDlg.js
619 %{_libdir}/%{name}/components/nsINIProcessor.js
620 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
621 %{_libdir}/%{name}/components/nsLivemarkService.js
622 %{_libdir}/%{name}/components/nsLoginInfo.js
623 %{_libdir}/%{name}/components/nsLoginManager.js
624 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
625 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
626 %{_libdir}/%{name}/components/nsPlacesExpiration.js
627 %{_libdir}/%{name}/components/nsPrompter.js
628 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
629 %{_libdir}/%{name}/components/nsSearchService.js
630 %{_libdir}/%{name}/components/nsSearchSuggestions.js
631 %{_libdir}/%{name}/components/nsTaggingService.js
632 %{_libdir}/%{name}/components/nsURLFormatter.js
633 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
634 %{_libdir}/%{name}/components/nsWebHandlerApp.js
635 %{_libdir}/%{name}/components/storage-Legacy.js
636 %{_libdir}/%{name}/components/storage-mozStorage.js
637 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
638 %endif
639
640 %{_libdir}/%{name}/components/nsAbout.js
641 %{_libdir}/%{name}/components/nsAboutCertError.js
642 %{_libdir}/%{name}/components/nsAboutData.js
643 %{_libdir}/%{name}/components/nsAboutFeeds.js
644 %{_libdir}/%{name}/components/nsAboutLife.js
645 %{_libdir}/%{name}/components/nsAboutRights.js
646 %{_libdir}/%{name}/components/nsAboutSessionRestore.js
647 %{_libdir}/%{name}/components/nsAboutSyncTabs.js
648 %{_libdir}/%{name}/components/nsComposerCmdLineHandler.js
649 %{_libdir}/%{name}/components/nsSuiteDownloadManagerUI.js
650 %{_libdir}/%{name}/components/nsSuiteGlue.js
651 %{_libdir}/%{name}/components/nsTypeAheadFind.js
652 %{_libdir}/%{name}/components/smileApplication.js
653
654 %if %{without xulrunner}
655 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
656 %endif
657
658 %if %{without xulrunner}
659 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
660 %endif
661
662 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
663
664 %attr(755,root,root) %{_libdir}/%{name}/iceape
665 %dir %{_libdir}/%{name}/plugins
666 %if %{without xulrunner}
667 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
668 %attr(755,root,root) %{_libdir}/%{name}/iceape-bin
669 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
670 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
671 %endif
672
673 # symlinks
674 %{_libdir}/%{name}/chrome
675 %{_libdir}/%{name}/defaults
676 %{_libdir}/%{name}/modules
677 %{_libdir}/%{name}/searchplugins
678 %if %{with xulrunner}
679 %{_libdir}/%{name}/xulrunner
680 %else
681 %{_libdir}/%{name}/dictionaries
682 %{_libdir}/%{name}/hyphenation
683 %{_libdir}/%{name}/greprefs.js
684 %{_libdir}/%{name}/res
685 %endif
686
687 %dir %{_datadir}/%{name}
688 %{_datadir}/%{name}/chrome
689 %{_datadir}/%{name}/defaults
690 %{_datadir}/%{name}/modules
691 %{_datadir}/%{name}/searchplugins
692 %if %{without xulrunner}
693 %{_datadir}/%{name}/greprefs.js
694 %{_datadir}/%{name}/res
695 %endif
696
697 %dir %{_datadir}/%{name}/extensions
698 %dir %{_libdir}/%{name}/extensions
699 # the signature of the default theme
700 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
701 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
702
703 # files created by iceape -register
704 %ghost %{_libdir}/%{name}/components/compreg.dat
705 %ghost %{_libdir}/%{name}/components/xpti.dat
706
707 %{_libdir}/%{name}/components/glautocomp.js
708 %{_libdir}/%{name}/components/jsmimeemitter.js
709 %{_libdir}/%{name}/components/mail.xpt
710 %{_libdir}/%{name}/components/mdn-service.js
711 %{_libdir}/%{name}/components/msgAsyncPrompter.js
712 %{_libdir}/%{name}/components/newsblog.js
713 %{_libdir}/%{name}/components/nsAbAutoCompleteMyDomain.js
714 %{_libdir}/%{name}/components/nsAbAutoCompleteSearch.js
715 %{_libdir}/%{name}/components/nsAbLDAPAttributeMap.js
716 %{_libdir}/%{name}/components/nsLDAPProtocolHandler.js
717 %{_libdir}/%{name}/components/nsMailNewsCommandLineHandler.js
718 %{_libdir}/%{name}/components/nsMsgTraitService.js
719 %{_libdir}/%{name}/components/nsSMTPProtocolHandler.js
720 %{_libdir}/%{name}/components/offlineStartup.js
721 %{_libdir}/%{name}/components/smime-service.js
722
723 %{_libdir}/%{name}/isp
724 %dir %{_datadir}/%{name}/isp
725 %{_datadir}/%{name}/isp/Bogofilter.sfd
726 %{_datadir}/%{name}/isp/DSPAM.sfd
727 %{_datadir}/%{name}/isp/POPFile.sfd
728 %{_datadir}/%{name}/isp/SpamAssassin.sfd
729 %{_datadir}/%{name}/isp/SpamPal.sfd
730 %{_datadir}/%{name}/isp/movemail.rdf
731 %{_datadir}/%{name}/isp/rss.rdf
732
733 %{_iconsdir}/hicolor/*/apps/iceape.png
734 %{_iconsdir}/hicolor/scalable/apps/iceape.svg
735 %{_desktopdir}/%{name}.desktop
736 %{_desktopdir}/%{name}-composer.desktop
737 %{_desktopdir}/%{name}-mail.desktop
738
739 %if %{with lightning}
740 %files addon-lightning
741 %defattr(644,root,root,755)
742 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
743 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
744 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
745 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
746 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
747 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
748 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
749 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
750 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
751 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
752 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
753 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
754 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
755 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
756 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
757 %endif
758
759 %if %{with enigmail}
760 %files addon-enigmail
761 %defattr(644,root,root,755)
762 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
763 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
764 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
765 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
766 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
767 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
768 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
769 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
770 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
771 %endif
772
773 %files chat
774 %defattr(644,root,root,755)
775 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
776 %{_desktopdir}/%{name}-chat.desktop
777
778 %files js-debugger
779 %defattr(644,root,root,755)
780 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
781 %{_desktopdir}/%{name}-venkman.desktop
782
783 %files dom-inspector
784 %defattr(644,root,root,755)
785 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.170541 seconds and 4 git commands to generate.