]> git.pld-linux.org Git - packages/iceape.git/blob - iceape.spec
- updated to 2.26.1
[packages/iceape.git] / iceape.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk3            # GTK+ 3.x instead of 2.x
4 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
5 %bcond_without  lightning       # disable Sunbird/Lightning calendar
6 %bcond_without  kerberos        # disable krb5 support
7 %bcond_with     xulrunner       # build with system xulrunner
8 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
9 %bcond_with     tests           # enable tests (whatever they check)
10
11 %define         nspr_ver        4.10.3
12 %define         nss_ver         3.16
13 %define         xulrunner_ver   29.0
14
15 %if %{without xulrunner}
16 # The actual sqlite version (see RHBZ#480989):
17 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
18 %endif
19
20 Summary:        Iceape - web browser
21 Summary(es.UTF-8):      Navegador de Internet Iceape
22 Summary(pl.UTF-8):      Iceape - przeglądarka WWW
23 Summary(pt_BR.UTF-8):   Navegador Iceape
24 Name:           iceape
25 Version:        2.26.1
26 Release:        1
27 License:        MPL v2.0
28 Group:          X11/Applications/Networking
29 Source0:        http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/seamonkey-%{version}.source.tar.bz2
30 # Source0-md5:  4bfa46b370b4d211eef56b90277a9517
31 Source2:        %{name}-branding.tar.bz2
32 # Source2-md5:  3feee544ef515f1dbf19b14479916784
33 Source3:        %{name}-rm_nonfree.sh
34 Source4:        %{name}.desktop
35 Source5:        %{name}-composer.desktop
36 Source6:        %{name}-chat.desktop
37 Source7:        %{name}-mail.desktop
38 Source8:        %{name}-venkman.desktop
39 Source9:        %{name}.sh
40 Patch0:         %{name}-branding.patch
41 Patch1:         %{name}-pld-branding.patch
42 Patch2:         %{name}-agent.patch
43 Patch3:         enable-addons.patch
44 Patch4:         system-mozldap.patch
45 Patch5:         makefile.patch
46 Patch6:         %{name}-pixman.patch
47 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
48 Patch7:         system-virtualenv.patch
49 Patch9:         %{name}-system-xulrunner.patch
50 URL:            http://www.pld-linux.org/Packages/Iceape
51 BuildRequires:  GConf2-devel >= 1.2.1
52 BuildRequires:  OpenGL-devel
53 BuildRequires:  alsa-lib-devel
54 BuildRequires:  automake
55 BuildRequires:  bzip2-devel
56 BuildRequires:  cairo-devel >= 1.10.2-5
57 BuildRequires:  dbus-glib-devel >= 0.60
58 BuildRequires:  freetype-devel >= 1:2.1.8
59 BuildRequires:  glib2-devel >= 1:2.20
60 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.18}
61 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
62 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
63 BuildRequires:  hunspell-devel
64 BuildRequires:  libIDL-devel >= 0.8.0
65 BuildRequires:  libdnet-devel
66 BuildRequires:  libevent-devel >= 1.4.7
67 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
68 BuildRequires:  libffi-devel >= 6:3.0.9
69 BuildRequires:  libicu-devel >= 50.1
70 # requires libjpeg-turbo implementing at least libjpeg 6b API
71 BuildRequires:  libjpeg-devel >= 6b
72 BuildRequires:  libjpeg-turbo-devel
73 BuildRequires:  libnotify-devel >= 0.4
74 BuildRequires:  libpng(APNG)-devel >= 0.10
75 BuildRequires:  libpng-devel >= 2:1.6.7
76 # rsvg-convert for iceape/branding
77 BuildRequires:  librsvg
78 BuildRequires:  libstdc++-devel
79 BuildRequires:  libvpx-devel >= 1.3.0
80 BuildRequires:  mozldap-devel
81 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
82 BuildRequires:  nss-devel >= 1:%{nss_ver}
83 BuildRequires:  pango-devel >= 1:1.14.0
84 BuildRequires:  perl-base >= 1:5.6
85 BuildRequires:  perl-modules >= 5.004
86 BuildRequires:  pkgconfig
87 BuildRequires:  python >= 1:2.5
88 BuildRequires:  python-modules
89 BuildRequires:  python-virtualenv
90 BuildRequires:  rpm >= 4.4.9-56
91 BuildRequires:  rpmbuild(macros) >= 1.601
92 BuildRequires:  sed >= 4.0
93 BuildRequires:  sqlite3-devel >= 3.8.2
94 BuildRequires:  startup-notification-devel >= 0.8
95 BuildRequires:  xorg-lib-libX11-devel
96 BuildRequires:  xorg-lib-libXScrnSaver-devel
97 BuildRequires:  xorg-lib-libXext-devel
98 BuildRequires:  xorg-lib-libXinerama-devel
99 BuildRequires:  xorg-lib-libXt-devel
100 %if %{with xulrunner}
101 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
102 BuildRequires:  xulrunner-devel < 2:30
103 %endif
104 BuildRequires:  yasm
105 BuildRequires:  zip
106 BuildRequires:  zlib-devel >= 1.2.3
107 Requires(post): mktemp >= 1.5-18
108 Requires:       desktop-file-utils
109 Requires:       hicolor-icon-theme
110 %if %{with xulrunner}
111 %requires_eq_to xulrunner xulrunner-devel
112 %else
113 Requires:       browser-plugins >= 2.0
114 Requires:       cairo >= 1.10.2-5
115 Requires:       dbus-glib >= 0.60
116 Requires:       glib2 >= 1:2.20
117 %{!?with_gtk3:Requires: gtk+2 >= 2:2.18}
118 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
119 Requires:       libjpeg-turbo
120 Requires:       libpng >= 2:1.6.7
121 Requires:       libpng(APNG) >= 0.10
122 Requires:       libvpx >= 1.3.0
123 Requires:       myspell-common
124 Requires:       nspr >= 1:%{nspr_ver}
125 Requires:       nss >= 1:%{nss_ver}
126 Requires:       pango >= 1:1.14.0
127 Requires:       sqlite3 >= %{sqlite_build_version}
128 Requires:       startup-notification >= 0.8
129 %endif
130 Provides:       iceape-embedded = %{version}-%{release}
131 Provides:       wwwbrowser
132 Obsoletes:      iceape-mailnews
133 Obsoletes:      iceape-gnomevfs
134 Obsoletes:      light
135 Obsoletes:      mozilla
136 Obsoletes:      mozilla-gnomevfs
137 Obsoletes:      seamonkey
138 Obsoletes:      seamonkey-calendar
139 Obsoletes:      seamonkey-libs
140 Obsoletes:      seamonkey-mailnews
141 Obsoletes:      seamonkey-gnomevfs
142 Conflicts:      iceape-lang-resources < %{version}
143 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
144
145 %define         topdir          %{_builddir}/%{name}-%{version}
146 %define         objdir          %{topdir}/obj-%{_target_cpu}
147
148 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
149
150 # don't satisfy other packages
151 %define         _noautoprovfiles        %{_libdir}/%{name}
152 # and as we don't provide them, don't require either
153 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
154 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
155
156 %description
157 Iceape is an open-source web browser, designed for standards
158 compliance, performance and portability.
159
160 %description -l es.UTF-8
161 Iceape es un navegador de Internet que se basa en una versión inicial
162 de Netscape Communicator.
163
164 %description -l pl.UTF-8
165 Iceape jest potężną graficzną przeglądarką WWW, która jest następcą
166 Mozilli, która następnie była następczynią Netscape Communikatora.
167
168 %description -l pt_BR.UTF-8
169 O Iceape é um web browser baseado numa versão inicial do Netscape
170 Communicator.
171
172 %description -l ru.UTF-8
173 Iceape - полнофункциональный web-browser с открытыми исходными
174 текстами, разработанный для максимального соотвествия стандартам,
175 максмимальной переносимости и скорости работы
176
177 %package addon-lightning
178 Summary:        An integrated calendar for Iceape
179 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Iceape
180 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
181 Group:          Applications/Networking
182 Requires:       %{name} = %{version}-%{release}
183 Obsoletes:      seamonkey-addon-lightning
184
185 %description addon-lightning
186 Lightning is an calendar extension to Icedove email client.
187
188 %description addon-lightning -l pl.UTF-8
189 Lightning to rozszerzenie do klienta poczty Icedove dodające
190 funkcjonalność kalendarza.
191
192 %package chat
193 Summary:        Iceape Chat - integrated IRC client
194 Summary(pl.UTF-8):      Iceape Chat - zintegrowany klient IRC-a
195 Group:          X11/Applications/Networking
196 Requires(post,postun):  %{name} = %{version}-%{release}
197 Requires:       %{name} = %{version}-%{release}
198 Obsoletes:      mozilla-chat
199 Obsoletes:      seamonkey-chat
200
201 %description chat
202 Iceape Chat - IRC client that is integrated with the Iceape web
203 browser.
204
205 %description chat -l pl.UTF-8
206 Iceape - klient IRC-a zintegrowany z przeglądarką Iceape.
207
208 %package js-debugger
209 Summary:        JavaScript debugger for use with Iceape
210 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z Iceape
211 Group:          X11/Applications/Networking
212 Requires(post,postun):  %{name} = %{version}-%{release}
213 Requires:       %{name} = %{version}-%{release}
214 Obsoletes:      mozilla-js-debugger
215 Obsoletes:      seamonkey-js-debugger
216
217 %description js-debugger
218 JavaScript debugger for use with Iceape.
219
220 %description js-debugger -l pl.UTF-8
221 Odpluskwiacz JavaScriptu do używania z Iceape.
222
223 %package dom-inspector
224 Summary:        A tool for inspecting the DOM of pages in Iceape
225 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w Iceape
226 Group:          X11/Applications/Networking
227 Requires(post,postun):  %{name} = %{version}-%{release}
228 Requires:       %{name} = %{version}-%{release}
229 Obsoletes:      mozilla-dom-inspector
230 Obsoletes:      seamonkey-dom-inspector
231
232 %description dom-inspector
233 This is a tool that allows you to inspect the DOM for web pages in
234 Iceape. This is of great use to people who are doing Iceape chrome
235 development or web page development.
236
237 %description dom-inspector -l pl.UTF-8
238 To narzędzie pozwala na oglądanie DOM dla stron WWW w Iceape. Jest
239 bardzo przydatne dla ludzi rozwijających chrome w Iceape lub
240 tworzących strony WWW.
241
242 %prep
243 %setup -qc
244 cd comm-release
245 tar -jxf %{SOURCE2}
246 %patch0 -p1
247 %patch1 -p1
248 %patch2 -p1
249 %patch3 -p2
250 %patch4 -p1
251 %patch5 -p1
252 %patch6 -p1
253 %patch7 -p1
254 %patch9 -p2
255
256 %build
257 cd comm-release
258 %if %{with xulrunner}
259 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
260         echo >&2
261         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
262         echo >&2
263         exit 1
264 fi
265 %endif
266
267 cp -f %{_datadir}/automake/config.* build/autoconf
268 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
269 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
270 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
271
272 cat << EOF > .mozconfig
273 mk_add_options MOZ_OBJDIR=%{objdir}
274
275 export CFLAGS="%{rpmcflags}"
276 export CXXFLAGS="%{rpmcflags}"
277
278 %if %{with crashreporter}
279 export MOZ_DEBUG_SYMBOLS=1
280 %endif
281
282 # Options for 'configure' (same as command-line options).
283 ac_add_options --prefix=%{_prefix}
284 ac_add_options --exec-prefix=%{_exec_prefix}
285 ac_add_options --bindir=%{_bindir}
286 ac_add_options --sbindir=%{_sbindir}
287 ac_add_options --sysconfdir=%{_sysconfdir}
288 ac_add_options --datadir=%{_datadir}
289 ac_add_options --includedir=%{_includedir}
290 ac_add_options --libdir=%{_libdir}
291 ac_add_options --libexecdir=%{_libexecdir}
292 ac_add_options --localstatedir=%{_localstatedir}
293 ac_add_options --sharedstatedir=%{_sharedstatedir}
294 ac_add_options --mandir=%{_mandir}
295 ac_add_options --infodir=%{_infodir}
296 %if %{?debug:1}0
297 ac_add_options --disable-optimize
298 ac_add_options --enable-debug
299 ac_add_options --enable-debug-modules
300 ac_add_options --enable-debugger-info-modules
301 ac_add_options --enable-crash-on-assert
302 %else
303 ac_add_options --disable-debug
304 ac_add_options --disable-debug-modules
305 ac_add_options --disable-logging
306 ac_add_options --enable-optimize="%{rpmcflags} -Os"
307 %endif
308 ac_add_options --disable-strip
309 ac_add_options --disable-strip-libs
310 %if %{with tests}
311 ac_add_options --enable-tests
312 %else
313 ac_add_options --disable-tests
314 %endif
315 %if %{with lightning}
316 ac_add_options --enable-calendar
317 %else
318 ac_add_options --disable-calendar
319 %endif
320 %if %{with crashreporter}
321 ac_add_options --enable-crashreporter
322 %else
323 ac_add_options --disable-crashreporter
324 %endif
325 ac_add_options --disable-elf-dynstr-gc
326 ac_add_options --disable-gnomeui
327 ac_add_options --disable-gnomevfs
328 ac_add_options --disable-installer
329 ac_add_options --disable-javaxpcom
330 ac_add_options --disable-updater
331 ac_add_options --disable-xterm-updates
332 ac_add_options --enable-application=suite
333 ac_add_options --enable-crypto
334 ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
335 ac_add_options --enable-gio
336 %if %{with ldap}
337 ac_add_options --enable-ldap
338 ac_add_options --with-system-ldap
339 %else
340 ac_add_options --disable-ldap
341 %endif
342 ac_add_options --enable-libxul
343 ac_add_options --enable-pango
344 ac_add_options --enable-postscript
345 ac_add_options --enable-shared-js
346 ac_add_options --enable-startup-notification
347 ac_add_options --enable-system-cairo
348 ac_add_options --enable-system-hunspell
349 ac_add_options --enable-system-sqlite
350 ac_add_options --with-branding=iceape/branding
351 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
352 ac_add_options --with-distribution-id=org.pld-linux
353 %if %{with xulrunner}
354 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
355 ac_add_options --with-system-libxul
356 %endif
357 ac_add_options --with-pthreads
358 ac_add_options --with-system-bz2
359 ac_add_options --with-system-ffi
360 ac_add_options --with-system-jpeg
361 ac_add_options --with-system-libevent
362 ac_add_options --with-system-libvpx
363 ac_add_options --with-system-nspr
364 ac_add_options --with-system-nss
365 ac_add_options --with-system-png
366 ac_add_options --with-system-zlib
367 EOF
368
369 %{__make} -j1 -f client.mk build \
370         STRIP="/bin/true" \
371         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
372         installdir=%{_libdir}/%{name} \
373         XLIBS="-lX11 -lXt" \
374         CC="%{__cc}" \
375         CXX="%{__cxx}"
376
377 %if %{with crashreporter}
378 # create debuginfo for crash-stats.mozilla.com
379 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
380 %endif
381
382 %install
383 rm -rf $RPM_BUILD_ROOT
384 cd comm-release
385 install -d \
386         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
387         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
388         $RPM_BUILD_ROOT%{_datadir}/%{name} \
389         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
390
391 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
392
393 cd %{objdir}
394 cwd=`pwd`
395 %{__make} -C suite/installer stage-package \
396         LD_LIBRARY_PATH=$cwd/mozilla/dist/lib \
397         DESTDIR=$RPM_BUILD_ROOT \
398         installdir=%{_libdir}/%{name} \
399         PKG_SKIP_STRIP=1
400
401 %{__make} -C iceape/branding install \
402         DESTDIR=$RPM_BUILD_ROOT
403
404 cp -a mozilla/dist/iceape/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
405
406 %if %{with xulrunner}
407 # >= 5.0 seems to require this
408 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
409 %endif
410
411 # Enable crash reporter for Thunderbird application
412 %if %{with crashreporter}
413 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
414
415 # Add debuginfo for crash-stats.mozilla.com
416 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
417 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
418 %endif
419
420 # copy manually lightning files, somewhy they are not installed by make
421 cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
422         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
423
424 # move arch independant ones to datadir
425 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
426 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
427 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
428
429 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
430 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
431 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
432
433 %if %{without xulrunner}
434 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
435 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
436 %endif
437
438 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
439         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
440
441 # dir for arch independant extensions besides arch dependant extensions
442 # see mozilla/xpcom/build/nsXULAppAPI.h
443 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
444 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
445  
446 %if %{without xulrunner}
447 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
448 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
449 %endif
450
451 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
452          -e "s|%MOZ_APP_DISPLAYNAME%|Iceape|" \
453         %{topdir}/comm-release/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/iceape
454
455 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE9} > $RPM_BUILD_ROOT%{_bindir}/iceape
456 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/iceape
457
458 install %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
459         $RPM_BUILD_ROOT%{_desktopdir}
460
461 # files created by iceape -register
462 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
463 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
464
465 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
466 #!/bin/sh
467 umask 022
468 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
469
470 # it attempts to touch files in $HOME/.mozilla
471 # beware if you run this with sudo!!!
472 export HOME=$(mktemp -d)
473 # also TMPDIR could be pointing to sudo user's homedir
474 unset TMPDIR TMP || :
475
476 %{_libdir}/%{name}/iceape -register
477
478 rm -rf $HOME
479 EOF
480 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
481
482 %if %{without xulrunner}
483 # never package these. always remove
484 # mozldap
485 %{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
486 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
487 %endif
488
489 %clean
490 rm -rf $RPM_BUILD_ROOT
491
492 %post
493 %{_libdir}/%{name}/register || :
494 %update_browser_plugins
495 %update_icon_cache hicolor
496 %update_desktop_database
497
498 %postun
499 if [ "$1" = 0 ]; then
500         %update_browser_plugins
501         %update_icon_cache hicolor
502 fi
503
504 %files
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_bindir}/iceape
507
508 # browser plugins v2
509 %{_browserpluginsconfdir}/browsers.d/%{name}.*
510 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
511
512 %dir %{_libdir}/%{name}
513 %if %{without xulrunner}
514 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
515 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
516 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
517 %endif
518
519 %{_libdir}/%{name}/blocklist.xml
520 %{_libdir}/%{name}/omni.ja
521 %attr(755,root,root) %{_libdir}/%{name}/register
522
523 %if %{with crashreporter}
524 %{_libdir}/%{name}/crashreporter
525 %{_libdir}/%{name}/crashreporter-override.ini
526 %{_libdir}/%{name}/crashreporter.ini
527 %{_libdir}/%{name}/Throbber-small.gif
528 %endif
529
530 # config?
531 %{_libdir}/%{name}/application.ini
532 %{_libdir}/%{name}/chrome.manifest
533
534 %dir %{_libdir}/%{name}/components
535 %{_libdir}/%{name}/components/components.manifest
536 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
537
538 %if %{without xulrunner}
539 %{_libdir}/%{name}/dependentlibs.list
540 %{_libdir}/%{name}/platform.ini
541 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
542 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
543 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
544 %attr(755,root,root) %{_libdir}/%{name}/iceape-bin
545 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
546 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
547 %endif
548
549 %attr(755,root,root) %{_libdir}/%{name}/iceape
550 %dir %{_libdir}/%{name}/plugins
551
552 # symlinks
553 %{_libdir}/%{name}/chrome
554 %{_libdir}/%{name}/defaults
555 %{_libdir}/%{name}/searchplugins
556 %if %{with xulrunner}
557 %{_libdir}/%{name}/xulrunner
558 %else
559 %{_libdir}/%{name}/dictionaries
560 %endif
561
562 %dir %{_datadir}/%{name}
563 %{_datadir}/%{name}/chrome
564 %{_datadir}/%{name}/defaults
565 %{_datadir}/%{name}/searchplugins
566
567 %dir %{_datadir}/%{name}/extensions
568 %dir %{_libdir}/%{name}/extensions
569 # the signature of the default theme
570 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
571 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
572
573 # files created by iceape -register
574 %ghost %{_libdir}/%{name}/components/compreg.dat
575 %ghost %{_libdir}/%{name}/components/xpti.dat
576
577 %if %{without xulrunner}
578 %{_libdir}/%{name}/isp
579 %dir %{_datadir}/%{name}/isp
580 %{_datadir}/%{name}/isp/Bogofilter.sfd
581 %{_datadir}/%{name}/isp/DSPAM.sfd
582 %{_datadir}/%{name}/isp/POPFile.sfd
583 %{_datadir}/%{name}/isp/SpamAssassin.sfd
584 %{_datadir}/%{name}/isp/SpamPal.sfd
585 %{_datadir}/%{name}/isp/movemail.rdf
586 %{_datadir}/%{name}/isp/rss.rdf
587 %endif
588
589 %{_iconsdir}/hicolor/*/apps/iceape.png
590 %{_iconsdir}/hicolor/scalable/apps/iceape.svg
591 %{_desktopdir}/%{name}.desktop
592 %{_desktopdir}/%{name}-composer.desktop
593 %{_desktopdir}/%{name}-mail.desktop
594
595 %if %{with lightning}
596 %files addon-lightning
597 %defattr(644,root,root,755)
598 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
599 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
600 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
601 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
602 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
603 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
604 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
605 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
606 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
607 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
608 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
609 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
610 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
611 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
612 %endif
613
614 %files chat
615 %defattr(644,root,root,755)
616 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
617 %{_desktopdir}/%{name}-chat.desktop
618
619 %files js-debugger
620 %defattr(644,root,root,755)
621 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
622 %{_desktopdir}/%{name}-venkman.desktop
623
624 %files dom-inspector
625 %defattr(644,root,root,755)
626 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.09888 seconds and 3 git commands to generate.