]> git.pld-linux.org Git - packages/iceape.git/blob - iceape.spec
5ceeeec2ce41001efc647a52b5a0d2241c875c4a
[packages/iceape.git] / iceape.spec
1 #
2 # Conditional build:
3 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
4 %bcond_without  gnomeui         # disable gnomeui support
5 %bcond_without  gnome           # disable gnomeui (alias)
6 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
7 %bcond_without  lightning       # disable Sunbird/Lightning calendar
8 %bcond_with     xulrunner       # build with system xulrunner
9 %bcond_with     tests           # enable tests (whatever they check)
10 %bcond_without  kerberos        # disable krb5 support
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 %define         enigmail_ver    1.5.1
17 %define         nspr_ver        4.9.3
18 %define         nss_ver         3.14.3
19 %define         xulrunner_ver   18.0.2
20
21 %if %{without xulrunner}
22 # The actual sqlite version (see RHBZ#480989):
23 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24 %endif
25
26 Summary:        Iceape - web browser
27 Summary(es.UTF-8):      Navegador de Internet Iceape
28 Summary(pl.UTF-8):      Iceape - przeglądarka WWW
29 Summary(pt_BR.UTF-8):   Navegador Iceape
30 Name:           iceape
31 Version:        2.17.1
32 Release:        1
33 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
34 Group:          X11/Applications/Networking
35 Source0:        http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/seamonkey-%{version}.source.tar.bz2
36 # Source0-md5:  a95013068da38fe3f8db30e0ebe6f2f5
37 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
38 # Source1-md5:  3e71f84ed2c11471282412ebe4f5eb2d
39 Source2:        %{name}-branding.tar.bz2
40 # Source2-md5:  0bc28b4382aa8a961f8f7b2ba66d8f89
41 Source3:        %{name}-rm_nonfree.sh
42 Source4:        %{name}.desktop
43 Source5:        %{name}-composer.desktop
44 Source6:        %{name}-chat.desktop
45 Source7:        %{name}-mail.desktop
46 Source8:        %{name}-venkman.desktop
47 Source9:        %{name}.sh
48 Patch0:         %{name}-branding.patch
49 Patch1:         %{name}-pld-branding.patch
50 Patch2:         %{name}-agent.patch
51 Patch3:         %{name}-glueload-fix.patch
52 Patch4:         system-mozldap.patch
53 Patch5:         makefile.patch
54 Patch6:         system-cairo.patch
55 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
56 Patch7:         system-virtualenv.patch
57 Patch8:         gyp-slashism.patch
58 Patch9:         %{name}-system-xulrunner.patch
59 URL:            http://www.pld-linux.org/Packages/Iceape
60 BuildRequires:  GConf2-devel >= 1.2.1
61 BuildRequires:  OpenGL-devel
62 BuildRequires:  alsa-lib-devel
63 BuildRequires:  automake
64 BuildRequires:  bzip2-devel
65 BuildRequires:  cairo-devel >= 1.10.2-5
66 BuildRequires:  dbus-glib-devel >= 0.60
67 BuildRequires:  freetype-devel >= 1:2.1.8
68 BuildRequires:  glib2-devel >= 1:2.18
69 BuildRequires:  gtk+2-devel >= 2:2.10
70 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
71 BuildRequires:  hunspell-devel
72 BuildRequires:  libIDL-devel >= 0.8.0
73 BuildRequires:  libdnet-devel
74 BuildRequires:  libevent-devel >= 1.4.7
75 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
76 BuildRequires:  libffi-devel >= 6:3.0.9
77 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
78 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
79 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
80 BuildRequires:  libiw-devel
81 # requires libjpeg-turbo implementing at least libjpeg 6b API
82 BuildRequires:  libjpeg-devel >= 6b
83 BuildRequires:  libjpeg-turbo-devel
84 BuildRequires:  libnotify-devel >= 0.4
85 BuildRequires:  libpng(APNG)-devel >= 0.10
86 BuildRequires:  libpng-devel >= 1.4.1
87 # rsvg-convert for iceape/branding
88 BuildRequires:  librsvg
89 BuildRequires:  libstdc++-devel
90 BuildRequires:  libvpx-devel >= 1.0.0
91 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
92 BuildRequires:  nss-devel >= 1:%{nss_ver}
93 BuildRequires:  pango-devel >= 1:1.14.0
94 BuildRequires:  perl-base >= 1:5.6
95 BuildRequires:  perl-modules >= 5.004
96 BuildRequires:  pkgconfig
97 BuildRequires:  python >= 1:2.5
98 BuildRequires:  python-modules
99 BuildRequires:  python-virtualenv
100 BuildRequires:  rpm >= 4.4.9-56
101 BuildRequires:  rpmbuild(macros) >= 1.601
102 BuildRequires:  sed >= 4.0
103 BuildRequires:  sqlite3-devel >= 3.7.15.2
104 BuildRequires:  startup-notification-devel >= 0.8
105 BuildRequires:  xorg-lib-libXScrnSaver-devel
106 BuildRequires:  xorg-lib-libXext-devel
107 BuildRequires:  xorg-lib-libXinerama-devel
108 BuildRequires:  xorg-lib-libXt-devel
109 %if %{with xulrunner}
110 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
111 BuildRequires:  xulrunner-devel < 2:19
112 %endif
113 BuildRequires:  yasm
114 BuildRequires:  zip
115 BuildRequires:  zlib-devel >= 1.2.3
116 Requires(post): mktemp >= 1.5-18
117 Requires:       desktop-file-utils
118 Requires:       hicolor-icon-theme
119 %if %{with xulrunner}
120 %requires_eq_to xulrunner xulrunner-devel
121 %else
122 Requires:       browser-plugins >= 2.0
123 Requires:       cairo >= 1.10.2-5
124 Requires:       dbus-glib >= 0.60
125 Requires:       gtk+2 >= 2:2.18
126 Requires:       libjpeg-turbo
127 Requires:       libpng >= 1.4.1
128 Requires:       libpng(APNG) >= 0.10
129 Requires:       myspell-common
130 Requires:       nspr >= 1:%{nspr_ver}
131 Requires:       nss >= 1:%{nss_ver}
132 Requires:       pango >= 1:1.14.0
133 Requires:       sqlite3 >= %{sqlite_build_version}
134 Requires:       startup-notification >= 0.8
135 %endif
136 Provides:       iceape-embedded = %{epoch}:%{version}-%{release}
137 Provides:       wwwbrowser
138 Obsoletes:      iceape-mailnews
139 Obsoletes:      iceape-gnomevfs
140 Obsoletes:      light
141 Obsoletes:      mozilla
142 Obsoletes:      mozilla-gnomevfs
143 Obsoletes:      seamonkey
144 Obsoletes:      seamonkey-calendar
145 Obsoletes:      seamonkey-libs
146 Obsoletes:      seamonkey-mailnews
147 Obsoletes:      seamonkey-gnomevfs
148 Conflicts:      iceape-lang-resources < %{version}
149 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
150
151 %define         topdir          %{_builddir}/%{name}-%{version}
152 %define         objdir          %{topdir}/obj-%{_target_cpu}
153
154 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
155
156 # don't satisfy other packages
157 %define         _noautoprovfiles        %{_libdir}/%{name}
158 # and as we don't provide them, don't require either
159 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
160 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
161
162 %description
163 Iceape is an open-source web browser, designed for standards
164 compliance, performance and portability.
165
166 %description -l es.UTF-8
167 Iceape es un navegador de Internet que se basa en una versión inicial
168 de Netscape Communicator.
169
170 %description -l pl.UTF-8
171 Iceape jest potężną graficzną przeglądarką WWW, która jest następcą
172 Mozilli, która następnie była następczynią Netscape Communikatora.
173
174 %description -l pt_BR.UTF-8
175 O Iceape é um web browser baseado numa versão inicial do Netscape
176 Communicator.
177
178 %description -l ru.UTF-8
179 Iceape - полнофункциональный web-browser с открытыми исходными
180 текстами, разработанный для максимального соотвествия стандартам,
181 максмимальной переносимости и скорости работы
182
183 %package addon-lightning
184 Summary:        An integrated calendar for Iceape
185 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Iceape
186 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
187 Group:          Applications/Networking
188 Requires:       %{name} = %{version}-%{release}
189 Obsoletes:      seamonkey-addon-lightning
190
191 %description addon-lightning
192 Lightning is an calendar extension to Icedove email client.
193
194 %description addon-lightning -l pl.UTF-8
195 Lightning to rozszerzenie do klienta poczty Icedove dodające
196 funkcjonalność kalendarza.
197
198 %package addon-enigmail
199 Summary:        Enigmail %{enigmail_ver} - PGP/GPG support for Iceape
200 Summary(pl.UTF-8):      Enigmail %{enigmail_ver} - obsługa PGP/GPG dla Iceape
201 Group:          X11/Applications/Networking
202 Requires:       %{name} = %{epoch}:%{version}-%{release}
203 Requires:       gnupg >= 1.4.2.2
204 Obsoletes:      seamonkey-addon-enigmail
205
206 %description addon-enigmail
207 Enigmail is an extension to the mail client of Iceape / SeaMonkey /
208 Mozilla / Netscape and Mozilla Thunderbird which allows users to
209 access the authentication and encryption features provided by GnuPG.
210
211 %description addon-enigmail -l pl.UTF-8
212 Enigmail jest rozszerzeniem dla klienta pocztowego Iceape, SeaMonkey,
213 Mozilla i Mozilla Thunderdbird pozwalającym użytkownikowi korzystać z
214 funkcjonalności GnuPG.
215
216 %package chat
217 Summary:        Iceape Chat - integrated IRC client
218 Summary(pl.UTF-8):      Iceape Chat - zintegrowany klient IRC-a
219 Group:          X11/Applications/Networking
220 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
221 Requires:       %{name} = %{epoch}:%{version}-%{release}
222 Obsoletes:      mozilla-chat
223 Obsoletes:      seamonkey-chat
224
225 %description chat
226 Iceape Chat - IRC client that is integrated with the Iceape web
227 browser.
228
229 %description chat -l pl.UTF-8
230 Iceape - klient IRC-a zintegrowany z przeglądarką Iceape.
231
232 %package js-debugger
233 Summary:        JavaScript debugger for use with Iceape
234 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z Iceape
235 Group:          X11/Applications/Networking
236 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
237 Requires:       %{name} = %{epoch}:%{version}-%{release}
238 Obsoletes:      mozilla-js-debugger
239 Obsoletes:      seamonkey-js-debugger
240
241 %description js-debugger
242 JavaScript debugger for use with Iceape.
243
244 %description js-debugger -l pl.UTF-8
245 Odpluskwiacz JavaScriptu do używania z Iceape.
246
247 %package dom-inspector
248 Summary:        A tool for inspecting the DOM of pages in Iceape
249 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w Iceape
250 Group:          X11/Applications/Networking
251 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
252 Requires:       %{name} = %{epoch}:%{version}-%{release}
253 Obsoletes:      mozilla-dom-inspector
254 Obsoletes:      seamonkey-dom-inspector
255
256 %description dom-inspector
257 This is a tool that allows you to inspect the DOM for web pages in
258 Iceape. This is of great use to people who are doing Iceape chrome
259 development or web page development.
260
261 %description dom-inspector -l pl.UTF-8
262 To narzędzie pozwala na oglądanie DOM dla stron WWW w Iceape. Jest
263 bardzo przydatne dla ludzi rozwijających chrome w Iceape lub
264 tworzących strony WWW.
265
266 %prep
267 %setup -qc
268 cd comm-release
269 tar -C mailnews/extensions -zxf %{SOURCE1}
270 tar -jxf %{SOURCE2}
271 %patch0 -p1
272 %patch1 -p1
273 %patch2 -p1
274 %patch3 -p1
275 %patch4 -p1
276 %patch5 -p1
277 %patch6 -p1
278 %patch7 -p1
279 %patch8 -p1
280 %patch9 -p2
281
282 %build
283 cd comm-release
284 %if %{with xulrunner}
285 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
286         echo >&2
287         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
288         echo >&2
289         exit 1
290 fi
291 %endif
292
293 cp -f %{_datadir}/automake/config.* build/autoconf
294 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
295 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
296 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
297
298 cat << EOF > .mozconfig
299 mk_add_options MOZ_OBJDIR=%{objdir}
300
301 export CFLAGS="%{rpmcflags}"
302 export CXXFLAGS="%{rpmcflags}"
303
304 %if %{with crashreporter}
305 export MOZ_DEBUG_SYMBOLS=1
306 %endif
307
308 # Options for 'configure' (same as command-line options).
309 ac_add_options --prefix=%{_prefix}
310 ac_add_options --exec-prefix=%{_exec_prefix}
311 ac_add_options --bindir=%{_bindir}
312 ac_add_options --sbindir=%{_sbindir}
313 ac_add_options --sysconfdir=%{_sysconfdir}
314 ac_add_options --datadir=%{_datadir}
315 ac_add_options --includedir=%{_includedir}
316 ac_add_options --libdir=%{_libdir}
317 ac_add_options --libexecdir=%{_libexecdir}
318 ac_add_options --localstatedir=%{_localstatedir}
319 ac_add_options --sharedstatedir=%{_sharedstatedir}
320 ac_add_options --mandir=%{_mandir}
321 ac_add_options --infodir=%{_infodir}
322 ac_add_options --disable-elf-hack
323 %if %{?debug:1}0
324 ac_add_options --disable-optimize
325 ac_add_options --enable-debug
326 ac_add_options --enable-debug-modules
327 ac_add_options --enable-debugger-info-modules
328 ac_add_options --enable-crash-on-assert
329 %else
330 ac_add_options --disable-debug
331 ac_add_options --disable-debug-modules
332 ac_add_options --disable-logging
333 ac_add_options --enable-optimize="%{rpmcflags} -Os"
334 %endif
335 ac_add_options --disable-strip
336 ac_add_options --disable-strip-libs
337 %if %{with tests}
338 ac_add_options --enable-tests
339 %else
340 ac_add_options --disable-tests
341 %endif
342 ac_add_options --enable-gio
343 %if %{with gnomeui}
344 ac_add_options --enable-gnomeui
345 %else
346 ac_add_options --disable-gnomeui
347 %endif
348 ac_add_options --disable-gnomevfs
349 %if %{with ldap}
350 ac_add_options --enable-ldap
351 ac_add_options --with-system-ldap
352 %else
353 ac_add_options --disable-ldap
354 %endif
355 %if %{with crashreporter}
356 ac_add_options --enable-crashreporter
357 %else
358 ac_add_options --disable-crashreporter
359 %endif
360 ac_add_options --disable-xterm-updates
361 ac_add_options --enable-postscript
362 %if %{with lightning}
363 ac_add_options --enable-calendar
364 %else
365 ac_add_options --disable-calendar
366 %endif
367 ac_add_options --disable-installer
368 ac_add_options --disable-javaxpcom
369 ac_add_options --disable-updater
370 ac_add_options --enable-crypto
371 ac_add_options --enable-libxul
372 ac_add_options --enable-pango
373 ac_add_options --enable-shared-js
374 ac_add_options --enable-startup-notification
375 ac_add_options --enable-system-cairo
376 ac_add_options --enable-system-hunspell
377 ac_add_options --enable-system-sqlite
378 ac_add_options --enable-application=suite
379 ac_add_options --with-distribution-id=org.pld-linux
380 ac_add_options --with-branding=iceape/branding
381 %if %{with xulrunner}
382 ac_add_options --with-system-libxul
383 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
384 %endif
385 ac_add_options --with-pthreads
386 ac_add_options --with-system-bz2
387 ac_add_options --with-system-ffi
388 ac_add_options --with-system-jpeg
389 ac_add_options --with-system-libevent
390 ac_add_options --with-system-libvpx
391 ac_add_options --with-system-nspr
392 ac_add_options --with-system-nss
393 ac_add_options --with-system-png
394 ac_add_options --with-system-zlib
395 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
396 EOF
397
398 %{__make} -j1 -f client.mk build \
399         STRIP="/bin/true" \
400         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
401         installdir=%{_libdir}/%{name} \
402         XLIBS="-lX11 -lXt" \
403         CC="%{__cc}" \
404         CXX="%{__cxx}"
405
406 %if %{with crashreporter}
407 # create debuginfo for crash-stats.mozilla.com
408 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
409 %endif
410
411 %if %{with enigmail}
412 cd mailnews/extensions/enigmail
413 ./makemake -r -o %{objdir}
414 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
415         STRIP="/bin/true" \
416         CC="%{__cc}" \
417         CXX="%{__cxx}"
418
419 %{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
420         STRIP="/bin/true" \
421         CC="%{__cc}" \
422         CXX="%{__cxx}"
423 %endif
424
425 %install
426 rm -rf $RPM_BUILD_ROOT
427 cd comm-release
428 install -d \
429         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
430         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
431         $RPM_BUILD_ROOT%{_datadir}/%{name} \
432         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
433
434 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
435
436 cd %{objdir}
437 %{__make} -C suite/installer stage-package \
438         DESTDIR=$RPM_BUILD_ROOT \
439         installdir=%{_libdir}/%{name} \
440         PKG_SKIP_STRIP=1
441
442 %{__make} -C iceape/branding install \
443         DESTDIR=$RPM_BUILD_ROOT
444
445 cp -a mozilla/dist/iceape/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
446
447 %if %{with xulrunner}
448 # >= 5.0 seems to require this
449 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
450 %endif
451
452 # Enable crash reporter for Thunderbird application
453 %if %{with crashreporter}
454 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
455
456 # Add debuginfo for crash-stats.mozilla.com
457 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
458 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
459 %endif
460
461 # copy manually lightning files, somewhy they are not installed by make
462 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
463         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
464         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
465                 
466 # move arch independant ones to datadir
467 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
468 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
469 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
470 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
471 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
472 %if %{without xulrunner}
473 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
474 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
475 %endif
476
477 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
478 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
479 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
480 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
481 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
482 %if %{without xulrunner}
483 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
484 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
485 %endif
486
487 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
488         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
489
490 # dir for arch independant extensions besides arch dependant extensions
491 # see mozilla/xpcom/build/nsXULAppAPI.h
492 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
493 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
494  
495 %if %{without xulrunner}
496 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
497 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
498 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
499 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
500 %endif
501
502 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
503          -e "s|%MOZ_APP_DISPLAYNAME%|Iceape|" \
504         %{topdir}/comm-release/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/iceape
505
506 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE9} > $RPM_BUILD_ROOT%{_bindir}/iceape
507 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/iceape
508
509 install %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
510         $RPM_BUILD_ROOT%{_desktopdir}
511
512 # files created by iceape -register
513 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
514 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
515
516 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
517 #!/bin/sh
518 umask 022
519 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
520
521 # it attempts to touch files in $HOME/.mozilla
522 # beware if you run this with sudo!!!
523 export HOME=$(mktemp -d)
524 # also TMPDIR could be pointing to sudo user's homedir
525 unset TMPDIR TMP || :
526
527 %{_libdir}/%{name}/iceape -register
528
529 rm -rf $HOME
530 EOF
531 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
532
533 %if %{with enigmail}
534 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
535 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
536 cd mozilla/dist/bin
537 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
538 cp -rfLp components/enig* $ext_dir/components
539 cp -rfLp components/libenigmime.so $ext_dir/components
540 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
541 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
542 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
543 cd -
544 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/install.rdf $ext_dir
545 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
546 %endif
547
548 # never package these. always remove
549 # nss
550 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
551 # nspr
552 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
553 # mozldap
554 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
555 # testpilot quiz
556 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
557
558 %clean
559 rm -rf $RPM_BUILD_ROOT
560
561 %post
562 %{_libdir}/%{name}/register || :
563 %update_browser_plugins
564 %update_icon_cache hicolor
565 %update_desktop_database
566
567 %postun
568 if [ "$1" = 0 ]; then
569         %update_browser_plugins
570         %update_icon_cache hicolor
571 fi
572
573 %files
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_bindir}/iceape
576
577 # browser plugins v2
578 %{_browserpluginsconfdir}/browsers.d/%{name}.*
579 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
580
581 %dir %{_libdir}/%{name}
582 %if %{without xulrunner}
583 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
584 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
585 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
586 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
587 %endif
588
589 %{_libdir}/%{name}/blocklist.xml
590 %attr(755,root,root) %{_libdir}/%{name}/register
591
592 %if %{with crashreporter}
593 %{_libdir}/%{name}/crashreporter
594 %{_libdir}/%{name}/crashreporter-override.ini
595 %{_libdir}/%{name}/crashreporter.ini
596 %{_libdir}/%{name}/Throbber-small.gif
597 %endif
598
599 # config?
600 %{_libdir}/%{name}/application.ini
601 %{_libdir}/%{name}/chrome.manifest
602
603 %dir %{_libdir}/%{name}/components
604
605 %{_libdir}/%{name}/components/Aitc.js
606 %{_libdir}/%{name}/components/AlarmsManager.js
607 %{_libdir}/%{name}/components/AppsService.js
608 %{_libdir}/%{name}/components/BrowserElementParent.js
609 %{_libdir}/%{name}/components/ColorAnalyzer.js
610 %{_libdir}/%{name}/components/ContactManager.js
611 %{_libdir}/%{name}/components/FeedConverter.js
612 %{_libdir}/%{name}/components/FeedWriter.js
613 %{_libdir}/%{name}/components/SettingsManager.js
614 %{_libdir}/%{name}/components/SiteSpecificUserAgent.js
615 %{_libdir}/%{name}/components/TCPSocket.js
616 %{_libdir}/%{name}/components/TCPSocketParentIntermediary.js
617 %{_libdir}/%{name}/components/Weave.js
618 %{_libdir}/%{name}/components/Webapps.js
619 %{_libdir}/%{name}/components/WebContentConverter.js
620 %{_libdir}/%{name}/components/messageWakeupService.js
621 %{_libdir}/%{name}/components/newMailNotificationService.js
622 %{_libdir}/%{name}/components/nsAbout.js
623 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
624 %{_libdir}/%{name}/components/nsComposerCmdLineHandler.js
625 %{_libdir}/%{name}/components/nsDOMIdentity.js
626 %{_libdir}/%{name}/components/nsIDService.js
627 %{_libdir}/%{name}/components/nsSessionStartup.js
628 %{_libdir}/%{name}/components/nsSessionStore.js
629 %{_libdir}/%{name}/components/nsSetDefault.js
630 %{_libdir}/%{name}/components/nsSidebar.js
631 %{_libdir}/%{name}/components/nsSuiteDownloadManagerUI.js
632 %{_libdir}/%{name}/components/nsSuiteGlue.js
633 %{_libdir}/%{name}/components/nsTypeAheadFind.js
634 %{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
635 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
636 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
637 %{_libdir}/%{name}/components/smileApplication.js
638
639 %{_libdir}/%{name}/components/browser.xpt
640 %{_libdir}/%{name}/components/components.manifest
641 %{_libdir}/%{name}/components/interfaces.manifest
642
643 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
644
645 %if %{without xulrunner}
646 %{_libdir}/%{name}/dependentlibs.list
647 %{_libdir}/%{name}/platform.ini
648 %{_libdir}/%{name}/components/ConsoleAPI.js
649 %{_libdir}/%{name}/components/FeedProcessor.js
650 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
651 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
652 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
653 %{_libdir}/%{name}/components/TelemetryPing.js
654 %{_libdir}/%{name}/components/addonManager.js
655 %{_libdir}/%{name}/components/amContentHandler.js
656 %{_libdir}/%{name}/components/amWebInstallListener.js
657 %{_libdir}/%{name}/components/contentAreaDropListener.js
658 %{_libdir}/%{name}/components/contentSecurityPolicy.js
659 %{_libdir}/%{name}/components/crypto-SDR.js
660 %{_libdir}/%{name}/components/jsconsole-clhandler.js
661 %{_libdir}/%{name}/components/nsBadCertHandler.js
662 %{_libdir}/%{name}/components/nsBlocklistService.js
663 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
664 %{_libdir}/%{name}/components/nsContentPrefService.js
665 %{_libdir}/%{name}/components/nsDefaultCLH.js
666 %{_libdir}/%{name}/components/nsFilePicker.js
667 %{_libdir}/%{name}/components/nsFormAutoComplete.js
668 %{_libdir}/%{name}/components/nsFormHistory.js
669 %{_libdir}/%{name}/components/nsHandlerService.js
670 %{_libdir}/%{name}/components/nsHelperAppDlg.js
671 %{_libdir}/%{name}/components/nsINIProcessor.js
672 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
673 %{_libdir}/%{name}/components/nsLivemarkService.js
674 %{_libdir}/%{name}/components/nsLoginInfo.js
675 %{_libdir}/%{name}/components/nsLoginManager.js
676 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
677 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
678 %{_libdir}/%{name}/components/nsPlacesExpiration.js
679 %{_libdir}/%{name}/components/nsPrompter.js
680 %{_libdir}/%{name}/components/nsSearchService.js
681 %{_libdir}/%{name}/components/nsSearchSuggestions.js
682 %{_libdir}/%{name}/components/nsTaggingService.js
683 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
684 %{_libdir}/%{name}/components/nsURLFormatter.js
685 %{_libdir}/%{name}/components/nsWebHandlerApp.js
686 %{_libdir}/%{name}/components/storage-Legacy.js
687 %{_libdir}/%{name}/components/storage-mozStorage.js
688 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
689 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
690 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
691 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
692 %attr(755,root,root) %{_libdir}/%{name}/iceape-bin
693 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
694 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
695 %endif
696
697 %attr(755,root,root) %{_libdir}/%{name}/iceape
698 %dir %{_libdir}/%{name}/plugins
699
700 # symlinks
701 %{_libdir}/%{name}/chrome
702 %{_libdir}/%{name}/defaults
703 %{_libdir}/%{name}/modules
704 %{_libdir}/%{name}/searchplugins
705 %if %{with xulrunner}
706 %{_libdir}/%{name}/xulrunner
707 %else
708 %{_libdir}/%{name}/dictionaries
709 %{_libdir}/%{name}/hyphenation
710 %{_libdir}/%{name}/greprefs.js
711 %{_libdir}/%{name}/res
712 %endif
713
714 %dir %{_datadir}/%{name}
715 %{_datadir}/%{name}/chrome
716 %{_datadir}/%{name}/defaults
717 %{_datadir}/%{name}/modules
718 %if %{with enigmail}
719 %exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
720 %exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
721 %exclude %{_datadir}/%{name}/modules/keyManagement.jsm
722 %exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
723 %exclude %{_datadir}/%{name}/modules/subprocess.jsm
724 %exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
725 %exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
726 %endif
727 %{_datadir}/%{name}/searchplugins
728 %if %{without xulrunner}
729 %{_datadir}/%{name}/greprefs.js
730 %{_datadir}/%{name}/res
731 %endif
732
733 %dir %{_datadir}/%{name}/extensions
734 %dir %{_libdir}/%{name}/extensions
735 # the signature of the default theme
736 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
737 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
738
739 # files created by iceape -register
740 %ghost %{_libdir}/%{name}/components/compreg.dat
741 %ghost %{_libdir}/%{name}/components/xpti.dat
742
743 %{_libdir}/%{name}/components/glautocomp.js
744 %{_libdir}/%{name}/components/jsmimeemitter.js
745 %{_libdir}/%{name}/components/mail.xpt
746 %{_libdir}/%{name}/components/mdn-service.js
747 %{_libdir}/%{name}/components/msgAsyncPrompter.js
748 %{_libdir}/%{name}/components/newsblog.js
749 %{_libdir}/%{name}/components/nsAbAutoCompleteMyDomain.js
750 %{_libdir}/%{name}/components/nsAbAutoCompleteSearch.js
751 %{_libdir}/%{name}/components/nsAbLDAPAttributeMap.js
752 %{_libdir}/%{name}/components/nsLDAPProtocolHandler.js
753 %{_libdir}/%{name}/components/nsMailNewsCommandLineHandler.js
754 %{_libdir}/%{name}/components/nsMsgTraitService.js
755 %{_libdir}/%{name}/components/nsSMTPProtocolHandler.js
756 %{_libdir}/%{name}/components/offlineStartup.js
757 %{_libdir}/%{name}/components/smime-service.js
758
759 %{_libdir}/%{name}/isp
760 %dir %{_datadir}/%{name}/isp
761 %{_datadir}/%{name}/isp/Bogofilter.sfd
762 %{_datadir}/%{name}/isp/DSPAM.sfd
763 %{_datadir}/%{name}/isp/POPFile.sfd
764 %{_datadir}/%{name}/isp/SpamAssassin.sfd
765 %{_datadir}/%{name}/isp/SpamPal.sfd
766 %{_datadir}/%{name}/isp/movemail.rdf
767 %{_datadir}/%{name}/isp/rss.rdf
768
769 %{_iconsdir}/hicolor/*/apps/iceape.png
770 %{_iconsdir}/hicolor/scalable/apps/iceape.svg
771 %{_desktopdir}/%{name}.desktop
772 %{_desktopdir}/%{name}-composer.desktop
773 %{_desktopdir}/%{name}-mail.desktop
774
775 %if %{with lightning}
776 %files addon-lightning
777 %defattr(644,root,root,755)
778 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
779 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
780 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
781 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
782 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
783 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
784 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
785 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
786 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
787 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
788 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
789 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
790 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
791 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
792 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
793 %endif
794
795 %if %{with enigmail}
796 %files addon-enigmail
797 %defattr(644,root,root,755)
798 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
799 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
800 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
801 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
802 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
803 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
804 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
805 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
806 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
807 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
808 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
809 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
810 %endif
811
812 %files chat
813 %defattr(644,root,root,755)
814 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
815 %{_desktopdir}/%{name}-chat.desktop
816
817 %files js-debugger
818 %defattr(644,root,root,755)
819 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
820 %{_desktopdir}/%{name}-venkman.desktop
821
822 %files dom-inspector
823 %defattr(644,root,root,755)
824 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.118577 seconds and 2 git commands to generate.