]> git.pld-linux.org Git - packages/iceape.git/blob - iceape.spec
- release 5 (by relup.sh)
[packages/iceape.git] / iceape.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk3            # GTK+ 3.x instead of 2.x
4 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
5 %bcond_without  lightning       # disable Sunbird/Lightning calendar
6 %bcond_without  kerberos        # disable krb5 support
7 %bcond_with     xulrunner       # build with system xulrunner
8 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
9 %bcond_with     tests           # enable tests (whatever they check)
10
11 %define         nspr_ver        4.10.3
12 %define         nss_ver         3.16
13 %define         xulrunner_ver   29.0
14
15 %if %{without xulrunner}
16 # The actual sqlite version (see RHBZ#480989):
17 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
18 %endif
19
20 Summary:        Iceape - web browser
21 Summary(es.UTF-8):      Navegador de Internet Iceape
22 Summary(pl.UTF-8):      Iceape - przeglądarka WWW
23 Summary(pt_BR.UTF-8):   Navegador Iceape
24 Name:           iceape
25 Version:        2.26.1
26 Release:        5
27 License:        MPL v2.0
28 Group:          X11/Applications/Networking
29 Source0:        http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/seamonkey-%{version}.source.tar.bz2
30 # Source0-md5:  4bfa46b370b4d211eef56b90277a9517
31 Source2:        %{name}-branding.tar.bz2
32 # Source2-md5:  3feee544ef515f1dbf19b14479916784
33 Source3:        %{name}-rm_nonfree.sh
34 Source4:        %{name}.desktop
35 Source5:        %{name}-composer.desktop
36 Source6:        %{name}-chat.desktop
37 Source7:        %{name}-mail.desktop
38 Source8:        %{name}-venkman.desktop
39 Source9:        %{name}.sh
40 Patch0:         %{name}-branding.patch
41 Patch1:         %{name}-pld-branding.patch
42 Patch2:         %{name}-agent.patch
43 Patch3:         enable-addons.patch
44 Patch4:         system-mozldap.patch
45 Patch5:         makefile.patch
46 Patch6:         %{name}-pixman.patch
47 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
48 Patch7:         system-virtualenv.patch
49 Patch8:         libvpx2.patch
50 Patch9:         %{name}-system-xulrunner.patch
51 Patch10:        gcc5.patch
52 URL:            http://www.pld-linux.org/Packages/Iceape
53 BuildRequires:  GConf2-devel >= 1.2.1
54 BuildRequires:  OpenGL-devel
55 BuildRequires:  alsa-lib-devel
56 BuildRequires:  automake
57 BuildRequires:  bzip2-devel
58 BuildRequires:  cairo-devel >= 1.10.2-5
59 BuildRequires:  dbus-glib-devel >= 0.60
60 BuildRequires:  freetype-devel >= 1:2.1.8
61 BuildRequires:  glib2-devel >= 1:2.20
62 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.18}
63 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
64 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
65 BuildRequires:  hunspell-devel
66 BuildRequires:  libIDL-devel >= 0.8.0
67 BuildRequires:  libdnet-devel
68 BuildRequires:  libevent-devel >= 1.4.7
69 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
70 BuildRequires:  libffi-devel >= 6:3.0.9
71 BuildRequires:  libicu-devel >= 50.1
72 # requires libjpeg-turbo implementing at least libjpeg 6b API
73 BuildRequires:  libjpeg-devel >= 6b
74 BuildRequires:  libjpeg-turbo-devel
75 BuildRequires:  libnotify-devel >= 0.4
76 BuildRequires:  libpng(APNG)-devel >= 0.10
77 BuildRequires:  libpng-devel >= 2:1.6.7
78 # rsvg-convert for iceape/branding
79 BuildRequires:  librsvg
80 BuildRequires:  libstdc++-devel
81 BuildRequires:  libvpx-devel >= 1.3.0
82 BuildRequires:  mozldap-devel
83 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
84 BuildRequires:  nss-devel >= 1:%{nss_ver}
85 BuildRequires:  pango-devel >= 1:1.14.0
86 BuildRequires:  perl-base >= 1:5.6
87 BuildRequires:  perl-modules >= 5.004
88 BuildRequires:  pkgconfig
89 BuildRequires:  python >= 1:2.5
90 BuildRequires:  python-modules
91 BuildRequires:  python-virtualenv
92 BuildRequires:  rpm >= 4.4.9-56
93 BuildRequires:  rpmbuild(macros) >= 1.601
94 BuildRequires:  sed >= 4.0
95 BuildRequires:  sqlite3-devel >= 3.8.2
96 BuildRequires:  startup-notification-devel >= 0.8
97 BuildRequires:  xorg-lib-libX11-devel
98 BuildRequires:  xorg-lib-libXScrnSaver-devel
99 BuildRequires:  xorg-lib-libXext-devel
100 BuildRequires:  xorg-lib-libXinerama-devel
101 BuildRequires:  xorg-lib-libXt-devel
102 %if %{with xulrunner}
103 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
104 BuildRequires:  xulrunner-devel < 2:30
105 %endif
106 BuildRequires:  yasm
107 BuildRequires:  zip
108 BuildRequires:  zlib-devel >= 1.2.3
109 Requires(post): mktemp >= 1.5-18
110 Requires:       desktop-file-utils
111 Requires:       hicolor-icon-theme
112 %if %{with xulrunner}
113 %requires_eq_to xulrunner xulrunner-devel
114 %else
115 Requires:       browser-plugins >= 2.0
116 Requires:       cairo >= 1.10.2-5
117 Requires:       dbus-glib >= 0.60
118 Requires:       glib2 >= 1:2.20
119 %{!?with_gtk3:Requires: gtk+2 >= 2:2.18}
120 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
121 Requires:       libjpeg-turbo
122 Requires:       libpng >= 2:1.6.7
123 Requires:       libpng(APNG) >= 0.10
124 Requires:       libvpx >= 1.3.0
125 Requires:       myspell-common
126 Requires:       nspr >= 1:%{nspr_ver}
127 Requires:       nss >= 1:%{nss_ver}
128 Requires:       pango >= 1:1.14.0
129 Requires:       sqlite3 >= %{sqlite_build_version}
130 Requires:       startup-notification >= 0.8
131 %endif
132 Provides:       iceape-embedded = %{version}-%{release}
133 Provides:       wwwbrowser
134 Obsoletes:      iceape-mailnews
135 Obsoletes:      iceape-gnomevfs
136 Obsoletes:      light
137 Obsoletes:      mozilla
138 Obsoletes:      mozilla-gnomevfs
139 Obsoletes:      seamonkey
140 Obsoletes:      seamonkey-calendar
141 Obsoletes:      seamonkey-libs
142 Obsoletes:      seamonkey-mailnews
143 Obsoletes:      seamonkey-gnomevfs
144 Conflicts:      iceape-lang-resources < %{version}
145 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
146
147 %define         topdir          %{_builddir}/%{name}-%{version}
148 %define         objdir          %{topdir}/obj-%{_target_cpu}
149
150 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
151
152 # don't satisfy other packages
153 %define         _noautoprovfiles        %{_libdir}/%{name}
154 # and as we don't provide them, don't require either
155 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
156 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
157
158 %description
159 Iceape is an open-source web browser, designed for standards
160 compliance, performance and portability.
161
162 %description -l es.UTF-8
163 Iceape es un navegador de Internet que se basa en una versión inicial
164 de Netscape Communicator.
165
166 %description -l pl.UTF-8
167 Iceape jest potężną graficzną przeglądarką WWW, która jest następcą
168 Mozilli, która następnie była następczynią Netscape Communikatora.
169
170 %description -l pt_BR.UTF-8
171 O Iceape é um web browser baseado numa versão inicial do Netscape
172 Communicator.
173
174 %description -l ru.UTF-8
175 Iceape - полнофункциональный web-browser с открытыми исходными
176 текстами, разработанный для максимального соотвествия стандартам,
177 максмимальной переносимости и скорости работы
178
179 %package addon-lightning
180 Summary:        An integrated calendar for Iceape
181 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Iceape
182 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
183 Group:          Applications/Networking
184 Requires:       %{name} = %{version}-%{release}
185 Obsoletes:      seamonkey-addon-lightning
186
187 %description addon-lightning
188 Lightning is an calendar extension to Icedove email client.
189
190 %description addon-lightning -l pl.UTF-8
191 Lightning to rozszerzenie do klienta poczty Icedove dodające
192 funkcjonalność kalendarza.
193
194 %package chat
195 Summary:        Iceape Chat - integrated IRC client
196 Summary(pl.UTF-8):      Iceape Chat - zintegrowany klient IRC-a
197 Group:          X11/Applications/Networking
198 Requires(post,postun):  %{name} = %{version}-%{release}
199 Requires:       %{name} = %{version}-%{release}
200 Obsoletes:      mozilla-chat
201 Obsoletes:      seamonkey-chat
202
203 %description chat
204 Iceape Chat - IRC client that is integrated with the Iceape web
205 browser.
206
207 %description chat -l pl.UTF-8
208 Iceape - klient IRC-a zintegrowany z przeglądarką Iceape.
209
210 %package js-debugger
211 Summary:        JavaScript debugger for use with Iceape
212 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z Iceape
213 Group:          X11/Applications/Networking
214 Requires(post,postun):  %{name} = %{version}-%{release}
215 Requires:       %{name} = %{version}-%{release}
216 Obsoletes:      mozilla-js-debugger
217 Obsoletes:      seamonkey-js-debugger
218
219 %description js-debugger
220 JavaScript debugger for use with Iceape.
221
222 %description js-debugger -l pl.UTF-8
223 Odpluskwiacz JavaScriptu do używania z Iceape.
224
225 %package dom-inspector
226 Summary:        A tool for inspecting the DOM of pages in Iceape
227 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w Iceape
228 Group:          X11/Applications/Networking
229 Requires(post,postun):  %{name} = %{version}-%{release}
230 Requires:       %{name} = %{version}-%{release}
231 Obsoletes:      mozilla-dom-inspector
232 Obsoletes:      seamonkey-dom-inspector
233
234 %description dom-inspector
235 This is a tool that allows you to inspect the DOM for web pages in
236 Iceape. This is of great use to people who are doing Iceape chrome
237 development or web page development.
238
239 %description dom-inspector -l pl.UTF-8
240 To narzędzie pozwala na oglądanie DOM dla stron WWW w Iceape. Jest
241 bardzo przydatne dla ludzi rozwijających chrome w Iceape lub
242 tworzących strony WWW.
243
244 %prep
245 %setup -qc
246 cd comm-release
247 tar -jxf %{SOURCE2}
248 %patch0 -p1
249 %patch1 -p1
250 %patch2 -p1
251 %patch3 -p2
252 %patch4 -p1
253 %patch5 -p1
254 %patch6 -p1
255 %patch7 -p1
256 %patch8 -p1
257 %patch9 -p2
258 %patch10 -p2
259
260 %build
261 cd comm-release
262 %if %{with xulrunner}
263 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
264         echo >&2
265         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
266         echo >&2
267         exit 1
268 fi
269 %endif
270
271 cp -f %{_datadir}/automake/config.* build/autoconf
272 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
273 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
274 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
275
276 cat << EOF > .mozconfig
277 mk_add_options MOZ_OBJDIR=%{objdir}
278
279 export CFLAGS="%{rpmcflags}"
280 export CXXFLAGS="%{rpmcflags}"
281
282 %if %{with crashreporter}
283 export MOZ_DEBUG_SYMBOLS=1
284 %endif
285
286 # Options for 'configure' (same as command-line options).
287 ac_add_options --prefix=%{_prefix}
288 ac_add_options --exec-prefix=%{_exec_prefix}
289 ac_add_options --bindir=%{_bindir}
290 ac_add_options --sbindir=%{_sbindir}
291 ac_add_options --sysconfdir=%{_sysconfdir}
292 ac_add_options --datadir=%{_datadir}
293 ac_add_options --includedir=%{_includedir}
294 ac_add_options --libdir=%{_libdir}
295 ac_add_options --libexecdir=%{_libexecdir}
296 ac_add_options --localstatedir=%{_localstatedir}
297 ac_add_options --sharedstatedir=%{_sharedstatedir}
298 ac_add_options --mandir=%{_mandir}
299 ac_add_options --infodir=%{_infodir}
300 %if %{?debug:1}0
301 ac_add_options --disable-optimize
302 ac_add_options --enable-debug
303 ac_add_options --enable-debug-modules
304 ac_add_options --enable-debugger-info-modules
305 ac_add_options --enable-crash-on-assert
306 %else
307 ac_add_options --disable-debug
308 ac_add_options --disable-debug-modules
309 ac_add_options --disable-logging
310 ac_add_options --enable-optimize="%{rpmcflags} -Os"
311 %endif
312 ac_add_options --disable-strip
313 ac_add_options --disable-strip-libs
314 %if %{with tests}
315 ac_add_options --enable-tests
316 %else
317 ac_add_options --disable-tests
318 %endif
319 %if %{with lightning}
320 ac_add_options --enable-calendar
321 %else
322 ac_add_options --disable-calendar
323 %endif
324 %if %{with crashreporter}
325 ac_add_options --enable-crashreporter
326 %else
327 ac_add_options --disable-crashreporter
328 %endif
329 ac_add_options --disable-elf-dynstr-gc
330 ac_add_options --disable-gnomeui
331 ac_add_options --disable-gnomevfs
332 ac_add_options --disable-installer
333 ac_add_options --disable-javaxpcom
334 ac_add_options --disable-updater
335 ac_add_options --disable-xterm-updates
336 ac_add_options --enable-application=suite
337 ac_add_options --enable-crypto
338 ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
339 ac_add_options --enable-gio
340 %if %{with ldap}
341 ac_add_options --enable-ldap
342 ac_add_options --with-system-ldap
343 %else
344 ac_add_options --disable-ldap
345 %endif
346 ac_add_options --enable-libxul
347 ac_add_options --enable-pango
348 ac_add_options --enable-postscript
349 ac_add_options --enable-shared-js
350 ac_add_options --enable-startup-notification
351 ac_add_options --enable-system-cairo
352 ac_add_options --enable-system-hunspell
353 ac_add_options --enable-system-sqlite
354 ac_add_options --with-branding=iceape/branding
355 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
356 ac_add_options --with-distribution-id=org.pld-linux
357 %if %{with xulrunner}
358 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
359 ac_add_options --with-system-libxul
360 %endif
361 ac_add_options --with-pthreads
362 ac_add_options --with-system-bz2
363 ac_add_options --with-system-ffi
364 ac_add_options --with-system-jpeg
365 ac_add_options --with-system-libevent
366 ac_add_options --with-system-libvpx
367 ac_add_options --with-system-nspr
368 ac_add_options --with-system-nss
369 ac_add_options --with-system-png
370 ac_add_options --with-system-zlib
371 EOF
372
373 %{__make} -j1 -f client.mk build \
374         STRIP="/bin/true" \
375         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
376         installdir=%{_libdir}/%{name} \
377         XLIBS="-lX11 -lXt" \
378         CC="%{__cc}" \
379         CXX="%{__cxx}"
380
381 %if %{with crashreporter}
382 # create debuginfo for crash-stats.mozilla.com
383 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
384 %endif
385
386 %install
387 rm -rf $RPM_BUILD_ROOT
388 cd comm-release
389 install -d \
390         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
391         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
392         $RPM_BUILD_ROOT%{_datadir}/%{name} \
393         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
394
395 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
396
397 cd %{objdir}
398 cwd=`pwd`
399 %{__make} -C suite/installer stage-package \
400         LD_LIBRARY_PATH=$cwd/mozilla/dist/lib \
401         DESTDIR=$RPM_BUILD_ROOT \
402         installdir=%{_libdir}/%{name} \
403         PKG_SKIP_STRIP=1
404
405 %{__make} -C iceape/branding install \
406         DESTDIR=$RPM_BUILD_ROOT
407
408 cp -a mozilla/dist/iceape/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
409
410 %if %{with xulrunner}
411 # >= 5.0 seems to require this
412 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
413 %endif
414
415 # Enable crash reporter for Thunderbird application
416 %if %{with crashreporter}
417 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
418
419 # Add debuginfo for crash-stats.mozilla.com
420 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
421 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
422 %endif
423
424 # copy manually lightning files, somewhy they are not installed by make
425 cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
426         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
427
428 # move arch independant ones to datadir
429 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
430 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
431 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
432
433 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
434 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
435 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
436
437 %if %{without xulrunner}
438 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
439 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
440 %endif
441
442 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
443         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
444
445 # dir for arch independant extensions besides arch dependant extensions
446 # see mozilla/xpcom/build/nsXULAppAPI.h
447 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
448 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
449  
450 %if %{without xulrunner}
451 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
452 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
453 %endif
454
455 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
456          -e "s|%MOZ_APP_DISPLAYNAME%|Iceape|" \
457         %{topdir}/comm-release/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/iceape
458
459 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE9} > $RPM_BUILD_ROOT%{_bindir}/iceape
460 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/iceape
461
462 install %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
463         $RPM_BUILD_ROOT%{_desktopdir}
464
465 # files created by iceape -register
466 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
467 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
468
469 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
470 #!/bin/sh
471 umask 022
472 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
473
474 # it attempts to touch files in $HOME/.mozilla
475 # beware if you run this with sudo!!!
476 export HOME=$(mktemp -d)
477 # also TMPDIR could be pointing to sudo user's homedir
478 unset TMPDIR TMP || :
479
480 %{_libdir}/%{name}/iceape -register
481
482 rm -rf $HOME
483 EOF
484 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
485
486 %if %{without xulrunner}
487 # never package these. always remove
488 # mozldap
489 %{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
490 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
491 %endif
492
493 %clean
494 rm -rf $RPM_BUILD_ROOT
495
496 %post
497 %{_libdir}/%{name}/register || :
498 %update_browser_plugins
499 %update_icon_cache hicolor
500 %update_desktop_database
501
502 %postun
503 if [ "$1" = 0 ]; then
504         %update_browser_plugins
505         %update_icon_cache hicolor
506 fi
507
508 %files
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_bindir}/iceape
511
512 # browser plugins v2
513 %{_browserpluginsconfdir}/browsers.d/%{name}.*
514 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
515
516 %dir %{_libdir}/%{name}
517 %if %{without xulrunner}
518 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
519 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
520 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
521 %endif
522
523 %{_libdir}/%{name}/blocklist.xml
524 %{_libdir}/%{name}/omni.ja
525 %attr(755,root,root) %{_libdir}/%{name}/register
526
527 %if %{with crashreporter}
528 %{_libdir}/%{name}/crashreporter
529 %{_libdir}/%{name}/crashreporter-override.ini
530 %{_libdir}/%{name}/crashreporter.ini
531 %{_libdir}/%{name}/Throbber-small.gif
532 %endif
533
534 # config?
535 %{_libdir}/%{name}/application.ini
536 %{_libdir}/%{name}/chrome.manifest
537
538 %dir %{_libdir}/%{name}/components
539 %{_libdir}/%{name}/components/components.manifest
540 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
541
542 %if %{without xulrunner}
543 %{_libdir}/%{name}/dependentlibs.list
544 %{_libdir}/%{name}/platform.ini
545 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
546 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
547 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
548 %attr(755,root,root) %{_libdir}/%{name}/iceape-bin
549 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
550 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
551 %endif
552
553 %attr(755,root,root) %{_libdir}/%{name}/iceape
554 %dir %{_libdir}/%{name}/plugins
555
556 # symlinks
557 %{_libdir}/%{name}/chrome
558 %{_libdir}/%{name}/defaults
559 %{_libdir}/%{name}/searchplugins
560 %if %{with xulrunner}
561 %{_libdir}/%{name}/xulrunner
562 %else
563 %{_libdir}/%{name}/dictionaries
564 %endif
565
566 %dir %{_datadir}/%{name}
567 %{_datadir}/%{name}/chrome
568 %{_datadir}/%{name}/defaults
569 %{_datadir}/%{name}/searchplugins
570
571 %dir %{_datadir}/%{name}/extensions
572 %dir %{_libdir}/%{name}/extensions
573 # the signature of the default theme
574 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
575 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
576
577 # files created by iceape -register
578 %ghost %{_libdir}/%{name}/components/compreg.dat
579 %ghost %{_libdir}/%{name}/components/xpti.dat
580
581 %if %{without xulrunner}
582 %{_libdir}/%{name}/isp
583 %dir %{_datadir}/%{name}/isp
584 %{_datadir}/%{name}/isp/Bogofilter.sfd
585 %{_datadir}/%{name}/isp/DSPAM.sfd
586 %{_datadir}/%{name}/isp/POPFile.sfd
587 %{_datadir}/%{name}/isp/SpamAssassin.sfd
588 %{_datadir}/%{name}/isp/SpamPal.sfd
589 %{_datadir}/%{name}/isp/movemail.rdf
590 %{_datadir}/%{name}/isp/rss.rdf
591 %endif
592
593 %{_iconsdir}/hicolor/*/apps/iceape.png
594 %{_iconsdir}/hicolor/scalable/apps/iceape.svg
595 %{_desktopdir}/%{name}.desktop
596 %{_desktopdir}/%{name}-composer.desktop
597 %{_desktopdir}/%{name}-mail.desktop
598
599 %if %{with lightning}
600 %files addon-lightning
601 %defattr(644,root,root,755)
602 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
603 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
604 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
605 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
606 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
607 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
608 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
609 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
610 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
611 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
612 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
613 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
614 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
615 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
616 %endif
617
618 %files chat
619 %defattr(644,root,root,755)
620 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
621 %{_desktopdir}/%{name}-chat.desktop
622
623 %files js-debugger
624 %defattr(644,root,root,755)
625 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
626 %{_desktopdir}/%{name}-venkman.desktop
627
628 %files dom-inspector
629 %defattr(644,root,root,755)
630 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.128716 seconds and 3 git commands to generate.