]> git.pld-linux.org Git - packages/iceape.git/blob - iceape.spec
14cc7e797037629cfc5897e4ba78b6d82a0d0f5f
[packages/iceape.git] / iceape.spec
1 #
2 # Conditional build:
3 %bcond_with     enigmail        # don't build enigmail - GPG/PGP support
4 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
5 %bcond_without  lightning       # disable Sunbird/Lightning calendar
6 %bcond_with     xulrunner       # build with system xulrunner
7 %bcond_with     tests           # enable tests (whatever they check)
8 %bcond_without  kerberos        # disable krb5 support
9
10 %define         enigmail_ver    1.6
11 %define         nspr_ver        4.9.3
12 %define         nss_ver         3.14.3
13 %define         xulrunner_ver   28.0
14
15 %if %{without xulrunner}
16 # The actual sqlite version (see RHBZ#480989):
17 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
18 %endif
19
20 Summary:        Iceape - web browser
21 Summary(es.UTF-8):      Navegador de Internet Iceape
22 Summary(pl.UTF-8):      Iceape - przeglądarka WWW
23 Summary(pt_BR.UTF-8):   Navegador Iceape
24 Name:           iceape
25 Version:        2.25
26 Release:        1
27 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
28 Group:          X11/Applications/Networking
29 Source0:        http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/seamonkey-%{version}.source.tar.bz2
30 # Source0-md5:  e9597622d2d843ed9095a9e1eeab01f1
31 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
32 # Source1-md5:  4a2bbcb020bdb282a660fda8c70d5608
33 Source2:        %{name}-branding.tar.bz2
34 # Source2-md5:  3feee544ef515f1dbf19b14479916784
35 Source3:        %{name}-rm_nonfree.sh
36 Source4:        %{name}.desktop
37 Source5:        %{name}-composer.desktop
38 Source6:        %{name}-chat.desktop
39 Source7:        %{name}-mail.desktop
40 Source8:        %{name}-venkman.desktop
41 Source9:        %{name}.sh
42 Patch0:         %{name}-branding.patch
43 Patch1:         %{name}-pld-branding.patch
44 Patch2:         %{name}-agent.patch
45 Patch3:         enable-addons.patch
46 Patch4:         system-mozldap.patch
47 Patch5:         makefile.patch
48 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
49 Patch7:         system-virtualenv.patch
50 Patch8:         gyp-slashism.patch
51 Patch9:         %{name}-system-xulrunner.patch
52 URL:            http://www.pld-linux.org/Packages/Iceape
53 BuildRequires:  GConf2-devel >= 1.2.1
54 BuildRequires:  OpenGL-devel
55 BuildRequires:  alsa-lib-devel
56 BuildRequires:  automake
57 BuildRequires:  bzip2-devel
58 BuildRequires:  cairo-devel >= 1.10.2-5
59 BuildRequires:  dbus-glib-devel >= 0.60
60 BuildRequires:  freetype-devel >= 1:2.1.8
61 BuildRequires:  glib2-devel >= 1:2.18
62 BuildRequires:  gtk+2-devel >= 2:2.10
63 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
64 BuildRequires:  hunspell-devel
65 BuildRequires:  libIDL-devel >= 0.8.0
66 BuildRequires:  libdnet-devel
67 BuildRequires:  libevent-devel >= 1.4.7
68 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
69 BuildRequires:  libffi-devel >= 6:3.0.9
70 BuildRequires:  libiw-devel
71 # requires libjpeg-turbo implementing at least libjpeg 6b API
72 BuildRequires:  libjpeg-devel >= 6b
73 BuildRequires:  libjpeg-turbo-devel
74 BuildRequires:  libnotify-devel >= 0.4
75 BuildRequires:  libpng(APNG)-devel >= 0.10
76 BuildRequires:  libpng-devel >= 1.4.1
77 # rsvg-convert for iceape/branding
78 BuildRequires:  librsvg
79 BuildRequires:  libstdc++-devel
80 BuildRequires:  libvpx-devel >= 1.0.0
81 BuildRequires:  mozldap-devel
82 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
83 BuildRequires:  nss-devel >= 1:%{nss_ver}
84 BuildRequires:  pango-devel >= 1:1.14.0
85 BuildRequires:  perl-base >= 1:5.6
86 BuildRequires:  perl-modules >= 5.004
87 BuildRequires:  pkgconfig
88 BuildRequires:  python >= 1:2.5
89 BuildRequires:  python-modules
90 BuildRequires:  python-virtualenv
91 BuildRequires:  rpm >= 4.4.9-56
92 BuildRequires:  rpmbuild(macros) >= 1.601
93 BuildRequires:  sed >= 4.0
94 BuildRequires:  sqlite3-devel >= 3.7.15.2
95 BuildRequires:  startup-notification-devel >= 0.8
96 BuildRequires:  xorg-lib-libXScrnSaver-devel
97 BuildRequires:  xorg-lib-libXext-devel
98 BuildRequires:  xorg-lib-libXinerama-devel
99 BuildRequires:  xorg-lib-libXt-devel
100 %if %{with xulrunner}
101 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
102 BuildRequires:  xulrunner-devel < 2:19
103 %endif
104 BuildRequires:  yasm
105 BuildRequires:  zip
106 BuildRequires:  zlib-devel >= 1.2.3
107 Requires(post): mktemp >= 1.5-18
108 Requires:       desktop-file-utils
109 Requires:       hicolor-icon-theme
110 %if %{with xulrunner}
111 %requires_eq_to xulrunner xulrunner-devel
112 %else
113 Requires:       browser-plugins >= 2.0
114 Requires:       cairo >= 1.10.2-5
115 Requires:       dbus-glib >= 0.60
116 Requires:       gtk+2 >= 2:2.18
117 Requires:       libjpeg-turbo
118 Requires:       libpng >= 1.4.1
119 Requires:       libpng(APNG) >= 0.10
120 Requires:       myspell-common
121 Requires:       nspr >= 1:%{nspr_ver}
122 Requires:       nss >= 1:%{nss_ver}
123 Requires:       pango >= 1:1.14.0
124 Requires:       sqlite3 >= %{sqlite_build_version}
125 Requires:       startup-notification >= 0.8
126 %endif
127 Provides:       iceape-embedded = %{epoch}:%{version}-%{release}
128 Provides:       wwwbrowser
129 Obsoletes:      iceape-mailnews
130 Obsoletes:      iceape-gnomevfs
131 Obsoletes:      light
132 Obsoletes:      mozilla
133 Obsoletes:      mozilla-gnomevfs
134 Obsoletes:      seamonkey
135 Obsoletes:      seamonkey-calendar
136 Obsoletes:      seamonkey-libs
137 Obsoletes:      seamonkey-mailnews
138 Obsoletes:      seamonkey-gnomevfs
139 Conflicts:      iceape-lang-resources < %{version}
140 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
141
142 %define         topdir          %{_builddir}/%{name}-%{version}
143 %define         objdir          %{topdir}/obj-%{_target_cpu}
144
145 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
146
147 # don't satisfy other packages
148 %define         _noautoprovfiles        %{_libdir}/%{name}
149 # and as we don't provide them, don't require either
150 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
151 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
152
153 %description
154 Iceape is an open-source web browser, designed for standards
155 compliance, performance and portability.
156
157 %description -l es.UTF-8
158 Iceape es un navegador de Internet que se basa en una versión inicial
159 de Netscape Communicator.
160
161 %description -l pl.UTF-8
162 Iceape jest potężną graficzną przeglądarką WWW, która jest następcą
163 Mozilli, która następnie była następczynią Netscape Communikatora.
164
165 %description -l pt_BR.UTF-8
166 O Iceape é um web browser baseado numa versão inicial do Netscape
167 Communicator.
168
169 %description -l ru.UTF-8
170 Iceape - полнофункциональный web-browser с открытыми исходными
171 текстами, разработанный для максимального соотвествия стандартам,
172 максмимальной переносимости и скорости работы
173
174 %package addon-lightning
175 Summary:        An integrated calendar for Iceape
176 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Iceape
177 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
178 Group:          Applications/Networking
179 Requires:       %{name} = %{version}-%{release}
180 Obsoletes:      seamonkey-addon-lightning
181
182 %description addon-lightning
183 Lightning is an calendar extension to Icedove email client.
184
185 %description addon-lightning -l pl.UTF-8
186 Lightning to rozszerzenie do klienta poczty Icedove dodające
187 funkcjonalność kalendarza.
188
189 %package addon-enigmail
190 Summary:        Enigmail %{enigmail_ver} - PGP/GPG support for Iceape
191 Summary(pl.UTF-8):      Enigmail %{enigmail_ver} - obsługa PGP/GPG dla Iceape
192 Group:          X11/Applications/Networking
193 Requires:       %{name} = %{epoch}:%{version}-%{release}
194 Requires:       gnupg >= 1.4.2.2
195 Obsoletes:      seamonkey-addon-enigmail
196
197 %description addon-enigmail
198 Enigmail is an extension to the mail client of Iceape / SeaMonkey /
199 Mozilla / Netscape and Mozilla Thunderbird which allows users to
200 access the authentication and encryption features provided by GnuPG.
201
202 %description addon-enigmail -l pl.UTF-8
203 Enigmail jest rozszerzeniem dla klienta pocztowego Iceape, SeaMonkey,
204 Mozilla i Mozilla Thunderdbird pozwalającym użytkownikowi korzystać z
205 funkcjonalności GnuPG.
206
207 %package chat
208 Summary:        Iceape Chat - integrated IRC client
209 Summary(pl.UTF-8):      Iceape Chat - zintegrowany klient IRC-a
210 Group:          X11/Applications/Networking
211 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
212 Requires:       %{name} = %{epoch}:%{version}-%{release}
213 Obsoletes:      mozilla-chat
214 Obsoletes:      seamonkey-chat
215
216 %description chat
217 Iceape Chat - IRC client that is integrated with the Iceape web
218 browser.
219
220 %description chat -l pl.UTF-8
221 Iceape - klient IRC-a zintegrowany z przeglądarką Iceape.
222
223 %package js-debugger
224 Summary:        JavaScript debugger for use with Iceape
225 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z Iceape
226 Group:          X11/Applications/Networking
227 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
228 Requires:       %{name} = %{epoch}:%{version}-%{release}
229 Obsoletes:      mozilla-js-debugger
230 Obsoletes:      seamonkey-js-debugger
231
232 %description js-debugger
233 JavaScript debugger for use with Iceape.
234
235 %description js-debugger -l pl.UTF-8
236 Odpluskwiacz JavaScriptu do używania z Iceape.
237
238 %package dom-inspector
239 Summary:        A tool for inspecting the DOM of pages in Iceape
240 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w Iceape
241 Group:          X11/Applications/Networking
242 Requires(post,postun):  %{name} = %{epoch}:%{version}-%{release}
243 Requires:       %{name} = %{epoch}:%{version}-%{release}
244 Obsoletes:      mozilla-dom-inspector
245 Obsoletes:      seamonkey-dom-inspector
246
247 %description dom-inspector
248 This is a tool that allows you to inspect the DOM for web pages in
249 Iceape. This is of great use to people who are doing Iceape chrome
250 development or web page development.
251
252 %description dom-inspector -l pl.UTF-8
253 To narzędzie pozwala na oglądanie DOM dla stron WWW w Iceape. Jest
254 bardzo przydatne dla ludzi rozwijających chrome w Iceape lub
255 tworzących strony WWW.
256
257 %prep
258 %setup -qc
259 cd comm-release
260 tar -C mailnews/extensions -zxf %{SOURCE1}
261 tar -jxf %{SOURCE2}
262 %patch0 -p1
263 %patch1 -p1
264 %patch2 -p1
265 %patch3 -p2
266 %patch4 -p1
267 %patch5 -p1
268 %patch7 -p1
269 %patch8 -p1
270 %patch9 -p2
271
272 %build
273 cd comm-release
274 %if %{with xulrunner}
275 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
276         echo >&2
277         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
278         echo >&2
279         exit 1
280 fi
281 %endif
282
283 cp -f %{_datadir}/automake/config.* build/autoconf
284 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
285 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
286 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
287
288 cat << EOF > .mozconfig
289 mk_add_options MOZ_OBJDIR=%{objdir}
290
291 export CFLAGS="%{rpmcflags}"
292 export CXXFLAGS="%{rpmcflags}"
293
294 %if %{with crashreporter}
295 export MOZ_DEBUG_SYMBOLS=1
296 %endif
297
298 # Options for 'configure' (same as command-line options).
299 ac_add_options --prefix=%{_prefix}
300 ac_add_options --exec-prefix=%{_exec_prefix}
301 ac_add_options --bindir=%{_bindir}
302 ac_add_options --sbindir=%{_sbindir}
303 ac_add_options --sysconfdir=%{_sysconfdir}
304 ac_add_options --datadir=%{_datadir}
305 ac_add_options --includedir=%{_includedir}
306 ac_add_options --libdir=%{_libdir}
307 ac_add_options --libexecdir=%{_libexecdir}
308 ac_add_options --localstatedir=%{_localstatedir}
309 ac_add_options --sharedstatedir=%{_sharedstatedir}
310 ac_add_options --mandir=%{_mandir}
311 ac_add_options --infodir=%{_infodir}
312 %if %{?debug:1}0
313 ac_add_options --disable-optimize
314 ac_add_options --enable-debug
315 ac_add_options --enable-debug-modules
316 ac_add_options --enable-debugger-info-modules
317 ac_add_options --enable-crash-on-assert
318 %else
319 ac_add_options --disable-debug
320 ac_add_options --disable-debug-modules
321 ac_add_options --disable-logging
322 ac_add_options --enable-optimize="%{rpmcflags} -Os"
323 %endif
324 ac_add_options --disable-strip
325 ac_add_options --disable-strip-libs
326 %if %{with tests}
327 ac_add_options --enable-tests
328 %else
329 ac_add_options --disable-tests
330 %endif
331 ac_add_options --enable-gio
332 ac_add_options --disable-gnomeui
333 ac_add_options --disable-gnomevfs
334 %if %{with ldap}
335 ac_add_options --enable-ldap
336 ac_add_options --with-system-ldap
337 %else
338 ac_add_options --disable-ldap
339 %endif
340 %if %{with crashreporter}
341 ac_add_options --enable-crashreporter
342 %else
343 ac_add_options --disable-crashreporter
344 %endif
345 ac_add_options --disable-xterm-updates
346 ac_add_options --enable-postscript
347 %if %{with lightning}
348 ac_add_options --enable-calendar
349 %else
350 ac_add_options --disable-calendar
351 %endif
352 ac_add_options --disable-elf-dynstr-gc
353 ac_add_options --disable-installer
354 ac_add_options --disable-javaxpcom
355 ac_add_options --disable-updater
356 ac_add_options --enable-crypto
357 ac_add_options --enable-libxul
358 ac_add_options --enable-pango
359 ac_add_options --enable-shared-js
360 ac_add_options --enable-startup-notification
361 ac_add_options --enable-system-cairo
362 ac_add_options --enable-system-hunspell
363 ac_add_options --enable-system-sqlite
364 ac_add_options --enable-application=suite
365 ac_add_options --with-distribution-id=org.pld-linux
366 ac_add_options --with-branding=iceape/branding
367 %if %{with xulrunner}
368 ac_add_options --with-system-libxul
369 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
370 %endif
371 ac_add_options --with-pthreads
372 ac_add_options --with-system-bz2
373 ac_add_options --with-system-ffi
374 ac_add_options --with-system-jpeg
375 ac_add_options --with-system-libevent
376 ac_add_options --with-system-libvpx
377 ac_add_options --with-system-nspr
378 ac_add_options --with-system-nss
379 ac_add_options --with-system-png
380 ac_add_options --with-system-zlib
381 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
382 EOF
383
384 %{__make} -j1 -f client.mk build \
385         STRIP="/bin/true" \
386         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
387         installdir=%{_libdir}/%{name} \
388         XLIBS="-lX11 -lXt" \
389         CC="%{__cc}" \
390         CXX="%{__cxx}"
391
392 %if %{with crashreporter}
393 # create debuginfo for crash-stats.mozilla.com
394 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
395 %endif
396
397 %if %{with enigmail}
398 cd mailnews/extensions/enigmail
399 ./makemake -r -o %{objdir}
400 %{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail \
401         STRIP="/bin/true" \
402         CC="%{__cc}" \
403         CXX="%{__cxx}"
404
405 %{__make} -j1 -C %{objdir}/mailnews/extensions/enigmail xpi \
406         STRIP="/bin/true" \
407         CC="%{__cc}" \
408         CXX="%{__cxx}"
409 %endif
410
411 %install
412 rm -rf $RPM_BUILD_ROOT
413 cd comm-release
414 install -d \
415         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
416         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
417         $RPM_BUILD_ROOT%{_datadir}/%{name} \
418         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
419
420 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
421
422 cd %{objdir}
423 cwd=`pwd`
424 %{__make} -C suite/installer stage-package \
425         LD_LIBRARY_PATH=$cwd/mozilla/dist/lib \
426         DESTDIR=$RPM_BUILD_ROOT \
427         installdir=%{_libdir}/%{name} \
428         PKG_SKIP_STRIP=1
429
430 %{__make} -C iceape/branding install \
431         DESTDIR=$RPM_BUILD_ROOT
432
433 cp -a mozilla/dist/iceape/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
434
435 %if %{with xulrunner}
436 # >= 5.0 seems to require this
437 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
438 %endif
439
440 # Enable crash reporter for Thunderbird application
441 %if %{with crashreporter}
442 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
443
444 # Add debuginfo for crash-stats.mozilla.com
445 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
446 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
447 %endif
448
449 # copy manually lightning files, somewhy they are not installed by make
450 cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
451         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
452
453 # move arch independant ones to datadir
454 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
455 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
456 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
457 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
458
459 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
460 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
461 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
462 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
463
464 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
465         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
466
467 # dir for arch independant extensions besides arch dependant extensions
468 # see mozilla/xpcom/build/nsXULAppAPI.h
469 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
470 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
471  
472 %if %{without xulrunner}
473 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
474 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
475 %endif
476
477 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
478          -e "s|%MOZ_APP_DISPLAYNAME%|Iceape|" \
479         %{topdir}/comm-release/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/iceape
480
481 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE9} > $RPM_BUILD_ROOT%{_bindir}/iceape
482 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/iceape
483
484 install %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
485         $RPM_BUILD_ROOT%{_desktopdir}
486
487 # files created by iceape -register
488 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
489 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
490
491 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
492 #!/bin/sh
493 umask 022
494 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
495
496 # it attempts to touch files in $HOME/.mozilla
497 # beware if you run this with sudo!!!
498 export HOME=$(mktemp -d)
499 # also TMPDIR could be pointing to sudo user's homedir
500 unset TMPDIR TMP || :
501
502 %{_libdir}/%{name}/iceape -register
503
504 rm -rf $HOME
505 EOF
506 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
507
508 %if %{with enigmail}
509 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
510 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
511 cd mozilla/dist/bin
512 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
513 cp -rfLp components/enig* $ext_dir/components
514 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
515 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
516 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
517 cd -
518 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/install.rdf $ext_dir
519 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
520 %endif
521
522 # never package these. always remove
523 # nss
524 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
525 # nspr
526 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
527 # mozldap
528 %{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
529 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
530 # testpilot quiz
531 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
532
533 %clean
534 rm -rf $RPM_BUILD_ROOT
535
536 %post
537 %{_libdir}/%{name}/register || :
538 %update_browser_plugins
539 %update_icon_cache hicolor
540 %update_desktop_database
541
542 %postun
543 if [ "$1" = 0 ]; then
544         %update_browser_plugins
545         %update_icon_cache hicolor
546 fi
547
548 %files
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/iceape
551
552 # browser plugins v2
553 %{_browserpluginsconfdir}/browsers.d/%{name}.*
554 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
555
556 %dir %{_libdir}/%{name}
557 %if %{without xulrunner}
558 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
559 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
560 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
561 %endif
562
563 %{_libdir}/%{name}/blocklist.xml
564 %{_libdir}/%{name}/omni.ja
565 %attr(755,root,root) %{_libdir}/%{name}/register
566
567 %if %{with crashreporter}
568 %{_libdir}/%{name}/crashreporter
569 %{_libdir}/%{name}/crashreporter-override.ini
570 %{_libdir}/%{name}/crashreporter.ini
571 %{_libdir}/%{name}/Throbber-small.gif
572 %endif
573
574 # config?
575 %{_libdir}/%{name}/application.ini
576 %{_libdir}/%{name}/chrome.manifest
577
578 %dir %{_libdir}/%{name}/components
579 %{_libdir}/%{name}/components/components.manifest
580 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
581
582 %if %{without xulrunner}
583 %{_libdir}/%{name}/dependentlibs.list
584 %{_libdir}/%{name}/platform.ini
585 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
586 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
587 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
588 %attr(755,root,root) %{_libdir}/%{name}/iceape-bin
589 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
590 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
591 %endif
592
593 %attr(755,root,root) %{_libdir}/%{name}/iceape
594 %dir %{_libdir}/%{name}/plugins
595
596 # symlinks
597 %{_libdir}/%{name}/chrome
598 %{_libdir}/%{name}/defaults
599 %{_libdir}/%{name}/searchplugins
600 %if %{with xulrunner}
601 %{_libdir}/%{name}/xulrunner
602 %else
603 %{_libdir}/%{name}/dictionaries
604 %endif
605
606 %dir %{_datadir}/%{name}
607 %{_datadir}/%{name}/chrome
608 %{_datadir}/%{name}/defaults
609 %{_datadir}/%{name}/searchplugins
610
611 %dir %{_datadir}/%{name}/extensions
612 %dir %{_libdir}/%{name}/extensions
613 # the signature of the default theme
614 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
615 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
616
617 # files created by iceape -register
618 %ghost %{_libdir}/%{name}/components/compreg.dat
619 %ghost %{_libdir}/%{name}/components/xpti.dat
620
621 %{_libdir}/%{name}/isp
622 %dir %{_datadir}/%{name}/isp
623 %{_datadir}/%{name}/isp/Bogofilter.sfd
624 %{_datadir}/%{name}/isp/DSPAM.sfd
625 %{_datadir}/%{name}/isp/POPFile.sfd
626 %{_datadir}/%{name}/isp/SpamAssassin.sfd
627 %{_datadir}/%{name}/isp/SpamPal.sfd
628 %{_datadir}/%{name}/isp/movemail.rdf
629 %{_datadir}/%{name}/isp/rss.rdf
630
631 %{_iconsdir}/hicolor/*/apps/iceape.png
632 %{_iconsdir}/hicolor/scalable/apps/iceape.svg
633 %{_desktopdir}/%{name}.desktop
634 %{_desktopdir}/%{name}-composer.desktop
635 %{_desktopdir}/%{name}-mail.desktop
636
637 %if %{with lightning}
638 %files addon-lightning
639 %defattr(644,root,root,755)
640 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
641 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
642 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
643 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
644 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
645 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
646 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
647 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
648 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
649 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
650 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
651 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
652 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
653 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
654 %endif
655
656 %if %{with enigmail}
657 %files addon-enigmail
658 %defattr(644,root,root,755)
659 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
660 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
661 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
662 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
663 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
664 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
665 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
666 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
667 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
668 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
669 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
670 %endif
671
672 %files chat
673 %defattr(644,root,root,755)
674 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
675 %{_desktopdir}/%{name}-chat.desktop
676
677 %files js-debugger
678 %defattr(644,root,root,755)
679 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
680 %{_desktopdir}/%{name}-venkman.desktop
681
682 %files dom-inspector
683 %defattr(644,root,root,755)
684 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.135946 seconds and 2 git commands to generate.