]> git.pld-linux.org Git - packages/iceape.git/blob - iceape.spec
- release 3 (by relup.sh)
[packages/iceape.git] / iceape.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk3            # GTK+ 3.x instead of 2.x
4 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
5 %bcond_without  lightning       # disable Sunbird/Lightning calendar
6 %bcond_without  kerberos        # disable krb5 support
7 %bcond_with     xulrunner       # build with system xulrunner
8 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
9 %bcond_with     tests           # enable tests (whatever they check)
10
11 %define         nspr_ver        4.10.3
12 %define         nss_ver         3.16
13 %define         xulrunner_ver   29.0
14
15 %if %{without xulrunner}
16 # The actual sqlite version (see RHBZ#480989):
17 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
18 %endif
19
20 Summary:        Iceape - web browser
21 Summary(es.UTF-8):      Navegador de Internet Iceape
22 Summary(pl.UTF-8):      Iceape - przeglądarka WWW
23 Summary(pt_BR.UTF-8):   Navegador Iceape
24 Name:           iceape
25 Version:        2.26.1
26 Release:        3
27 License:        MPL v2.0
28 Group:          X11/Applications/Networking
29 Source0:        http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/seamonkey-%{version}.source.tar.bz2
30 # Source0-md5:  4bfa46b370b4d211eef56b90277a9517
31 Source2:        %{name}-branding.tar.bz2
32 # Source2-md5:  3feee544ef515f1dbf19b14479916784
33 Source3:        %{name}-rm_nonfree.sh
34 Source4:        %{name}.desktop
35 Source5:        %{name}-composer.desktop
36 Source6:        %{name}-chat.desktop
37 Source7:        %{name}-mail.desktop
38 Source8:        %{name}-venkman.desktop
39 Source9:        %{name}.sh
40 Patch0:         %{name}-branding.patch
41 Patch1:         %{name}-pld-branding.patch
42 Patch2:         %{name}-agent.patch
43 Patch3:         enable-addons.patch
44 Patch4:         system-mozldap.patch
45 Patch5:         makefile.patch
46 Patch6:         %{name}-pixman.patch
47 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
48 Patch7:         system-virtualenv.patch
49 Patch8:         libvpx2.patch
50 Patch9:         %{name}-system-xulrunner.patch
51 URL:            http://www.pld-linux.org/Packages/Iceape
52 BuildRequires:  GConf2-devel >= 1.2.1
53 BuildRequires:  OpenGL-devel
54 BuildRequires:  alsa-lib-devel
55 BuildRequires:  automake
56 BuildRequires:  bzip2-devel
57 BuildRequires:  cairo-devel >= 1.10.2-5
58 BuildRequires:  dbus-glib-devel >= 0.60
59 BuildRequires:  freetype-devel >= 1:2.1.8
60 BuildRequires:  glib2-devel >= 1:2.20
61 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.18}
62 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
63 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
64 BuildRequires:  hunspell-devel
65 BuildRequires:  libIDL-devel >= 0.8.0
66 BuildRequires:  libdnet-devel
67 BuildRequires:  libevent-devel >= 1.4.7
68 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
69 BuildRequires:  libffi-devel >= 6:3.0.9
70 BuildRequires:  libicu-devel >= 50.1
71 # requires libjpeg-turbo implementing at least libjpeg 6b API
72 BuildRequires:  libjpeg-devel >= 6b
73 BuildRequires:  libjpeg-turbo-devel
74 BuildRequires:  libnotify-devel >= 0.4
75 BuildRequires:  libpng(APNG)-devel >= 0.10
76 BuildRequires:  libpng-devel >= 2:1.6.7
77 # rsvg-convert for iceape/branding
78 BuildRequires:  librsvg
79 BuildRequires:  libstdc++-devel
80 BuildRequires:  libvpx-devel >= 1.3.0
81 BuildRequires:  mozldap-devel
82 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
83 BuildRequires:  nss-devel >= 1:%{nss_ver}
84 BuildRequires:  pango-devel >= 1:1.14.0
85 BuildRequires:  perl-base >= 1:5.6
86 BuildRequires:  perl-modules >= 5.004
87 BuildRequires:  pkgconfig
88 BuildRequires:  python >= 1:2.5
89 BuildRequires:  python-modules
90 BuildRequires:  python-virtualenv
91 BuildRequires:  rpm >= 4.4.9-56
92 BuildRequires:  rpmbuild(macros) >= 1.601
93 BuildRequires:  sed >= 4.0
94 BuildRequires:  sqlite3-devel >= 3.8.2
95 BuildRequires:  startup-notification-devel >= 0.8
96 BuildRequires:  xorg-lib-libX11-devel
97 BuildRequires:  xorg-lib-libXScrnSaver-devel
98 BuildRequires:  xorg-lib-libXext-devel
99 BuildRequires:  xorg-lib-libXinerama-devel
100 BuildRequires:  xorg-lib-libXt-devel
101 %if %{with xulrunner}
102 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
103 BuildRequires:  xulrunner-devel < 2:30
104 %endif
105 BuildRequires:  yasm
106 BuildRequires:  zip
107 BuildRequires:  zlib-devel >= 1.2.3
108 Requires(post): mktemp >= 1.5-18
109 Requires:       desktop-file-utils
110 Requires:       hicolor-icon-theme
111 %if %{with xulrunner}
112 %requires_eq_to xulrunner xulrunner-devel
113 %else
114 Requires:       browser-plugins >= 2.0
115 Requires:       cairo >= 1.10.2-5
116 Requires:       dbus-glib >= 0.60
117 Requires:       glib2 >= 1:2.20
118 %{!?with_gtk3:Requires: gtk+2 >= 2:2.18}
119 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
120 Requires:       libjpeg-turbo
121 Requires:       libpng >= 2:1.6.7
122 Requires:       libpng(APNG) >= 0.10
123 Requires:       libvpx >= 1.3.0
124 Requires:       myspell-common
125 Requires:       nspr >= 1:%{nspr_ver}
126 Requires:       nss >= 1:%{nss_ver}
127 Requires:       pango >= 1:1.14.0
128 Requires:       sqlite3 >= %{sqlite_build_version}
129 Requires:       startup-notification >= 0.8
130 %endif
131 Provides:       iceape-embedded = %{version}-%{release}
132 Provides:       wwwbrowser
133 Obsoletes:      iceape-mailnews
134 Obsoletes:      iceape-gnomevfs
135 Obsoletes:      light
136 Obsoletes:      mozilla
137 Obsoletes:      mozilla-gnomevfs
138 Obsoletes:      seamonkey
139 Obsoletes:      seamonkey-calendar
140 Obsoletes:      seamonkey-libs
141 Obsoletes:      seamonkey-mailnews
142 Obsoletes:      seamonkey-gnomevfs
143 Conflicts:      iceape-lang-resources < %{version}
144 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
145
146 %define         topdir          %{_builddir}/%{name}-%{version}
147 %define         objdir          %{topdir}/obj-%{_target_cpu}
148
149 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
150
151 # don't satisfy other packages
152 %define         _noautoprovfiles        %{_libdir}/%{name}
153 # and as we don't provide them, don't require either
154 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
155 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
156
157 %description
158 Iceape is an open-source web browser, designed for standards
159 compliance, performance and portability.
160
161 %description -l es.UTF-8
162 Iceape es un navegador de Internet que se basa en una versión inicial
163 de Netscape Communicator.
164
165 %description -l pl.UTF-8
166 Iceape jest potężną graficzną przeglądarką WWW, która jest następcą
167 Mozilli, która następnie była następczynią Netscape Communikatora.
168
169 %description -l pt_BR.UTF-8
170 O Iceape é um web browser baseado numa versão inicial do Netscape
171 Communicator.
172
173 %description -l ru.UTF-8
174 Iceape - полнофункциональный web-browser с открытыми исходными
175 текстами, разработанный для максимального соотвествия стандартам,
176 максмимальной переносимости и скорости работы
177
178 %package addon-lightning
179 Summary:        An integrated calendar for Iceape
180 Summary(pl.UTF-8):      Zintegrowany kalendarz dla Iceape
181 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
182 Group:          Applications/Networking
183 Requires:       %{name} = %{version}-%{release}
184 Obsoletes:      seamonkey-addon-lightning
185
186 %description addon-lightning
187 Lightning is an calendar extension to Icedove email client.
188
189 %description addon-lightning -l pl.UTF-8
190 Lightning to rozszerzenie do klienta poczty Icedove dodające
191 funkcjonalność kalendarza.
192
193 %package chat
194 Summary:        Iceape Chat - integrated IRC client
195 Summary(pl.UTF-8):      Iceape Chat - zintegrowany klient IRC-a
196 Group:          X11/Applications/Networking
197 Requires(post,postun):  %{name} = %{version}-%{release}
198 Requires:       %{name} = %{version}-%{release}
199 Obsoletes:      mozilla-chat
200 Obsoletes:      seamonkey-chat
201
202 %description chat
203 Iceape Chat - IRC client that is integrated with the Iceape web
204 browser.
205
206 %description chat -l pl.UTF-8
207 Iceape - klient IRC-a zintegrowany z przeglądarką Iceape.
208
209 %package js-debugger
210 Summary:        JavaScript debugger for use with Iceape
211 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z Iceape
212 Group:          X11/Applications/Networking
213 Requires(post,postun):  %{name} = %{version}-%{release}
214 Requires:       %{name} = %{version}-%{release}
215 Obsoletes:      mozilla-js-debugger
216 Obsoletes:      seamonkey-js-debugger
217
218 %description js-debugger
219 JavaScript debugger for use with Iceape.
220
221 %description js-debugger -l pl.UTF-8
222 Odpluskwiacz JavaScriptu do używania z Iceape.
223
224 %package dom-inspector
225 Summary:        A tool for inspecting the DOM of pages in Iceape
226 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w Iceape
227 Group:          X11/Applications/Networking
228 Requires(post,postun):  %{name} = %{version}-%{release}
229 Requires:       %{name} = %{version}-%{release}
230 Obsoletes:      mozilla-dom-inspector
231 Obsoletes:      seamonkey-dom-inspector
232
233 %description dom-inspector
234 This is a tool that allows you to inspect the DOM for web pages in
235 Iceape. This is of great use to people who are doing Iceape chrome
236 development or web page development.
237
238 %description dom-inspector -l pl.UTF-8
239 To narzędzie pozwala na oglądanie DOM dla stron WWW w Iceape. Jest
240 bardzo przydatne dla ludzi rozwijających chrome w Iceape lub
241 tworzących strony WWW.
242
243 %prep
244 %setup -qc
245 cd comm-release
246 tar -jxf %{SOURCE2}
247 %patch0 -p1
248 %patch1 -p1
249 %patch2 -p1
250 %patch3 -p2
251 %patch4 -p1
252 %patch5 -p1
253 %patch6 -p1
254 %patch7 -p1
255 %patch8 -p1
256 %patch9 -p2
257
258 %build
259 cd comm-release
260 %if %{with xulrunner}
261 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
262         echo >&2
263         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
264         echo >&2
265         exit 1
266 fi
267 %endif
268
269 cp -f %{_datadir}/automake/config.* build/autoconf
270 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
271 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
272 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
273
274 cat << EOF > .mozconfig
275 mk_add_options MOZ_OBJDIR=%{objdir}
276
277 export CFLAGS="%{rpmcflags}"
278 export CXXFLAGS="%{rpmcflags}"
279
280 %if %{with crashreporter}
281 export MOZ_DEBUG_SYMBOLS=1
282 %endif
283
284 # Options for 'configure' (same as command-line options).
285 ac_add_options --prefix=%{_prefix}
286 ac_add_options --exec-prefix=%{_exec_prefix}
287 ac_add_options --bindir=%{_bindir}
288 ac_add_options --sbindir=%{_sbindir}
289 ac_add_options --sysconfdir=%{_sysconfdir}
290 ac_add_options --datadir=%{_datadir}
291 ac_add_options --includedir=%{_includedir}
292 ac_add_options --libdir=%{_libdir}
293 ac_add_options --libexecdir=%{_libexecdir}
294 ac_add_options --localstatedir=%{_localstatedir}
295 ac_add_options --sharedstatedir=%{_sharedstatedir}
296 ac_add_options --mandir=%{_mandir}
297 ac_add_options --infodir=%{_infodir}
298 %if %{?debug:1}0
299 ac_add_options --disable-optimize
300 ac_add_options --enable-debug
301 ac_add_options --enable-debug-modules
302 ac_add_options --enable-debugger-info-modules
303 ac_add_options --enable-crash-on-assert
304 %else
305 ac_add_options --disable-debug
306 ac_add_options --disable-debug-modules
307 ac_add_options --disable-logging
308 ac_add_options --enable-optimize="%{rpmcflags} -Os"
309 %endif
310 ac_add_options --disable-strip
311 ac_add_options --disable-strip-libs
312 %if %{with tests}
313 ac_add_options --enable-tests
314 %else
315 ac_add_options --disable-tests
316 %endif
317 %if %{with lightning}
318 ac_add_options --enable-calendar
319 %else
320 ac_add_options --disable-calendar
321 %endif
322 %if %{with crashreporter}
323 ac_add_options --enable-crashreporter
324 %else
325 ac_add_options --disable-crashreporter
326 %endif
327 ac_add_options --disable-elf-dynstr-gc
328 ac_add_options --disable-gnomeui
329 ac_add_options --disable-gnomevfs
330 ac_add_options --disable-installer
331 ac_add_options --disable-javaxpcom
332 ac_add_options --disable-updater
333 ac_add_options --disable-xterm-updates
334 ac_add_options --enable-application=suite
335 ac_add_options --enable-crypto
336 ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
337 ac_add_options --enable-gio
338 %if %{with ldap}
339 ac_add_options --enable-ldap
340 ac_add_options --with-system-ldap
341 %else
342 ac_add_options --disable-ldap
343 %endif
344 ac_add_options --enable-libxul
345 ac_add_options --enable-pango
346 ac_add_options --enable-postscript
347 ac_add_options --enable-shared-js
348 ac_add_options --enable-startup-notification
349 ac_add_options --enable-system-cairo
350 ac_add_options --enable-system-hunspell
351 ac_add_options --enable-system-sqlite
352 ac_add_options --with-branding=iceape/branding
353 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
354 ac_add_options --with-distribution-id=org.pld-linux
355 %if %{with xulrunner}
356 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
357 ac_add_options --with-system-libxul
358 %endif
359 ac_add_options --with-pthreads
360 ac_add_options --with-system-bz2
361 ac_add_options --with-system-ffi
362 ac_add_options --with-system-jpeg
363 ac_add_options --with-system-libevent
364 ac_add_options --with-system-libvpx
365 ac_add_options --with-system-nspr
366 ac_add_options --with-system-nss
367 ac_add_options --with-system-png
368 ac_add_options --with-system-zlib
369 EOF
370
371 %{__make} -j1 -f client.mk build \
372         STRIP="/bin/true" \
373         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
374         installdir=%{_libdir}/%{name} \
375         XLIBS="-lX11 -lXt" \
376         CC="%{__cc}" \
377         CXX="%{__cxx}"
378
379 %if %{with crashreporter}
380 # create debuginfo for crash-stats.mozilla.com
381 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
382 %endif
383
384 %install
385 rm -rf $RPM_BUILD_ROOT
386 cd comm-release
387 install -d \
388         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
389         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
390         $RPM_BUILD_ROOT%{_datadir}/%{name} \
391         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
392
393 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
394
395 cd %{objdir}
396 cwd=`pwd`
397 %{__make} -C suite/installer stage-package \
398         LD_LIBRARY_PATH=$cwd/mozilla/dist/lib \
399         DESTDIR=$RPM_BUILD_ROOT \
400         installdir=%{_libdir}/%{name} \
401         PKG_SKIP_STRIP=1
402
403 %{__make} -C iceape/branding install \
404         DESTDIR=$RPM_BUILD_ROOT
405
406 cp -a mozilla/dist/iceape/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
407
408 %if %{with xulrunner}
409 # >= 5.0 seems to require this
410 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
411 %endif
412
413 # Enable crash reporter for Thunderbird application
414 %if %{with crashreporter}
415 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
416
417 # Add debuginfo for crash-stats.mozilla.com
418 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
419 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
420 %endif
421
422 # copy manually lightning files, somewhy they are not installed by make
423 cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
424         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
425
426 # move arch independant ones to datadir
427 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
428 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
429 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
430
431 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
432 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
433 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
434
435 %if %{without xulrunner}
436 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
437 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
438 %endif
439
440 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
441         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
442
443 # dir for arch independant extensions besides arch dependant extensions
444 # see mozilla/xpcom/build/nsXULAppAPI.h
445 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
446 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
447  
448 %if %{without xulrunner}
449 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
450 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
451 %endif
452
453 %{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
454          -e "s|%MOZ_APP_DISPLAYNAME%|Iceape|" \
455         %{topdir}/comm-release/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/iceape
456
457 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE9} > $RPM_BUILD_ROOT%{_bindir}/iceape
458 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/iceape
459
460 install %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
461         $RPM_BUILD_ROOT%{_desktopdir}
462
463 # files created by iceape -register
464 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
465 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
466
467 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
468 #!/bin/sh
469 umask 022
470 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
471
472 # it attempts to touch files in $HOME/.mozilla
473 # beware if you run this with sudo!!!
474 export HOME=$(mktemp -d)
475 # also TMPDIR could be pointing to sudo user's homedir
476 unset TMPDIR TMP || :
477
478 %{_libdir}/%{name}/iceape -register
479
480 rm -rf $HOME
481 EOF
482 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
483
484 %if %{without xulrunner}
485 # never package these. always remove
486 # mozldap
487 %{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
488 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
489 %endif
490
491 %clean
492 rm -rf $RPM_BUILD_ROOT
493
494 %post
495 %{_libdir}/%{name}/register || :
496 %update_browser_plugins
497 %update_icon_cache hicolor
498 %update_desktop_database
499
500 %postun
501 if [ "$1" = 0 ]; then
502         %update_browser_plugins
503         %update_icon_cache hicolor
504 fi
505
506 %files
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_bindir}/iceape
509
510 # browser plugins v2
511 %{_browserpluginsconfdir}/browsers.d/%{name}.*
512 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
513
514 %dir %{_libdir}/%{name}
515 %if %{without xulrunner}
516 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
517 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
518 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
519 %endif
520
521 %{_libdir}/%{name}/blocklist.xml
522 %{_libdir}/%{name}/omni.ja
523 %attr(755,root,root) %{_libdir}/%{name}/register
524
525 %if %{with crashreporter}
526 %{_libdir}/%{name}/crashreporter
527 %{_libdir}/%{name}/crashreporter-override.ini
528 %{_libdir}/%{name}/crashreporter.ini
529 %{_libdir}/%{name}/Throbber-small.gif
530 %endif
531
532 # config?
533 %{_libdir}/%{name}/application.ini
534 %{_libdir}/%{name}/chrome.manifest
535
536 %dir %{_libdir}/%{name}/components
537 %{_libdir}/%{name}/components/components.manifest
538 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
539
540 %if %{without xulrunner}
541 %{_libdir}/%{name}/dependentlibs.list
542 %{_libdir}/%{name}/platform.ini
543 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
544 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
545 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
546 %attr(755,root,root) %{_libdir}/%{name}/iceape-bin
547 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
548 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
549 %endif
550
551 %attr(755,root,root) %{_libdir}/%{name}/iceape
552 %dir %{_libdir}/%{name}/plugins
553
554 # symlinks
555 %{_libdir}/%{name}/chrome
556 %{_libdir}/%{name}/defaults
557 %{_libdir}/%{name}/searchplugins
558 %if %{with xulrunner}
559 %{_libdir}/%{name}/xulrunner
560 %else
561 %{_libdir}/%{name}/dictionaries
562 %endif
563
564 %dir %{_datadir}/%{name}
565 %{_datadir}/%{name}/chrome
566 %{_datadir}/%{name}/defaults
567 %{_datadir}/%{name}/searchplugins
568
569 %dir %{_datadir}/%{name}/extensions
570 %dir %{_libdir}/%{name}/extensions
571 # the signature of the default theme
572 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
573 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
574
575 # files created by iceape -register
576 %ghost %{_libdir}/%{name}/components/compreg.dat
577 %ghost %{_libdir}/%{name}/components/xpti.dat
578
579 %if %{without xulrunner}
580 %{_libdir}/%{name}/isp
581 %dir %{_datadir}/%{name}/isp
582 %{_datadir}/%{name}/isp/Bogofilter.sfd
583 %{_datadir}/%{name}/isp/DSPAM.sfd
584 %{_datadir}/%{name}/isp/POPFile.sfd
585 %{_datadir}/%{name}/isp/SpamAssassin.sfd
586 %{_datadir}/%{name}/isp/SpamPal.sfd
587 %{_datadir}/%{name}/isp/movemail.rdf
588 %{_datadir}/%{name}/isp/rss.rdf
589 %endif
590
591 %{_iconsdir}/hicolor/*/apps/iceape.png
592 %{_iconsdir}/hicolor/scalable/apps/iceape.svg
593 %{_desktopdir}/%{name}.desktop
594 %{_desktopdir}/%{name}-composer.desktop
595 %{_desktopdir}/%{name}-mail.desktop
596
597 %if %{with lightning}
598 %files addon-lightning
599 %defattr(644,root,root,755)
600 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
601 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
602 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
603 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
604 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
605 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
606 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
607 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
608 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
609 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
610 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
611 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
612 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
613 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
614 %endif
615
616 %files chat
617 %defattr(644,root,root,755)
618 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
619 %{_desktopdir}/%{name}-chat.desktop
620
621 %files js-debugger
622 %defattr(644,root,root,755)
623 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
624 %{_desktopdir}/%{name}-venkman.desktop
625
626 %files dom-inspector
627 %defattr(644,root,root,755)
628 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.112999 seconds and 3 git commands to generate.