]> git.pld-linux.org Git - packages/ice.git/blob - ice.spec
b53216ba992e20fca1b06a751215b51d076e917d
[packages/ice.git] / ice.spec
1 # TODO
2 # - finish (pldize) -servers package
3 #
4 # Conditional build:
5 %bcond_without  gui                     # IceGrid GUI
6 %bcond_without  dotnet          # .NET bindings
7 %bcond_without  java            # Java bindings
8 %bcond_without  php                     # PHP bindings
9 %bcond_without  python          # Python bindings
10 %bcond_without  ruby            # Ruby bindings
11
12 %if %{without java}
13 %undefine       with_gui
14 %endif
15
16 # fails with php5.5, use php5.3
17 %if "%{?php_suffix}" == ""
18 %define         php_suffix      53
19 %endif
20 %define         php_name        php%{?php_suffix}
21
22 %{?with_java:%include   /usr/lib/rpm/macros.java}
23 Summary:        The Ice base runtime and services
24 Name:           ice
25 Version:        3.4.2
26 Release:        7
27 License:        GPL v2 with exceptions (see ICE_LICENSE)
28 Group:          Applications
29 Source0:        http://www.zeroc.com/download/Ice/3.4/Ice-%{version}.tar.gz
30 # Source0-md5:  e97672eb4a63c6b8dd202d0773e19dc7
31 # Extracted from http://zeroc.com/download/Ice/3.4/ice-3.4.0-1.src.rpm
32 Source1:        Ice-rpmbuild-3.4.0.tar.gz
33 # Source1-md5:  869cc60645e7e2b4115584a5ab17d1e9
34 # Man pages courtesy of Francisco Moya's Debian packages
35 Source2:        Ice-3.3.0-man-pages.tbz2
36 # Source2-md5:  c6c17ee1be2e6b615af5b40edae88b75
37 Source3:        %{name}gridgui
38 Source4:        IceGridAdmin.desktop
39 Patch0:         %{name}-build.patch
40 Patch1:         dont-build-demo-test.patch
41 Patch2:         java-build.patch
42 Patch3:         jgoodies.patch
43 Patch4:         %{name}-gcc46.patch
44 Patch5:         %{name}-gcc47.patch
45 Patch6:         %{name}-db.patch
46 Patch7:         %{name}-format-security.patch
47 URL:            http://www.zeroc.com/
48 BuildRequires:  bzip2-devel
49 BuildRequires:  db-cxx-devel
50 BuildRequires:  expat-devel
51 BuildRequires:  mcpp-devel
52 BuildRequires:  openssl-devel
53 BuildRequires:  rpmbuild(macros) >= 1.665
54 %if %{with gui}
55 BuildRequires:  ImageMagick
56 BuildRequires:  ImageMagick-coder-png
57 %endif
58 %if %{with dotnet}
59 BuildRequires:  mono-csharp
60 %endif
61 %if %{with java}
62 BuildRequires:  ant
63 BuildRequires:  db-java-devel
64 BuildRequires:  java-jgoodies-common
65 BuildRequires:  java-jgoodies-forms
66 BuildRequires:  java-jgoodies-looks
67 BuildRequires:  jdk
68 BuildRequires:  jpackage-utils
69 BuildRequires:  rpm-javaprov
70 %endif
71 %if %{with php}
72 BuildRequires:  %{php_name}-devel >= 3:5.0.0
73 %endif
74 %if %{with python}
75 BuildRequires:  python-devel
76 BuildRequires:  rpm-pythonprov
77 %endif
78 %if %{with ruby}
79 BuildRequires:  rpm-rubyprov
80 BuildRequires:  ruby >= 1:1.8.6
81 BuildRequires:  ruby-devel
82 %endif
83 # Ice doesn't officially support ppc64 at all; sparc64 doesnt have mono
84 ExcludeArch:    ppc64 sparc64
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 # Some file suffixes we need to grab the right stuff for the file lists
88 %define         soversion       34
89
90 %description
91 Ice is a modern alternative to object middleware such as CORBA or
92 COM/DCOM/COM+. It is easy to learn, yet provides a powerful network
93 infrastructure for demanding technical applications. It features an
94 object-oriented specification language, easy to use C++, C#, Java,
95 Python, Ruby, PHP, and Visual Basic mappings, a highly efficient
96 protocol, asynchronous method invocation and dispatch, dynamic
97 transport plug-ins, TCP/IP and UDP/IP support, SSL-based security, a
98 firewall solution, and much more.
99
100 %package devel
101 Summary:        Tools for developing Ice applications in C++
102 Group:          Development/Libraries
103 Requires:       %{name} = %{version}-%{release}
104
105 %description devel
106 Tools for developing Ice applications in C++.
107
108 %package servers
109 Summary:        Ice services to run through /etc/rc.d/init.d
110 Group:          Development/Tools
111 Requires(post,preun):   /sbin/chkconfig
112 Requires:       %{name} = %{version}-%{release}
113 Requires:       rc-scripts
114
115 %description servers
116 Ice services to run through /etc/rc.d/init.d
117
118 %package -n icegrid-gui
119 Summary:        IceGrid Admin Tool
120 Group:          Development/Tools
121 Requires:       %{name} = %{version}-%{release}
122 Requires:       java-%{name} = %{version}-%{release}
123 Requires:       java-jgoodies-forms
124 Requires:       java-jgoodies-looks
125 Requires:       jpackage-utils
126
127 %description -n icegrid-gui
128 Graphical administration tool for IceGrid
129
130 %package -n java-%{name}
131 Summary:        The Ice runtime for Java
132 Group:          Libraries/Java
133 Requires:       %{name} = %{version}-%{release}
134 Requires:       db-java
135 Requires:       jpackage-utils
136
137 %description -n java-%{name}
138 The Ice runtime for Java
139
140 %package -n csharp-%{name}
141 Summary:        The Ice runtime for C#
142 Group:          Libraries
143 Requires:       %{name} = %{version}-%{release}
144 Requires:       mono >= 1.2.2
145
146 %description -n csharp-%{name}
147 The Ice runtime for C#
148
149 %package -n ruby-%{name}
150 Summary:        The Ice runtime for Ruby applications
151 Group:          Development/Languages
152 Requires:       %{name} = %{version}-%{release}
153
154 %description -n ruby-%{name}
155 The Ice runtime for Ruby applications.
156
157 %package -n python-%{name}
158 Summary:        The Ice runtime for Python applications
159 Group:          Development/Languages/Python
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       python >= 1:2.3.4
162
163 %description -n python-%{name}
164 The Ice runtime for Python applications.
165
166 %package -n %{php_name}-%{name}
167 Summary:        The Ice runtime for PHP applications
168 Group:          Development/Languages/PHP
169 Requires:       %{name} = %{version}-%{release}
170 %{?requires_php_extension}
171
172 %description -n %{php_name}-%{name}
173 The Ice runtime for PHP applications.
174
175 %prep
176 %setup -q -n Ice-%{version} -a1 -a2
177 %patch0 -p0
178 %patch1 -p1
179 %patch2 -p1
180 %patch3 -p1
181 %patch4 -p1
182 %patch5 -p1
183 %patch6 -p1
184 %patch7 -p1
185
186 # no longer included in 3.4
187 rm -f *man-pages/slice2docbook.1
188
189 # Fix the encoding and line-endings of all the IceGridAdmin documentation files
190 cd java/resources/IceGridAdmin
191 %undos -f js,css
192
193 for f in helpman_topicinit.js icegridadmin_navigation.js IceGridAdmin_popup_html.js zoom_pageinfo.js; do
194         iconv -f ISO88591 -t UTF8 $f -o $f.tmp
195         mv $f.tmp $f
196 done
197 cd -
198
199 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' cpp/src/ca/iceca
200
201 %if %{with java}
202 # we nuke it only when we build new class later, as ice build system expects the file being around
203 rm cpp/src/ca/ImportKey.class
204 %endif
205
206 # update path to our install
207 sed -i -e 's,/usr/share/Ice-%{version},%{_datadir}/Ice,' cpp/src/ca/iceca Ice-rpmbuild-*/icegridregistry.conf
208
209 # force our CC/CXX as build system compares for exactly "c++" to setup other rules
210 sed -i -e 's,c++,%{__cxx},g' cpp/config/Make.rules.Linux
211
212 %build
213 # Compile the main Ice runtime
214 # TODO: CC/CXX passing as make param breaks build system
215
216 %if %{with java}
217 # Rebuild the Java ImportKey class - need it early for main cpp build
218 javac cpp/src/ca/ImportKey.java
219 %endif
220
221 %{__make} -j1 -C cpp \
222         CC="%{__cc}" \
223         CXX="%{__cxx}" \
224         CFLAGS="%{rpmcflags} -fPIC" \
225         CXXFLAGS="%{rpmcxxflags} -fPIC" \
226         embedded_runpath_prefix=""
227
228 %if %{with gui}
229 # Create the IceGrid icon
230 convert java/resources/icons/icegrid.ico temp.png
231 mv temp-8.png java/resources/icons/icegrid.png
232 rm temp*.png
233 %endif
234
235 %if %{with java}
236
237 # Set the CLASSPATH correctly for the Java compile
238 export CLASSPATH=$(build-classpath db jgoodies-forms jgoodies-looks)
239
240 %{__make} -j1 -C java \
241         CC="%{__cc}" \
242         CXX="%{__cxx}" \
243         CFLAGS="%{rpmcflags} -fPIC" \
244         CXXFLAGS="%{rpmcxxflags} -fPIC" \
245         embedded_runpath_prefix=""
246 %endif
247
248 %if %{with dotnet}
249 %{__make} -j1 -C cs \
250         CC="%{__cc}" \
251         CXX="%{__cxx}" \
252         CFLAGS="%{rpmcflags} -fPIC" \
253         CXXFLAGS="%{rpmcxxflags} -fPIC" \
254         embedded_runpath_prefix=""
255 %endif
256
257 %if %{with python}
258 %{__make} -j1 -C py \
259         CC="%{__cc}" \
260         CXX="%{__cxx}" \
261         CFLAGS="%{rpmcflags} -fPIC" \
262         CXXFLAGS="%{rpmcxxflags} -fPIC" \
263         embedded_runpath_prefix=""
264 %endif
265
266 %if %{with ruby}
267 %{__make} -j1 -C rb \
268         CC="%{__cc}" \
269         CXX="%{__cxx}" \
270         CFLAGS="%{rpmcflags} -fPIC" \
271         CXXFLAGS="%{rpmcxxflags} -fPIC" \
272         embedded_runpath_prefix=""
273 %endif
274
275 %if %{with php}
276 %{__make} -j1 -C php \
277         CC="%{__cc}" \
278         CXX="%{__cxx}" \
279         PHP_HOME=%{_prefix} \
280         CFLAGS="%{rpmcflags} -fPIC" \
281         CXXFLAGS="%{rpmcxxflags} -fPIC" \
282         embedded_runpath_prefix=""
283 %endif
284
285 %install
286 rm -rf $RPM_BUILD_ROOT
287 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_docdir}/Ice-%{version},%{_datadir}/Ice}
288
289 %{__make} -C cpp install \
290         prefix=$RPM_BUILD_ROOT
291
292 # Move the ImportKey.class file
293 mv $RPM_BUILD_ROOT/lib/ImportKey.class $RPM_BUILD_ROOT%{_datadir}/Ice
294
295 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
296 mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT%{_includedir}
297 mv $RPM_BUILD_ROOT/%{_lib}/* $RPM_BUILD_ROOT%{_libdir}
298
299 mv $RPM_BUILD_ROOT/config/* $RPM_BUILD_ROOT%{_datadir}/Ice
300
301 # Copy the man pages into the correct directory
302 install -d $RPM_BUILD_ROOT%{_mandir}/man1
303 cp -a *man-pages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
304
305 %if %{with java}
306 %{__make} -C java install \
307         prefix=$RPM_BUILD_ROOT
308
309 # Move Java stuff where it should be
310 install -d $RPM_BUILD_ROOT%{_javadir}
311 mv $RPM_BUILD_ROOT/lib/Ice.jar $RPM_BUILD_ROOT%{_javadir}/Ice-%{version}.jar
312 ln -s Ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Ice.jar
313 mv $RPM_BUILD_ROOT/lib/Freeze.jar $RPM_BUILD_ROOT%{_javadir}/Freeze-%{version}.jar
314 ln -s Freeze-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Freeze.jar
315
316 # Register ant target
317 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ant.d,%{_javadir}/ant}
318 mv $RPM_BUILD_ROOT/lib/ant-ice.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice-%{version}.jar
319 ln -s ant-ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice.jar
320 echo 'ice ant/ant-ice' > $RPM_BUILD_ROOT%{_sysconfdir}/ant.d/ice
321 %endif
322
323 %if %{with gui}
324 # Install the IceGrid GUI
325 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
326 mv $RPM_BUILD_ROOT/lib/IceGridGUI.jar $RPM_BUILD_ROOT%{_datadir}/Ice
327 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
328 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
329 cp -a java/resources/icons/icegrid.png $RPM_BUILD_ROOT%{_pixmapsdir}
330 mv $RPM_BUILD_ROOT/help/IceGridAdmin $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
331 %endif
332
333 %if %{with dotnet}
334 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
335 %{__make} -C cs install \
336         prefix=$RPM_BUILD_ROOT \
337         GACINSTALL=yes \
338         GAC_ROOT=$RPM_BUILD_ROOT%{_prefix}/lib \
339
340 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
341 # .NET spec files (for csharp-devel) -- convert the paths
342 for f in IceGrid Glacier2 IceBox Ice IceStorm IcePatch2; do
343         sed -i -e "s#/lib/#%{_prefix}/lib/#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
344         sed -i -e "s#mono_root}/usr#mono_root}#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
345         mv $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/$f.pc
346         mv $RPM_BUILD_ROOT%{_bindir}/$f.xml $RPM_BUILD_ROOT%{_prefix}/lib/mono/gac/$f/%{version}.*/
347 done
348 %endif
349
350 %if %{with python}
351 %{__make} -C py install \
352         prefix=$RPM_BUILD_ROOT
353 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT/python/Ice.py
354 install -d $RPM_BUILD_ROOT%{py_sitedir}/Ice
355 mv $RPM_BUILD_ROOT/python/IcePy.so.*.*.* $RPM_BUILD_ROOT%{py_sitedir}/Ice/IcePy.so
356 rm -f $RPM_BUILD_ROOT/python/IcePy.so*
357 mv $RPM_BUILD_ROOT/python/* $RPM_BUILD_ROOT%{py_sitedir}/Ice
358 cp -a Ice-rpmbuild-*/ice.pth $RPM_BUILD_ROOT%{py_sitedir}
359 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
360 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
361 %py_postclean
362 %endif
363
364 %if %{with ruby}
365 %{__make} -C rb install \
366         prefix=$RPM_BUILD_ROOT
367 %{__sed} -i -e '1s,/usr/bin/env ruby,%{__ruby},' $RPM_BUILD_ROOT/ruby/*.rb
368 install -d $RPM_BUILD_ROOT%{ruby_vendorarchdir}
369 mv $RPM_BUILD_ROOT/ruby/IceRuby.so.*.*.* $RPM_BUILD_ROOT%{ruby_vendorarchdir}/IceRuby.so
370 rm -f $RPM_BUILD_ROOT/ruby/IceRuby.so*
371 mv $RPM_BUILD_ROOT/ruby/* $RPM_BUILD_ROOT%{ruby_vendorarchdir}
372 %endif
373
374 %if %{with php}
375 %{__make} -C php install \
376         prefix=$RPM_BUILD_ROOT
377 # Put the PHP stuff into the right place
378 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{php_data_dir}}
379 cp -a Ice-rpmbuild-*/ice.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
380 mv $RPM_BUILD_ROOT/php/IcePHP.so $RPM_BUILD_ROOT%{php_extensiondir}
381 mv $RPM_BUILD_ROOT/php/* $RPM_BUILD_ROOT%{php_data_dir}
382 %endif
383
384 # move as last, bindings reinstall these if missing
385 mv $RPM_BUILD_ROOT/slice $RPM_BUILD_ROOT%{_datadir}/Ice
386
387 # Move the license files into the documentation directory
388 mv $RPM_BUILD_ROOT/ICE_LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/ICE_LICENSE
389 mv $RPM_BUILD_ROOT/LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/LICENSE
390 # Copy in the other files too
391 cp CHANGES RELEASE_NOTES  $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
392
393 # Install the servers
394 install -d $RPM_BUILD_ROOT%{_sysconfdir}
395 cp -a Ice-rpmbuild-*/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
396 install -d $RPM_BUILD_ROOT%{_initrddir}
397 for i in icegridregistry icegridnode glacier2router; do
398         cp -a Ice-rpmbuild-*/$i.redhat $RPM_BUILD_ROOT%{_initrddir}/$i
399 done
400 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/icegrid
401
402 %clean
403 rm -rf $RPM_BUILD_ROOT
404
405 %post   -p /sbin/ldconfig
406 %postun -p /sbin/ldconfig
407
408 %post -n %{php_name}-%{name}
409 %php_webserver_restart
410
411 %postun -n %{php_name}-%{name}
412 if [ "$1" = 0 ]; then
413         %php_webserver_restart
414 fi
415
416 %files
417 %defattr(644,root,root,755)
418 %doc %{_docdir}/Ice-%{version}
419 %attr(755,root,root) %{_bindir}/dumpdb
420 %attr(755,root,root) %{_bindir}/glacier2router
421 %attr(755,root,root) %{_bindir}/icebox
422 %attr(755,root,root) %{_bindir}/iceboxadmin
423 %attr(755,root,root) %{_bindir}/iceca
424 %attr(755,root,root) %{_bindir}/icegridadmin
425 %attr(755,root,root) %{_bindir}/icegridnode
426 %attr(755,root,root) %{_bindir}/icegridregistry
427 %attr(755,root,root) %{_bindir}/icepatch2calc
428 %attr(755,root,root) %{_bindir}/icepatch2client
429 %attr(755,root,root) %{_bindir}/icepatch2server
430 %attr(755,root,root) %{_bindir}/icestormadmin
431 %attr(755,root,root) %{_bindir}/icestormmigrate
432 %attr(755,root,root) %{_bindir}/slice2html
433 %attr(755,root,root) %{_bindir}/transformdb
434 %{_mandir}/man1/dumpdb.1*
435 %{_mandir}/man1/glacier2router.1*
436 %{_mandir}/man1/icebox.1*
437 %{_mandir}/man1/iceboxadmin.1*
438 %{_mandir}/man1/icegridadmin.1*
439 %{_mandir}/man1/icegridnode.1*
440 %{_mandir}/man1/icegridregistry.1*
441 %{_mandir}/man1/icepatch2calc.1*
442 %{_mandir}/man1/icepatch2client.1*
443 %{_mandir}/man1/icepatch2server.1*
444 %{_mandir}/man1/icestormadmin.1*
445 %{_mandir}/man1/slice2html.1*
446 %{_mandir}/man1/transformdb.1*
447 %attr(755,root,root) %{_libdir}/libFreeze.so.*.*.*
448 %attr(755,root,root) %ghost %{_libdir}/libFreeze.so.%{soversion}
449 %attr(755,root,root) %{_libdir}/libGlacier2.so.*.*.*
450 %attr(755,root,root) %ghost %{_libdir}/libGlacier2.so.%{soversion}
451 %attr(755,root,root) %{_libdir}/libIce.so.*.*.*
452 %attr(755,root,root) %ghost %{_libdir}/libIce.so.%{soversion}
453 %attr(755,root,root) %{_libdir}/libIceBox.so.*.*.*
454 %attr(755,root,root) %ghost %{_libdir}/libIceBox.so.%{soversion}
455 %attr(755,root,root) %{_libdir}/libIceDB.so.*.*.*
456 %attr(755,root,root) %ghost %{_libdir}/libIceDB.so.%{soversion}
457 %attr(755,root,root) %{_libdir}/libIceGrid.so.*.*.*
458 %attr(755,root,root) %ghost %{_libdir}/libIceGrid.so.%{soversion}
459 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so.*.*.*
460 %attr(755,root,root) %ghost %{_libdir}/libIceGridFreezeDB.so.%{soversion}
461 %attr(755,root,root) %{_libdir}/libIcePatch2.so.*.*.*
462 %attr(755,root,root) %ghost %{_libdir}/libIcePatch2.so.%{soversion}
463 %attr(755,root,root) %{_libdir}/libIceSSL.so.*.*.*
464 %attr(755,root,root) %ghost %{_libdir}/libIceSSL.so.%{soversion}
465 %attr(755,root,root) %{_libdir}/libIceStorm.so.*.*.*
466 %attr(755,root,root) %ghost %{_libdir}/libIceStorm.so.%{soversion}
467 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so.*.*.*
468 %attr(755,root,root) %ghost %{_libdir}/libIceStormFreezeDB.so.%{soversion}
469 %attr(755,root,root) %{_libdir}/libIceStormService.so.*.*.*
470 %attr(755,root,root) %ghost %{_libdir}/libIceStormService.so.%{soversion}
471 %attr(755,root,root) %{_libdir}/libIceUtil.so.*.*.*
472 %attr(755,root,root) %ghost %{_libdir}/libIceUtil.so.%{soversion}
473 %attr(755,root,root) %{_libdir}/libIceXML.so.*.*.*
474 %attr(755,root,root) %ghost %{_libdir}/libIceXML.so.%{soversion}
475 %attr(755,root,root) %{_libdir}/libSlice.so.*.*.*
476 %attr(755,root,root) %ghost %{_libdir}/libSlice.so.%{soversion}
477 %{_datadir}/Ice
478
479 %if %{with gui}
480 # Exclude the stuff that's in IceGrid
481 %exclude %{_docdir}/Ice-%{version}/IceGridAdmin
482 %exclude %{_datadir}/Ice/IceGridGUI.jar
483
484 %files -n icegrid-gui
485 %defattr(644,root,root,755)
486 %doc %{_docdir}/Ice-%{version}/IceGridAdmin
487 %attr(755,root,root) %{_bindir}/icegridgui
488 %{_datadir}/Ice/IceGridGUI.jar
489 %{_mandir}/man1/icegridgui.1*
490 %{_desktopdir}/IceGridAdmin.desktop
491 %{_pixmapsdir}/icegrid.png
492 %endif
493
494 %files devel
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{_bindir}/slice2cpp
497 %attr(755,root,root) %{_bindir}/slice2freeze
498 %attr(755,root,root) %{_libdir}/libFreeze.so
499 %attr(755,root,root) %{_libdir}/libGlacier2.so
500 %attr(755,root,root) %{_libdir}/libIce.so
501 %attr(755,root,root) %{_libdir}/libIceBox.so
502 %attr(755,root,root) %{_libdir}/libIceDB.so
503 %attr(755,root,root) %{_libdir}/libIceGrid.so
504 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so
505 %attr(755,root,root) %{_libdir}/libIcePatch2.so
506 %attr(755,root,root) %{_libdir}/libIceSSL.so
507 %attr(755,root,root) %{_libdir}/libIceStorm.so
508 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so
509 %attr(755,root,root) %{_libdir}/libIceStormService.so
510 %attr(755,root,root) %{_libdir}/libIceUtil.so
511 %attr(755,root,root) %{_libdir}/libIceXML.so
512 %attr(755,root,root) %{_libdir}/libSlice.so
513 %{_includedir}/Freeze
514 %{_includedir}/Glacier2
515 %{_includedir}/Ice
516 %{_includedir}/IceBox
517 %{_includedir}/IceGrid
518 %{_includedir}/IcePatch2
519 %{_includedir}/IceSSL
520 %{_includedir}/IceStorm
521 %{_includedir}/IceUtil
522 %{_includedir}/IceXML
523 %{_includedir}/Slice
524 %{_mandir}/man1/slice2cpp.1*
525 %{_mandir}/man1/slice2freeze.1*
526 %if %{with java}
527 %{_sysconfdir}/ant.d/ice
528 %{_javadir}/ant/ant-ice-%{version}.jar
529 %{_javadir}/ant/ant-ice.jar
530 %endif
531
532 %if %{with dotnet}
533 %{_pkgconfigdir}/Glacier2.pc
534 %{_pkgconfigdir}/Ice.pc
535 %{_pkgconfigdir}/IceBox.pc
536 %{_pkgconfigdir}/IceGrid.pc
537 %{_pkgconfigdir}/IcePatch2.pc
538 %{_pkgconfigdir}/IceStorm.pc
539 %endif
540
541 # as we do not have -devel for each binding, these are in main -devel
542 # -csharp
543 %attr(755,root,root) %{_bindir}/slice2cs
544 %{_mandir}/man1/slice2cs.1*
545 # -java
546 %attr(755,root,root) %{_bindir}/slice2freezej
547 %attr(755,root,root) %{_bindir}/slice2java
548 %{_mandir}/man1/slice2freezej.1*
549 %{_mandir}/man1/slice2java.1*
550 # -php
551 %attr(755,root,root) %{_bindir}/slice2php
552 # -python
553 %attr(755,root,root) %{_bindir}/slice2py
554 %{_mandir}/man1/slice2py.1*
555 # -ruby
556 %attr(755,root,root) %{_bindir}/slice2rb
557 %{_mandir}/man1/slice2rb.1*
558
559 %files servers
560 %defattr(644,root,root,755)
561 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/glacier2router.conf
562 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridnode.conf
563 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridregistry.conf
564 %attr(754,root,root) /etc/rc.d/init.d/glacier2router
565 %attr(754,root,root) /etc/rc.d/init.d/icegridnode
566 %attr(754,root,root) /etc/rc.d/init.d/icegridregistry
567
568 %if %{with dotnet}
569 %files -n csharp-%{name}
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_bindir}/iceboxnet.exe
572 %{_mandir}/man1/iceboxnet.exe.1*
573 %{_prefix}/lib/mono/Glacier2
574 %{_prefix}/lib/mono/Ice
575 %{_prefix}/lib/mono/IceBox
576 %{_prefix}/lib/mono/IceGrid
577 %{_prefix}/lib/mono/IcePatch2
578 %{_prefix}/lib/mono/IceStorm
579
580 %{_prefix}/lib/mono/gac/Glacier2
581 %{_prefix}/lib/mono/gac/Ice
582 %{_prefix}/lib/mono/gac/IceBox
583 %{_prefix}/lib/mono/gac/IceGrid
584 %{_prefix}/lib/mono/gac/IcePatch2
585 %{_prefix}/lib/mono/gac/IceStorm
586
587 %{_prefix}/lib/mono/gac/policy.3.4.Glacier2
588 %{_prefix}/lib/mono/gac/policy.3.4.Ice
589 %{_prefix}/lib/mono/gac/policy.3.4.IceBox
590 %{_prefix}/lib/mono/gac/policy.3.4.IceGrid
591 %{_prefix}/lib/mono/gac/policy.3.4.IcePatch2
592 %{_prefix}/lib/mono/gac/policy.3.4.IceStorm
593 %endif
594
595 %if %{with python}
596 %files -n python-%{name}
597 %defattr(644,root,root,755)
598 %{py_sitedir}/ice.pth
599 %dir %{py_sitedir}/Ice
600 %dir %{py_sitedir}/Ice/IceBox
601 %dir %{py_sitedir}/Ice/IceGrid
602 %dir %{py_sitedir}/Ice/IcePatch2
603 %dir %{py_sitedir}/Ice/IceStorm
604 %{py_sitedir}/Ice/*.py[co]
605 %{py_sitedir}/Ice/IceBox/*.py[co]
606 %{py_sitedir}/Ice/IceGrid/*.py[co]
607 %{py_sitedir}/Ice/IcePatch2/*.py[co]
608 %{py_sitedir}/Ice/IceStorm/*.py[co]
609 %attr(755,root,root) %{py_sitedir}/Ice/IcePy.so
610 %endif
611
612 %if %{with ruby}
613 %files -n ruby-%{name}
614 %defattr(644,root,root,755)
615 %{ruby_vendorarchdir}/Glacier2.rb
616 %{ruby_vendorarchdir}/Glacier2
617 %{ruby_vendorarchdir}/Ice.rb
618 %{ruby_vendorarchdir}/Ice
619 %{ruby_vendorarchdir}/IceBox.rb
620 %{ruby_vendorarchdir}/IceBox
621 %{ruby_vendorarchdir}/IceGrid.rb
622 %{ruby_vendorarchdir}/IceGrid
623 %{ruby_vendorarchdir}/IcePatch2.rb
624 %{ruby_vendorarchdir}/IcePatch2
625 %{ruby_vendorarchdir}/IceStorm.rb
626 %dir %{ruby_vendorarchdir}/IceStorm
627 %{ruby_vendorarchdir}/IceStorm/IceStorm.rb
628 %attr(755,root,root) %{ruby_vendorarchdir}/IceRuby.so
629 %endif
630
631 %if %{with java}
632 %files -n java-%{name}
633 %defattr(644,root,root,755)
634 %{_javadir}/Freeze-%{version}.jar
635 %{_javadir}/Freeze.jar
636 %{_javadir}/Ice-%{version}.jar
637 %{_javadir}/Ice.jar
638 %endif
639
640 %if %{with php}
641 %files -n %{php_name}-%{name}
642 %defattr(644,root,root,755)
643 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/ice.ini
644 %attr(755,root,root) %{php_extensiondir}/IcePHP.so
645 %{php_data_dir}/Glacier2.php
646 %{php_data_dir}/Glacier2
647 %{php_data_dir}/Ice.php
648 %{php_data_dir}/Ice
649 %{php_data_dir}/IceBox.php
650 %{php_data_dir}/IceBox
651 %{php_data_dir}/IceGrid.php
652 %{php_data_dir}/IceGrid
653 %{php_data_dir}/IcePatch2.php
654 %{php_data_dir}/IcePatch2
655 %{php_data_dir}/IceStorm.php
656 %{php_data_dir}/IceStorm
657 %endif
This page took 0.115564 seconds and 2 git commands to generate.