]> git.pld-linux.org Git - packages/ice.git/blob - ice.spec
6ea708b0641fe9ce07f860dbb3d5105531a0814a
[packages/ice.git] / ice.spec
1 # TODO
2 # - finish (pldize) -servers package
3 #
4 # Conditional build:
5 %bcond_without  gui                     # IceGrid GUI
6 %bcond_without  dotnet          # .NET bindings
7 %bcond_without  java            # Java bindings
8 %bcond_without  php                     # PHP bindings
9 %bcond_without  python          # Python bindings
10 %bcond_without  ruby            # Ruby bindings
11
12 %if %{without java}
13 %undefine       with_gui
14 %endif
15
16 %{?with_java:%include   /usr/lib/rpm/macros.java}
17 Summary:        The Ice base runtime and services
18 Name:           ice
19 Version:        3.4.2
20 Release:        5
21 License:        GPL v2 with exceptions (see ICE_LICENSE)
22 Group:          Applications
23 URL:            http://www.zeroc.com/
24 Source0:        http://www.zeroc.com/download/Ice/3.4/Ice-%{version}.tar.gz
25 # Source0-md5:  e97672eb4a63c6b8dd202d0773e19dc7
26 # Extracted from http://zeroc.com/download/Ice/3.4/ice-3.4.0-1.src.rpm
27 Source1:        Ice-rpmbuild-3.4.0.tar.gz
28 # Source1-md5:  869cc60645e7e2b4115584a5ab17d1e9
29 # Man pages courtesy of Francisco Moya's Debian packages
30 Source2:        Ice-3.3.0-man-pages.tbz2
31 # Source2-md5:  c6c17ee1be2e6b615af5b40edae88b75
32 Source3:        %{name}gridgui
33 Source4:        IceGridAdmin.desktop
34 Patch0:         %{name}-build.patch
35 Patch1:         dont-build-demo-test.patch
36 Patch2:         java-build.patch
37 Patch3:         jgoodies.patch
38 Patch4:         ice-gcc46.patch
39 Patch5:         ice-gcc47.patch
40 Patch6:         ice-db.patch
41 Patch7:         ice-format-security.patch
42 BuildRequires:  bzip2-devel
43 BuildRequires:  db-cxx-devel
44 BuildRequires:  expat-devel
45 BuildRequires:  mcpp-devel
46 BuildRequires:  openssl-devel
47 BuildRequires:  rpmbuild(macros) >= 1.533
48 %if %{with gui}
49 BuildRequires:  ImageMagick
50 BuildRequires:  ImageMagick-coder-png
51 %endif
52 %if %{with dotnet}
53 BuildRequires:  mono-csharp
54 %endif
55 %if %{with java}
56 BuildRequires:  ant
57 BuildRequires:  db-java-devel
58 BuildRequires:  java-jgoodies-common
59 BuildRequires:  java-jgoodies-forms
60 BuildRequires:  java-jgoodies-looks
61 BuildRequires:  jdk
62 BuildRequires:  jpackage-utils
63 BuildRequires:  rpm-javaprov
64 %endif
65 %if %{with php}
66 BuildRequires:  php-devel >= 3:5.0.0
67 %endif
68 %if %{with python}
69 BuildRequires:  python-devel
70 BuildRequires:  rpm-pythonprov
71 %endif
72 %if %{with ruby}
73 BuildRequires:  ruby >= 1:1.8.6
74 BuildRequires:  ruby-devel
75 %endif
76 # Ice doesn't officially support ppc64 at all; sparc64 doesnt have mono
77 ExcludeArch:    ppc64 sparc64
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 # Some file suffixes we need to grab the right stuff for the file lists
81 %define         soversion       34
82
83 %description
84 Ice is a modern alternative to object middleware such as CORBA or
85 COM/DCOM/COM+. It is easy to learn, yet provides a powerful network
86 infrastructure for demanding technical applications. It features an
87 object-oriented specification language, easy to use C++, C#, Java,
88 Python, Ruby, PHP, and Visual Basic mappings, a highly efficient
89 protocol, asynchronous method invocation and dispatch, dynamic
90 transport plug-ins, TCP/IP and UDP/IP support, SSL-based security, a
91 firewall solution, and much more.
92
93 %package devel
94 Summary:        Tools for developing Ice applications in C++
95 Group:          Development/Libraries
96 Requires:       %{name} = %{version}-%{release}
97
98 %description devel
99 Tools for developing Ice applications in C++.
100
101 %package servers
102 Summary:        Ice services to run through /etc/rc.d/init.d
103 Group:          Development/Tools
104 Requires(post,preun):   /sbin/chkconfig
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       rc-scripts
107
108 %description servers
109 Ice services to run through /etc/rc.d/init.d
110
111 %package -n icegrid-gui
112 Summary:        IceGrid Admin Tool
113 Group:          Development/Tools
114 Requires:       %{name} = %{version}-%{release}
115 Requires:       java-%{name} = %{version}-%{release}
116 Requires:       java-jgoodies-forms
117 Requires:       java-jgoodies-looks
118 Requires:       jpackage-utils
119
120 %description -n icegrid-gui
121 Graphical administration tool for IceGrid
122
123 %package -n java-%{name}
124 Summary:        The Ice runtime for Java
125 Group:          Libraries/Java
126 Requires:       %{name} = %{version}-%{release}
127 Requires:       db-java
128 Requires:       jpackage-utils
129
130 %description -n java-%{name}
131 The Ice runtime for Java
132
133 %package -n csharp-%{name}
134 Summary:        The Ice runtime for C#
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137 Requires:       mono >= 1.2.2
138
139 %description -n csharp-%{name}
140 The Ice runtime for C#
141
142 %package -n ruby-%{name}
143 Summary:        The Ice runtime for Ruby applications
144 Group:          Development/Languages
145 Requires:       %{name} = %{version}-%{release}
146 %{?ruby_mod_ver_requires_eq}
147
148 %description -n ruby-%{name}
149 The Ice runtime for Ruby applications.
150
151 %package -n python-%{name}
152 Summary:        The Ice runtime for Python applications
153 Group:          Development/Languages/Python
154 Requires:       %{name} = %{version}-%{release}
155 Requires:       python >= 1:2.3.4
156
157 %description -n python-%{name}
158 The Ice runtime for Python applications.
159
160 %package -n php-%{name}
161 Summary:        The Ice runtime for PHP applications
162 Group:          Development/Languages/PHP
163 Requires:       %{name} = %{version}-%{release}
164 %{?requires_php_extension}
165
166 %description -n php-%{name}
167 The Ice runtime for PHP applications.
168
169 %prep
170 %setup -q -n Ice-%{version} -a1 -a2
171 %patch0 -p0
172 %patch1 -p1
173 %patch2 -p1
174 %patch3 -p1
175 %patch4 -p1
176 %patch5 -p1
177 %patch6 -p1
178 %patch7 -p1
179
180 # no longer included in 3.4
181 rm -f *man-pages/slice2docbook.1
182
183 # Fix the encoding and line-endings of all the IceGridAdmin documentation files
184 cd java/resources/IceGridAdmin
185 %undos -f js,css
186
187 for f in helpman_topicinit.js icegridadmin_navigation.js IceGridAdmin_popup_html.js zoom_pageinfo.js; do
188         iconv -f ISO88591 -t UTF8 $f -o $f.tmp
189         mv $f.tmp $f
190 done
191 cd -
192
193 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' cpp/src/ca/iceca
194
195 %if %{with java}
196 # we nuke it only when we build new class later, as ice build system expects the file being around
197 rm cpp/src/ca/ImportKey.class
198 %endif
199
200 # update path to our install
201 sed -i -e 's,/usr/share/Ice-%{version},%{_datadir}/Ice,' cpp/src/ca/iceca Ice-rpmbuild-*/icegridregistry.conf
202
203 # force our CC/CXX as build system compares for exactly "c++" to setup other rules
204 sed -i -e 's,c++,%{__cxx},g' cpp/config/Make.rules.Linux
205
206 %build
207 # Compile the main Ice runtime
208 # TODO: CC/CXX passing as make param breaks build system
209
210 %if %{with java}
211 # Rebuild the Java ImportKey class - need it early for main cpp build
212 javac cpp/src/ca/ImportKey.java
213 %endif
214
215 %{__make} -j1 -C cpp \
216         CC="%{__cc}" \
217         CXX="%{__cxx}" \
218         CFLAGS="%{rpmcflags} -fPIC" \
219         CXXFLAGS="%{rpmcxxflags} -fPIC" \
220         embedded_runpath_prefix=""
221
222 %if %{with gui}
223 # Create the IceGrid icon
224 convert java/resources/icons/icegrid.ico temp.png
225 mv temp-8.png java/resources/icons/icegrid.png
226 rm temp*.png
227 %endif
228
229 %if %{with java}
230
231 # Set the CLASSPATH correctly for the Java compile
232 export CLASSPATH=$(build-classpath db jgoodies-forms jgoodies-looks)
233
234 %{__make} -j1 -C java \
235         CC="%{__cc}" \
236         CXX="%{__cxx}" \
237         CFLAGS="%{rpmcflags} -fPIC" \
238         CXXFLAGS="%{rpmcxxflags} -fPIC" \
239         embedded_runpath_prefix=""
240 %endif
241
242 %if %{with dotnet}
243 %{__make} -j1 -C cs \
244         CC="%{__cc}" \
245         CXX="%{__cxx}" \
246         CFLAGS="%{rpmcflags} -fPIC" \
247         CXXFLAGS="%{rpmcxxflags} -fPIC" \
248         embedded_runpath_prefix=""
249 %endif
250
251 %if %{with python}
252 %{__make} -j1 -C py \
253         CC="%{__cc}" \
254         CXX="%{__cxx}" \
255         CFLAGS="%{rpmcflags} -fPIC" \
256         CXXFLAGS="%{rpmcxxflags} -fPIC" \
257         embedded_runpath_prefix=""
258 %endif
259
260 %if %{with ruby}
261 %{__make} -j1 -C rb \
262         CC="%{__cc}" \
263         CXX="%{__cxx}" \
264         CFLAGS="%{rpmcflags} -fPIC" \
265         CXXFLAGS="%{rpmcxxflags} -fPIC" \
266         embedded_runpath_prefix=""
267 %endif
268
269 %if %{with php}
270 %{__make} -j1 -C php \
271         CC="%{__cc}" \
272         CXX="%{__cxx}" \
273         PHP_HOME=%{_prefix} \
274         CFLAGS="%{rpmcflags} -fPIC" \
275         CXXFLAGS="%{rpmcxxflags} -fPIC" \
276         embedded_runpath_prefix=""
277 %endif
278
279 %install
280 rm -rf $RPM_BUILD_ROOT
281 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_docdir}/Ice-%{version},%{_datadir}/Ice}
282
283 %{__make} -C cpp install \
284         prefix=$RPM_BUILD_ROOT
285
286 # Move the ImportKey.class file
287 mv $RPM_BUILD_ROOT/lib/ImportKey.class $RPM_BUILD_ROOT%{_datadir}/Ice
288
289 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
290 mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT%{_includedir}
291 mv $RPM_BUILD_ROOT/%{_lib}/* $RPM_BUILD_ROOT%{_libdir}
292
293 mv $RPM_BUILD_ROOT/config/* $RPM_BUILD_ROOT%{_datadir}/Ice
294
295 # Copy the man pages into the correct directory
296 install -d $RPM_BUILD_ROOT%{_mandir}/man1
297 cp -a *man-pages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
298
299 %if %{with java}
300 %{__make} -C java install \
301         prefix=$RPM_BUILD_ROOT
302
303 # Move Java stuff where it should be
304 install -d $RPM_BUILD_ROOT%{_javadir}
305 mv $RPM_BUILD_ROOT/lib/Ice.jar $RPM_BUILD_ROOT%{_javadir}/Ice-%{version}.jar
306 ln -s Ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Ice.jar
307 mv $RPM_BUILD_ROOT/lib/Freeze.jar $RPM_BUILD_ROOT%{_javadir}/Freeze-%{version}.jar
308 ln -s Freeze-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Freeze.jar
309
310 # Register ant target
311 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ant.d,%{_javadir}/ant}
312 mv $RPM_BUILD_ROOT/lib/ant-ice.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice-%{version}.jar
313 ln -s ant-ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice.jar
314 echo 'ice ant/ant-ice' > $RPM_BUILD_ROOT%{_sysconfdir}/ant.d/ice
315 %endif
316
317 %if %{with gui}
318 # Install the IceGrid GUI
319 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
320 mv $RPM_BUILD_ROOT/lib/IceGridGUI.jar $RPM_BUILD_ROOT%{_datadir}/Ice
321 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
322 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
323 cp -a java/resources/icons/icegrid.png $RPM_BUILD_ROOT%{_pixmapsdir}
324 mv $RPM_BUILD_ROOT/help/IceGridAdmin $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
325 %endif
326
327 %if %{with dotnet}
328 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
329 %{__make} -C cs install \
330         prefix=$RPM_BUILD_ROOT \
331         GACINSTALL=yes \
332         GAC_ROOT=$RPM_BUILD_ROOT%{_prefix}/lib \
333
334 mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
335 # .NET spec files (for csharp-devel) -- convert the paths
336 for f in IceGrid Glacier2 IceBox Ice IceStorm IcePatch2; do
337         sed -i -e "s#/lib/#%{_prefix}/lib/#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
338         sed -i -e "s#mono_root}/usr#mono_root}#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
339         mv $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/$f.pc
340         mv $RPM_BUILD_ROOT%{_bindir}/$f.xml $RPM_BUILD_ROOT%{_prefix}/lib/mono/gac/$f/%{version}.*/
341 done
342 %endif
343
344 %if %{with python}
345 %{__make} -C py install \
346         prefix=$RPM_BUILD_ROOT
347 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT/python/Ice.py
348 install -d $RPM_BUILD_ROOT%{py_sitedir}/Ice
349 mv $RPM_BUILD_ROOT/python/IcePy.so.*.*.* $RPM_BUILD_ROOT%{py_sitedir}/Ice/IcePy.so
350 rm -f $RPM_BUILD_ROOT/python/IcePy.so*
351 mv $RPM_BUILD_ROOT/python/* $RPM_BUILD_ROOT%{py_sitedir}/Ice
352 cp -a Ice-rpmbuild-*/ice.pth $RPM_BUILD_ROOT%{py_sitedir}
353 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
354 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
355 %py_postclean
356 %endif
357
358 %if %{with ruby}
359 %{__make} -C rb install \
360         prefix=$RPM_BUILD_ROOT
361 %{__sed} -i -e '1s,/usr/bin/env ruby,%{__ruby},' $RPM_BUILD_ROOT/ruby/*.rb
362 install -d $RPM_BUILD_ROOT%{ruby_sitearchdir}
363 mv $RPM_BUILD_ROOT/ruby/IceRuby.so.*.*.* $RPM_BUILD_ROOT%{ruby_sitearchdir}/IceRuby.so
364 rm -f $RPM_BUILD_ROOT/ruby/IceRuby.so*
365 mv $RPM_BUILD_ROOT/ruby/* $RPM_BUILD_ROOT%{ruby_sitearchdir}
366 %endif
367
368 %if %{with php}
369 %{__make} -C php install \
370         prefix=$RPM_BUILD_ROOT
371 # Put the PHP stuff into the right place
372 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{php_data_dir}}
373 cp -a Ice-rpmbuild-*/ice.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
374 mv $RPM_BUILD_ROOT/php/IcePHP.so $RPM_BUILD_ROOT%{php_extensiondir}
375 mv $RPM_BUILD_ROOT/php/* $RPM_BUILD_ROOT%{php_data_dir}
376 %endif
377
378 # move as last, bindings reinstall these if missing
379 mv $RPM_BUILD_ROOT/slice $RPM_BUILD_ROOT%{_datadir}/Ice
380
381 # Move the license files into the documentation directory
382 mv $RPM_BUILD_ROOT/ICE_LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/ICE_LICENSE
383 mv $RPM_BUILD_ROOT/LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/LICENSE
384 # Copy in the other files too
385 cp CHANGES RELEASE_NOTES  $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
386
387 # Install the servers
388 install -d $RPM_BUILD_ROOT%{_sysconfdir}
389 cp -a Ice-rpmbuild-*/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
390 install -d $RPM_BUILD_ROOT%{_initrddir}
391 for i in icegridregistry icegridnode glacier2router; do
392         cp -a Ice-rpmbuild-*/$i.redhat $RPM_BUILD_ROOT%{_initrddir}/$i
393 done
394 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/icegrid
395
396 %clean
397 rm -rf $RPM_BUILD_ROOT
398
399 %post   -p /sbin/ldconfig
400 %postun -p /sbin/ldconfig
401
402 %post -n php-%{name}
403 %php_webserver_restart
404
405 %postun -n php-%{name}
406 if [ "$1" = 0 ]; then
407         %php_webserver_restart
408 fi
409
410 %files
411 %defattr(644,root,root,755)
412 %doc %{_docdir}/Ice-%{version}
413 %attr(755,root,root) %{_bindir}/dumpdb
414 %attr(755,root,root) %{_bindir}/glacier2router
415 %attr(755,root,root) %{_bindir}/icebox
416 %attr(755,root,root) %{_bindir}/iceboxadmin
417 %attr(755,root,root) %{_bindir}/iceca
418 %attr(755,root,root) %{_bindir}/icegridadmin
419 %attr(755,root,root) %{_bindir}/icegridnode
420 %attr(755,root,root) %{_bindir}/icegridregistry
421 %attr(755,root,root) %{_bindir}/icepatch2calc
422 %attr(755,root,root) %{_bindir}/icepatch2client
423 %attr(755,root,root) %{_bindir}/icepatch2server
424 %attr(755,root,root) %{_bindir}/icestormadmin
425 %attr(755,root,root) %{_bindir}/icestormmigrate
426 %attr(755,root,root) %{_bindir}/slice2html
427 %attr(755,root,root) %{_bindir}/transformdb
428 %{_mandir}/man1/dumpdb.1*
429 %{_mandir}/man1/glacier2router.1*
430 %{_mandir}/man1/icebox.1*
431 %{_mandir}/man1/iceboxadmin.1*
432 %{_mandir}/man1/icegridadmin.1*
433 %{_mandir}/man1/icegridnode.1*
434 %{_mandir}/man1/icegridregistry.1*
435 %{_mandir}/man1/icepatch2calc.1*
436 %{_mandir}/man1/icepatch2client.1*
437 %{_mandir}/man1/icepatch2server.1*
438 %{_mandir}/man1/icestormadmin.1*
439 %{_mandir}/man1/slice2html.1*
440 %{_mandir}/man1/transformdb.1*
441 %attr(755,root,root) %{_libdir}/libFreeze.so.*.*.*
442 %attr(755,root,root) %ghost %{_libdir}/libFreeze.so.%{soversion}
443 %attr(755,root,root) %{_libdir}/libGlacier2.so.*.*.*
444 %attr(755,root,root) %ghost %{_libdir}/libGlacier2.so.%{soversion}
445 %attr(755,root,root) %{_libdir}/libIce.so.*.*.*
446 %attr(755,root,root) %ghost %{_libdir}/libIce.so.%{soversion}
447 %attr(755,root,root) %{_libdir}/libIceBox.so.*.*.*
448 %attr(755,root,root) %ghost %{_libdir}/libIceBox.so.%{soversion}
449 %attr(755,root,root) %{_libdir}/libIceDB.so.*.*.*
450 %attr(755,root,root) %ghost %{_libdir}/libIceDB.so.%{soversion}
451 %attr(755,root,root) %{_libdir}/libIceGrid.so.*.*.*
452 %attr(755,root,root) %ghost %{_libdir}/libIceGrid.so.%{soversion}
453 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so.*.*.*
454 %attr(755,root,root) %ghost %{_libdir}/libIceGridFreezeDB.so.%{soversion}
455 %attr(755,root,root) %{_libdir}/libIcePatch2.so.*.*.*
456 %attr(755,root,root) %ghost %{_libdir}/libIcePatch2.so.%{soversion}
457 %attr(755,root,root) %{_libdir}/libIceSSL.so.*.*.*
458 %attr(755,root,root) %ghost %{_libdir}/libIceSSL.so.%{soversion}
459 %attr(755,root,root) %{_libdir}/libIceStorm.so.*.*.*
460 %attr(755,root,root) %ghost %{_libdir}/libIceStorm.so.%{soversion}
461 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so.*.*.*
462 %attr(755,root,root) %ghost %{_libdir}/libIceStormFreezeDB.so.%{soversion}
463 %attr(755,root,root) %{_libdir}/libIceStormService.so.*.*.*
464 %attr(755,root,root) %ghost %{_libdir}/libIceStormService.so.%{soversion}
465 %attr(755,root,root) %{_libdir}/libIceUtil.so.*.*.*
466 %attr(755,root,root) %ghost %{_libdir}/libIceUtil.so.%{soversion}
467 %attr(755,root,root) %{_libdir}/libIceXML.so.*.*.*
468 %attr(755,root,root) %ghost %{_libdir}/libIceXML.so.%{soversion}
469 %attr(755,root,root) %{_libdir}/libSlice.so.*.*.*
470 %attr(755,root,root) %ghost %{_libdir}/libSlice.so.%{soversion}
471 %{_datadir}/Ice
472
473 %if %{with gui}
474 # Exclude the stuff that's in IceGrid
475 %exclude %{_docdir}/Ice-%{version}/IceGridAdmin
476 %exclude %{_datadir}/Ice/IceGridGUI.jar
477
478 %files -n icegrid-gui
479 %defattr(644,root,root,755)
480 %doc %{_docdir}/Ice-%{version}/IceGridAdmin
481 %attr(755,root,root) %{_bindir}/icegridgui
482 %{_datadir}/Ice/IceGridGUI.jar
483 %{_mandir}/man1/icegridgui.1*
484 %{_desktopdir}/IceGridAdmin.desktop
485 %{_pixmapsdir}/icegrid.png
486 %endif
487
488 %files devel
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{_bindir}/slice2cpp
491 %attr(755,root,root) %{_bindir}/slice2freeze
492 %attr(755,root,root) %{_libdir}/libFreeze.so
493 %attr(755,root,root) %{_libdir}/libGlacier2.so
494 %attr(755,root,root) %{_libdir}/libIce.so
495 %attr(755,root,root) %{_libdir}/libIceBox.so
496 %attr(755,root,root) %{_libdir}/libIceDB.so
497 %attr(755,root,root) %{_libdir}/libIceGrid.so
498 %attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so
499 %attr(755,root,root) %{_libdir}/libIcePatch2.so
500 %attr(755,root,root) %{_libdir}/libIceSSL.so
501 %attr(755,root,root) %{_libdir}/libIceStorm.so
502 %attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so
503 %attr(755,root,root) %{_libdir}/libIceStormService.so
504 %attr(755,root,root) %{_libdir}/libIceUtil.so
505 %attr(755,root,root) %{_libdir}/libIceXML.so
506 %attr(755,root,root) %{_libdir}/libSlice.so
507 %{_includedir}/Freeze
508 %{_includedir}/Glacier2
509 %{_includedir}/Ice
510 %{_includedir}/IceBox
511 %{_includedir}/IceGrid
512 %{_includedir}/IcePatch2
513 %{_includedir}/IceSSL
514 %{_includedir}/IceStorm
515 %{_includedir}/IceUtil
516 %{_includedir}/IceXML
517 %{_includedir}/Slice
518 %{_mandir}/man1/slice2cpp.1*
519 %{_mandir}/man1/slice2freeze.1*
520 %if %{with java}
521 %{_sysconfdir}/ant.d/ice
522 %{_javadir}/ant/ant-ice-%{version}.jar
523 %{_javadir}/ant/ant-ice.jar
524 %endif
525
526 %if %{with dotnet}
527 %{_pkgconfigdir}/Glacier2.pc
528 %{_pkgconfigdir}/Ice.pc
529 %{_pkgconfigdir}/IceBox.pc
530 %{_pkgconfigdir}/IceGrid.pc
531 %{_pkgconfigdir}/IcePatch2.pc
532 %{_pkgconfigdir}/IceStorm.pc
533 %endif
534
535 # as we do not have -devel for each binding, these are in main -devel
536 # -csharp
537 %attr(755,root,root) %{_bindir}/slice2cs
538 %{_mandir}/man1/slice2cs.1*
539 # -java
540 %attr(755,root,root) %{_bindir}/slice2freezej
541 %attr(755,root,root) %{_bindir}/slice2java
542 %{_mandir}/man1/slice2freezej.1*
543 %{_mandir}/man1/slice2java.1*
544 # -php
545 %attr(755,root,root) %{_bindir}/slice2php
546 # -python
547 %attr(755,root,root) %{_bindir}/slice2py
548 %{_mandir}/man1/slice2py.1*
549 # -ruby
550 %attr(755,root,root) %{_bindir}/slice2rb
551 %{_mandir}/man1/slice2rb.1*
552
553 %files servers
554 %defattr(644,root,root,755)
555 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/glacier2router.conf
556 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridnode.conf
557 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridregistry.conf
558 %attr(754,root,root) /etc/rc.d/init.d/glacier2router
559 %attr(754,root,root) /etc/rc.d/init.d/icegridnode
560 %attr(754,root,root) /etc/rc.d/init.d/icegridregistry
561
562 %if %{with dotnet}
563 %files -n csharp-%{name}
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_bindir}/iceboxnet.exe
566 %{_mandir}/man1/iceboxnet.exe.1*
567 %{_prefix}/lib/mono/Glacier2
568 %{_prefix}/lib/mono/Ice
569 %{_prefix}/lib/mono/IceBox
570 %{_prefix}/lib/mono/IceGrid
571 %{_prefix}/lib/mono/IcePatch2
572 %{_prefix}/lib/mono/IceStorm
573
574 %{_prefix}/lib/mono/gac/Glacier2
575 %{_prefix}/lib/mono/gac/Ice
576 %{_prefix}/lib/mono/gac/IceBox
577 %{_prefix}/lib/mono/gac/IceGrid
578 %{_prefix}/lib/mono/gac/IcePatch2
579 %{_prefix}/lib/mono/gac/IceStorm
580
581 %{_prefix}/lib/mono/gac/policy.3.4.Glacier2
582 %{_prefix}/lib/mono/gac/policy.3.4.Ice
583 %{_prefix}/lib/mono/gac/policy.3.4.IceBox
584 %{_prefix}/lib/mono/gac/policy.3.4.IceGrid
585 %{_prefix}/lib/mono/gac/policy.3.4.IcePatch2
586 %{_prefix}/lib/mono/gac/policy.3.4.IceStorm
587 %endif
588
589 %if %{with python}
590 %files -n python-%{name}
591 %defattr(644,root,root,755)
592 %{py_sitedir}/ice.pth
593 %dir %{py_sitedir}/Ice
594 %dir %{py_sitedir}/Ice/IceBox
595 %dir %{py_sitedir}/Ice/IceGrid
596 %dir %{py_sitedir}/Ice/IcePatch2
597 %dir %{py_sitedir}/Ice/IceStorm
598 %{py_sitedir}/Ice/*.py[co]
599 %{py_sitedir}/Ice/IceBox/*.py[co]
600 %{py_sitedir}/Ice/IceGrid/*.py[co]
601 %{py_sitedir}/Ice/IcePatch2/*.py[co]
602 %{py_sitedir}/Ice/IceStorm/*.py[co]
603 %attr(755,root,root) %{py_sitedir}/Ice/IcePy.so
604 %endif
605
606 %if %{with ruby}
607 %files -n ruby-%{name}
608 %defattr(644,root,root,755)
609 %{ruby_sitearchdir}/Glacier2.rb
610 %{ruby_sitearchdir}/Glacier2
611 %{ruby_sitearchdir}/Ice.rb
612 %{ruby_sitearchdir}/Ice
613 %{ruby_sitearchdir}/IceBox.rb
614 %{ruby_sitearchdir}/IceBox
615 %{ruby_sitearchdir}/IceGrid.rb
616 %{ruby_sitearchdir}/IceGrid
617 %{ruby_sitearchdir}/IcePatch2.rb
618 %{ruby_sitearchdir}/IcePatch2
619 %{ruby_sitearchdir}/IceStorm.rb
620 %dir %{ruby_sitearchdir}/IceStorm
621 %{ruby_sitearchdir}/IceStorm/IceStorm.rb
622 %attr(755,root,root) %{ruby_sitearchdir}/IceRuby.so
623 %endif
624
625 %if %{with java}
626 %files -n java-%{name}
627 %defattr(644,root,root,755)
628 %{_javadir}/Freeze-%{version}.jar
629 %{_javadir}/Freeze.jar
630 %{_javadir}/Ice-%{version}.jar
631 %{_javadir}/Ice.jar
632 %endif
633
634 %if %{with php}
635 %files -n php-%{name}
636 %defattr(644,root,root,755)
637 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/ice.ini
638 %attr(755,root,root) %{php_extensiondir}/IcePHP.so
639 %{php_data_dir}/Glacier2.php
640 %{php_data_dir}/Glacier2
641 %{php_data_dir}/Ice.php
642 %{php_data_dir}/Ice
643 %{php_data_dir}/IceBox.php
644 %{php_data_dir}/IceBox
645 %{php_data_dir}/IceGrid.php
646 %{php_data_dir}/IceGrid
647 %{php_data_dir}/IcePatch2.php
648 %{php_data_dir}/IcePatch2
649 %{php_data_dir}/IceStorm.php
650 %{php_data_dir}/IceStorm
651 %endif
This page took 0.170391 seconds and 2 git commands to generate.