]> git.pld-linux.org Git - packages/hypre.git/blob - hypre.spec
a79f623cbfc21aef52e9615a201038481516b729
[packages/hypre.git] / hypre.spec
1 #
2 # Conditional build:
3 %bcond_with     mpi             # MPI support
4 %bcond_without  openmp          # OpenMP support
5 #
6 Summary:        High performance preconditioners and solvers library
7 Summary(pl.UTF-8):      Biblioteka preconditionerów i rozwiązywania układów równań o wysokiej wydajności
8 Name:           hypre
9 Version:        2.27.0
10 Release:        0.1
11 License:        Apache v2.0
12 Group:          Libraries
13 #Source0Download: https://github.com/hypre-space/hypre/releases
14 Source0:        https://github.com/hypre-space/hypre/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  0fc4d98040c2232e753464ab3fed66aa
16 #Patch0:        %{name}-what.patch
17 URL:            https://computing.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods
18 BuildRequires:  cmake >= 3.13
19 %if %{with mpi}
20 BuildRequires:  mpich-devel
21 %endif
22 %{?with_openmp:BuildRequires:   libgomp-devel}
23 BuildRequires:  rpmbuild(macros) >= 1.605
24 #BuildRequires: autoconf
25 #BuildRequires: automake
26 #BuildRequires: intltool
27 #BuildRequires: libtool
28 # if using noarch subpackages:
29 #BuildRequires: rpm-build >= 4.6
30 #Requires(postun):      -
31 #Requires(pre,post):    -
32 #Requires(preun):       -
33 #Requires:      -
34 #Provides:      -
35 #Obsoletes:     -
36 #Conflicts:     -
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 HYPRE is a library of high performance preconditioners and solvers
41 featuring multigrid methods for the solution of large, sparse linear
42 systems of equations on massively parallel computers.
43
44 %description -l pl.UTF-8
45 HYPRE to biblioteka wysoko wydajnych preconditionerów oraz procesdur
46 rozwiązywania dużych, rzadkich układów równań liniowych z
47 zastosowaniem metod wielosiatkowych na bardzo zrównoleglonych
48 komputerach.
49
50 %package devel
51 Summary:        Header files for HYPRE library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HYPRE
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 Header files for HYPRE library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki HYPRE.
61
62 %prep
63 %setup -q
64
65 %build
66 %cmake -B build -S src \
67         -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}/HYPRE \
68         -DHYPRE_ENABLE_HYPRE_BLAS=OFF \
69         -DHYPRE_ENABLE_HYPRE_LAPACK=OFF \
70         -DHYPRE_ENABLE_SHARED=ON \
71         %{!?with_mpi:-DHYPRE_WITH_MPI=OFF} \
72         %{?with_openmp:-DHYPRE_WITH_OPENMP=ON} \
73
74 # HYPRE_ENABLE_HOPSCOTCH?
75 # HYPRE_WITH_SUPERLU?
76 # HYPRE_WITH_DSUPERLU?
77 # HYPRE_WITH_CALIPER?
78 # HYPRE_WITH_CUDA on bcond + other CUDA options
79 # HYPRE_WITH_SYCL?
80 # oneMKL
81
82 %{__make} -C build
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} -C build install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc CHANGELOG COPYRIGHT LICENSE-MIT NOTICE README.md SUPPORT.md
99 %attr(755,root,root) %{_libdir}/libHYPRE.so
100
101 %files devel
102 %defattr(644,root,root,755)
103 %{_includedir}/HYPRE
104 %{_libdir}/cmake/HYPRE
This page took 0.046482 seconds and 2 git commands to generate.