]> git.pld-linux.org Git - packages/hypre.git/blob - hypre.spec
- cleanup
[packages/hypre.git] / hypre.spec
1 #
2 # Conditional build:
3 %bcond_with     mpi             # MPI support
4 %bcond_without  openmp          # OpenMP support
5 #
6 Summary:        High performance preconditioners and solvers library
7 Summary(pl.UTF-8):      Biblioteka preconditionerów i rozwiązywania układów równań o wysokiej wydajności
8 Name:           hypre
9 Version:        2.27.0
10 Release:        0.1
11 License:        Apache v2.0
12 Group:          Libraries
13 #Source0Download: https://github.com/hypre-space/hypre/releases
14 Source0:        https://github.com/hypre-space/hypre/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  0fc4d98040c2232e753464ab3fed66aa
16 #Patch0:        %{name}-what.patch
17 URL:            https://computing.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods
18 BuildRequires:  cmake >= 3.13
19 %if %{with mpi}
20 BuildRequires:  mpich-devel
21 %endif
22 %{?with_openmp:BuildRequires:   libgomp-devel}
23 BuildRequires:  rpmbuild(macros) >= 1.605
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 HYPRE is a library of high performance preconditioners and solvers
28 featuring multigrid methods for the solution of large, sparse linear
29 systems of equations on massively parallel computers.
30
31 %description -l pl.UTF-8
32 HYPRE to biblioteka wysoko wydajnych preconditionerów oraz procesdur
33 rozwiązywania dużych, rzadkich układów równań liniowych z
34 zastosowaniem metod wielosiatkowych na bardzo zrównoleglonych
35 komputerach.
36
37 %package devel
38 Summary:        Header files for HYPRE library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HYPRE
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for HYPRE library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki HYPRE.
48
49 %prep
50 %setup -q
51
52 %build
53 %cmake -B build -S src \
54         -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}/HYPRE \
55         -DHYPRE_ENABLE_HYPRE_BLAS=OFF \
56         -DHYPRE_ENABLE_HYPRE_LAPACK=OFF \
57         -DHYPRE_ENABLE_SHARED=ON \
58         %{!?with_mpi:-DHYPRE_WITH_MPI=OFF} \
59         %{?with_openmp:-DHYPRE_WITH_OPENMP=ON} \
60
61 # HYPRE_ENABLE_HOPSCOTCH?
62 # HYPRE_WITH_SUPERLU?
63 # HYPRE_WITH_DSUPERLU?
64 # HYPRE_WITH_CALIPER?
65 # HYPRE_WITH_CUDA on bcond + other CUDA options
66 # HYPRE_WITH_SYCL?
67 # oneMKL
68
69 %{__make} -C build
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} -C build install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc CHANGELOG COPYRIGHT LICENSE-MIT NOTICE README.md SUPPORT.md
86 %attr(755,root,root) %{_libdir}/libHYPRE.so
87
88 %files devel
89 %defattr(644,root,root,755)
90 %{_includedir}/HYPRE
91 %{_libdir}/cmake/HYPRE
This page took 0.079619 seconds and 3 git commands to generate.