]> git.pld-linux.org Git - packages/htmlgrid-charisma.git/blob - htmlgrid-charisma.spec
new, version 1.0.0
[packages/htmlgrid-charisma.git] / htmlgrid-charisma.spec
1 Summary:        Charisma - free, responsive, multiple skin admin template
2 Name:           htmlgrid-charisma
3 Version:        1.0.0
4 Release:        0.4
5 License:        Apache v2.0
6 Group:          Applications/WWW
7 Source0:        https://github.com/usmanhalalit/charisma/archive/master.tar.gz?/charisma.tgz
8 # Source0-md5:  b0278cac300ee0f6d22c957a124c4b0f
9 Source1:        apache.conf
10 Source2:        lighttpd.conf
11 URL:            http://usman.it/free-responsive-admin-template/
12 BuildRequires:  rpmbuild(macros) >= 1.268
13 Requires:       webapps
14 Requires:       webserver(access)
15 Requires:       webserver(alias)
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _webapps        /etc/webapps
20 %define         _webapp         %{name}
21 %define         _sysconfdir     %{_webapps}/%{_webapp}
22 %define         _appdir         %{_datadir}/%{_webapp}
23
24 %description
25 Charisma is a fully featured, free, premium quality, responsive, HTML5
26 admin template (or backend template) based on Bootstrap from Twitter,
27 it comes with 9 different themes to suit your style and application
28 type.
29
30 %prep
31 %setup -qc
32 mv charisma-master/* .
33
34 # samples
35 rm -r img/gallery
36
37 # jquery
38 rm -v js/jquery{,-1.7.2.min}.js
39
40 # jquery-datatables
41 rm -v js/jquery.dataTables.min.js
42
43 # jquery-history
44 rm -v js/jquery.history.js
45
46 # jquery-twitter-bootstrap
47 rm -vf `grep 2.0.4 {css,js}/bootstrap-* -l`
48 rm -v img/glyphicons-halflings*
49
50 # jquery-cookie
51 rm -v js/jquery.cookie.js
52
53 # jquery-ui
54 rm -v js/jquery-ui-1.8.21.custom.min.js
55 rm -v css/jquery-ui-1.8.21.custom.css
56 rm -vf img/ui-{bg_,icons_}*
57
58 # jquery-uploadify
59 rm -v js/jquery.uploadify-3.1.min.js
60 rm -v img/uploadify-cancel.png
61 rm -v css/uploadify.css
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
66 cp -a js css img  $RPM_BUILD_ROOT%{_appdir}
67
68 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
69 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
70 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
71
72 %triggerin -- apache1 < 1.3.37-3, apache1-base
73 %webapp_register apache %{_webapp}
74
75 %triggerun -- apache1 < 1.3.37-3, apache1-base
76 %webapp_unregister apache %{_webapp}
77
78 %triggerin -- apache < 2.2.0, apache-base
79 %webapp_register httpd %{_webapp}
80
81 %triggerun -- apache < 2.2.0, apache-base
82 %webapp_unregister httpd %{_webapp}
83
84 %triggerin -- lighttpd
85 %webapp_register lighttpd %{_webapp}
86
87 %triggerun -- lighttpd
88 %webapp_unregister lighttpd %{_webapp}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %doc README.md license.txt
96 %dir %attr(750,root,http) %{_sysconfdir}
97 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
98 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
99 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
100 %{_appdir}
This page took 0.05895 seconds and 3 git commands to generate.