]> git.pld-linux.org Git - packages/hostapd.git/blob - hostapd.spec
- updated to 2.6 (fixes CVE-2016-4476 CVE-2015-5314)
[packages/hostapd.git] / hostapd.spec
1 Summary:        HostAP - acts as an access point
2 Summary(es.UTF-8):      HostAP - actúa como un punto de acceso
3 Summary(pl.UTF-8):      HostAP - praca jako access point
4 Name:           hostapd
5 Version:        2.6
6 Release:        1
7 License:        BSD
8 Group:          Daemons
9 Source0:        http://w1.fi/releases/%{name}-%{version}.tar.gz
10 # Source0-md5:  eaa56dce9bd8f1d195eb62596eab34c7
11 Source1:        %{name}.init
12 Patch0:         %{name}-config.patch
13 Patch1:         %{name}-build-time-config.patch
14 URL:            http://w1.fi/
15 BuildRequires:  libnl-devel >= 1:3.2
16 BuildRequires:  openssl-devel >= 1.0.2
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 BuildRequires:  sed >= 4.0
19 BuildRequires:  sqlite3-devel >= 3
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       openssl >= 1.0.2
22 Requires:       rc-scripts
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This package contains utilities and userspace daemon for the Linux
27 driver for wireless LAN cards based on Intersil's Prism2/2.5/3,
28 Intersil/Conexant Prism GT/Duette/Indigo (Prism54), Atheros ar521x
29 (madwifi) chipsets. The driver supports a so called Host AP mode,
30 i.e., it takes care of IEEE 802.11 management functions in the host
31 computer and acts as an access point. This does not require any
32 special firmware for the wireless LAN card. In addition to this, it
33 has support for normal station operations in BSS and possible also in
34 IBSS.
35
36 %description -l es.UTF-8
37 Este paquete contiene unas herramientas y un servidor del espacio de
38 usuario para tarjetas LAN inalámbricas basadas en el chipset Intersil
39 Prism2/2.5/3, Intersil/Conexant Prism GT/Duette/Indigo (Prism54),
40 Atheros ar521x (madwifi). El driver soporta el llamado modo Host AP,
41 es decir, se encarga de las funciones administrativas el el host,
42 actuando como "access point". Ello no requiere ningún firmware
43 especial para la tarjeta LAN inalámbrica. Además, también hay soporte
44 para operaciones normales de estación en BSS y posiblemente también en
45 IBSS.
46
47 %description -l pl.UTF-8
48 Ten pakiet zawiera narzędzia oraz demona działającego w przestrzeni
49 użytkownika dla linuksowego sterownika kart sieci bezprzewodowych
50 opartych na układach Intersil Prism2/2.5/3, Intersil/Conexant Prism
51 GT/Duette/Indigo (Prism54), Atheros ar521x (madwifi). Sterownik
52 obsługuje tak zwany tryb Host AP, czyli dba o funkcje zarządzające
53 IEEE 802.11 na komputerze i działa jako access point. Nie wymaga to
54 żadnego specjalnego firmware dla karty sieci bezprzewodowej. Ponadto
55 ma obsługę normalnych operacji stacyjnych w BSS, a być może także
56 IBSS.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p1
62
63 %{__sed} '/CFLAGS =/{s/-g//; s/-O2/$(OPTCFLAGS)/}' -i hostapd/Makefile
64
65 %build
66 %{__make} -C hostapd all nt_password_hash hlr_auc_gw \
67         V=1 \
68         CC="%{__cc}" \
69         OPTCFLAGS="%{rpmcflags} %{rpmcppflags}" \
70         LDFLAGS="%{rpmcflags} %{rpmldflags}"
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT{/sbin,%{_sysconfdir}/{hostap,pcmcia},%{_mandir}/man{1,8}}
75 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
76
77 # hostapd hostapd_cli nt_password_hash hlr_auc_gw
78 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/hostapd
79 install -p hostapd/hostapd $RPM_BUILD_ROOT/sbin
80 install -p hostapd/hostapd_cli $RPM_BUILD_ROOT/sbin
81 install -p hostapd/nt_password_hash $RPM_BUILD_ROOT/sbin
82 install -p hostapd/hlr_auc_gw $RPM_BUILD_ROOT/sbin
83 cp -p hostapd/hostapd.8 $RPM_BUILD_ROOT%{_mandir}/man8
84 cp -p hostapd/hostapd_cli.1 $RPM_BUILD_ROOT%{_mandir}/man1
85
86 # hostapd configuration
87 cp -a hostapd/hostapd.accept $RPM_BUILD_ROOT%{_sysconfdir}/hostap
88 cp -a hostapd/hostapd.conf $RPM_BUILD_ROOT%{_sysconfdir}/hostap
89 cp -a hostapd/hostapd.deny $RPM_BUILD_ROOT%{_sysconfdir}/hostap
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 /sbin/chkconfig --add hostapd
96 %service hostapd restart "HostAP Daemon"
97
98 %preun
99 if [ "$1" = "0" ]; then
100         %service hostapd stop
101         /sbin/chkconfig --del hostapd
102 fi
103
104 %files
105 %defattr(644,root,root,755)
106 %doc COPYING hostapd/{ChangeLog,README,README-WPS}
107 %dir %{_sysconfdir}/hostap
108 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostap/hostapd.accept
109 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostap/hostapd.conf
110 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostap/hostapd.deny
111 %attr(755,root,root) /sbin/hlr_auc_gw
112 %attr(755,root,root) /sbin/hostapd
113 %attr(755,root,root) /sbin/hostapd_cli
114 %attr(755,root,root) /sbin/nt_password_hash
115 %attr(754,root,root) /etc/rc.d/init.d/hostapd
116 %{_mandir}/man1/hostapd_cli.1*
117 %{_mandir}/man8/hostapd.8*
This page took 0.070998 seconds and 3 git commands to generate.