]> git.pld-linux.org Git - packages/horde-kronolith.git/blob - horde-kronolith.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/horde-kronolith.git] / horde-kronolith.spec
1 %define         hordeapp kronolith
2 #
3 Summary:        Kronolith - calendar for Horde
4 Summary(pl.UTF-8):      Kronolith - kalendarz dla Horde
5 Name:           horde-%{hordeapp}
6 Version:        2.3.5
7 Release:        4
8 License:        LGPL
9 Group:          Applications/WWW
10 Source0:        ftp://ftp.horde.org/pub/kronolith/%{hordeapp}-h3-%{version}.tar.gz
11 # Source0-md5:  3305f6f2951c863b57c39d258d796ae6
12 Source1:        %{hordeapp}-apache.conf
13 Source2:        %{hordeapp}-httpd.conf
14 URL:            http://www.horde.org/kronolith/
15 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
16 BuildRequires:  rpmbuild(macros) >= 1.268
17 Requires:       horde >= 3.1
18 Requires:       php(core) >= 4.1.0
19 Requires:       php(xml)
20 Requires:       webapps
21 Suggests:       php-pear-Date
22 Suggests:       php-pear-Date_Holidays >= 0.17.1
23 Suggests:       php-pear-XML_Serializer
24 Obsoletes:      kronolith
25 Conflicts:      apache-base < 2.4.0-1
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreq_pear Horde.*
30
31 %define         hordedir        /usr/share/horde
32 %define         _appdir         %{hordedir}/%{hordeapp}
33 %define         _webapps        /etc/webapps
34 %define         _webapp         horde-%{hordeapp}
35 %define         _sysconfdir     %{_webapps}/%{_webapp}
36
37 %description
38 Kronolith is the Horde calendar application. It provides a stable and
39 featureful individual calendar system for every Horde user, with
40 integrated collaboration/scheduling features. It makes extensive use
41 of the Horde Framework to provide integration with other applications.
42
43 Right now, Kronolith implements a solid, stand-alone calendar system,
44 allowing repeating events, all-day events, custom fields, keywords,
45 shared calendars, iCalendar support, generation of free/busy
46 information, and managing multiple users through Horde Authentication.
47 The calendar API that Kronolith uses is abstracted such that it could
48 work with any backend, but right now we provide SQL (abstracted to
49 support most databases, including MySQL, PostgreSQL, Oracle, and MSSQL
50 via PEAR DB), MCAL, and Kolab backend libraries.
51
52 %description -l pl.UTF-8
53 Kronolith to kalendarz będący aplikacją dla Horde. Dostarcza stabilny
54 system kalendarza o dużych możliwościach dla każdego użytkownika Horde
55 wraz ze zintegrowanymi możliwościami współpracy/planowania.
56 Intensywnie wykorzystuje szkielet Horde w celu integracji z innymi
57 aplikacjami.
58
59 Jak na razie Kronolith implementuje solidny, samodzielny system
60 kalendarza, pozwalający na powtarzanie zdarzeń, zdarzenia codzienne,
61 własne pola, słowa kluczowe, współdzielone kalendarze, obsługę
62 iCalendar, generowanie informacji o wolnym i zajętym czasie oraz
63 zarządzanie wieloma użytkownikami poprzez uwierzytelnianie Horde. API
64 kalendarza używane przez Kronolith jest abstrakcyjne, tak że może
65 działać z dowolnym backendem, ale aktualnie dostarczane są biblioteki
66 backendów SQL (jako abstrakcja do obsługi większości baz, w tym MySQL,
67 PostgreSQL, Oracle i MS SQL poprzez PEAR DB), MCAL i Kolab.
68
69 %prep
70 %setup -q -n %{hordeapp}-h3-%{version}
71
72 for i in config/*.dist; do
73         mv $i config/$(basename $i .dist)
74 done
75
76 # Described in documentation as dangerous file...
77 rm test.php
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/docs}
82
83 cp -a *.php $RPM_BUILD_ROOT%{_appdir}
84 cp -a config/* $RPM_BUILD_ROOT%{_sysconfdir}
85 echo '<?php ?>' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.php
86 touch $RPM_BUILD_ROOT%{_sysconfdir}/conf.php.bak
87 cp -a calendars feed js lib locale templates themes $RPM_BUILD_ROOT%{_appdir}
88 cp -a docs/CREDITS $RPM_BUILD_ROOT%{_appdir}/docs
89
90 ln -s %{_sysconfdir} $RPM_BUILD_ROOT%{_appdir}/config
91 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
92 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post
98 if [ ! -f %{_sysconfdir}/conf.php.bak ]; then
99         install /dev/null -o root -g http -m660 %{_sysconfdir}/conf.php.bak
100 fi
101
102 if [ "$1" = 1 ]; then
103 %banner %{name} -e <<EOF
104 IMPORTANT:
105 If you are installing Kronolith for the first time, you must now
106 create the Kronolith database tables. Look into directory
107 %{_docdir}/%{name}-%{version}/sql
108 to find out how to do this for your database.
109 EOF
110 fi
111
112 %triggerin -- apache1 < 1.3.37-3, apache1-base
113 %webapp_register apache %{_webapp}
114
115 %triggerun -- apache1 < 1.3.37-3, apache1-base
116 %webapp_unregister apache %{_webapp}
117
118 %triggerin -- apache-base
119 %webapp_register httpd %{_webapp}
120
121 %triggerun -- apache-base
122 %webapp_unregister httpd %{_webapp}
123
124 %files
125 %defattr(644,root,root,755)
126 %doc README docs/* scripts/*
127 %dir %attr(750,root,http) %{_sysconfdir}
128 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
129 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
130 %attr(660,root,http) %config(noreplace) %{_sysconfdir}/conf.php
131 %attr(660,root,http) %config(noreplace) %ghost %{_sysconfdir}/conf.php.bak
132 %attr(640,root,http) %config(noreplace) %{_sysconfdir}/[!c]*.php
133 %attr(640,root,http) %{_sysconfdir}/conf.xml
134
135 %dir %{_appdir}
136 %{_appdir}/*.php
137 %{_appdir}/calendars
138 %{_appdir}/config
139 %{_appdir}/docs
140 %{_appdir}/feed
141 %{_appdir}/js
142 %{_appdir}/lib
143 %{_appdir}/locale
144 %{_appdir}/templates
145 %{_appdir}/themes
This page took 0.062236 seconds and 4 git commands to generate.