]> git.pld-linux.org Git - packages/hhvm.git/blob - hiphop-php.spec
fails with newer libmemcached
[packages/hhvm.git] / hiphop-php.spec
1 # TODO
2 # - system libevent2: https://github.com/facebook/hiphop-php/pull/421
3 # - build with newer libmemcached than 1.0.7, https://github.com/facebook/hiphop-php/issues/560
4 # - system libmbfl, system xhp, sqlite3
5 # - there should be a bit more packaged into files
6 # - linking segfaults
7 #   using bfd and gcc-6:4.6.2-2.x86_64 binutils-3:2.22.51.0.1-1.x86_64
8 #   cd /home/users/glen/rpm/packages/BUILD.x86_64-linux/hiphop-php-1.000_cf9b612/src/hphpi && /home/users/glen/rpm/BUILD.x86_64-linux/hiphop-php-1.000_cf9b612/build/src/hphp/hphp -t cpp -f exe --input-dir . -i hphpi.php -o gen -vEnableEval=2 --log=1
9 #   Segmentation fault
10 #   make[2]: *** [src/hphp/hphp] Error 139
11 #   relinking succeeds, but resulting binary segfaults as well:
12 #   0x0000000000b9cc0b in HPHP::Extension::LoadModules(HPHP::Hdf) ()
13 Summary:        Virtual Machine, Runtime, and JIT for PHP
14 Name:           hiphop-php
15 Version:        2.1.0
16 Release:        0.1
17 License:        PHP 3.01
18 Group:          Development/Languages
19 Source0:        https://github.com/facebook/hiphop-php/archive/HPHP-%{version}.tar.gz
20 # Source0-md5:  edd3d8b4371d38286c7c5f0c2582f5e1
21 # need fb.changes.patch, which is available for 1.4 only
22 Source1:        http://www.monkey.org/~provos/libevent-1.4.14b-stable.tar.gz
23 # Source1-md5:  a00e037e4d3f9e4fe9893e8a2d27918c
24 Source2:        get-source.sh
25 Patch0:         cmake-missing-library.patch
26 Patch1:         libevent14.patch
27 Patch3:         system-xhp.patch
28 Patch4:         system-libafdt.patch
29 Patch5:         system-folly.patch
30 Patch6:         boost-system-category.patch
31 Patch7:         gcc4.8.patch
32 URL:            http://wiki.github.com/facebook/hiphop-php/
33 BuildRequires:  binutils-devel
34 BuildRequires:  bison >= 2.3
35 BuildRequires:  boost-devel >= 1.50
36 BuildRequires:  cmake >= 2.8.5
37 BuildRequires:  curl-devel >= 7.29.0
38 BuildRequires:  elfutils-devel
39 BuildRequires:  expat-devel
40 BuildRequires:  flex >= 2.5.35
41 BuildRequires:  gd-devel
42 BuildRequires:  glog-devel >= 0.3.2
43 BuildRequires:  imap-devel >= 1:2007
44 #BuildRequires: jemalloc-devel
45 BuildRequires:  libafdt-devel >= 0.1.0
46 BuildRequires:  libcap-devel
47 BuildRequires:  libdwarf-devel
48 #BuildRequires: libevent-devel >= 1.4.14
49 BuildRequires:  libicu-devel >= 4.2
50 #BuildRequires: libmbfl-devel
51 BuildRequires:  libmcrypt-devel
52 BuildRequires:  libmemcached-devel < 1.0.8
53 BuildRequires:  libmemcached-devel >= 1.0.4
54 BuildRequires:  libstdc++-devel >= 6:4.3
55 BuildRequires:  libunwind-devel
56 BuildRequires:  libxml2-devel
57 BuildRequires:  mysql-devel
58 BuildRequires:  oniguruma-devel
59 BuildRequires:  openssl-devel
60 BuildRequires:  pcre-devel
61 #BuildRequires: php-xhp-devel >= 1.3.9-6
62 BuildRequires:  re2c >= 0.13.0
63 BuildRequires:  readline-devel
64 BuildRequires:  rpmbuild(macros) >= 1.600
65 BuildRequires:  tbb-devel >= 4.0.6000
66 BuildRequires:  zlib-devel
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 HipHop VM (HHVM) is a new open-source virtual machine designed for
71 executing programs written in PHP. HHVM uses a just-in-time
72 compilation approach to achieve superior performance while maintaining
73 the flexibility that PHP developers are accustomed to. HipHop VM (and
74 before it HPHPc) has realized > 5x increase in throughput for Facebook
75 compared with Zend PHP 5.2.
76
77 HipHop is most commonly run as a standalone server, replacing both
78 Apache and mod_php.
79
80 %prep
81 %setup -q -n %{name}-HPHP-%{version} -a1
82 %patch5 -p1
83 %patch6 -p1
84 %patch7 -p1
85
86 ln -s libevent-1.4.*-stable libevent
87 %{__patch} -d libevent -p1 < hphp/third_party/libevent-1.4.14.fb-changes.diff
88
89 %if 0
90 %patch0 -p1
91 %patch1 -p1
92 #%patch3 -p1
93 %patch4 -p1
94
95
96 #rm -rf src/third_party/libmbfl
97 #sed -i -e '/add_subdirectory(third_party\/libmbfl)/d' src/CMakeLists.txt
98
99 rm -rf src/third_party/xhp
100 rm -rf src/third_party/libafdt
101 %endif
102
103 %build
104 # build libevent 1.4 with fb patches
105 if [ ! -d libevent/.libs ]; then
106         cd libevent
107         # TODO: should use static linking, but then it fails to detect libraries due missing -lrt
108         %configure \
109                 %{?0:--enable-static} \
110                 %{?0:--disable-shared}
111         %{__make}
112         ln -s .libs lib
113         ln -s . include
114         cd ..
115 fi
116
117 export HPHP_HOME=$(pwd)
118 export HPHP_LIB=$HPHP_HOME/bin
119
120 %if 0
121 export LIBEVENT_PREFIX=$HPHP_HOME/libevent
122
123         -DLibEvent_LIB=$HPHP_HOME/libevent/libevent.so \
124         -DLibEvent_INCLUDE_PATHS=$HPHP_HOME/libevent \
125         -DLibEvent_LIB_PATHS=$HPHP_HOME/libevent/.libs \
126 %endif
127
128 %if 0
129 # out of dir build broken (can't find it's tools)
130 install -d build
131 cd build
132 %endif
133
134 CPPFLAGS="%{rpmcppflags} -fno-permissive"
135 %cmake \
136         -DLIBEVENT_LIB=$HPHP_HOME/libevent/lib/libevent.so \
137         -DLIBEVENT_INCLUDE_DIR=$HPHP_HOME/libevent \
138         -DCMAKE_PREFIX_PATH=%{_prefix} \
139         -DSKIP_BUNDLED_XHP=ON \
140         -DUSE_JEMALLOC=OFF \
141         -DUSE_TCMALLOC=OFF \
142         ./
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 install -d $RPM_BUILD_ROOT%{_bindir}
148 install -p build/src/hphp/hphp $RPM_BUILD_ROOT%{_bindir}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/hphp
This page took 0.0372 seconds and 3 git commands to generate.