]> git.pld-linux.org Git - packages/highlight.git/blob - highlight.spec
53e90e8d55927d729d9575b60fca9d50a9da7d36
[packages/highlight.git] / highlight.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs # don't generate apidocs subpackage
4
5 Summary:        A source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
6 Summary(pl.UTF-8):      Konwerter kodu źródłowego do formatów HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
7 Name:           highlight
8 Version:        3.60
9 Release:        1
10 License:        GPL v3
11 Group:          Applications/Publishing
12 Source0:        http://www.andre-simon.de/zip/%{name}-%{version}.tar.bz2
13 # Source0-md5:  33f7f5548ac86e18a39b93fbefbe7e5d
14 Patch0:         %{name}-Makefile.patch
15 URL:            http://www.andre-simon.de/
16 BuildRequires:  Qt5Core-devel
17 BuildRequires:  Qt5Gui-devel
18 BuildRequires:  Qt5Widgets-devel
19 BuildRequires:  boost-devel
20 %{?with_apidocs:BuildRequires:  doxygen}
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  lua53-devel
23 BuildRequires:  qt5-build
24 BuildRequires:  qt5-qmake
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sysconfdir     /etc/highlight
28
29 %description
30 Highlight is a universal converter from source code to HTML, XHTML,
31 RTF, TeX, LaTeX, XSL-FO, and XML. (X)HTML output is formatted by
32 Cascading Style Sheets. It supports 100 programming languages and
33 includes 50 highlighting color themes. It's possible to easily enhance
34 the parsing database. The converter includes some features to provide
35 a consistent layout of the input code.
36
37 %description -l pl.UTF-8
38 Highlight jest uniwersalnym konwerterem kodu źródłowego do formatów
39 HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML. Wyjście (X)HTML jest
40 formatowane przez kaskadowe arkusze stylów (CSS). Highlight wspiera
41 100 języków programowania i zawiera 50 kolorystycznych motywów
42 podświetlania składni. Umożliwia łatwe ulepszanie bazy parsowania.
43 Konwerter zawiera pewne cechy zapewniające spójny układ graficzny kodu
44 wejściowego.
45
46 %package apidocs
47 Summary:        API documentation for highlight - a source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
48 Summary(pl.UTF-8):      Dokumentacja API highlight - konwertera kodu źródłowego do HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
49 Group:          Documentation
50 %if "%{_rpmversion}" >= "5"
51 BuildArch:      noarch
52 %endif
53
54 %description apidocs
55 API documentation for highlight - a source code converter to HTML,
56 XHTML, RTF, TeX, LaTeX, XSL-FO, and XML.
57
58 %description apidocs -l pl.UTF-8
59 Dokumentacja API highlight - konwertera kodu źródłowego do formatu
60 HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML.
61
62 %package gui
63 Summary:        GUI for highlight - a source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
64 Summary(pl.UTF-8):      GUI do highlight - konwertera kodu źródłowego do HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
65 Group:          Development/Tools
66 Requires:       %{name}
67 Requires(post,postun):  gtk-update-icon-cache
68 Requires:       hicolor-icon-theme
69
70 %description gui
71 Qt4 GUI for for highlight - a source code converter to HTML, XHTML,
72 RTF, TeX, LaTeX, XSL-FO, and XML.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77
78 %build
79 %{__make} \
80         CXX="%{__cxx}" \
81         CXXFLAGS="%{rpmcxxflags} -std=c++11"
82 %{__make} gui \
83         QMAKE=qmake-qt5 \
84         CXX="%{__cxx}"
85
86 %{?with_apidocs:%{__make} apidocs}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %{__make} install-gui \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 # to avoid false `warning: Installed (but unpackaged) file(s) found:' - these files are packaged through %doc
98 rm -fr $RPM_BUILD_ROOT%{_docdir}/highlight
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post gui
104 %update_icon_cache hicolor
105
106 %postun gui
107 %update_icon_cache hicolor
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS ChangeLog.adoc README.adoc README_LANGLIST.adoc README_PLUGINS.adoc README_REGEX.adoc extras
112 %lang(de) %doc README_DE.adoc
113 %attr(755,root,root) %{_bindir}/%{name}
114 %dir %{_datadir}/%{name}
115 %{_datadir}/%{name}/langDefs
116 %{_datadir}/%{name}/themes
117 %{_mandir}/man1/highlight.1*
118 %{_mandir}/man5/filetypes.conf.5*
119 %dir %{_sysconfdir}
120 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
121
122 %if %{with apidocs}
123 %files apidocs
124 %defattr(644,root,root,755)
125 %doc apidocs/html/*
126 %endif
127
128 %files gui
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/%{name}-gui
131 %dir %{_datadir}/%{name}/gui_files
132 %dir %{_datadir}/%{name}/gui_files/l10n
133 %lang(bg) %{_datadir}/%{name}/gui_files/l10n/highlight_bg_BG.qm
134 %lang(cs) %{_datadir}/%{name}/gui_files/l10n/highlight_cs_CZ.qm
135 %lang(de) %{_datadir}/%{name}/gui_files/l10n/highlight_de_DE.qm
136 %lang(es) %{_datadir}/%{name}/gui_files/l10n/highlight_es_ES.qm
137 %lang(fr) %{_datadir}/%{name}/gui_files/l10n/highlight_fr_FR.qm
138 %lang(it) %{_datadir}/%{name}/gui_files/l10n/highlight_it_IT.qm
139 %lang(zh) %{_datadir}/%{name}/gui_files/l10n/highlight_zh_CN.qm
140 %{_datadir}/%{name}/gui_files/ext
141 %dir %{_datadir}/%{name}/plugins
142 %{_datadir}/%{name}/plugins/*.lua
143 %{_desktopdir}/*.desktop
144 %{_iconsdir}/hicolor/*x*/apps/highlight.png
This page took 0.066565 seconds and 2 git commands to generate.