]> git.pld-linux.org Git - packages/highlight.git/blob - highlight.spec
1633ef6234826a8a1ea353f3c9480d87bcd399df
[packages/highlight.git] / highlight.spec
1 #
2 # Conditional build:
3 %bcond_with     apidocs # don't generate apidocs subpackage
4
5 Summary:        A source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
6 Summary(pl.UTF-8):      Konwerter kodu źródłowego do formatów HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
7 Name:           highlight
8 Version:        3.34
9 Release:        1
10 License:        GPL v3
11 Group:          Applications/Publishing
12 Source0:        http://www.andre-simon.de/zip/%{name}-%{version}.tar.bz2
13 # Source0-md5:  6c886515231f5c16eca991a736eefe6e
14 Patch0:         %{name}-Makefile.patch
15 URL:            http://www.andre-simon.de/
16 BuildRequires:  QtCore-devel
17 BuildRequires:  QtGui-devel
18 BuildRequires:  boost-devel
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  lua52-devel
22 BuildRequires:  qt4-build
23 BuildRequires:  qt4-qmake
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _sysconfdir     /etc/highlight
27
28 %description
29 Highlight is a universal converter from source code to HTML, XHTML,
30 RTF, TeX, LaTeX, XSL-FO, and XML. (X)HTML output is formatted by
31 Cascading Style Sheets. It supports 100 programming languages and
32 includes 50 highlighting color themes. It's possible to easily enhance
33 the parsing database. The converter includes some features to provide
34 a consistent layout of the input code.
35
36 %description -l pl.UTF-8
37 Highlight jest uniwersalnym konwerterem kodu źródłowego do formatów
38 HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML. Wyjście (X)HTML jest
39 formatowane przez kaskadowe arkusze stylów (CSS). Highlight wspiera
40 100 języków programowania i zawiera 50 kolorystycznych motywów
41 podświetlania składni. Umożliwia łatwe ulepszanie bazy parsowania.
42 Konwerter zawiera pewne cechy zapewniające spójny układ graficzny kodu
43 wejściowego.
44
45 %package apidocs
46 Summary:        API documentation for highlight - a source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
47 Summary(pl.UTF-8):      Dokumentacja API highlight - konwertera kodu źródłowego do HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
48 Group:          Documentation
49 %if "%{_rpmversion}" >= "5"
50 BuildArch:      noarch
51 %endif
52
53 %description apidocs
54 API documentation for highlight - a source code converter to HTML,
55 XHTML, RTF, TeX, LaTeX, XSL-FO, and XML.
56
57 %description apidocs -l pl.UTF-8
58 Dokumentacja API highlight - konwertera kodu źródłowego do formatu
59 HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML.
60
61 %package gui
62 Summary:        GUI for highlight - a source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
63 Summary(pl.UTF-8):      GUI do highlight - konwertera kodu źródłowego do HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
64 Group:          Development/Tools
65 Requires:       %{name}
66
67 %description gui
68 Qt4 GUI for for highlight - a source code converter to HTML, XHTML,
69 RTF, TeX, LaTeX, XSL-FO, and XML.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 %build
76 %{__make} \
77         CXX="%{__cxx}" \
78         CXXFLAGS="%{rpmcxxflags} -std=c++11"
79 %{__make} gui \
80         QMAKE=qmake-qt4 \
81         CXX="%{__cxx}" \
82         CXXFLAGS="%{rpmcxxflags} -std=c++11 "'$(DEFINES)'
83
84 %{?with_apidocs:%{__make} apidocs}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 %{__make} install-gui \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 # to avoid false `warning: Installed (but unpackaged) file(s) found:' - these files are packaged through %doc
96 rm -fr $RPM_BUILD_ROOT%{_docdir}/highlight
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS ChangeLog README README_LANGLIST README_REGEX TODO examples
104 %lang(de) %doc README_DE
105 %attr(755,root,root) %{_bindir}/%{name}
106 %dir %{_datadir}/%{name}
107 %{_datadir}/%{name}/langDefs
108 %{_datadir}/%{name}/themes
109 %{_mandir}/man1/*
110 %dir %{_sysconfdir}
111 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
112
113 %if %{with apidocs}
114 %files apidocs
115 %defattr(644,root,root,755)
116 %doc apidocs/html/*
117 %endif
118
119 %files gui
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/%{name}-gui
122 %dir %{_datadir}/%{name}/gui_files
123 %dir %{_datadir}/%{name}/gui_files/l10n
124 %lang(cs) %dir %{_datadir}/%{name}/gui_files/l10n/highlight_cs_CZ.qm
125 %lang(de) %dir %{_datadir}/%{name}/gui_files/l10n/highlight_de_DE.qm
126 %lang(es) %dir %{_datadir}/%{name}/gui_files/l10n/highlight_es_ES.qm
127 %lang(zh) %dir %{_datadir}/%{name}/gui_files/l10n/highlight_zh_CN.qm
128 %{_datadir}/%{name}/gui_files/ext
129 %dir %{_datadir}/%{name}/plugins
130 %{_datadir}/%{name}/plugins/*.lua
131 %{_desktopdir}/*.desktop
132 %{_pixmapsdir}/*.xpm
This page took 0.025415 seconds and 2 git commands to generate.