]> git.pld-linux.org Git - packages/highlight.git/blob - highlight.spec
034cc28a7c33e3073f9378cf628f10e0a73721a6
[packages/highlight.git] / highlight.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # don't generate apidocs subpackage
4 #
5 Summary:        A source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
6 Summary(pl.UTF-8):      Konwerter kodu źródłowego do formatów HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
7 Name:           highlight
8 Version:        2.16
9 Release:        1
10 License:        GPL v3
11 Group:          Applications/Publishing
12 Source0:        http://www.andre-simon.de/zip/%{name}-%{version}.tar.bz2
13 # Source0-md5:  08f1429a6db258ab1a7eecbb4e0d44b2
14 Patch0:         %{name}-Makefile.patch
15 URL:            http://www.andre-simon.de/
16 %{?with_apidocs:BuildRequires:  doxygen}
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  QtCore-devel
19 BuildRequires:  QtGui-devel
20 BuildRequires:  qt4-build
21 BuildRequires:  qt4-qmake
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sysconfdir     /etc/highlight
25
26 %description
27 Highlight is a universal converter from source code to HTML, XHTML,
28 RTF, TeX, LaTeX, XSL-FO, and XML. (X)HTML output is formatted by
29 Cascading Style Sheets. It supports 100 programming languages and
30 includes 50 highlighting color themes. It's possible to easily enhance
31 the parsing database. The converter includes some features to provide
32 a consistent layout of the input code.
33
34 %description -l pl.UTF-8
35 Highlight jest uniwersalnym konwerterem kodu źródłowego do formatów
36 HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML. Wyjście (X)HTML jest
37 formatowane przez kaskadowe arkusze stylów (CSS). Highlight wspiera
38 100 języków programowania i zawiera 50 kolorystycznych motywów
39 podświetlania składni. Umożliwia łatwe ulepszanie bazy parsowania.
40 Konwerter zawiera pewne cechy zapewniające spójny układ graficzny kodu
41 wejściowego.
42
43 %package apidocs
44 Summary:        API documentation for highlight - a source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
45 Summary(pl.UTF-8):      Dokumentacja API highlight - konwertera kodu źródłowego do HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
46 Group:          Documentation
47
48 %description apidocs
49 API documentation for highlight - a source code converter to HTML,
50 XHTML, RTF, TeX, LaTeX, XSL-FO, and XML.
51
52 %description apidocs -l pl.UTF-8
53 Dokumentacja API highlight - konwertera kodu źródłowego do formatu
54 HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML.
55
56 %package gui
57 Summary:        GUI for highlight - a source code converter to HTML, XHTML, RTF, TeX, LaTeX, XSL-FO, and XML
58 Summary(pl.UTF-8):      GUI do highlight - konwertera kodu źródłowego do HTML, XHTML, RTF, TeX, LaTeX, XSL-FO oraz XML
59 Group:          Development/Tools
60 Requires:       %{name}
61
62 %description gui
63 Qt4 GUI for for highlight - a source code converter to HTML, XHTML,
64 RTF, TeX, LaTeX, XSL-FO, and XML.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69
70 %build
71 %{__make} \
72         CXX="%{__cxx}" \
73         CXXFLAGS="%{rpmcxxflags}"
74 %{__make} gui \
75         QMAKE=qmake-qt4 \
76         CXX="%{__cxx}" \
77         CXXFLAGS="%{rpmcxxflags} "'$(DEFINES)'
78
79 %{?with_apidocs:%{__make} apidocs}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %{__make} install-gui \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 # to avoid false `warning: Installed (but unpackaged) file(s) found:' - these files are packaged through %doc
91 rm -fr $RPM_BUILD_ROOT/usr/share/doc/highlight
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS ChangeLog README README_LANGLIST README_REGEX TODO examples
99 %lang(de) %doc README_DE
100 %attr(755,root,root) %{_bindir}/%{name}
101 %dir %{_datadir}/%{name}
102 %{_datadir}/%{name}/langDefs
103 %{_datadir}/%{name}/themes
104 %{_mandir}/man1/*
105 %dir %{_sysconfdir}
106 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
107
108 %if %{with apidocs}
109 %files apidocs
110 %defattr(644,root,root,755)
111 %doc apidocs/html/*
112 %endif
113
114 %files gui
115 %attr(755,root,root) %{_bindir}/%{name}-gui
116 %dir %{_datadir}/%{name}/gui_files
117 %dir %{_datadir}/%{name}/gui_files/l10n
118 %lang(de) %dir %{_datadir}/%{name}/gui_files/l10n/highlight_de_DE.qm
119 %lang(es) %dir %{_datadir}/%{name}/gui_files/l10n/highlight_es_ES.qm
120 %{_datadir}/%{name}/gui_files/ext
121 %{_desktopdir}/*.desktop
122 %{_pixmapsdir}/*.xpm
This page took 0.112008 seconds and 2 git commands to generate.