]> git.pld-linux.org Git - packages/hdf5_hl_region.git/blob - hdf5_hl_region.spec
c3f300c6960c1dc61e8b904ddea26527a386033b
[packages/hdf5_hl_region.git] / hdf5_hl_region.spec
1 #
2 # Conditional build:
3 %bcond_without  fortran         # Fortran API
4 %bcond_with     tests           # perform "make tests" (reference dumps differ from current h5dump)
5 #
6 Summary:        High-Level Library for handling HDF5 object and region references
7 Summary(pl.UTF-8):      Wysokopoziomowa biblioteka do obsługi odniesień do obiektów i regionów HDF5
8 Name:           hdf5_hl_region
9 Version:        1.1.3
10 Release:        5
11 License:        BSD-like, changed sources must be marked
12 Group:          Libraries
13 Source0:        http://www.hdfgroup.uiuc.edu/ftp/pub/outgoing/NPOESS/source/hdf5_HL_REGION-%{version}.tar
14 # Source0-md5:  72b64bca020e8657f4e54ca7d9dfa57d
15 Patch0:         %{name}-shared.patch
16 Patch1:         %{name}-destdir.patch
17 Patch2:         hdf5-1.10.patch
18 URL:            http://www.hdfgroup.org/projects/npoess/HL_index.html
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake
21 BuildRequires:  hdf5-devel
22 %{?with_fortran:BuildRequires:  hdf5-fortran-devel}
23 %{?with_tests:BuildRequires:    hdf5-progs}
24 BuildRequires:  libtool
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This package contains C library to:
29  - Get information and read data pointed to by region references
30  - Create an array of region references using paths to datasets and
31    corner coordinates of hyperslabs
32  - Create a dataset and write data pointed to by region references
33  - Copy data pointed to by region references
34  - Retrieve data packed in an integer (quality flags)
35
36 %description -l pl.UTF-8
37 Ten pakiet zawiera bibliotekę C pozwalającą na:
38  - uzyskanie informacji i odczyt danych wskazanych przez regionu
39  - utworzenie tablicy wskazań regionu przy użyciu ścieżek do zbiorów
40    danych i współrzędnych rogów obiektów hyperslab
41  - utworzenie zbioru danych i zapis danych wskazanych przez region
42  - skopiowanie danych wskazanych przez region
43  - odtworzenie danych spakowanych w liczbie całkowitej (flag jakości)
44
45 %package devel
46 Summary:        Header files for HDF5 HL_REGION library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF5 HL_REGION
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       hdf5-devel
51
52 %description devel
53 Header files for HDF5 HL_REGION library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki HDF5 HL_REGION.
57
58 %package static
59 Summary:        Static HDF5 HL_REGION library
60 Summary(pl.UTF-8):      Statyczna biblioteka HDF5 HL_REGION
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static HDF5 HL_REGION library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka HDF5 HL_REGION.
69
70 %package fortran
71 Summary:        High-Level Fortran Library for handling HDF5 object and region references
72 Summary(pl.UTF-8):      Wysokopoziomowa biblioteka Fortranu do obsługi odniesień do obiektów i regionów HDF5
73 Group:          Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description fortran
77 This package contains Fortran library to:
78  - Get information and read data pointed to by region references
79  - Create an array of region references using paths to datasets and
80    corner coordinates of hyperslabs
81  - Create a dataset and write data pointed to by region references
82  - Copy data pointed to by region references
83  - Retrieve data packed in an integer (quality flags)
84
85 %description fortran -l pl.UTF-8
86 Ten pakiet zawiera bibliotekę języka Fortran pozwalającą na:
87  - uzyskanie informacji i odczyt danych wskazanych przez regionu
88  - utworzenie tablicy wskazań regionu przy użyciu ścieżek do zbiorów
89    danych i współrzędnych rogów obiektów hyperslab
90  - utworzenie zbioru danych i zapis danych wskazanych przez region
91  - skopiowanie danych wskazanych przez region
92  - odtworzenie danych spakowanych w liczbie całkowitej (flag jakości)
93
94 %package fortran-devel
95 Summary:        Header files for HDF5 HL_REGION Fortran library
96 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HDF5 HL_REGION dla Fortranu
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99 Requires:       %{name}-fortran = %{version}-%{release}
100
101 %description fortran-devel
102 Header files for HDF5 HL_REGION library.
103
104 %description fortran-devel -l pl.UTF-8
105 Pliki nagłówkowe biblioteki HDF5 HL_REGION dla Foortranu.
106
107 %package fortran-static
108 Summary:        Static HDF5 HL_REGION Fortran library
109 Summary(pl.UTF-8):      Statyczna biblioteka HDF5 HL_REGION dla Fortranu
110 Group:          Development/Libraries
111 Requires:       %{name}-fortran-devel = %{version}-%{release}
112
113 %description fortran-static
114 Static HDF5 HL_REGION Fortran library.
115
116 %description fortran-static -l pl.UTF-8
117 Statyczna biblioteka HDF5 HL_REGION dla Fortranu.
118
119 %prep
120 %setup -q -n hdf5_HL_REGION-%{version}
121 %patch0 -p1
122 %patch1 -p1
123 %patch2 -p1
124
125 %build
126 %{__make} -j1 \
127         CC="%{__cc}" \
128         FC="%{_target_alias}-gfortran" \
129         CCFLAGS="%{rpmcflags}" \
130         FCFLAGS="%{rpmcflags}" \
131         CHCK_H5FC2003="Fortran 2003 Compiler: yes" \
132         HDF5_INSTALL_DIR=/usr \
133         HDF5_USE_SHLIB=yes \
134         LIBDIR=%{_libdir} \
135         enable-fortran=yes
136
137 %if %{with tests}
138 %{__make} tests \
139         HDF5_INSTALL_DIR=/usr
140 %endif
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT \
147         PREFIX=%{_prefix} \
148         LIBDIR=%{_libdir} \
149         HDF5_INSTALL_DIR=/usr \
150         enable-fortran=yes
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %post   fortran -p /sbin/ldconfig
159 %postun fortran -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc COPYING README.txt doc/RELEASE.txt
164 %attr(755,root,root) %{_libdir}/libhdf5_hl_region.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl_region.so.0
166
167 %files devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libhdf5_hl_region.so
170 %{_libdir}/libhdf5_hl_region.la
171 %{_includedir}/h5hl_api.h
172 %{_includedir}/h5hl_region.h
173 %{_includedir}/hl_region_H5LRpublic.h
174 %{_includedir}/hl_region_H5LTpublic.h
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libhdf5_hl_region.a
179
180 %files fortran
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libhdf5_hl_region_fortran.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libhdf5_hl_region_fortran.so.0
184
185 %files fortran-devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libhdf5_hl_region_fortran.so
188 %{_libdir}/libhdf5_hl_region_fortran.la
189 %{_includedir}/h5hl_region.mod
190 %{_includedir}/hl_region_h5lr.mod
191 %{_includedir}/hl_region_h5lt.mod
192
193 %files fortran-static
194 %defattr(644,root,root,755)
195 %{_libdir}/libhdf5_hl_region_fortran.a
This page took 0.049368 seconds and 2 git commands to generate.